Don't install rtelnet when sgtty is not available anymore.
rtelnet cannot easily be ported to the termios interface without performing very thorough tests. We'd better not risk it and disconnect rtelnet from the build when sgtty is not available. We can always restore it when someone offers a patch. PR: 124473 Approved by: philip (mentor)
This commit is contained in:
parent
2396f28e1c
commit
1867f1355f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=215242
3 changed files with 16 additions and 4 deletions
|
@ -7,7 +7,7 @@
|
|||
|
||||
PORTNAME= annextools
|
||||
PORTVERSION= 10.0
|
||||
PORTREVISION= 0
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= net-mgmt
|
||||
MASTER_SITES= ftp://www142.nortelnetworks.com/pub/swcode/remacc/microannex_xl/
|
||||
DISTNAME= R10.0B-R2.3
|
||||
|
@ -21,6 +21,14 @@ WRKSRC= ${WRKDIR}/src
|
|||
|
||||
EXTRACT_AFTER_ARGS= | ${TAR} -xf - src
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 800039
|
||||
PLIST_SUB+= RTELNET=""
|
||||
.else
|
||||
PLIST_SUB+= RTELNET="@comment "
|
||||
.endif
|
||||
|
||||
post-extract:
|
||||
${FIND} ${WRKDIR}/src -type d -exec ${CHMOD} u+w \{\} \;
|
||||
|
||||
|
@ -33,7 +41,9 @@ do-install:
|
|||
${INSTALL_PROGRAM} ${WRKSRC}/erpcd/tms_convert ${PREFIX}/annex/sbin
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/erpcd/tms_dbm ${PREFIX}/annex/sbin
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/na/na ${PREFIX}/annex/sbin
|
||||
.if ${OSVERSION} < 800039
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/rtelnet/rtelnet ${PREFIX}/annex/sbin
|
||||
.endif
|
||||
${INSTALL_DATA} ${WRKSRC}/snmp/xylo-anx.mib ${PREFIX}/annex/snmp
|
||||
${INSTALL_DATA} ${WRKSRC}/snmp/xylo-callmgmt.mib ${PREFIX}/annex/snmp
|
||||
${INSTALL_DATA} ${WRKSRC}/snmp/xylo-modem.mib ${PREFIX}/annex/snmp
|
||||
|
@ -54,4 +64,4 @@ do-install:
|
|||
${INSTALL_DATA} ${WRKSRC}/examples/misc/rotary ${PREFIX}/annex/examples
|
||||
${INSTALL_DATA} ${WRKSRC}/examples/misc/termcap ${PREFIX}/annex/examples
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,10 +1,12 @@
|
|||
--- Makefile.orig Thu Sep 18 20:10:32 2003
|
||||
+++ Makefile Thu Sep 18 20:10:32 2003
|
||||
@@ -0,0 +1,7 @@
|
||||
@@ -0,0 +1,9 @@
|
||||
+SUBDIR= libannex
|
||||
+SUBDIR+= netadm
|
||||
+SUBDIR+= erpcd
|
||||
+SUBDIR+= na
|
||||
+.if ${OSVERSION} < 800039
|
||||
+SUBDIR+= rtelnet
|
||||
+.endif
|
||||
+
|
||||
+.include <bsd.subdir.mk>
|
||||
|
|
|
@ -5,7 +5,7 @@ annex/sbin/spy
|
|||
annex/sbin/tms_convert
|
||||
annex/sbin/tms_dbm
|
||||
annex/sbin/na
|
||||
annex/sbin/rtelnet
|
||||
%%RTELNET%%annex/sbin/rtelnet
|
||||
@dirrm annex/sbin
|
||||
annex/snmp/xylo-anx.mib
|
||||
annex/snmp/xylo-callmgmt.mib
|
||||
|
|
Loading…
Reference in a new issue