upgrade to 0.4.1

PR:		40083
Submitted by:	maintainer
This commit is contained in:
Ying-Chieh Liao 2002-07-02 13:47:31 +00:00
parent d37d5f372c
commit 187fe28d37
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=62341
42 changed files with 82 additions and 710 deletions

View file

@ -6,21 +6,51 @@
#
PORTNAME= libuta
PORTVERSION= 0.3.38
PORTVERSION= 0.4.1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= lehmann@ans-netz.de
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
sigc.1:${PORTSDIR}/devel/libsigc++ \
SDL-1.1.4:${PORTSDIR}/devel/sdl12 \
SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
SDL-1.1.4:${PORTSDIR}/devel/sdl12
USE_FREETYPE= yes
USE_LIBTOOL= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/freetype1"
GNU_CONFIGURE= yes
USE_REINPLACE= yes
.include <bsd.port.mk>
CONFIGURE_ENV= SDL_CONFIG="${LOCALBASE}/bin/sdl11-config" \
LIBS="-L${LOCALBASE}/lib"
SDL11_FILES= configure uta/color.h uta/event.h uta/keysym.h uta/mutex.h \
uta/pixelformat.h uta/rect.h uta/sge_blib.cc uta/sge_blib.h \
uta/sge_draw.cc uta/sge_draw.h uta/sound.h uta/surface_io.cc \
uta/surface.h uta/timer.cc
.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/lib/libSDL_mixer.so.2)
WITH_SDL_MIXER= yes
.endif
.if defined(WITH_SDL_MIXER)
LIB_DEPENDS+= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
.endif
pre-everything::
@${ECHO} ""
@${ECHO} "You may use the following build options:"
@${ECHO} ""
@${ECHO} " WITH_SDL_MIXER=yes Enable music and sound support"
@${ECHO} ""
post-patch:
.for i in ${SDL11_FILES}
${REINPLACE_CMD} -e 's|SDL/|SDL11/|' ${WRKSRC}/$i
.endfor
.include <bsd.port.post.mk>

View file

@ -1 +1 @@
MD5 (libuta-0.3.38.tar.gz) = 19e9b692fa046fb7c8e16c5cceaea232
MD5 (libuta-0.4.1.tar.gz) = 102eebdf70941cd11ed36af9ba8726d6

View file

@ -1,60 +0,0 @@
$FreeBSD$
--- configure.orig Thu Apr 12 12:21:35 2001
+++ configure Thu Mar 14 13:09:31 2002
@@ -7,6 +7,9 @@
# This configure script is free software; the Free Software Foundation
# gives unlimited permission to copy, distribute and modify it.
+LIBS="$LIBS -L/usr/local/lib"
+SDL_CONFIG="/usr/local/bin/sdl11-config"
+
# Defaults:
ac_help=
ac_default_prefix=/usr/local
@@ -3573,7 +3576,7 @@
CFLAGS=
CXXFLAGS=
-CPPFLAGS=-Wall
+CPPFLAGS="$CPPFLAGS -Wall"
case $win32 in
true)
@@ -4603,7 +4606,7 @@
no_sdl=yes
else
SDL_CFLAGS=`$SDL_CONFIG $sdlconf_args --cflags`
- SDL_LIBS=`$SDL_CONFIG $sdlconf_args --libs`
+ SDL_LIBS=`$SDL_CONFIG $sdlconf_args --libs | sed 's/-lXxf86vm -lXxf86dga -lXv //g'`
sdl_major_version=`$SDL_CONFIG $sdl_args --version | \
sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\1/'`
@@ -4627,7 +4630,7 @@
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
char*
my_strdup (char *str)
@@ -4717,7 +4720,7 @@
#include "confdefs.h"
#include <stdio.h>
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
int main() {
return 0;
@@ -5042,7 +5045,7 @@
cat > conftest.$ac_ext <<EOF
#line 5044 "configure"
#include "confdefs.h"
-#include <SDL/SDL_mixer.h>
+#include <SDL11/SDL_mixer.h>
EOF
ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
{ (eval echo configure:5049: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }

View file

@ -1,11 +0,0 @@
--- uta/color.h.orig Sat Mar 31 05:24:37 2001
+++ uta/color.h Sat Mar 31 05:26:10 2001
@@ -22,7 +22,7 @@
#define _COLOR_H
#include <iostream>
-#include <SDL/SDL_version.h>
+#include <SDL11/SDL_version.h>
namespace uta {
///

View file

@ -1,11 +0,0 @@
--- uta/event.h.orig Sat Mar 31 05:24:44 2001
+++ uta/event.h Sat Mar 31 05:26:20 2001
@@ -21,7 +21,7 @@
#ifndef _EVENT_H
#define _EVENT_H
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include "keysym.h"
#include "point.h"

View file

@ -1,11 +0,0 @@
--- uta/keysym.h.orig Sat Mar 31 05:24:56 2001
+++ uta/keysym.h Sat Mar 31 05:26:32 2001
@@ -20,7 +20,7 @@
#ifndef KEYSYM_H
#define KEYSYM_H
-#include <SDL/SDL_keysym.h>
+#include <SDL11/SDL_keysym.h>
namespace uta {

View file

@ -1,11 +0,0 @@
--- uta/mutex.h.orig Sat Mar 31 05:25:05 2001
+++ uta/mutex.h Sat Mar 31 05:26:54 2001
@@ -22,7 +22,7 @@
#ifndef _MUTEX_H_
#define _MUTEX_H_
-#include <SDL/SDL_mutex.h>
+#include <SDL11/SDL_mutex.h>
namespace uta {

View file

@ -1,11 +0,0 @@
--- uta/rect.h.orig Sat Mar 31 05:25:30 2001
+++ uta/rect.h Sat Mar 31 05:27:27 2001
@@ -21,7 +21,7 @@
#ifndef _RECT_H
#define _RECT_H
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include "point.h"

View file

@ -1,14 +0,0 @@
--- uta/sound.h.orig Sat Mar 31 05:25:38 2001
+++ uta/sound.h Sat Mar 31 05:27:39 2001
@@ -36,9 +36,9 @@
#endif
#ifdef HAVE_MIXER
-#include <SDL/SDL_mixer.h>
+#include <SDL11/SDL_mixer.h>
#else
-#include <SDL/SDL_types.h>
+#include <SDL11/SDL_types.h>
#endif
namespace uta {

View file

@ -1,11 +0,0 @@
--- uta/surface.h.orig Sat Mar 31 05:25:49 2001
+++ uta/surface.h Sat Mar 31 05:27:49 2001
@@ -22,7 +22,7 @@
#ifndef _SURFACE_H_
#define _SURFACE_H_
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include "color.h"
#include "point.h"

View file

@ -1,11 +0,0 @@
--- uta/sge_blib.h.orig Sat Mar 31 05:44:18 2001
+++ uta/sge_blib.h Sat Mar 31 05:38:40 2001
@@ -18,7 +18,7 @@
#ifndef sge_blib_H
#define sge_blib_H
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include "sge_internal.h"

View file

@ -1,11 +0,0 @@
--- uta/sge_blib.cc.orig Sat Mar 31 05:40:36 2001
+++ uta/sge_blib.cc Sat Mar 31 05:40:51 2001
@@ -19,7 +19,7 @@
* This is written by Johan E. Thélin and is slightly modified by me.
*/
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include "sge_draw.h"
#include "sge_blib.h"

View file

@ -1,11 +0,0 @@
--- uta/sge_draw.cc.orig Sat Mar 31 05:41:03 2001
+++ uta/sge_draw.cc Sat Mar 31 05:41:56 2001
@@ -20,7 +20,7 @@
* John Garrison's PowerPak
*/
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include <math.h>
#include <string.h>
#include <stdarg.h>

View file

@ -1,11 +0,0 @@
--- uta/surface_io.cc.orig Sat Mar 31 05:41:28 2001
+++ uta/surface_io.cc Sat Mar 31 05:42:29 2001
@@ -79,7 +79,7 @@
#include <assert.h>
#include <png.h>
-#include <SDL/SDL_endian.h>
+#include <SDL11/SDL_endian.h>
namespace uta {

View file

@ -1,11 +0,0 @@
--- uta/timer.cc.orig Sat Mar 31 05:41:43 2001
+++ uta/timer.cc Sat Mar 31 05:42:38 2001
@@ -18,7 +18,7 @@
Boston, MA 02111-1307, SA.
*/
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include "timer.h"
#include <stl.h>

View file

@ -1,11 +0,0 @@
--- uta/pixelformat.h.orig Sat Mar 31 05:51:51 2001
+++ uta/pixelformat.h Sat Mar 31 05:52:22 2001
@@ -27,7 +27,7 @@
//just for typedefs ...
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include <string>
#include <stl.h>

View file

@ -1,11 +0,0 @@
--- uta/sge_draw.h.orig Sat Mar 31 05:52:07 2001
+++ uta/sge_draw.h Sat Mar 31 05:52:34 2001
@@ -18,7 +18,7 @@
#ifndef sge_draw_H
#define sge_draw_H
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include "sge_internal.h"

View file

@ -1,62 +0,0 @@
--- acinclude.m4.orig Tue Nov 21 11:10:07 2000
+++ acinclude.m4 Sat Mar 31 06:08:52 2001
@@ -606,8 +606,8 @@
CHECK_LIB_HEADER_VERSION(
SDL,
SDL_Init,
- SDL/SDL.h,
- SDL/SDL_version.h,
+ SDL11/SDL.h,
+ SDL11/SDL_version.h,
SDL_MAJOR_VERSION.SDL_MINOR_VERSION.SDL_PATCHLEVEL,
$1,
http://www.devolution.com/~slouken/SDL/SDL-0.10/src/SDL-$1.tar.gz)
@@ -618,7 +618,7 @@
[
TEST_SKIP(
[
- AC_CHECK_HEADER(SDL/SDL_mixer.h,
+ AC_CHECK_HEADER(SDL11/SDL_mixer.h,
[
AC_DEFINE(HAVE_MIXER))
AC_CHECK_LIB([
@@ -1027,13 +1027,13 @@
if test x$sdl_exec_prefix != x ; then
sdl_args="$sdl_args --exec-prefix=$sdl_exec_prefix"
if test x${SDL_CONFIG+set} != xset ; then
- SDL_CONFIG=$sdl_exec_prefix/bin/sdl-config
+ SDL_CONFIG=$sdl_exec_prefix/bin/sdl11-config
fi
fi
if test x$sdl_prefix != x ; then
sdl_args="$sdl_args --prefix=$sdl_prefix"
if test x${SDL_CONFIG+set} != xset ; then
- SDL_CONFIG=$sdl_prefix/bin/sdl-config
+ SDL_CONFIG=$sdl_prefix/bin/sdl11-config
fi
fi
@@ -1067,7 +1067,7 @@
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
char*
my_strdup (char *str)
@@ -1141,7 +1141,7 @@
LIBS="$LIBS $SDL_LIBS"
AC_TRY_LINK([
#include <stdio.h>
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
], [ return 0; ],
[ echo "*** The test program compiled, but did not run. This usually means"
echo "*** that the run-time linker is not finding SDL or finding the wrong"
@@ -1292,4 +1292,4 @@
AC_SUBST(SIGC_CFLAGS)
AC_SUBST(SIGC_LIBS)
-])
+])

View file

@ -1,11 +0,0 @@
--- configure.in.orig Sat Mar 31 06:01:00 2001
+++ configure.in Sat Mar 31 06:01:12 2001
@@ -186,7 +186,7 @@
])
AM_CONDITIONAL(SMPEG_AVAILABLE, test x$have_smpeg = xyes)
-AC_CHECK_HEADER(SDL/SDL_mixer.h,AC_CHECK_LIB(SDL_mixer, Mix_SetPostMix, [
+AC_CHECK_HEADER(SDL11/SDL_mixer.h,AC_CHECK_LIB(SDL_mixer, Mix_SetPostMix, [
MIXLIBS=-lSDL_mixer
AC_DEFINE(HAVE_MIXER)
]))

View file

@ -1,56 +0,0 @@
--- aclocal.m4.orig Wed Mar 21 13:44:06 2001
+++ aclocal.m4 Sat Mar 31 06:09:47 2001
@@ -618,8 +618,8 @@
CHECK_LIB_HEADER_VERSION(
SDL,
SDL_Init,
- SDL/SDL.h,
- SDL/SDL_version.h,
+ SDL11/SDL.h,
+ SDL11/SDL_version.h,
SDL_MAJOR_VERSION.SDL_MINOR_VERSION.SDL_PATCHLEVEL,
$1,
http://www.devolution.com/~slouken/SDL/SDL-0.10/src/SDL-$1.tar.gz)
@@ -630,7 +630,7 @@
[
TEST_SKIP(
[
- AC_CHECK_HEADER(SDL/SDL_mixer.h,
+ AC_CHECK_HEADER(SDL11/SDL_mixer.h,
[
AC_DEFINE(HAVE_MIXER))
AC_CHECK_LIB([
@@ -1039,13 +1039,13 @@
if test x$sdl_exec_prefix != x ; then
sdl_args="$sdl_args --exec-prefix=$sdl_exec_prefix"
if test x${SDL_CONFIG+set} != xset ; then
- SDL_CONFIG=$sdl_exec_prefix/bin/sdl-config
+ SDL_CONFIG=$sdl_exec_prefix/bin/sdl11-config
fi
fi
if test x$sdl_prefix != x ; then
sdl_args="$sdl_args --prefix=$sdl_prefix"
if test x${SDL_CONFIG+set} != xset ; then
- SDL_CONFIG=$sdl_prefix/bin/sdl-config
+ SDL_CONFIG=$sdl_prefix/bin/sdl11-config
fi
fi
@@ -1079,7 +1079,7 @@
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
char*
my_strdup (char *str)
@@ -1153,7 +1153,7 @@
LIBS="$LIBS $SDL_LIBS"
AC_TRY_LINK([
#include <stdio.h>
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
], [ return 0; ],
[ echo "*** The test program compiled, but did not run. This usually means"
echo "*** that the run-time linker is not finding SDL or finding the wrong"

View file

@ -1,6 +1,8 @@
bin/uta-config
lib/libuta.la
lib/libuta.so
lib/libuta-0.3.so.38
lib/libuta-0.4.so
lib/libuta-0.4.so.0
lib/libuta.a
include/uta/debug.h
include/uta/color.h

View file

@ -6,21 +6,51 @@
#
PORTNAME= libuta
PORTVERSION= 0.3.38
PORTVERSION= 0.4.1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= lehmann@ans-netz.de
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
sigc.1:${PORTSDIR}/devel/libsigc++ \
SDL-1.1.4:${PORTSDIR}/devel/sdl12 \
SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
SDL-1.1.4:${PORTSDIR}/devel/sdl12
USE_FREETYPE= yes
USE_LIBTOOL= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/freetype1"
GNU_CONFIGURE= yes
USE_REINPLACE= yes
.include <bsd.port.mk>
CONFIGURE_ENV= SDL_CONFIG="${LOCALBASE}/bin/sdl11-config" \
LIBS="-L${LOCALBASE}/lib"
SDL11_FILES= configure uta/color.h uta/event.h uta/keysym.h uta/mutex.h \
uta/pixelformat.h uta/rect.h uta/sge_blib.cc uta/sge_blib.h \
uta/sge_draw.cc uta/sge_draw.h uta/sound.h uta/surface_io.cc \
uta/surface.h uta/timer.cc
.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/lib/libSDL_mixer.so.2)
WITH_SDL_MIXER= yes
.endif
.if defined(WITH_SDL_MIXER)
LIB_DEPENDS+= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
.endif
pre-everything::
@${ECHO} ""
@${ECHO} "You may use the following build options:"
@${ECHO} ""
@${ECHO} " WITH_SDL_MIXER=yes Enable music and sound support"
@${ECHO} ""
post-patch:
.for i in ${SDL11_FILES}
${REINPLACE_CMD} -e 's|SDL/|SDL11/|' ${WRKSRC}/$i
.endfor
.include <bsd.port.post.mk>

View file

@ -1 +1 @@
MD5 (libuta-0.3.38.tar.gz) = 19e9b692fa046fb7c8e16c5cceaea232
MD5 (libuta-0.4.1.tar.gz) = 102eebdf70941cd11ed36af9ba8726d6

View file

@ -1,60 +0,0 @@
$FreeBSD$
--- configure.orig Thu Apr 12 12:21:35 2001
+++ configure Thu Mar 14 13:09:31 2002
@@ -7,6 +7,9 @@
# This configure script is free software; the Free Software Foundation
# gives unlimited permission to copy, distribute and modify it.
+LIBS="$LIBS -L/usr/local/lib"
+SDL_CONFIG="/usr/local/bin/sdl11-config"
+
# Defaults:
ac_help=
ac_default_prefix=/usr/local
@@ -3573,7 +3576,7 @@
CFLAGS=
CXXFLAGS=
-CPPFLAGS=-Wall
+CPPFLAGS="$CPPFLAGS -Wall"
case $win32 in
true)
@@ -4603,7 +4606,7 @@
no_sdl=yes
else
SDL_CFLAGS=`$SDL_CONFIG $sdlconf_args --cflags`
- SDL_LIBS=`$SDL_CONFIG $sdlconf_args --libs`
+ SDL_LIBS=`$SDL_CONFIG $sdlconf_args --libs | sed 's/-lXxf86vm -lXxf86dga -lXv //g'`
sdl_major_version=`$SDL_CONFIG $sdl_args --version | \
sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\1/'`
@@ -4627,7 +4630,7 @@
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
char*
my_strdup (char *str)
@@ -4717,7 +4720,7 @@
#include "confdefs.h"
#include <stdio.h>
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
int main() {
return 0;
@@ -5042,7 +5045,7 @@
cat > conftest.$ac_ext <<EOF
#line 5044 "configure"
#include "confdefs.h"
-#include <SDL/SDL_mixer.h>
+#include <SDL11/SDL_mixer.h>
EOF
ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
{ (eval echo configure:5049: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }

View file

@ -1,11 +0,0 @@
--- uta/color.h.orig Sat Mar 31 05:24:37 2001
+++ uta/color.h Sat Mar 31 05:26:10 2001
@@ -22,7 +22,7 @@
#define _COLOR_H
#include <iostream>
-#include <SDL/SDL_version.h>
+#include <SDL11/SDL_version.h>
namespace uta {
///

View file

@ -1,11 +0,0 @@
--- uta/event.h.orig Sat Mar 31 05:24:44 2001
+++ uta/event.h Sat Mar 31 05:26:20 2001
@@ -21,7 +21,7 @@
#ifndef _EVENT_H
#define _EVENT_H
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include "keysym.h"
#include "point.h"

View file

@ -1,11 +0,0 @@
--- uta/keysym.h.orig Sat Mar 31 05:24:56 2001
+++ uta/keysym.h Sat Mar 31 05:26:32 2001
@@ -20,7 +20,7 @@
#ifndef KEYSYM_H
#define KEYSYM_H
-#include <SDL/SDL_keysym.h>
+#include <SDL11/SDL_keysym.h>
namespace uta {

View file

@ -1,11 +0,0 @@
--- uta/mutex.h.orig Sat Mar 31 05:25:05 2001
+++ uta/mutex.h Sat Mar 31 05:26:54 2001
@@ -22,7 +22,7 @@
#ifndef _MUTEX_H_
#define _MUTEX_H_
-#include <SDL/SDL_mutex.h>
+#include <SDL11/SDL_mutex.h>
namespace uta {

View file

@ -1,11 +0,0 @@
--- uta/rect.h.orig Sat Mar 31 05:25:30 2001
+++ uta/rect.h Sat Mar 31 05:27:27 2001
@@ -21,7 +21,7 @@
#ifndef _RECT_H
#define _RECT_H
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include "point.h"

View file

@ -1,14 +0,0 @@
--- uta/sound.h.orig Sat Mar 31 05:25:38 2001
+++ uta/sound.h Sat Mar 31 05:27:39 2001
@@ -36,9 +36,9 @@
#endif
#ifdef HAVE_MIXER
-#include <SDL/SDL_mixer.h>
+#include <SDL11/SDL_mixer.h>
#else
-#include <SDL/SDL_types.h>
+#include <SDL11/SDL_types.h>
#endif
namespace uta {

View file

@ -1,11 +0,0 @@
--- uta/surface.h.orig Sat Mar 31 05:25:49 2001
+++ uta/surface.h Sat Mar 31 05:27:49 2001
@@ -22,7 +22,7 @@
#ifndef _SURFACE_H_
#define _SURFACE_H_
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include "color.h"
#include "point.h"

View file

@ -1,11 +0,0 @@
--- uta/sge_blib.h.orig Sat Mar 31 05:44:18 2001
+++ uta/sge_blib.h Sat Mar 31 05:38:40 2001
@@ -18,7 +18,7 @@
#ifndef sge_blib_H
#define sge_blib_H
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include "sge_internal.h"

View file

@ -1,11 +0,0 @@
--- uta/sge_blib.cc.orig Sat Mar 31 05:40:36 2001
+++ uta/sge_blib.cc Sat Mar 31 05:40:51 2001
@@ -19,7 +19,7 @@
* This is written by Johan E. Thélin and is slightly modified by me.
*/
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include "sge_draw.h"
#include "sge_blib.h"

View file

@ -1,11 +0,0 @@
--- uta/sge_draw.cc.orig Sat Mar 31 05:41:03 2001
+++ uta/sge_draw.cc Sat Mar 31 05:41:56 2001
@@ -20,7 +20,7 @@
* John Garrison's PowerPak
*/
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include <math.h>
#include <string.h>
#include <stdarg.h>

View file

@ -1,11 +0,0 @@
--- uta/surface_io.cc.orig Sat Mar 31 05:41:28 2001
+++ uta/surface_io.cc Sat Mar 31 05:42:29 2001
@@ -79,7 +79,7 @@
#include <assert.h>
#include <png.h>
-#include <SDL/SDL_endian.h>
+#include <SDL11/SDL_endian.h>
namespace uta {

View file

@ -1,11 +0,0 @@
--- uta/timer.cc.orig Sat Mar 31 05:41:43 2001
+++ uta/timer.cc Sat Mar 31 05:42:38 2001
@@ -18,7 +18,7 @@
Boston, MA 02111-1307, SA.
*/
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include "timer.h"
#include <stl.h>

View file

@ -1,11 +0,0 @@
--- uta/pixelformat.h.orig Sat Mar 31 05:51:51 2001
+++ uta/pixelformat.h Sat Mar 31 05:52:22 2001
@@ -27,7 +27,7 @@
//just for typedefs ...
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include <string>
#include <stl.h>

View file

@ -1,11 +0,0 @@
--- uta/sge_draw.h.orig Sat Mar 31 05:52:07 2001
+++ uta/sge_draw.h Sat Mar 31 05:52:34 2001
@@ -18,7 +18,7 @@
#ifndef sge_draw_H
#define sge_draw_H
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include "sge_internal.h"

View file

@ -1,62 +0,0 @@
--- acinclude.m4.orig Tue Nov 21 11:10:07 2000
+++ acinclude.m4 Sat Mar 31 06:08:52 2001
@@ -606,8 +606,8 @@
CHECK_LIB_HEADER_VERSION(
SDL,
SDL_Init,
- SDL/SDL.h,
- SDL/SDL_version.h,
+ SDL11/SDL.h,
+ SDL11/SDL_version.h,
SDL_MAJOR_VERSION.SDL_MINOR_VERSION.SDL_PATCHLEVEL,
$1,
http://www.devolution.com/~slouken/SDL/SDL-0.10/src/SDL-$1.tar.gz)
@@ -618,7 +618,7 @@
[
TEST_SKIP(
[
- AC_CHECK_HEADER(SDL/SDL_mixer.h,
+ AC_CHECK_HEADER(SDL11/SDL_mixer.h,
[
AC_DEFINE(HAVE_MIXER))
AC_CHECK_LIB([
@@ -1027,13 +1027,13 @@
if test x$sdl_exec_prefix != x ; then
sdl_args="$sdl_args --exec-prefix=$sdl_exec_prefix"
if test x${SDL_CONFIG+set} != xset ; then
- SDL_CONFIG=$sdl_exec_prefix/bin/sdl-config
+ SDL_CONFIG=$sdl_exec_prefix/bin/sdl11-config
fi
fi
if test x$sdl_prefix != x ; then
sdl_args="$sdl_args --prefix=$sdl_prefix"
if test x${SDL_CONFIG+set} != xset ; then
- SDL_CONFIG=$sdl_prefix/bin/sdl-config
+ SDL_CONFIG=$sdl_prefix/bin/sdl11-config
fi
fi
@@ -1067,7 +1067,7 @@
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
char*
my_strdup (char *str)
@@ -1141,7 +1141,7 @@
LIBS="$LIBS $SDL_LIBS"
AC_TRY_LINK([
#include <stdio.h>
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
], [ return 0; ],
[ echo "*** The test program compiled, but did not run. This usually means"
echo "*** that the run-time linker is not finding SDL or finding the wrong"
@@ -1292,4 +1292,4 @@
AC_SUBST(SIGC_CFLAGS)
AC_SUBST(SIGC_LIBS)
-])
+])

View file

@ -1,11 +0,0 @@
--- configure.in.orig Sat Mar 31 06:01:00 2001
+++ configure.in Sat Mar 31 06:01:12 2001
@@ -186,7 +186,7 @@
])
AM_CONDITIONAL(SMPEG_AVAILABLE, test x$have_smpeg = xyes)
-AC_CHECK_HEADER(SDL/SDL_mixer.h,AC_CHECK_LIB(SDL_mixer, Mix_SetPostMix, [
+AC_CHECK_HEADER(SDL11/SDL_mixer.h,AC_CHECK_LIB(SDL_mixer, Mix_SetPostMix, [
MIXLIBS=-lSDL_mixer
AC_DEFINE(HAVE_MIXER)
]))

View file

@ -1,56 +0,0 @@
--- aclocal.m4.orig Wed Mar 21 13:44:06 2001
+++ aclocal.m4 Sat Mar 31 06:09:47 2001
@@ -618,8 +618,8 @@
CHECK_LIB_HEADER_VERSION(
SDL,
SDL_Init,
- SDL/SDL.h,
- SDL/SDL_version.h,
+ SDL11/SDL.h,
+ SDL11/SDL_version.h,
SDL_MAJOR_VERSION.SDL_MINOR_VERSION.SDL_PATCHLEVEL,
$1,
http://www.devolution.com/~slouken/SDL/SDL-0.10/src/SDL-$1.tar.gz)
@@ -630,7 +630,7 @@
[
TEST_SKIP(
[
- AC_CHECK_HEADER(SDL/SDL_mixer.h,
+ AC_CHECK_HEADER(SDL11/SDL_mixer.h,
[
AC_DEFINE(HAVE_MIXER))
AC_CHECK_LIB([
@@ -1039,13 +1039,13 @@
if test x$sdl_exec_prefix != x ; then
sdl_args="$sdl_args --exec-prefix=$sdl_exec_prefix"
if test x${SDL_CONFIG+set} != xset ; then
- SDL_CONFIG=$sdl_exec_prefix/bin/sdl-config
+ SDL_CONFIG=$sdl_exec_prefix/bin/sdl11-config
fi
fi
if test x$sdl_prefix != x ; then
sdl_args="$sdl_args --prefix=$sdl_prefix"
if test x${SDL_CONFIG+set} != xset ; then
- SDL_CONFIG=$sdl_prefix/bin/sdl-config
+ SDL_CONFIG=$sdl_prefix/bin/sdl11-config
fi
fi
@@ -1079,7 +1079,7 @@
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
char*
my_strdup (char *str)
@@ -1153,7 +1153,7 @@
LIBS="$LIBS $SDL_LIBS"
AC_TRY_LINK([
#include <stdio.h>
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
], [ return 0; ],
[ echo "*** The test program compiled, but did not run. This usually means"
echo "*** that the run-time linker is not finding SDL or finding the wrong"

View file

@ -1,6 +1,8 @@
bin/uta-config
lib/libuta.la
lib/libuta.so
lib/libuta-0.3.so.38
lib/libuta-0.4.so
lib/libuta-0.4.so.0
lib/libuta.a
include/uta/debug.h
include/uta/color.h