Update to 1.0, announce message is here:
http://lists.nongnu.org/archive/html/qemu-devel/2011-12/msg00121.html Feature safe: yes
This commit is contained in:
parent
fd60a48f98
commit
188ce96b32
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=286779
8 changed files with 37 additions and 86 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= qemu
|
||||
PORTVERSION= 0.15.1
|
||||
PORTVERSION= 1.0
|
||||
CATEGORIES= emulators
|
||||
MASTER_SITES= SAVANNAH:release \
|
||||
http://wiki.qemu.org/download/:release \
|
||||
|
@ -26,6 +26,7 @@ COMMENT= QEMU CPU Emulator - development version
|
|||
HAS_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
USE_PERL5_BUILD= yes
|
||||
USE_GNOME+= glib20
|
||||
PATCH_STRIP= -p1
|
||||
MAKE_ENV+= BSD_MAKE="${MAKE}"
|
||||
MAN1= qemu.1 qemu-img.1
|
||||
|
@ -41,7 +42,7 @@ OPTIONS= SAMBA "samba dependency (for -smb)" Off \
|
|||
SASL "cyrus-sasl dependency (vnc encryption)" On \
|
||||
JPEG "jpeg dependency (vnc lossy compression)" On \
|
||||
PNG "png dependency (vnc compression)" On \
|
||||
GA "glib20 dependency (guest agent)" On \
|
||||
GA "python build dependency (guest agent)" On \
|
||||
CURL "libcurl dependency (remote images)" On \
|
||||
CDROM_DMA "IDE CDROM DMA" On \
|
||||
PCAP "pcap dependency (networking with bpf)" On \
|
||||
|
@ -121,7 +122,6 @@ CONFIGURE_ARGS+= --disable-guest-agent --python="${NONEXISTENT}"
|
|||
PLIST_SUB+= GA="@comment "
|
||||
.else
|
||||
USE_PYTHON_BUILD= yes
|
||||
USE_GNOME+= glib20
|
||||
PLIST_SUB+= GA=""
|
||||
.endif
|
||||
|
||||
|
|
|
@ -1,12 +1,12 @@
|
|||
SHA256 (qemu/0.15.1/qemu-0.15.1.tar.gz) = 7705b14d9b8e4df4a0b1790980e618084261e8daef0672a1aa7a830a0f3db5ba
|
||||
SIZE (qemu/0.15.1/qemu-0.15.1.tar.gz) = 9576745
|
||||
SHA256 (qemu/0.15.1/sgabios-read-only-r8.tar.gz) = b5a511f237f9e3fbceb8d406b818253c1661773fc12c3ec14f0580ab15151384
|
||||
SIZE (qemu/0.15.1/sgabios-read-only-r8.tar.gz) = 31201
|
||||
SHA256 (qemu/0.15.1/hw_e1000_c.patch) = a9c8f29b8493ac62526b2ed4078b3e69c8e9c709a049f4fa11765ce37067e5a5
|
||||
SIZE (qemu/0.15.1/hw_e1000_c.patch) = 407
|
||||
SHA256 (qemu/0.15.1/net_udp_c.patch) = 6cbe5b229381db94fb6865bb53741217f914749723eea734917143f6db457a51
|
||||
SIZE (qemu/0.15.1/net_udp_c.patch) = 4115
|
||||
SHA256 (qemu/0.15.1/net_udp_h.patch) = e43853ba86689cb9ace6a177f891ab8536f6fbce21c7e9fa3ee0d5b25c47b463
|
||||
SIZE (qemu/0.15.1/net_udp_h.patch) = 1518
|
||||
SHA256 (qemu/0.15.1/Makefile_objs.patch) = 7bfed73dfa87b78fd9b3231c1664ff9c871e8b38009b82bf9311573cbb679d58
|
||||
SIZE (qemu/0.15.1/Makefile_objs.patch) = 371
|
||||
SHA256 (qemu/1.0/qemu-1.0.tar.gz) = 47674b7da559d5e1b44cc401af9ac5ad962d14e9eede12567b13e4b841989737
|
||||
SIZE (qemu/1.0/qemu-1.0.tar.gz) = 10848714
|
||||
SHA256 (qemu/1.0/sgabios-read-only-r8.tar.gz) = b5a511f237f9e3fbceb8d406b818253c1661773fc12c3ec14f0580ab15151384
|
||||
SIZE (qemu/1.0/sgabios-read-only-r8.tar.gz) = 31201
|
||||
SHA256 (qemu/1.0/hw_e1000_c.patch) = a9c8f29b8493ac62526b2ed4078b3e69c8e9c709a049f4fa11765ce37067e5a5
|
||||
SIZE (qemu/1.0/hw_e1000_c.patch) = 407
|
||||
SHA256 (qemu/1.0/net_udp_c.patch) = 6cbe5b229381db94fb6865bb53741217f914749723eea734917143f6db457a51
|
||||
SIZE (qemu/1.0/net_udp_c.patch) = 4115
|
||||
SHA256 (qemu/1.0/net_udp_h.patch) = e43853ba86689cb9ace6a177f891ab8536f6fbce21c7e9fa3ee0d5b25c47b463
|
||||
SIZE (qemu/1.0/net_udp_h.patch) = 1518
|
||||
SHA256 (qemu/1.0/Makefile_objs.patch) = 7bfed73dfa87b78fd9b3231c1664ff9c871e8b38009b82bf9311573cbb679d58
|
||||
SIZE (qemu/1.0/Makefile_objs.patch) = 371
|
||||
|
|
|
@ -35,18 +35,6 @@ Index: qemu/hw/fdc.c
|
|||
FLOPPY_ERROR("writing sector %d\n", fd_sector(cur_drv));
|
||||
return;
|
||||
}
|
||||
Index: qemu-0.8.2/hw/pc.c
|
||||
@@ -335,8 +336,9 @@ void bochs_bios_write(void *opaque, uint
|
||||
/* LGPL'ed VGA BIOS messages */
|
||||
case 0x501:
|
||||
case 0x502:
|
||||
+ /* according to documentation, these can be safely ignored */
|
||||
fprintf(stderr, "VGA BIOS panic, line %d\n", val);
|
||||
- exit(1);
|
||||
+ break;
|
||||
case 0x500:
|
||||
case 0x503:
|
||||
#ifdef DEBUG_BIOS
|
||||
Index: qemu-0.8.2/hw/sb16.c
|
||||
===================================================================
|
||||
--- qemu-0.8.2.orig/hw/sb16.c 2006-07-22 20:23:34.000000000 +0300
|
||||
|
@ -65,13 +53,13 @@ Index: qemu-0.8.2/hw/sb16.c
|
|||
|
||||
return dma_pos;
|
||||
Index: qemu/hw/i8259.c
|
||||
@@ -302,7 +302,8 @@
|
||||
@@ -291,7 +291,8 @@ static void pic_ioport_write(void *opaqu
|
||||
s->init4 = val & 1;
|
||||
s->single_mode = val & 2;
|
||||
if (val & 0x08)
|
||||
if (val & 0x08) {
|
||||
- hw_error("level sensitive irq not supported");
|
||||
+ /* hw_error("level sensitive irq not supported"); */
|
||||
+ return;
|
||||
+ return;
|
||||
}
|
||||
} else if (val & 0x08) {
|
||||
if (val & 0x04)
|
||||
s->poll = 1;
|
||||
if (val & 0x04) {
|
||||
|
|
|
@ -1,10 +0,0 @@
|
|||
--- a/Makefile.objs
|
||||
+++ b/Makefile.objs
|
||||
@@ -166,6 +166,7 @@ user-obj-y =
|
||||
user-obj-y += envlist.o path.o
|
||||
user-obj-y += tcg-runtime.o host-utils.o
|
||||
user-obj-y += cutils.o cache-utils.o
|
||||
+user-obj-y += qemu-thread-posix.o
|
||||
|
||||
######################################################################
|
||||
# libhw
|
|
@ -1,31 +0,0 @@
|
|||
--- qemu/hw/ide/ahci.c.prev 2011-09-11 16:39:53.000000000 +0300
|
||||
+++ qemu/hw/ide/ahci.c 2011-09-11 16:39:48.000000000 +0300
|
||||
@@ -505,10 +505,7 @@ static void ahci_reset_port(AHCIState *s
|
||||
ide_bus_reset(&d->port);
|
||||
ide_state->ncq_queues = AHCI_MAX_CMDS;
|
||||
|
||||
- pr->irq_stat = 0;
|
||||
- pr->irq_mask = 0;
|
||||
pr->scr_stat = 0;
|
||||
- pr->scr_ctl = 0;
|
||||
pr->scr_err = 0;
|
||||
pr->scr_act = 0;
|
||||
d->busy_slot = -1;
|
||||
@@ -1157,12 +1154,17 @@ void ahci_uninit(AHCIState *s)
|
||||
void ahci_reset(void *opaque)
|
||||
{
|
||||
struct AHCIPCIState *d = opaque;
|
||||
+ AHCIPortRegs *pr;
|
||||
int i;
|
||||
|
||||
d->ahci.control_regs.irqstatus = 0;
|
||||
d->ahci.control_regs.ghc = 0;
|
||||
|
||||
for (i = 0; i < d->ahci.ports; i++) {
|
||||
+ pr = &d->ahci.dev[i].port_regs;
|
||||
+ pr->irq_stat = 0;
|
||||
+ pr->irq_mask = 0;
|
||||
+ pr->scr_ctl = 0;
|
||||
ahci_reset_port(&d->ahci, i);
|
||||
}
|
||||
}
|
|
@ -1,16 +1,16 @@
|
|||
--- configure.orig 2010-01-29 14:36:00.000000000 -0500
|
||||
+++ configure 2010-01-29 14:36:00.000000000 -0500
|
||||
@@ -180,6 +180,9 @@ smartcard_nss=""
|
||||
usb_redir=""
|
||||
opengl=""
|
||||
@@ -185,6 +185,9 @@ opengl=""
|
||||
zlib="yes"
|
||||
guest_agent="yes"
|
||||
libiscsi=""
|
||||
+pcap="no"
|
||||
+pcap_create="no"
|
||||
+bpf="no"
|
||||
|
||||
# parse CC options first
|
||||
for opt do
|
||||
@@ -611,6 +614,8 @@ for opt do
|
||||
@@ -638,6 +641,8 @@ for opt do
|
||||
;;
|
||||
--enable-vnc-thread) vnc_thread="yes"
|
||||
;;
|
||||
|
@ -19,7 +19,7 @@
|
|||
--disable-slirp) slirp="no"
|
||||
;;
|
||||
--disable-uuid) uuid="no"
|
||||
@@ -1438,6 +1443,49 @@ EOF
|
||||
@@ -1529,6 +1534,49 @@ EOF
|
||||
fi
|
||||
|
||||
##########################################
|
||||
|
@ -69,8 +69,8 @@
|
|||
# VNC TLS detection
|
||||
if test "$vnc" = "yes" -a "$vnc_tls" != "no" ; then
|
||||
cat > $TMPC <<EOF
|
||||
@@ -2797,6 +2845,15 @@ fi
|
||||
if test $profiler = "yes" ; then
|
||||
@@ -2950,6 +2998,15 @@ fi
|
||||
if test "$profiler" = "yes" ; then
|
||||
echo "CONFIG_PROFILER=y" >> $config_host_mak
|
||||
fi
|
||||
+if test "$pcap" = "yes" ; then
|
||||
|
@ -84,7 +84,7 @@
|
|||
+fi
|
||||
if test "$slirp" = "yes" ; then
|
||||
echo "CONFIG_SLIRP=y" >> $config_host_mak
|
||||
QEMU_INCLUDES="-I\$(SRC_PATH)/slirp $QEMU_INCLUDES"
|
||||
echo "CONFIG_SMBD_COMMAND=\"$smbd\"" >> $config_host_mak
|
||||
Index: net.c
|
||||
@@ -37,6 +37,11 @@
|
||||
#include "hw/qdev.h"
|
||||
|
@ -175,7 +175,7 @@ Index: net.c
|
|||
+#endif
|
||||
+ int i;
|
||||
+
|
||||
+ s = qemu_mallocz(sizeof(PCAPState));
|
||||
+ s = g_malloc0(sizeof(PCAPState));
|
||||
+ nc = qemu_new_net_client(&net_pcap_info, vlan, NULL, model, name);
|
||||
+
|
||||
+ s = DO_UPCAST(PCAPState, nc, nc);
|
||||
|
@ -299,7 +299,7 @@ Index: net.c
|
|||
+ if (s) {
|
||||
+ if (s->handle)
|
||||
+ pcap_close(s->handle);
|
||||
+ qemu_free(s);
|
||||
+ g_free(s);
|
||||
+ }
|
||||
+
|
||||
+ return -1;
|
||||
|
|
|
@ -92,8 +92,8 @@ FreeBSD host notes
|
|||
processing error - resetting ehci HC
|
||||
Assertion failed: (0), function ehci_advance_state, file /data/ports/emulators/qemu-devel/work/qemu-0.15.0/hw/usb-ehci.c, line 2045.
|
||||
|
||||
Starting the same without ehci (-readconfig) works, tho usbredirserver
|
||||
crashes when qemu exits.]
|
||||
Starting the same without ehci (-readconfig) works (may need
|
||||
-usb), tho usbredirserver crashes when qemu exits.]
|
||||
|
||||
- Still usb: since the hub is no longer attached to the uchi controller and
|
||||
the wakeup mechanism, resume interrupt is not implemented yet linux guests
|
||||
|
|
|
@ -1,10 +1,11 @@
|
|||
bin/qemu
|
||||
%%GA%%bin/qemu-ga
|
||||
bin/qemu-img
|
||||
bin/qemu-io
|
||||
bin/qemu-nbd
|
||||
bin/qemu-system-alpha
|
||||
bin/qemu-system-arm
|
||||
bin/qemu-system-cris
|
||||
bin/qemu-system-i386
|
||||
bin/qemu-system-lm32
|
||||
bin/qemu-system-m68k
|
||||
bin/qemu-system-microblaze
|
||||
|
@ -26,6 +27,8 @@ bin/qemu-system-sparc64
|
|||
%%ALLTARGETS%%bin/qemu-sparc64
|
||||
%%ALLTARGETS%%bin/qemu-x86_64
|
||||
bin/qemu-system-x86_64
|
||||
bin/qemu-system-xtensa
|
||||
bin/qemu-system-xtensaeb
|
||||
@unexec if cmp -s %D/etc/qemu-ifup.sample %D/etc/qemu-ifup; then rm -f %D/etc/qemu-ifup; fi
|
||||
etc/qemu-ifup.sample
|
||||
@exec if [ ! -f %D/etc/qemu-ifup ] ; then cp -p %D/%F %B/qemu-ifup; fi
|
||||
|
@ -42,6 +45,7 @@ etc/qemu/target-x86_64.conf.sample
|
|||
%%DATADIR%%/vgabios-qxl.bin
|
||||
%%DATADIR%%/vgabios-stdvga.bin
|
||||
%%DATADIR%%/vgabios-vmware.bin
|
||||
%%DATADIR%%/palcode-clipper
|
||||
%%DATADIR%%/ppc_rom.bin
|
||||
%%DATADIR%%/openbios-ppc
|
||||
%%DATADIR%%/openbios-sparc32
|
||||
|
|
Loading…
Reference in a new issue