- Update to 5.8

PR:		ports/147161
Submitted by:	Jeroen Schot <schot@A-Eskwadraat.nl> (maintainer)
This commit is contained in:
Sylvio Cesar Teixeira 2010-05-30 23:37:39 +00:00
parent d97e658177
commit 18cb8ac049
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=255353
3 changed files with 15 additions and 17 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= dwm
PORTVERSION= 5.7.2
PORTVERSION= 5.8
CATEGORIES= x11-wm
MASTER_SITES= http://dl.suckless.org/${PORTNAME}/ \
http://schot.a-eskwadraat.nl/files/

View file

@ -1,3 +1,3 @@
MD5 (dwm-5.7.2.tar.gz) = a0b8a799ddc5034dd8a818c9bd76f3a3
SHA256 (dwm-5.7.2.tar.gz) = 32bffe33d5da9cec55de7e6b215568ff9950cc24b93aca72e7097437a2bfcde0
SIZE (dwm-5.7.2.tar.gz) = 19989
MD5 (dwm-5.8.tar.gz) = a0143b29c17545ac292b69cae3646d83
SHA256 (dwm-5.8.tar.gz) = 34a00ad6a0b51a187a5b9396ff48256330cf09c23caccd6c1c75db84302b9b2e
SIZE (dwm-5.8.tar.gz) = 20165

View file

@ -1,5 +1,5 @@
--- config.mk.orig 2009-07-14 20:07:55.000000000 +0200
+++ config.mk 2009-07-20 13:29:40.000000000 +0200
--- config.mk.orig 2010-05-28 12:43:17.000000000 +0200
+++ config.mk 2010-05-28 14:05:14.000000000 +0200
@@ -4,11 +4,11 @@
# Customize below to fit your system
@ -14,23 +14,21 @@
+X11INC = $(LOCALBASE)/include
+X11LIB = $(LOCALBASE)/lib
# Xinerama, un-comment if you want it
# Xinerama
XINERAMALIBS = -L${X11LIB} -lXinerama
@@ -19,15 +19,15 @@
LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 ${XINERAMALIBS}
@@ -20,9 +20,9 @@
# flags
-CPPFLAGS = -DVERSION=\"${VERSION}\" ${XINERAMAFLAGS}
+CPPFLAGS+= -DVERSION=\"${VERSION}\" ${XINERAMAFLAGS}
#CFLAGS = -g -std=c99 -pedantic -Wall -O0 ${INCS} ${CPPFLAGS}
-CFLAGS = -std=c99 -pedantic -Wall -Os ${INCS} ${CPPFLAGS}
CPPFLAGS = -DVERSION=\"${VERSION}\" ${XINERAMAFLAGS}
-CFLAGS = -g -std=c99 -pedantic -Wall -O0 ${INCS} ${CPPFLAGS}
+CFLAGS+= -std=c99 ${INCS} ${CPPFLAGS}
#LDFLAGS = -g ${LIBS}
-LDFLAGS = -s ${LIBS}
+LDFLAGS+= ${LIBS}
#CFLAGS = -std=c99 -pedantic -Wall -Os ${INCS} ${CPPFLAGS}
-LDFLAGS = -g ${LIBS}
+LDFLAGS+= ${LIBS}
#LDFLAGS = -s ${LIBS}
# Solaris
#CFLAGS = -fast ${INCS} -DVERSION=\"${VERSION}\"
@@ -30,4 +30,4 @@
#LDFLAGS = ${LIBS}
# compiler and linker