devel/py-simplejson: Update to 3.9.0
- Update PORTVERSION and distinfo checksum (3.9.0) - Add USES=python comment about specific versions supported - Add LICENSE_FILE - Patch setup.py to run tests properly using test_suite - Update test target to use PYDISTUTILS_SETUP (not PYSETUP) https://github.com/simplejson/simplejson/blob/v3.9.0/CHANGES.txt Reported by: portscout Approved by: python (maintainer, with hat)
This commit is contained in:
parent
bfb0c41f86
commit
18e31e4fdc
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=424464
3 changed files with 44 additions and 4 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= simplejson
|
||||
PORTVERSION= 3.8.2
|
||||
PORTVERSION= 3.9.0
|
||||
CATEGORIES= devel python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
@ -12,7 +12,9 @@ COMMENT= Simple, fast, extensible JSON encoder/decoder
|
|||
|
||||
# dual-licensed under MIT and Academic Free License version 2.1
|
||||
LICENSE= MIT
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
|
||||
|
||||
# 2.5-2.7,3.3+
|
||||
USES= python
|
||||
USE_PYTHON= autoplist distutils
|
||||
|
||||
|
@ -20,6 +22,6 @@ post-install:
|
|||
${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/simplejson/_speedups.so
|
||||
|
||||
do-test:
|
||||
cd ${WRKSRC}/ && ${PYTHON_CMD} ${PYSETUP} test
|
||||
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,3 @@
|
|||
SHA256 (simplejson-3.8.2.tar.gz) = d58439c548433adcda98e695be53e526ba940a4b9c44fb9a05d92cd495cdd47f
|
||||
SIZE (simplejson-3.8.2.tar.gz) = 76578
|
||||
TIMESTAMP = 1477131606
|
||||
SHA256 (simplejson-3.9.0.tar.gz) = e9abeee37424f4bfcd27d001d943582fb8c729ffc0b74b72bd0e9b626ed0d1b6
|
||||
SIZE (simplejson-3.9.0.tar.gz) = 77211
|
||||
|
|
37
devel/py-simplejson/files/patch-setup.py
Normal file
37
devel/py-simplejson/files/patch-setup.py
Normal file
|
@ -0,0 +1,37 @@
|
|||
--- setup.py.orig 2016-10-21 07:55:07 UTC
|
||||
+++ setup.py
|
||||
@@ -64,25 +64,8 @@ class ve_build_ext(build_ext):
|
||||
raise BuildFailed()
|
||||
|
||||
|
||||
-class TestCommand(Command):
|
||||
- user_options = []
|
||||
-
|
||||
- def initialize_options(self):
|
||||
- pass
|
||||
-
|
||||
- def finalize_options(self):
|
||||
- pass
|
||||
-
|
||||
- def run(self):
|
||||
- import sys, subprocess
|
||||
- raise SystemExit(
|
||||
- subprocess.call([sys.executable,
|
||||
- # Turn on deprecation warnings
|
||||
- '-Wd',
|
||||
- 'simplejson/tests/__init__.py']))
|
||||
-
|
||||
def run_setup(with_binary):
|
||||
- cmdclass = dict(test=TestCommand)
|
||||
+ cmdclass = dict()
|
||||
if with_binary:
|
||||
kw = dict(
|
||||
ext_modules = [
|
||||
@@ -105,6 +88,7 @@ def run_setup(with_binary):
|
||||
license="MIT License",
|
||||
packages=['simplejson', 'simplejson.tests'],
|
||||
platforms=['any'],
|
||||
+ test_suite='simplejson.tests',
|
||||
**kw)
|
||||
|
||||
try:
|
Loading…
Reference in a new issue