A Qt based application for tutorial to Open CASCADE Technology.

This commit is contained in:
Thierry Thomas 2007-04-01 09:05:46 +00:00
parent 4837f7e1fb
commit 1912e1fdcf
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=188920
7 changed files with 183 additions and 0 deletions

View file

@ -53,6 +53,7 @@
SUBDIR += netgen
SUBDIR += ngspice_rework
SUBDIR += opencascade
SUBDIR += opencascade-tutorial
SUBDIR += oregano
SUBDIR += pcb
SUBDIR += pdnmesh

View file

@ -0,0 +1,68 @@
# New ports collection makefile for: opencascade-tutorial
# Date created: 15 March 2007
# Whom: Thierry Thomas <thierry@pompo.net>
#
# $FreeBSD$
#
PORTNAME= opencascade-tutorial
PORTVERSION= 6.1
CATEGORIES= cad
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= thierry
MAINTAINER= thierry@FreeBSD.org
COMMENT= OpenCascade sample tutorial
LIB_DEPENDS= TKernel.0:${PORTSDIR}/cad/opencascade
USE_BZIP2= yes
USE_GL= yes
USE_QT_VER= 3
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --with-gl-include=${X11BASE}/include \
--with-gl-library=${X11BASE}/lib \
--with-qt-dir=${QTDIR} \
--enable-qt-mt \
--with-cascade-dir=${CASROOT}
WRKSRC= ${WRKDIR}/opencascade-${PORTVERSION}/samples/tutorial
CONFIGURE_LOG= adm/${OPSYS}/config.log
QTDIR?= ${QT_PREFIX}
LOCCROOT= OpenCAS
OCCROOT= ${PREFIX}/${LOCCROOT}
CASROOT= ${OCCROOT}/ros
LINSTDIR= ${LOCCROOT}/samples/tutorial
INSTDIR= ${PREFIX}/${LINSTDIR}
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
SUB_LIST= INSTDIR=${INSTDIR}
PLIST_SUB= INSTDIR=${LINSTDIR}
pre-configure:
${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' \
${WRKSRC}/${CONFIGURE_SCRIPT}
do-install:
${MKDIR} ${INSTDIR}/src ${INSTDIR}/${OPSYS}/obj \
${INSTDIR}/${OPSYS}/bin ${INSTDIR}/${OPSYS}/res \
${INSTDIR}/adm/${OPSYS} ${INSTDIR}/res
${TOUCH} ${INSTDIR}/${OPSYS}/obj/.fake_build
${INSTALL_DATA} ${WRKSRC}/src/* ${INSTDIR}/src
${INSTALL_DATA} ${WRKSRC}/res/* ${INSTDIR}/res
${INSTALL_DATA} ${WRKSRC}/${OPSYS}/res/* ${INSTDIR}/${OPSYS}/res
${INSTALL_DATA} ${WRKSRC}/adm/${OPSYS}/config.${OPSYS} \
${INSTDIR}/adm/${OPSYS}
${INSTALL_PROGRAM} ${WRKSRC}/${OPSYS}/bin/Tutorial \
${INSTDIR}/${OPSYS}/bin
${INSTALL_SCRIPT} ${WRKSRC}/run.sh ${INSTDIR}
post-install:
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
.include <bsd.port.mk>

View file

@ -0,0 +1,3 @@
MD5 (opencascade-tutorial-6.1.tar.bz2) = 8de6a078db90c97be4b3db8febc8817b
SHA256 (opencascade-tutorial-6.1.tar.bz2) = d1b2a69895898ad77bf493100d4d6995a8b9ff061676877ff91d106445cb06fe
SIZE (opencascade-tutorial-6.1.tar.bz2) = 40392

View file

@ -0,0 +1,38 @@
--- configure.orig Wed Oct 5 13:45:26 2005
+++ configure Thu Mar 15 23:27:32 2007
@@ -436,6 +436,8 @@
case $host in
Linux*) #ac_station=lin
ac_c_flags="-DLIN -DLININTEL";;
+ FreeBSD*) #ac_station=bsd
+ ac_c_flags="-DFREEBSD" ;;
IRIX*) #ac_station=sil
ac_c_flags="-DIRIX" ;;
SunOS*) #ac_station=sun
@@ -1271,7 +1273,7 @@
fi
-LIBS="$LIBS -lm -ldl -lc"
+LIBS="$LIBS -lm -lc"
if test -n "$x_includes"; then
X_INCLUDES="-I$x_includes"
@@ -1824,7 +1826,7 @@
echo $ac_n "checking for CasCade""... $ac_c" 1>&6
echo "configure:1813: checking for CasCade" >&5
-LIBOCC="-lTKernel -ldl"
+LIBOCC="-lTKernel"
ac_occ_includes=NO
ac_occ_libraries=NO
occ_libraries=""
@@ -1928,6 +1930,8 @@
LIBSTL="-l$STLPortLib_CC"
else
if test "$host" = "Linux"; then
+ LIBSTL="-lstlport_gcc"
+ elif test "$host" = "FreeBSD"; then
LIBSTL="-lstlport_gcc"
else
LIBSTL="-lstlport_cc"

View file

@ -0,0 +1,5 @@
---------------------------------------------------------------------------
This tutorial has been installed under %%INSTDIR%%.
You can run %%INSTDIR%%/run.sh and draw a bottle!
---------------------------------------------------------------------------

View file

@ -0,0 +1,3 @@
A Qt based application for tutorial to Open CASCADE Technology.
WWW: http://www.opencascade.org/

View file

@ -0,0 +1,65 @@
%%INSTDIR%%/FreeBSD/bin/Tutorial
%%INSTDIR%%/FreeBSD/obj/.fake_build
%%INSTDIR%%/FreeBSD/res/icon.qm
%%INSTDIR%%/FreeBSD/res/string.qm
%%INSTDIR%%/adm/FreeBSD/config.FreeBSD
%%INSTDIR%%/res/Bottle.png
%%INSTDIR%%/res/SampleImportExport.png
%%INSTDIR%%/res/cascade.png
%%INSTDIR%%/res/close.png
%%INSTDIR%%/res/cursor_rotate.png
%%INSTDIR%%/res/cursor_zoom.png
%%INSTDIR%%/res/document.png
%%INSTDIR%%/res/help.png
%%INSTDIR%%/res/lamp.png
%%INSTDIR%%/res/new.png
%%INSTDIR%%/res/tile.png
%%INSTDIR%%/res/tool-shading.png
%%INSTDIR%%/res/tool_color.png
%%INSTDIR%%/res/tool_delete.png
%%INSTDIR%%/res/tool_material.png
%%INSTDIR%%/res/tool_shading.png
%%INSTDIR%%/res/tool_transparency.png
%%INSTDIR%%/res/tool_wireframe.png
%%INSTDIR%%/res/view_axo.png
%%INSTDIR%%/res/view_back.png
%%INSTDIR%%/res/view_bottom.png
%%INSTDIR%%/res/view_comp_off.png
%%INSTDIR%%/res/view_comp_on.png
%%INSTDIR%%/res/view_fitall.png
%%INSTDIR%%/res/view_fitarea.png
%%INSTDIR%%/res/view_front.png
%%INSTDIR%%/res/view_glpan.png
%%INSTDIR%%/res/view_left.png
%%INSTDIR%%/res/view_pan.png
%%INSTDIR%%/res/view_reset.png
%%INSTDIR%%/res/view_right.png
%%INSTDIR%%/res/view_rotate.png
%%INSTDIR%%/res/view_top.png
%%INSTDIR%%/res/view_zoom.png
%%INSTDIR%%/run.sh
%%INSTDIR%%/src/Application.cxx
%%INSTDIR%%/src/Application.h
%%INSTDIR%%/src/Document.cxx
%%INSTDIR%%/src/Document.h
%%INSTDIR%%/src/MDIWindow.cxx
%%INSTDIR%%/src/MDIWindow.h
%%INSTDIR%%/src/Main.cxx
%%INSTDIR%%/src/MakeBottle.cxx
%%INSTDIR%%/src/Material.cxx
%%INSTDIR%%/src/Material.h
%%INSTDIR%%/src/Transparency.cxx
%%INSTDIR%%/src/Transparency.h
%%INSTDIR%%/src/View.cxx
%%INSTDIR%%/src/View.h
%%INSTDIR%%/src/icon.po
%%INSTDIR%%/src/string.po
@dirrm %%INSTDIR%%/src
@dirrm %%INSTDIR%%/res
@dirrm %%INSTDIR%%/adm/FreeBSD
@dirrm %%INSTDIR%%/adm
@dirrm %%INSTDIR%%/FreeBSD/res
@dirrm %%INSTDIR%%/FreeBSD/obj
@dirrm %%INSTDIR%%/FreeBSD/bin
@dirrm %%INSTDIR%%/FreeBSD
@dirrm %%INSTDIR%%