graphics/geeqie: update 1.6 → 1.7.1

This commit is contained in:
Dmitry Marakasov 2022-01-18 00:34:46 +03:00
parent 0dbd3e11b0
commit 1926b06b75
6 changed files with 38 additions and 34 deletions

View file

@ -1,10 +1,9 @@
# Created by: Martin Tournoij <carpetsmoker@rwxrwxrwx.net>
PORTNAME= geeqie
PORTVERSION= 1.6
PORTREVISION= 16
DISTVERSIONPREFIX= v
DISTVERSION= 1.7.1
CATEGORIES= graphics
MASTER_SITES= http://www.geeqie.org/
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Lightweight image viewer forked from GQview
@ -17,21 +16,23 @@ RUN_DEPENDS= bash:shells/bash
CONFLICTS= geeqie-devel
USES= autoreconf compiler:c++11-lang gettext gmake gnome jpeg \
USES= autoreconf compiler:c++11-lang gmake gnome jpeg \
localbase pkgconfig desktop-file-utils tar:xz lua:53 shebangfix
USE_GNOME= cairo gdkpixbuf2 intltool
USE_GITHUB= yes
GH_ACCOUNT= BestImageViewer
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-readmedir="${DOCSDIR}"
CONFIGURE_ARGS+=--disable-j2k # not in ports (yet), disable proactively to avoid hidden dependency
SHEBANG_FILES= plugins/*/geeqie-*
PORTDOCS= *
OPTIONS_DEFINE= EXIV2 LCMS LIRC MAP TIFF PDF FFMPEGTHUMBNAILER DOCS NLS HEIF WEBP DJVU OPENJPEG
OPTIONS_DEFAULT=EXIV2 LCMS GTK3 PDF FFMPEGTHUMBNAILER HEIF WEBP DJVU OPENJPEG
OPTIONS_DEFINE= EXIV2 LCMS LIRC MAP FFMPEGTHUMBNAILER DOCS NLS ARCHIVE
OPTIONS_DEFAULT=EXIV2 LCMS GTK3 PDF FFMPEGTHUMBNAILER HEIF WEBP DJVU OPENJPEG RAW ARCHIVE JPEGXL
OPTIONS_SINGLE= TOOLKIT
OPTIONS_SINGLE_TOOLKIT=GTK2 GTK3
OPTIONS_GROUP= FORMATS
OPTIONS_GROUP_FORMATS= TIFF PDF HEIF WEBP DJVU OPENJPEG RAW JPEGXL
OPTIONS_SUB= yes
EXIV2_DESC= Metadata editing
@ -39,6 +40,7 @@ LCMS_DESC= Color adjusting
LIRC_DESC= Remote control (broken)
MAP_DESC= GPS map support via libchamplain
TOOLKIT_DESC= Graphical user interface toolkit
FORMATS_DESC= Image formats support
GTK2_DESC= Use GTK 2
GTK3_DESC= Use GTK 3
HEIF_DESC= HEIF image format support
@ -84,6 +86,8 @@ GTK2_LIB_DEPENDS= libfreetype.so:print/freetype2 \
libfontconfig.so:x11-fonts/fontconfig
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext
NLS_USES_OFF= gettext-tools
HEIF_CONFIGURE_ENABLE= heif
HEIF_LIB_DEPENDS= libheif.so:graphics/libheif
@ -97,4 +101,14 @@ DJVU_LIB_DEPENDS= libdjvulibre.so:graphics/djvulibre
OPENJPEG_CONFIGURE_ENABLE= j2k
OPENJPEG_LIB_DEPENDS= libopenjp2.so:graphics/openjpeg
RAW_CONFIGURE_ENABLE= raw
RAW_LIB_DEPENDS= libraw.so:graphics/libraw
ARCHIVE_CONFIGURE_ENABLE= archive
ARCHIVE_USES= libarchive
JPEGXL_DESC= JPEG XL support
JPEGXL_CONFIGURE_ENABLE=jxl
JPEGXL_LIB_DEPENDS= libjxl.so:graphics/libjxl
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1606937789
SHA256 (geeqie-1.6.tar.xz) = 48f8a4474454d182353100e43878754b76227f3b8f30cfc258afc9d90a4e1920
SIZE (geeqie-1.6.tar.xz) = 1693488
TIMESTAMP = 1642440876
SHA256 (BestImageViewer-geeqie-v1.7.1_GH0.tar.gz) = 6625f174abfda86883fd94f4cbd1054528db0f90915ae5d00f4a080dcb80411d
SIZE (BestImageViewer-geeqie-v1.7.1_GH0.tar.gz) = 37803488

View file

@ -1,7 +1,11 @@
--- configure.ac.orig 2020-11-20 21:36:33 UTC
--- configure.ac.orig 2022-01-16 14:23:16 UTC
+++ configure.ac
@@ -18,7 +18,7 @@ AC_PREREQ(2.57)
AC_INIT([geeqie], 1.6, [https://github.com/BestImageViewer/geeqie/issues], [], [http://www.geeqie.org/])
@@ -15,10 +15,10 @@ dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOS
dnl GNU General Public License for more details.
AC_PREREQ(2.57)
-AC_INIT([geeqie], m4_translit(m4_esyscmd([if [ $(git tag --list 'v[1-9]*' --points-at HEAD | wc -c) -gt 0 ]; then git tag --list v[1-9]* --points-at HEAD | tail -n 1 | tr -d 'v' ; else git tag --list v[1-9]* | tail -n 1 | tr -d 'v' && echo "+git" && git log --max-count=1 --date=format:"%Y%m%d" --format="%ad" && echo "-" && git rev-parse --quiet --verify --short HEAD; fi ]), m4_newline), [geeqie@freelists.org], [], [http://www.geeqie.org/])
+AC_INIT([geeqie], 0, [geeqie@freelists.org], [], [http://www.geeqie.org/])
# Add -Werror to the default CFLAGS
-CFLAGS+=" -Werror -Wno-error=deprecated-declarations -Wno-error=sign-compare -Wno-error=return-type"
@ -9,7 +13,7 @@
# Check for rightly dirs
AC_CONFIG_SRCDIR([src/main.c])
@@ -525,7 +525,7 @@ AC_ARG_ENABLE([lua],
@@ -550,7 +550,7 @@ AC_ARG_ENABLE([lua],
[liblua=$enableval], [liblua=auto])
if test "x${liblua}" != "xno"; then
@ -18,7 +22,7 @@
[
HAVE_LUA=yes
AC_DEFINE(HAVE_LUA, 1, [define to enable lua support])
@@ -688,7 +688,7 @@ AC_SUBST(DJVU_LIBS)
@@ -763,7 +763,7 @@ AC_SUBST(JPEGXL_LIBS)
# Markdown support
# ----------------------------------------------------------------------

View file

@ -1,10 +0,0 @@
--- src/misc.c.orig 2020-11-20 21:36:33 UTC
+++ src/misc.c
@@ -378,6 +378,7 @@ gchar *get_symbolic_link(const gchar *path_utf8)
gint get_cpu_cores(void)
{
+ return MAX(1, sysconf(_SC_NPROCESSORS_ONLN));
FILE *cpuinfo = fopen("/proc/cpuinfo", "rb");
char *arg = 0;
size_t size = 0;

View file

@ -12,4 +12,4 @@ History
contact gqview author and the only maintainer. Geeqie projects goal is to move
the development forward and also integrate the existing patches.
WWW: http://www.geeqie.org/
WWW: https://www.geeqie.org/

View file

@ -1,23 +1,19 @@
bin/geeqie
lib/geeqie/geeqie-rotate
lib/geeqie/geeqie-symlink
lib/geeqie/geeqie-ufraw
lib/geeqie/geocode-parameters.awk
lib/geeqie/geeqie-camera-import
lib/geeqie/geeqie-camera-import-hook-script
lib/geeqie/geeqie-export-jpeg
lib/geeqie/geeqie-image-crop
lib/geeqie/geeqie-random-image
lib/geeqie/geeqie-rotate
lib/geeqie/geeqie-symlink
lib/geeqie/geeqie-tethered-photography
lib/geeqie/geeqie-tethered-photography-hook-script
lib/geeqie/geocode-parameters.awk
lib/geeqie/lensID
man/man1/geeqie.1.gz
share/applications/geeqie.desktop
%%DATADIR%%/applications/camera-import.desktop
%%DATADIR%%/applications/export-jpeg.desktop
%%DATADIR%%/applications/geeqie-ufraw-id.desktop
%%DATADIR%%/applications/geeqie-ufraw-recursive.desktop
%%DATADIR%%/applications/geeqie-ufraw.desktop
%%DATADIR%%/applications/image-crop.desktop
%%DATADIR%%/applications/random-image.desktop
%%DATADIR%%/applications/rotate.desktop