- respect CFLAGS/PREFIX properly
- utilize WANT_GNOME - install pkg-config .pc file to correct place - bump PORTREVISION PR: 52142 Submitted by: Ports Fury
This commit is contained in:
parent
06b4254dc3
commit
1954490a5a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=81314
4 changed files with 62 additions and 6 deletions
|
@ -8,26 +8,32 @@
|
|||
|
||||
PORTNAME= xmlwrapp
|
||||
PORTVERSION= 0.4.1
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= http://pmade.org/pjones/software/xmlwrapp/download/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= A modern style C++ library for working with XML data
|
||||
|
||||
LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
|
||||
BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
|
||||
RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
|
||||
|
||||
USE_PERL5_BUILD= yes
|
||||
|
||||
USE_GNOME= libxml2
|
||||
WANT_GNOME= yes
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_SCRIPT= configure.pl
|
||||
CONFIGURE_ARGS= --prefix ${PREFIX}
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
.if defined(WITH_XSLT)
|
||||
LIB_DEPENDS+= xslt.1:${PORTSDIR}/textproc/libxslt
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${HAVE_GNOME:Mlibxslt}!=""
|
||||
USE_GNOME+= libxslt
|
||||
PLIST_SUB+= XSLT=""
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-xslt
|
||||
PLIST_SUB+= XSLT="@comment "
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
20
textproc/xmlwrapp/files/patch-tools::cxxflags
Normal file
20
textproc/xmlwrapp/files/patch-tools::cxxflags
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- tools/cxxflags.orig Wed Jan 8 06:26:51 2003
|
||||
+++ tools/cxxflags Tue May 13 05:50:41 2003
|
||||
@@ -240,7 +240,7 @@
|
||||
|
||||
$flags{'debug'} = "-g";
|
||||
$flags{'depend'} = '-M';
|
||||
- $flags{'optimize'} = '-O2';
|
||||
+ $flags{'optimize'} = '';
|
||||
$flags{'ar'} = $ENV{'AR'} || 'ar';
|
||||
$flags{'arflags'} = $ENV{'ARFLAGS'} || 'rc';
|
||||
$flags{'sar'} = $clo{'cxx'};
|
||||
@@ -353,7 +353,7 @@
|
||||
$flags{'debug'} = "-g";
|
||||
$flags{'depend'} = '-xM';
|
||||
$flags{'pic'} = '-Kpic';
|
||||
- $flags{'optimize'} = '-s -xlibmil -xlibmopt -xO2';
|
||||
+ $flags{'optimize'} = '-s -xlibmil -xlibmopt';
|
||||
$flags{'ar'} = $clo{'cxx'};
|
||||
$flags{'arflags'} = '-xar -o';
|
||||
$flags{'sar'} = $clo{'cxx'};
|
30
textproc/xmlwrapp/files/patch-tools::mkmf
Normal file
30
textproc/xmlwrapp/files/patch-tools::mkmf
Normal file
|
@ -0,0 +1,30 @@
|
|||
--- tools/mkmf.orig Tue Apr 8 07:23:38 2003
|
||||
+++ tools/mkmf Tue May 13 06:05:24 2003
|
||||
@@ -469,6 +469,7 @@
|
||||
'BINDIR' => '/usr/local/bin',
|
||||
'INCLUDEDIR' => '/usr/local/include',
|
||||
'LIBDIR' => '/usr/local/lib',
|
||||
+ 'LIBDATADIR' => '/usr/local/libdata',
|
||||
'MANDIR' => '/usr/local/share/man',
|
||||
);
|
||||
|
||||
@@ -558,7 +559,7 @@
|
||||
print MF "\tmkdir -p $vars{'BINDIR'}\n" if @binaries;
|
||||
print MF "\tmkdir -p $vars{'INCLUDEDIR'}\n" if @include_files or @include_dirs;
|
||||
print MF "\tmkdir -p $vars{'LIBDIR'}\n" if @static_libraries or @shared_libraries;
|
||||
- print MF "\tmkdir -p $vars{'LIBDIR'}/pkgconfig\n" if @pkgconfig;
|
||||
+ print MF "\tmkdir -p $vars{'LIBDATADIR'}/pkgconfig\n" if @pkgconfig;
|
||||
print MF "\tmkdir -p $vars{'MANDIR'}\n" if @man_pages;
|
||||
|
||||
foreach my $binary (@binaries) {
|
||||
@@ -567,8 +568,8 @@
|
||||
}
|
||||
|
||||
foreach my $pc (@pkgconfig) {
|
||||
- print MF "\tcp $pc $vars{'LIBDIR'}/pkgconfig/$pc\n";
|
||||
- print MF "\tchmod 644 $vars{'LIBDIR'}/pkgconfig/$pc\n";
|
||||
+ print MF "\tcp $pc $vars{'LIBDATADIR'}/pkgconfig/$pc\n";
|
||||
+ print MF "\tchmod 644 $vars{'LIBDATADIR'}/pkgconfig/$pc\n";
|
||||
}
|
||||
|
||||
foreach my $directory (@include_dirs) {
|
|
@ -18,4 +18,4 @@ lib/libxmlwrapp.so.4
|
|||
%%XSLT%%lib/libxsltwrapp.a
|
||||
%%XSLT%%lib/libxsltwrapp.so
|
||||
%%XSLT%%lib/libxsltwrapp.so.1
|
||||
lib/pkgconfig/xmlwrapp.pc
|
||||
libdata/pkgconfig/xmlwrapp.pc
|
||||
|
|
Loading…
Reference in a new issue