- Update to 3.2

This commit is contained in:
Philip M. Gollucci 2009-02-03 06:32:52 +00:00
parent 164d970ce6
commit 1959b9dfbd
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=227508
5 changed files with 8 additions and 789 deletions

View file

@ -5,10 +5,9 @@
# $FreeBSD$
PORTNAME= mod_auth_mysql
PORTVERSION= 2.20
PORTREVISION= 8
PORTVERSION= 3.2
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITES= SF
MASTER_SITE_SUBDIR= mod-auth-mysql
MAINTAINER= apache@FreeBSD.org
@ -22,13 +21,10 @@ USE_MYSQL= yes
USE_APACHE= 13
AP_GENPLIST= yes
PORTDOCS= README USAGE
PLIST_FILES+= libexec/apache/libauth_mysql.so
PLIST_FILES+= libexec/apache/mod_auth_mysql.so
PKGMESSAGE= ${WRKSRC}/.install_notes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --with-mysql=${PREFIX} \
--with-apxs=${APXS}
post-patch:
${REINPLACE_CMD} -e 's,/usr,${LOCALBASE},g' -e 's,apxs,${APXS},' ${WRKSRC}/Makefile
post-install:
.if !defined(NOPORTDOCS)

View file

@ -1,3 +1,3 @@
MD5 (mod_auth_mysql-2.20.tar.gz) = 3e88c23aabf2089fc753b2631a938f53
SHA256 (mod_auth_mysql-2.20.tar.gz) = f51b92ac636af0b3ecd889f0b6c138dee3997bfad33dff7c5a81028491d7a297
SIZE (mod_auth_mysql-2.20.tar.gz) = 30531
MD5 (mod_auth_mysql-3.2.tar.gz) = 66e9ee64094946199a5e524c60ceeee5
SHA256 (mod_auth_mysql-3.2.tar.gz) = 099c7a5621dab9ee8ea564fd996c1148cd793b2968d753ce6c9713a7de79af6f
SIZE (mod_auth_mysql-3.2.tar.gz) = 11940

View file

@ -1,55 +0,0 @@
--- configure.in.orig Sat Oct 3 06:54:17 1998
+++ configure.in Fri May 19 23:58:48 2000
@@ -48,6 +48,7 @@
APXS_ON=1
APXS="$withval"
APXS_LDFLAGS="@MYSQL_LFLAGS@ @MYSQL_LIBS@"
+ APXS_INCLUDE="@MYSQL_INCLUDE@"
APACHE_INCLUDE="-I`$APXS -q INCLUDEDIR`"
INSTALL_IT="\$(APXS) -i -a -n auth_mysql libauth_mysql.so"
CFLAGS_SHLIB=`perl -V:cccdlflags | cut -d\' -f2`
@@ -56,6 +57,7 @@
STRONGHOLD=
AC_SUBST(APXS)
AC_SUBST(APXS_LDFLAGS)
+ AC_SUBST(APXS_INCLUDE)
AC_SUBST(INSTALL_IT)
AC_DEFINE(HAVE_AP_COMPAT_H)
AC_MSG_RESULT(yes)
@@ -237,7 +239,11 @@
AC_SUBST(LDFLAGS_SHLIB)
AC_SUBST(LDFLAGS_SHLIB_EXPORT)
-if test "$APACHE_VERSION" = "1.2"; then
+if test $APXS_ON -eq 1 ; then
+cat > .install_notes <<EOF
++------------------------------------------------------------------+
+EOF
+elif test "$APACHE_VERSION" = "1.2"; then
cat > .install_notes <<EOF
+------------------------------------------------------------------+
@@ -268,10 +274,9 @@
fi
cat >> .install_notes <<EOF
-| If you are upgrading from an earlier version of mod_auth_mysql, |
-| you would have to update your .htaccess files to reflect the |
-| changes in the directive names. You can do that automatically |
-| by running the bundled update_htaccess_files.sh script. |
+| If you are upgrading from a version of mod_auth_mysql < 2.20, |
+| you will need to update your .htaccess files to reflect the |
+| changes in the directive names. |
+------------------------------------------------------------------+
| Please register this module at |
| http://bourbon.netvision.net.il/mod_auth_mysql/ |
@@ -285,9 +290,6 @@
AC_SUBST(INSTALL_NOTES)
AC_OUTPUT(Makefile libauth_mysql.module, [], [])
-
-echo ""
-echo "Please run 'make'"
# Local Variables:
# tab-width: 4

View file

@ -1,692 +0,0 @@
--- configure.orig Sat Oct 3 06:54:20 1998
+++ configure Fri May 19 23:59:29 2000
@@ -1,7 +1,7 @@
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
-# Generated automatically using autoconf version 2.12
+# Generated automatically using autoconf version 2.13
# Copyright (C) 1992, 93, 94, 95, 96 Free Software Foundation, Inc.
#
# This configure script is free software; the Free Software Foundation
@@ -62,6 +62,7 @@
# Initialize some other variables.
subdirs=
MFLAGS= MAKEFLAGS=
+SHELL=${CONFIG_SHELL-/bin/sh}
# Maximum number of lines to put in a shell here document.
ac_max_here_lines=12
@@ -345,7 +346,7 @@
verbose=yes ;;
-version | --version | --versio | --versi | --vers)
- echo "configure generated by autoconf version 2.12"
+ echo "configure generated by autoconf version 2.13"
exit 0 ;;
-with-* | --with-*)
@@ -515,9 +516,11 @@
# CFLAGS is not in ac_cpp because -g, -O, etc. are not valid cpp options.
ac_cpp='$CPP $CPPFLAGS'
ac_compile='${CC-cc} -c $CFLAGS $CPPFLAGS conftest.$ac_ext 1>&5'
-ac_link='${CC-cc} -o conftest $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
+ac_link='${CC-cc} -o conftest${ac_exeext} $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
cross_compiling=$ac_cv_prog_cc_cross
+ac_exeext=
+ac_objext=o
if (echo "testing\c"; echo 1,2,3) | grep c >/dev/null; then
# Stardent Vistra SVR4 grep lacks -e, says ghazi@caip.rutgers.edu.
if (echo -n testing; echo 1,2,3) | sed s/-n/xn/ | grep xn >/dev/null; then
@@ -539,15 +542,16 @@
# Extract the first word of "gcc", so it can be a program name with args.
set dummy gcc; ac_word=$2
echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
-echo "configure:543: checking for $ac_word" >&5
+echo "configure:546: checking for $ac_word" >&5
if eval "test \"`echo '$''{'ac_cv_prog_CC'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
if test -n "$CC"; then
ac_cv_prog_CC="$CC" # Let the user override the test.
else
- IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS="${IFS}:"
- for ac_dir in $PATH; do
+ IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS=":"
+ ac_dummy="$PATH"
+ for ac_dir in $ac_dummy; do
test -z "$ac_dir" && ac_dir=.
if test -f $ac_dir/$ac_word; then
ac_cv_prog_CC="gcc"
@@ -568,16 +572,17 @@
# Extract the first word of "cc", so it can be a program name with args.
set dummy cc; ac_word=$2
echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
-echo "configure:572: checking for $ac_word" >&5
+echo "configure:576: checking for $ac_word" >&5
if eval "test \"`echo '$''{'ac_cv_prog_CC'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
if test -n "$CC"; then
ac_cv_prog_CC="$CC" # Let the user override the test.
else
- IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS="${IFS}:"
+ IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS=":"
ac_prog_rejected=no
- for ac_dir in $PATH; do
+ ac_dummy="$PATH"
+ for ac_dir in $ac_dummy; do
test -z "$ac_dir" && ac_dir=.
if test -f $ac_dir/$ac_word; then
if test "$ac_dir/$ac_word" = "/usr/ucb/cc"; then
@@ -612,25 +617,61 @@
echo "$ac_t""no" 1>&6
fi
+ if test -z "$CC"; then
+ case "`uname -s`" in
+ *win32* | *WIN32*)
+ # Extract the first word of "cl", so it can be a program name with args.
+set dummy cl; ac_word=$2
+echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
+echo "configure:627: checking for $ac_word" >&5
+if eval "test \"`echo '$''{'ac_cv_prog_CC'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+else
+ if test -n "$CC"; then
+ ac_cv_prog_CC="$CC" # Let the user override the test.
+else
+ IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS=":"
+ ac_dummy="$PATH"
+ for ac_dir in $ac_dummy; do
+ test -z "$ac_dir" && ac_dir=.
+ if test -f $ac_dir/$ac_word; then
+ ac_cv_prog_CC="cl"
+ break
+ fi
+ done
+ IFS="$ac_save_ifs"
+fi
+fi
+CC="$ac_cv_prog_CC"
+if test -n "$CC"; then
+ echo "$ac_t""$CC" 1>&6
+else
+ echo "$ac_t""no" 1>&6
+fi
+ ;;
+ esac
+ fi
test -z "$CC" && { echo "configure: error: no acceptable cc found in \$PATH" 1>&2; exit 1; }
fi
echo $ac_n "checking whether the C compiler ($CC $CFLAGS $LDFLAGS) works""... $ac_c" 1>&6
-echo "configure:620: checking whether the C compiler ($CC $CFLAGS $LDFLAGS) works" >&5
+echo "configure:659: checking whether the C compiler ($CC $CFLAGS $LDFLAGS) works" >&5
ac_ext=c
# CFLAGS is not in ac_cpp because -g, -O, etc. are not valid cpp options.
ac_cpp='$CPP $CPPFLAGS'
ac_compile='${CC-cc} -c $CFLAGS $CPPFLAGS conftest.$ac_ext 1>&5'
-ac_link='${CC-cc} -o conftest $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
+ac_link='${CC-cc} -o conftest${ac_exeext} $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
cross_compiling=$ac_cv_prog_cc_cross
-cat > conftest.$ac_ext <<EOF
-#line 630 "configure"
+cat > conftest.$ac_ext << EOF
+
+#line 670 "configure"
#include "confdefs.h"
+
main(){return(0);}
EOF
-if { (eval echo configure:634: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest; then
+if { (eval echo configure:675: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
ac_cv_prog_cc_works=yes
# If we can't run a trivial program, we are probably using a cross compiler.
if (./conftest; exit) 2>/dev/null; then
@@ -644,18 +685,24 @@
ac_cv_prog_cc_works=no
fi
rm -fr conftest*
+ac_ext=c
+# CFLAGS is not in ac_cpp because -g, -O, etc. are not valid cpp options.
+ac_cpp='$CPP $CPPFLAGS'
+ac_compile='${CC-cc} -c $CFLAGS $CPPFLAGS conftest.$ac_ext 1>&5'
+ac_link='${CC-cc} -o conftest${ac_exeext} $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
+cross_compiling=$ac_cv_prog_cc_cross
echo "$ac_t""$ac_cv_prog_cc_works" 1>&6
if test $ac_cv_prog_cc_works = no; then
{ echo "configure: error: installation or configuration problem: C compiler cannot create executables." 1>&2; exit 1; }
fi
echo $ac_n "checking whether the C compiler ($CC $CFLAGS $LDFLAGS) is a cross-compiler""... $ac_c" 1>&6
-echo "configure:654: checking whether the C compiler ($CC $CFLAGS $LDFLAGS) is a cross-compiler" >&5
+echo "configure:701: checking whether the C compiler ($CC $CFLAGS $LDFLAGS) is a cross-compiler" >&5
echo "$ac_t""$ac_cv_prog_cc_cross" 1>&6
cross_compiling=$ac_cv_prog_cc_cross
echo $ac_n "checking whether we are using GNU C""... $ac_c" 1>&6
-echo "configure:659: checking whether we are using GNU C" >&5
+echo "configure:706: checking whether we are using GNU C" >&5
if eval "test \"`echo '$''{'ac_cv_prog_gcc'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
@@ -664,7 +711,7 @@
yes;
#endif
EOF
-if { ac_try='${CC-cc} -E conftest.c'; { (eval echo configure:668: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }; } | egrep yes >/dev/null 2>&1; then
+if { ac_try='${CC-cc} -E conftest.c'; { (eval echo configure:715: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }; } | egrep yes >/dev/null 2>&1; then
ac_cv_prog_gcc=yes
else
ac_cv_prog_gcc=no
@@ -675,11 +722,15 @@
if test $ac_cv_prog_gcc = yes; then
GCC=yes
- ac_test_CFLAGS="${CFLAGS+set}"
- ac_save_CFLAGS="$CFLAGS"
- CFLAGS=
- echo $ac_n "checking whether ${CC-cc} accepts -g""... $ac_c" 1>&6
-echo "configure:683: checking whether ${CC-cc} accepts -g" >&5
+else
+ GCC=
+fi
+
+ac_test_CFLAGS="${CFLAGS+set}"
+ac_save_CFLAGS="$CFLAGS"
+CFLAGS=
+echo $ac_n "checking whether ${CC-cc} accepts -g""... $ac_c" 1>&6
+echo "configure:734: checking whether ${CC-cc} accepts -g" >&5
if eval "test \"`echo '$''{'ac_cv_prog_cc_g'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
@@ -694,24 +745,28 @@
fi
echo "$ac_t""$ac_cv_prog_cc_g" 1>&6
- if test "$ac_test_CFLAGS" = set; then
- CFLAGS="$ac_save_CFLAGS"
- elif test $ac_cv_prog_cc_g = yes; then
+if test "$ac_test_CFLAGS" = set; then
+ CFLAGS="$ac_save_CFLAGS"
+elif test $ac_cv_prog_cc_g = yes; then
+ if test "$GCC" = yes; then
CFLAGS="-g -O2"
else
- CFLAGS="-O2"
+ CFLAGS="-g"
fi
else
- GCC=
- test "${CFLAGS+set}" = set || CFLAGS="-g"
+ if test "$GCC" = yes; then
+ CFLAGS="-O2"
+ else
+ CFLAGS=
+ fi
fi
if test "x$CC" != xcc; then
echo $ac_n "checking whether $CC and cc understand -c and -o together""... $ac_c" 1>&6
-echo "configure:712: checking whether $CC and cc understand -c and -o together" >&5
+echo "configure:767: checking whether $CC and cc understand -c and -o together" >&5
else
echo $ac_n "checking whether cc understands -c and -o together""... $ac_c" 1>&6
-echo "configure:715: checking whether cc understands -c and -o together" >&5
+echo "configure:770: checking whether cc understands -c and -o together" >&5
fi
set dummy $CC; ac_cc="`echo $2 |
sed -e 's/[^a-zA-Z0-9_]/_/g' -e 's/^[0-9]/_/'`"
@@ -723,16 +778,16 @@
# We do the test twice because some compilers refuse to overwrite an
# existing .o file with -o, though they will create one.
ac_try='${CC-cc} -c conftest.c -o conftest.o 1>&5'
-if { (eval echo configure:727: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; } &&
- test -f conftest.o && { (eval echo configure:728: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; };
+if { (eval echo configure:782: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; } &&
+ test -f conftest.o && { (eval echo configure:783: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; };
then
eval ac_cv_prog_cc_${ac_cc}_c_o=yes
if test "x$CC" != xcc; then
# Test first that cc exists at all.
- if { ac_try='cc -c conftest.c 1>&5'; { (eval echo configure:733: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }; }; then
+ if { ac_try='cc -c conftest.c 1>&5'; { (eval echo configure:788: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }; }; then
ac_try='cc -c conftest.c -o conftest.o 1>&5'
- if { (eval echo configure:735: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; } &&
- test -f conftest.o && { (eval echo configure:736: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; };
+ if { (eval echo configure:790: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; } &&
+ test -f conftest.o && { (eval echo configure:791: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; };
then
# cc works too.
:
@@ -761,15 +816,16 @@
# Extract the first word of "ranlib", so it can be a program name with args.
set dummy ranlib; ac_word=$2
echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
-echo "configure:765: checking for $ac_word" >&5
+echo "configure:820: checking for $ac_word" >&5
if eval "test \"`echo '$''{'ac_cv_prog_RANLIB'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
if test -n "$RANLIB"; then
ac_cv_prog_RANLIB="$RANLIB" # Let the user override the test.
else
- IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS="${IFS}:"
- for ac_dir in $PATH; do
+ IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS=":"
+ ac_dummy="$PATH"
+ for ac_dir in $ac_dummy; do
test -z "$ac_dir" && ac_dir=.
if test -f $ac_dir/$ac_word; then
ac_cv_prog_RANLIB="ranlib"
@@ -799,7 +855,7 @@
fi
echo $ac_n "checking how to run the C preprocessor""... $ac_c" 1>&6
-echo "configure:803: checking how to run the C preprocessor" >&5
+echo "configure:859: checking how to run the C preprocessor" >&5
# On Suns, sometimes $CPP names a directory.
if test -n "$CPP" && test -d "$CPP"; then
CPP=
@@ -814,14 +870,14 @@
# On the NeXT, cc -E runs the code through the compiler's parser,
# not just through cpp.
cat > conftest.$ac_ext <<EOF
-#line 818 "configure"
+#line 874 "configure"
#include "confdefs.h"
#include <assert.h>
Syntax Error
EOF
ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
-{ (eval echo configure:824: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
-ac_err=`grep -v '^ *+' conftest.out`
+{ (eval echo configure:880: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
+ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
if test -z "$ac_err"; then
:
else
@@ -831,14 +887,31 @@
rm -rf conftest*
CPP="${CC-cc} -E -traditional-cpp"
cat > conftest.$ac_ext <<EOF
-#line 835 "configure"
+#line 891 "configure"
+#include "confdefs.h"
+#include <assert.h>
+Syntax Error
+EOF
+ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
+{ (eval echo configure:897: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
+ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
+if test -z "$ac_err"; then
+ :
+else
+ echo "$ac_err" >&5
+ echo "configure: failed program was:" >&5
+ cat conftest.$ac_ext >&5
+ rm -rf conftest*
+ CPP="${CC-cc} -nologo -E"
+ cat > conftest.$ac_ext <<EOF
+#line 908 "configure"
#include "confdefs.h"
#include <assert.h>
Syntax Error
EOF
ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
-{ (eval echo configure:841: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
-ac_err=`grep -v '^ *+' conftest.out`
+{ (eval echo configure:914: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
+ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
if test -z "$ac_err"; then
:
else
@@ -851,6 +924,8 @@
rm -f conftest*
fi
rm -f conftest*
+fi
+rm -f conftest*
ac_cv_prog_CPP="$CPP"
fi
CPP="$ac_cv_prog_CPP"
@@ -863,18 +938,18 @@
do
ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
-echo "configure:867: checking for $ac_hdr" >&5
+echo "configure:942: checking for $ac_hdr" >&5
if eval "test \"`echo '$''{'ac_cv_header_$ac_safe'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 872 "configure"
+#line 947 "configure"
#include "confdefs.h"
#include <$ac_hdr>
EOF
ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
-{ (eval echo configure:877: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
-ac_err=`grep -v '^ *+' conftest.out`
+{ (eval echo configure:952: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
+ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
if test -z "$ac_err"; then
rm -rf conftest*
eval "ac_cv_header_$ac_safe=yes"
@@ -902,12 +977,12 @@
for ac_func in crypt
do
echo $ac_n "checking for $ac_func""... $ac_c" 1>&6
-echo "configure:906: checking for $ac_func" >&5
+echo "configure:981: checking for $ac_func" >&5
if eval "test \"`echo '$''{'ac_cv_func_$ac_func'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 911 "configure"
+#line 986 "configure"
#include "confdefs.h"
/* System header to define __stub macros and hopefully few prototypes,
which can conflict with char $ac_func(); below. */
@@ -930,7 +1005,7 @@
; return 0; }
EOF
-if { (eval echo configure:934: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest; then
+if { (eval echo configure:1009: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_func_$ac_func=yes"
else
@@ -956,7 +1031,7 @@
echo $ac_n "checking for crypt in -lc""... $ac_c" 1>&6
-echo "configure:960: checking for crypt in -lc" >&5
+echo "configure:1035: checking for crypt in -lc" >&5
ac_lib_var=`echo c'_'crypt | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
@@ -964,7 +1039,7 @@
ac_save_LIBS="$LIBS"
LIBS="-lc $LIBS"
cat > conftest.$ac_ext <<EOF
-#line 968 "configure"
+#line 1043 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error. */
/* We use char because int might match the return type of a gcc2
@@ -975,7 +1050,7 @@
crypt()
; return 0; }
EOF
-if { (eval echo configure:979: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest; then
+if { (eval echo configure:1054: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_lib_$ac_lib_var=yes"
else
@@ -995,7 +1070,7 @@
echo "$ac_t""no" 1>&6
echo $ac_n "checking for crypt in -lcrypt""... $ac_c" 1>&6
-echo "configure:999: checking for crypt in -lcrypt" >&5
+echo "configure:1074: checking for crypt in -lcrypt" >&5
ac_lib_var=`echo crypt'_'crypt | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
@@ -1003,7 +1078,7 @@
ac_save_LIBS="$LIBS"
LIBS="-lcrypt $LIBS"
cat > conftest.$ac_ext <<EOF
-#line 1007 "configure"
+#line 1082 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error. */
/* We use char because int might match the return type of a gcc2
@@ -1014,7 +1089,7 @@
crypt()
; return 0; }
EOF
-if { (eval echo configure:1018: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest; then
+if { (eval echo configure:1093: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_lib_$ac_lib_var=yes"
else
@@ -1045,7 +1120,7 @@
echo $ac_n "checking for standard DES crypt""... $ac_c" 1>&6
-echo "configure:1049: checking for standard DES crypt" >&5
+echo "configure:1124: checking for standard DES crypt" >&5
if test "$cross_compiling" = yes; then
cat >> confdefs.h <<\EOF
@@ -1056,7 +1131,7 @@
else
cat > conftest.$ac_ext <<EOF
-#line 1060 "configure"
+#line 1135 "configure"
#include "confdefs.h"
main() {
@@ -1067,7 +1142,7 @@
#endif
}
EOF
-if { (eval echo configure:1071: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest && (./conftest; exit) 2>/dev/null
+if { (eval echo configure:1146: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null
then
cat >> confdefs.h <<\EOF
@@ -1093,7 +1168,7 @@
echo $ac_n "checking for extended DES crypt""... $ac_c" 1>&6
-echo "configure:1097: checking for extended DES crypt" >&5
+echo "configure:1172: checking for extended DES crypt" >&5
if test "$cross_compiling" = yes; then
cat >> confdefs.h <<\EOF
@@ -1104,7 +1179,7 @@
else
cat > conftest.$ac_ext <<EOF
-#line 1108 "configure"
+#line 1183 "configure"
#include "confdefs.h"
main() {
@@ -1115,7 +1190,7 @@
#endif
}
EOF
-if { (eval echo configure:1119: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest && (./conftest; exit) 2>/dev/null
+if { (eval echo configure:1194: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null
then
cat >> confdefs.h <<\EOF
@@ -1141,7 +1216,7 @@
echo $ac_n "checking for MD5 crypt""... $ac_c" 1>&6
-echo "configure:1145: checking for MD5 crypt" >&5
+echo "configure:1220: checking for MD5 crypt" >&5
if test "$cross_compiling" = yes; then
cat >> confdefs.h <<\EOF
@@ -1152,7 +1227,7 @@
else
cat > conftest.$ac_ext <<EOF
-#line 1156 "configure"
+#line 1231 "configure"
#include "confdefs.h"
main() {
@@ -1172,7 +1247,7 @@
#endif
}
EOF
-if { (eval echo configure:1176: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest && (./conftest; exit) 2>/dev/null
+if { (eval echo configure:1251: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null
then
cat >> confdefs.h <<\EOF
@@ -1198,7 +1273,7 @@
echo $ac_n "checking for Blowfish crypt""... $ac_c" 1>&6
-echo "configure:1202: checking for Blowfish crypt" >&5
+echo "configure:1277: checking for Blowfish crypt" >&5
if test "$cross_compiling" = yes; then
cat >> confdefs.h <<\EOF
@@ -1209,7 +1284,7 @@
else
cat > conftest.$ac_ext <<EOF
-#line 1213 "configure"
+#line 1288 "configure"
#include "confdefs.h"
main() {
@@ -1226,7 +1301,7 @@
#endif
}
EOF
-if { (eval echo configure:1230: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest && (./conftest; exit) 2>/dev/null
+if { (eval echo configure:1305: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null
then
cat >> confdefs.h <<\EOF
@@ -1253,7 +1328,7 @@
echo $ac_n "checking for Apache module support via DSO through APXS""... $ac_c" 1>&6
-echo "configure:1257: checking for Apache module support via DSO through APXS" >&5
+echo "configure:1332: checking for Apache module support via DSO through APXS" >&5
# Check whether --with-apxs or --without-apxs was given.
if test "${with_apxs+set}" = set; then
withval="$with_apxs"
@@ -1264,6 +1339,7 @@
APXS_ON=1
APXS="$withval"
APXS_LDFLAGS="@MYSQL_LFLAGS@ @MYSQL_LIBS@"
+ APXS_INCLUDE="@MYSQL_INCLUDE@"
APACHE_INCLUDE="-I`$APXS -q INCLUDEDIR`"
INSTALL_IT="\$(APXS) -i -a -n auth_mysql libauth_mysql.so"
CFLAGS_SHLIB=`perl -V:cccdlflags | cut -d\' -f2`
@@ -1273,6 +1349,7 @@
+
cat >> confdefs.h <<\EOF
#define HAVE_AP_COMPAT_H 1
EOF
@@ -1287,7 +1364,7 @@
echo $ac_n "checking for Apache module support via DSO through APACI""... $ac_c" 1>&6
-echo "configure:1291: checking for Apache module support via DSO through APACI" >&5
+echo "configure:1368: checking for Apache module support via DSO through APACI" >&5
# Check whether --with-shared-apache or --without-shared-apache was given.
if test "${with_shared_apache+set}" = set; then
withval="$with_shared_apache"
@@ -1342,7 +1419,7 @@
if test "$APACI_DSO_ON" != "1"; then
if test "$APXS_ON" != "1"; then
echo $ac_n "checking for Apache directory""... $ac_c" 1>&6
-echo "configure:1346: checking for Apache directory" >&5
+echo "configure:1423: checking for Apache directory" >&5
# Check whether --with-apache or --without-apache was given.
if test "${with_apache+set}" = set; then
withval="$with_apache"
@@ -1449,7 +1526,7 @@
fi
echo $ac_n "checking for MySQL directory""... $ac_c" 1>&6
-echo "configure:1453: checking for MySQL directory" >&5
+echo "configure:1530: checking for MySQL directory" >&5
# Check whether --with-mysql or --without-mysql was given.
if test "${with_mysql+set}" = set; then
withval="$with_mysql"
@@ -1492,7 +1569,11 @@
-if test "$APACHE_VERSION" = "1.2"; then
+if test $APXS_ON -eq 1 ; then
+cat > .install_notes <<EOF
++------------------------------------------------------------------+
+EOF
+elif test "$APACHE_VERSION" = "1.2"; then
cat > .install_notes <<EOF
+------------------------------------------------------------------+
@@ -1523,10 +1604,9 @@
fi
cat >> .install_notes <<EOF
-| If you are upgrading from an earlier version of mod_auth_mysql, |
-| you would have to update your .htaccess files to reflect the |
-| changes in the directive names. You can do that automatically |
-| by running the bundled update_htaccess_files.sh script. |
+| If you are upgrading from a version of mod_auth_mysql < 2.20, |
+| you will need to update your .htaccess files to reflect the |
+| changes in the directive names. |
+------------------------------------------------------------------+
| Please register this module at |
| http://bourbon.netvision.net.il/mod_auth_mysql/ |
@@ -1562,7 +1642,7 @@
# Ultrix sh set writes to stderr and can't be redirected directly,
# and sets the high bit in the cache file unless we assign to the vars.
(set) 2>&1 |
- case `(ac_space=' '; set) 2>&1` in
+ case `(ac_space=' '; set | grep ac_space) 2>&1` in
*ac_space=\ *)
# `set' does not quote correctly, so add quotes (double-quote substitution
# turns \\\\ into \\, and sed turns \\ into \).
@@ -1629,7 +1709,7 @@
echo "running \${CONFIG_SHELL-/bin/sh} $0 $ac_configure_args --no-create --no-recursion"
exec \${CONFIG_SHELL-/bin/sh} $0 $ac_configure_args --no-create --no-recursion ;;
-version | --version | --versio | --versi | --vers | --ver | --ve | --v)
- echo "$CONFIG_STATUS generated by autoconf version 2.12"
+ echo "$CONFIG_STATUS generated by autoconf version 2.13"
exit 0 ;;
-help | --help | --hel | --he | --h)
echo "\$ac_cs_usage"; exit 0 ;;
@@ -1648,9 +1728,11 @@
s/@@/%@/; s/@@/@%/; s/@g\$/%g/' > conftest.subs <<\\CEOF
$ac_vpsub
$extrasub
+s%@SHELL@%$SHELL%g
s%@CFLAGS@%$CFLAGS%g
s%@CPPFLAGS@%$CPPFLAGS%g
s%@CXXFLAGS@%$CXXFLAGS%g
+s%@FFLAGS@%$FFLAGS%g
s%@DEFS@%$DEFS%g
s%@LDFLAGS@%$LDFLAGS%g
s%@LIBS@%$LIBS%g
@@ -1674,6 +1756,7 @@
s%@CPP@%$CPP%g
s%@APXS@%$APXS%g
s%@APXS_LDFLAGS@%$APXS_LDFLAGS%g
+s%@APXS_INCLUDE@%$APXS_INCLUDE%g
s%@INSTALL_IT@%$INSTALL_IT%g
s%@APACHE_INCLUDE@%$APACHE_INCLUDE%g
s%@APACHE_TARGET@%$APACHE_TARGET%g
@@ -1899,9 +1982,6 @@
rm -fr confdefs* $ac_clean_files
test "$no_create" = yes || ${CONFIG_SHELL-/bin/sh} $CONFIG_STATUS || exit 1
-
-echo ""
-echo "Please run 'make'"
# Local Variables:
# tab-width: 4

View file

@ -1,30 +0,0 @@
--- Makefile.in.orig Sat Oct 3 06:24:28 1998
+++ Makefile.in Fri May 19 23:52:29 2000
@@ -14,9 +14,27 @@
REGCFLAGS = $(CFLAGS)
APXS = @APXS@
APXS_LDFLAGS = @APXS_LDFLAGS@
+APXS_INCLUDE = @APXS_INCLUDE@
WARNING_LEVEL = @WARNING_LEVEL@
+# the default target
+all: build
+
+# build the shared object file for Apache
+build: mod_auth_mysql.so
+
+# compile the shared object file
+mod_auth_mysql.so: auth_mysql_config.h mod_auth_mysql.c
+ $(APXS) -c -o libauth_mysql.so ${APXS_LDFLAGS} ${APXS_INCLUDE} mod_auth_mysql.c
+
+auth_mysql_config.h:
+ cp config.h auth_mysql_config.h
+
+# install the shared object file into Apache
install:
$(INSTALL_IT)
@cat .install_notes
+# cleanup
+clean:
+ -rm -f mod_auth_mysql.o mod_auth_mysql.so