- Update to 1.2.5
- Remove DOCS option, and unneeded patch - Cleanup Makefile - Adjust dependencies (reported by QA script) - Switch to USES= localbase
This commit is contained in:
parent
1878af2fe6
commit
19629d0216
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=429109
3 changed files with 17 additions and 42 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= pcmanfm
|
||||
PORTVERSION= 1.2.4
|
||||
PORTVERSION= 1.2.5
|
||||
CATEGORIES= x11-fm
|
||||
MASTER_SITES= SF/${PORTNAME}/PCManFM%20%2B%20Libfm%20%28tarball%20release%29/PCManFM/
|
||||
|
||||
|
@ -11,39 +11,29 @@ COMMENT= PCMan File Manager
|
|||
|
||||
LICENSE= GPLv2
|
||||
|
||||
LIB_DEPENDS= libfm-gtk.so:x11/libfm
|
||||
LIB_DEPENDS= libfm-gtk.so:x11/libfm \
|
||||
libfontconfig.so:x11-fonts/fontconfig \
|
||||
libfreetype.so:print/freetype2
|
||||
|
||||
USES= autoreconf desktop-file-utils gettext gmake libtool pkgconfig \
|
||||
USES= desktop-file-utils gettext gmake libtool localbase pkgconfig \
|
||||
tar:xz
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GNOME= glib20 gtk20 intltool intlhack
|
||||
USE_GNOME= glib20 gtk20 cairo pango gdkpixbuf2 intltool intlhack
|
||||
USE_XORG= x11
|
||||
|
||||
CONFIGURE_ARGS=--with-gtk=2
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
|
||||
PORTDOCS= AUTHORS NEWS
|
||||
|
||||
OPTIONS_DEFINE= DOCS NLS
|
||||
OPTIONS_DEFINE= NLS
|
||||
OPTIONS_SUB= yes
|
||||
NLS_CONFIGURE_ENABLE= nls
|
||||
NLS_USES_OFF= gettext-tools
|
||||
|
||||
post-extract:
|
||||
${MV} ${WRKSRC}/data/pcmanfm.conf \
|
||||
${WRKSRC}/data/pcmanfm.conf.sample
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e '/pcmanfm.conf/ d' ${WRKSRC}/data/Makefile.am
|
||||
|
||||
post-configure:
|
||||
# Replace locales files in right place
|
||||
${REINPLACE_CMD} -e 's|[$$][(]DATADIRNAME[)]|share|' \
|
||||
${WRKSRC}/po/Makefile
|
||||
|
||||
post-install:
|
||||
@${MKDIR} ${STAGEDIR}${PREFIX}/etc/xdg/pcmanfm/default/
|
||||
${INSTALL_DATA} ${WRKSRC}/data/pcmanfm.conf \
|
||||
${STAGEDIR}${PREFIX}/etc/xdg/pcmanfm/default/pcmanfm.conf.sample
|
||||
|
||||
post-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
|
||||
${REINPLACE_CMD} -e 's|pcmanfm.conf|pcmanfm.conf.sample|' \
|
||||
${WRKSRC}/data/Makefile.in
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,3 @@
|
|||
SHA256 (pcmanfm-1.2.4.tar.xz) = 38cdbb5f01d24483b41b8e6846e4aa66a5751bb3982a8618899e88a853dbe313
|
||||
SIZE (pcmanfm-1.2.4.tar.xz) = 417316
|
||||
TIMESTAMP = 1482343112
|
||||
SHA256 (pcmanfm-1.2.5.tar.xz) = 0c86cac028b705ff314c7464d814c2cf7ff604c17491c20aa204b1ef1a80ad67
|
||||
SIZE (pcmanfm-1.2.5.tar.xz) = 417808
|
||||
|
|
|
@ -1,16 +0,0 @@
|
|||
--- src/Makefile.am.orig 2014-05-16 16:51:21 UTC
|
||||
+++ src/Makefile.am
|
||||
@@ -50,6 +50,13 @@ pcmanfm_LDADD = \
|
||||
$(FM_LIBS) \
|
||||
$(NULL)
|
||||
|
||||
+# create plugins' directory anyway
|
||||
+install-exec-hook:
|
||||
+ $(MKDIR_P) $(DESTDIR)$(libdir)/pcmanfm
|
||||
+
|
||||
+uninstall-hook:
|
||||
+ -rmdir $(DESTDIR)$(libdir)/pcmanfm
|
||||
+
|
||||
# prepare modules directory
|
||||
install-exec-local:
|
||||
$(MKDIR_P) "$(DESTDIR)$(libdir)/pcmanfm"
|
Loading…
Reference in a new issue