- Support staging

- Respect CC
- Respect CFLAGS
- This port does not build with clang, use gcc
This commit is contained in:
Emanuel Haupt 2014-02-24 15:00:15 +00:00
parent 0f7c79edd7
commit 19954bc0f8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=345859
2 changed files with 15 additions and 2 deletions

View file

@ -13,11 +13,12 @@ COMMENT= Utility to check for traffic shapers
LICENSE= GPLv2
USE_GCC= yes
MAKEFILE= Makefile.osx
PLIST_FILES= bin/prober
NO_STAGE= yes
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/prober ${PREFIX}/bin/
${INSTALL_PROGRAM} ${WRKSRC}/prober ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>

View file

@ -0,0 +1,12 @@
--- Makefile.osx.orig 2012-01-24 21:33:22.000000000 +0100
+++ Makefile.osx 2014-02-24 15:57:22.575172070 +0100
@@ -1,7 +1,7 @@
-CC=gcc
+CC?=gcc
-CFLAGS=-c -Wall -O3 -fno-strict-aliasing -DOSX
+CFLAGS+=-c -DOSX
LDFLAGS=-lm
SOURCES=prober.c tcp_client.c tcpserver.c wrappers.c tbdetect.c measflow.c