- finance/kmymoney-kde4: KDE4 version of KMyMoney
- Updated to 3.97.2 release PR: 144520 Submitted by: Jason E. Hale <bsdkaffee@gmail.com>
This commit is contained in:
parent
6c017c69f0
commit
19993becee
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=253651
12 changed files with 1136 additions and 1399 deletions
|
@ -5,59 +5,69 @@
|
|||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= kmymoney2
|
||||
PORTVERSION= 1.0.3
|
||||
PORTREVISION= 2
|
||||
PORTNAME= kmymoney
|
||||
PORTVERSION= 3.97.2
|
||||
CATEGORIES= finance
|
||||
MASTER_SITES= SF/${PORTNAME}/KMyMoney/${PORTVERSION}
|
||||
MASTER_SITES= SF/${PORTNAME}2/KMyMoney-KDE4/${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= KDE-based personal finance assistant
|
||||
MAINTAINER= bsdkaffee@gmail.com
|
||||
COMMENT= KDE 4.x-based personal finance manager
|
||||
|
||||
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
|
||||
LIB_DEPENDS= boost_graph.4:${PORTSDIR}/devel/boost-libs
|
||||
|
||||
LIB_DEPENDS= osp.5:${PORTSDIR}/textproc/opensp
|
||||
|
||||
LIB_DEPENDS+= ofx.4:${PORTSDIR}/finance/libofx
|
||||
|
||||
USE_KDELIBS_VER=3
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_AUTOTOOLS= libtool:22
|
||||
USE_PERL5= yes
|
||||
USE_BZIP2= yes
|
||||
USE_CMAKE= yes
|
||||
USE_QT_VER= 4
|
||||
QT_COMPONENTS= gui dbus network phonon qt3support sql svg xml \
|
||||
moc_build rcc_build uic_build
|
||||
USE_KDE4= kdehier kdeprefix automoc4 kdelibs pimlibs sharedmime
|
||||
USE_LDCONFIG= yes
|
||||
USE_GETTEXT= yes
|
||||
USE_XORG= xext
|
||||
MAKE_JOBS_SAFE= yes
|
||||
|
||||
INSTALLS_ICONS= yes
|
||||
MAN1= kmymoney.1
|
||||
|
||||
MAN1= kmymoney2.1
|
||||
MANCOMPRESSED= yes
|
||||
OPTIONS= CALENDAR "Enable Calendar plugin" on \
|
||||
KBANKING "Enable KBanking plugin" off \
|
||||
OFX "Enable OFX plugin" off \
|
||||
QUOTES "Enable online price quotes" off
|
||||
|
||||
DATADIR= ${PREFIX}/share/apps/${PORTNAME}
|
||||
DOCSDIR= ${PREFIX}/share/doc/HTML/en/${PORTNAME}
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
CONFIGURE_ARGS= --enable-ofxplugin --enable-ofxbanking --enable-pdf-docs
|
||||
|
||||
# Add more build-time dependencies to generate the PDF docs
|
||||
BUILD_DEPENDS+= jade:${PORTSDIR}/textproc/jade \
|
||||
pdfjadetex:${PORTSDIR}/print/jadetex \
|
||||
html2ps:${PORTSDIR}/print/html2ps-letter \
|
||||
dsssl-docbook-modular>=0:${PORTSDIR}/textproc/dsssl-docbook-modular \
|
||||
cppunit-config:${PORTSDIR}/devel/cppunit \
|
||||
recode:${PORTSDIR}/converters/recode
|
||||
.if defined(WITH_CALENDAR)
|
||||
LIB_DEPENDS+= ical.43:${PORTSDIR}/devel/libical
|
||||
CMAKE_ARGS+= -DENABLE_LIBICAL:BOOL=ON
|
||||
PLIST_SUB+= WITH_CALENDAR=""
|
||||
.else
|
||||
CONFIGURE_ARGS= --enable-ofxplugin --enable-ofxbanking
|
||||
EXTRA_PATCHES= ${FILESDIR}/extra-patch-Makefile.in \
|
||||
${FILESDIR}/extra-patch-doc__en__Makefile.in
|
||||
CMAKE_ARGS+= -DENABLE_LIBICAL:BOOL=OFF
|
||||
PLIST_SUB+= WITH_CALENDAR="@comment "
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|%%LIBTOOL%%|${LIBTOOL}|g ; \
|
||||
s|%%LTMAIN%%|${LTMAIN}|g' ${WRKSRC}/configure
|
||||
.if defined(WITH_KBANKING)
|
||||
LIB_DEPENDS+= aqbanking.31:${PORTSDIR}/finance/aqbanking
|
||||
CMAKE_ARGS+= -DENABLE_KBANKING:BOOL=ON
|
||||
PLIST_SUB+= WITH_KBANKING=""
|
||||
.else
|
||||
CMAKE_ARGS+= -DENABLE_KBANKING:BOOL=OFF
|
||||
PLIST_SUB+= WITH_KBANKING="@comment "
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.if defined(WITH_OFX)
|
||||
LIB_DEPENDS+= ofx.4:${PORTSDIR}/finance/libofx
|
||||
CMAKE_ARGS+= -DENABLE_LIBOFX:BOOL=ON
|
||||
PLIST_SUB+= WITH_OFX=""
|
||||
.else
|
||||
CMAKE_ARGS+= -DENABLE_LIBOFX:BOOL=OFF
|
||||
PLIST_SUB+= WITH_OFX="@comment "
|
||||
.endif
|
||||
|
||||
.if defined(WITH_QUOTES)
|
||||
USE_PERL5= yes
|
||||
RUN_DEPENDS+= ${SITE_PERL}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip \
|
||||
${SITE_PERL}/Finance/Quote.pm:${PORTSDIR}/finance/p5-Finance-Quote \
|
||||
${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
|
||||
${SITE_PERL}/XML/Writer.pm:${PORTSDIR}/textproc/p5-XML-Writer \
|
||||
${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (kmymoney2-1.0.3.tar.bz2) = f131bdf4d2c9f2f5778126fe2ade7c1e
|
||||
SHA256 (kmymoney2-1.0.3.tar.bz2) = d2d15448626e8446ec8156af8da18f0618f82171e1928951baf912e349d7dc97
|
||||
SIZE (kmymoney2-1.0.3.tar.bz2) = 12245425
|
||||
MD5 (kmymoney-3.97.2.tar.bz2) = 3a58c497840d7d5f276415ff0657e384
|
||||
SHA256 (kmymoney-3.97.2.tar.bz2) = 2e5f33594ba1c125f9ad627119e68695d850f25a145ff07443425980677e5df5
|
||||
SIZE (kmymoney-3.97.2.tar.bz2) = 14793343
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- Makefile.in.orig 2010-02-23 22:14:08.000000000 -0300
|
||||
+++ Makefile.in 2010-02-12 12:02:37.000000000 -0200
|
||||
@@ -342,7 +342,7 @@
|
||||
xdg_menudir = @xdg_menudir@
|
||||
|
||||
# just make sure, we don't ship the sqlite subdirectory with the tarball
|
||||
-SOURCEDIRS = libkgpgfile libkdchart kmymoney2 po doc developer-doc
|
||||
+SOURCEDIRS = libkgpgfile libkdchart kmymoney2 po doc
|
||||
SUBDIRS = @SQLITE3@ $(SOURCEDIRS)
|
||||
DIST_SUBDIRS = $(SOURCEDIRS) contrib
|
||||
|
|
@ -1,32 +0,0 @@
|
|||
--- doc/en/Makefile.in.orig 2010-02-12 12:02:37.000000000 -0200
|
||||
+++ doc/en/Makefile.in 2010-02-23 22:20:32.000000000 -0300
|
||||
@@ -338,9 +338,9 @@
|
||||
select_database.png budgets_view.png forecast_view.png \
|
||||
newfile-2.png newfile-3.png newfile-4.png newfile-5.png \
|
||||
newfile-6.png
|
||||
-EXTRA_DIST = kmymoney2.1 $(DOCBOOK_FILES)
|
||||
+EXTRA_DIST = kmymoney2.1
|
||||
MOSTLYCLEANFILES = index.cache.bz2 kmymoney2.1.gz index.xml *.aux *.tex *.log **.out *.pdf errorlog *.ps *.html online-manual.tar.bz2
|
||||
-BUILT_SOURCES = index.cache.bz2 kmymoney2.1.gz $(PDF_TARGET)
|
||||
+BUILT_SOURCES = kmymoney2.1.gz
|
||||
CHARSET =
|
||||
KDE_LANG = en
|
||||
KDE_DOCS = kmymoney2 - $(DOCBOOK_FILES) $(SCREENSHOT_FILES)
|
||||
@@ -492,7 +492,7 @@
|
||||
|
||||
#>- install-data-am:
|
||||
#>+ 1
|
||||
-install-data-am: install-nls
|
||||
+install-data-am:
|
||||
@$(NORMAL_INSTALL)
|
||||
$(MAKE) $(AM_MAKEFLAGS) install-data-hook
|
||||
|
||||
@@ -652,7 +652,7 @@
|
||||
# Also install the man pages on this system
|
||||
.PHONY: install-docs uninstall-docs
|
||||
|
||||
-install-data-hook: kmymoney2.1.gz install-docs
|
||||
+install-data-hook: kmymoney2.1.gz
|
||||
-rm -f $(DESTDIR)$(kde_htmldir)/$(KDE_LANG)/kmymoney2/kmymoney2.1
|
||||
$(mkinstalldirs) $(DESTDIR)$(mandir)/man1/
|
||||
$(INSTALL_DATA) kmymoney2.1.gz $(DESTDIR)$(mandir)/man1/kmymoney2.1.gz
|
|
@ -1,28 +0,0 @@
|
|||
--- ./admin/install-sh.orig 2004-12-28 15:10:08.000000000 -0500
|
||||
+++ ./admin/install-sh 2008-10-10 09:39:06.000000000 -0400
|
||||
@@ -50,6 +50,7 @@
|
||||
stripcmd=""
|
||||
rmcmd="$rmprog -f"
|
||||
mvcmd="$mvprog"
|
||||
+mkdircmd="$mkdirprog -p"
|
||||
src=""
|
||||
dst=""
|
||||
dir_arg=""
|
||||
@@ -120,7 +121,7 @@
|
||||
instcmd=:
|
||||
chmodcmd=""
|
||||
else
|
||||
- instcmd=$mkdirprog
|
||||
+ instcmd=$mkdircmd
|
||||
fi
|
||||
else
|
||||
|
||||
@@ -181,7 +182,7 @@
|
||||
|
||||
if [ ! -d "$pathcomp" ] ;
|
||||
then
|
||||
- $mkdirprog "$pathcomp"
|
||||
+ $mkdircmd "$pathcomp"
|
||||
else
|
||||
:
|
||||
fi
|
|
@ -1,30 +0,0 @@
|
|||
--- configure.orig 2010-02-12 12:02:25.000000000 -0200
|
||||
+++ configure 2010-03-06 21:40:16.000000000 -0300
|
||||
@@ -1,4 +1,4 @@
|
||||
-#! /bin/sh
|
||||
+#! /usr/local/bin/bash
|
||||
# Guess values for system-dependent variables and create Makefiles.
|
||||
# Generated by GNU Autoconf 2.61.
|
||||
#
|
||||
@@ -22548,10 +22548,10 @@
|
||||
|
||||
|
||||
# This can be used to rebuild libtool when needed
|
||||
-LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
|
||||
+LIBTOOL_DEPS=" %%LTMAIN%%"
|
||||
|
||||
# Always use our own libtool.
|
||||
-LIBTOOL='$(SHELL) $(top_builddir)/libtool --silent'
|
||||
+LIBTOOL='$(SHELL) %%LIBTOOL%% --silent'
|
||||
|
||||
# Prevent multiple expansion
|
||||
|
||||
@@ -34605,7 +34605,7 @@
|
||||
fi
|
||||
{ echo "$as_me:$LINENO: result: $QTDIR" >&5
|
||||
echo "${ECHO_T}$QTDIR" >&6; }
|
||||
- ac_qmake=${QTDIR}/bin/qmake
|
||||
+ ac_qmake="${QTDIR}/bin/qmake -spec freebsd-g++"
|
||||
|
||||
# Check whether --with-qmake was given.
|
||||
if test "${with_qmake+set}" = set; then
|
|
@ -1,10 +0,0 @@
|
|||
--- developer-doc/phb/Makefile.am.orig 2010-02-17 20:01:44.000000000 -0200
|
||||
+++ developer-doc/phb/Makefile.am 2010-02-17 21:42:28.000000000 -0200
|
||||
@@ -106,7 +106,6 @@
|
||||
kmymoney-phb.pdf: $(DOCBOOK_FILES)
|
||||
$(MAKE) get-files
|
||||
$(MEINPROC) --stylesheet `dirname $(KDE_XSL_STYLESHEET)`/kde-nochunk.xsl $(srcdir)/phb.docbook -o index.html
|
||||
- recode utf8..latin1 index.html
|
||||
html2ps -o kmymoney-phb.ps -n index.html
|
||||
ps2pdf kmymoney-phb.ps kmymoney-phb.pdf
|
||||
rm index.html kmymoney-phb.ps
|
|
@ -1,18 +0,0 @@
|
|||
--- developer-doc/phb/Makefile.in.orig 2010-02-17 20:02:33.000000000 -0200
|
||||
+++ developer-doc/phb/Makefile.in 2010-02-17 21:43:06.000000000 -0200
|
||||
@@ -238,7 +238,6 @@
|
||||
exec_prefix = @exec_prefix@
|
||||
found_html2ps = @found_html2ps@
|
||||
found_ps2pdf = @found_ps2pdf@
|
||||
-found_recode = @found_recode@
|
||||
host = @host@
|
||||
host_alias = @host_alias@
|
||||
host_cpu = @host_cpu@
|
||||
@@ -583,7 +582,6 @@
|
||||
@GENERATE_PDF_TRUE@kmymoney-phb.pdf: $(DOCBOOK_FILES)
|
||||
@GENERATE_PDF_TRUE@ $(MAKE) get-files
|
||||
@GENERATE_PDF_TRUE@ $(MEINPROC) --stylesheet `dirname $(KDE_XSL_STYLESHEET)`/kde-nochunk.xsl $(srcdir)/phb.docbook -o index.html
|
||||
-@GENERATE_PDF_TRUE@ recode utf8..latin1 index.html
|
||||
@GENERATE_PDF_TRUE@ html2ps -o kmymoney-phb.ps -n index.html
|
||||
@GENERATE_PDF_TRUE@ ps2pdf kmymoney-phb.ps kmymoney-phb.pdf
|
||||
@GENERATE_PDF_TRUE@ rm index.html kmymoney-phb.ps
|
|
@ -1,20 +0,0 @@
|
|||
--- doc/en/Makefile.am.orig 2010-02-17 20:04:44.000000000 -0200
|
||||
+++ doc/en/Makefile.am 2010-02-17 21:47:06.000000000 -0200
|
||||
@@ -87,9 +87,6 @@
|
||||
for file in $(DOCBOOK_FILES); do \
|
||||
cp $(srcdir)/$$file .; \
|
||||
chmod +w $$file; \
|
||||
- if test -n $(CHARSET); then \
|
||||
- recode utf-8..$(CHARSET) $$file; \
|
||||
- fi \
|
||||
done; \
|
||||
for file in $(SCREENSHOT_FILES); do \
|
||||
cp $(srcdir)/$$file .; \
|
||||
@@ -111,7 +108,6 @@
|
||||
kmymoney-user.pdf: $(DOCBOOK_FILES) $(SCREENSHOT_FILES)
|
||||
$(MAKE) get-files
|
||||
$(MEINPROC) --check --stylesheet `dirname $(KDE_XSL_STYLESHEET)`/kde-nochunk.xsl $(srcdir)/index.docbook -o index.html;
|
||||
- recode utf8..latin1 index.html
|
||||
html2ps -o kmymoney-user.ps -n index.html
|
||||
ps2pdf kmymoney-user.ps kmymoney-user.pdf
|
||||
rm index.html kmymoney-user.ps
|
|
@ -1,28 +0,0 @@
|
|||
--- doc/en/Makefile.in.orig 2010-02-17 20:06:19.000000000 -0200
|
||||
+++ doc/en/Makefile.in 2010-02-17 21:46:14.000000000 -0200
|
||||
@@ -238,7 +238,6 @@
|
||||
exec_prefix = @exec_prefix@
|
||||
found_html2ps = @found_html2ps@
|
||||
found_ps2pdf = @found_ps2pdf@
|
||||
-found_recode = @found_recode@
|
||||
host = @host@
|
||||
host_alias = @host_alias@
|
||||
host_cpu = @host_cpu@
|
||||
@@ -620,9 +619,6 @@
|
||||
for file in $(DOCBOOK_FILES); do \
|
||||
cp $(srcdir)/$$file .; \
|
||||
chmod +w $$file; \
|
||||
- if test -n $(CHARSET); then \
|
||||
- recode utf-8..$(CHARSET) $$file; \
|
||||
- fi \
|
||||
done; \
|
||||
for file in $(SCREENSHOT_FILES); do \
|
||||
cp $(srcdir)/$$file .; \
|
||||
@@ -641,7 +637,6 @@
|
||||
@GENERATE_PDF_TRUE@kmymoney-user.pdf: $(DOCBOOK_FILES) $(SCREENSHOT_FILES)
|
||||
@GENERATE_PDF_TRUE@ $(MAKE) get-files
|
||||
@GENERATE_PDF_TRUE@ $(MEINPROC) --check --stylesheet `dirname $(KDE_XSL_STYLESHEET)`/kde-nochunk.xsl $(srcdir)/index.docbook -o index.html;
|
||||
-@GENERATE_PDF_TRUE@ recode utf8..latin1 index.html
|
||||
@GENERATE_PDF_TRUE@ html2ps -o kmymoney-user.ps -n index.html
|
||||
@GENERATE_PDF_TRUE@ ps2pdf kmymoney-user.ps kmymoney-user.pdf
|
||||
@GENERATE_PDF_TRUE@ rm index.html kmymoney-user.ps
|
|
@ -1,5 +1,11 @@
|
|||
KMyMoney is striving to be a full-featured replacement for your
|
||||
Windows-based finance software. We are a KDE-based full double-entry
|
||||
accounting software package, for personal or small-business use.
|
||||
WARNING!!! This is a beta release. More conservative users may want to use the
|
||||
KDE3 version (finance/kmymoney2).
|
||||
|
||||
WWW: http://kmymoney2.sourceforge.net/
|
||||
KMyMoney is a personal finance manager for KDE 4.x.
|
||||
|
||||
It operates similar to MS-Money, supports different account types,
|
||||
categorization of expenses and incomes, reconciliation of bank accounts and QIF
|
||||
import/export. Online banking support (statement download) is also provided for
|
||||
the OFX and HBCI protocols.
|
||||
|
||||
WWW: http://kmymoney2.sourceforge.net/index-home.html
|
||||
|
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue