Update to 1.4
PR: ports/82079 Submitted by: ports fury
This commit is contained in:
parent
c88bfadd68
commit
19a4dd6f5a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=137160
6 changed files with 20 additions and 53 deletions
|
@ -7,8 +7,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= sock
|
||||
PORTVERSION= 1.3
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 1.4
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= rxsock
|
||||
|
@ -21,13 +20,21 @@ COMMENT= A function package for Rexx programmers to create sockets
|
|||
BUILD_DEPENDS= rexx:${PORTSDIR}/lang/rexx-regina
|
||||
RUN_DEPENDS= rexx:${PORTSDIR}/lang/rexx-regina
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-rexx=regina
|
||||
USE_REINPLACE= yes
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}"
|
||||
CONFIGURE_ARGS= --with-rexx=regina
|
||||
MAKE_ARGS= INSTALL="${INSTALL}"
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
DATADIR= ${PREFIX}/share/rx${PORTNAME}
|
||||
|
||||
post-extract:
|
||||
@${CHMOD} +x ${WRKSRC}/install-sh
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|ld -Bdynamic -Bshareable|$${CC} -shared|g' \
|
||||
${WRKSRC}/configure
|
||||
.for file in Makefile.in rxsock-config.in
|
||||
@${REINPLACE_CMD} -e 's|-lc||g' ${WRKSRC}/${file}
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (RxSock-1.3.tar.gz) = 963c3328c632dbb8879296a97ca6bff2
|
||||
SIZE (RxSock-1.3.tar.gz) = 94653
|
||||
MD5 (RxSock-1.4.tar.gz) = e0c5a29b3b012a4589321cf4aa3d6223
|
||||
SIZE (RxSock-1.4.tar.gz) = 124168
|
||||
|
|
|
@ -1,20 +0,0 @@
|
|||
--- Makefile.in.orig Tue Jan 27 12:04:50 2004
|
||||
+++ Makefile.in Tue Jan 27 12:16:35 2004
|
||||
@@ -195,13 +195,13 @@
|
||||
-$(INSTALL) -c -m 755 ./$(SHLPRE)$(PACKAGE_NAME)$(SHLPST) $(libdir)/$(SHLPRE)$(PACKAGE_NAME)$(SHLPST)
|
||||
$(INSTALL) -c -m 755 ./$(LIBPRE)$(PACKAGE_NAME)$(LIBPST) $(libdir)/$(LIBPRE)$(PACKAGE_NAME)$(LIBPST)
|
||||
./$(PACKAGE_NAME) $(basedir)/preinst.rexx $(bindir)/$(PACKAGE_NAME) $(demodir)/tcpc.cmd $(sharedir)/tcpcmd.cmd
|
||||
- -chmod 755 $(sharedir)/tcpc.cmd
|
||||
+ -chmod 755 $(sharedir)/tcpcmd.cmd
|
||||
./$(PACKAGE_NAME) $(basedir)/preinst.rexx $(bindir)/$(PACKAGE_NAME) $(demodir)/tcps.cmd $(sharedir)/tcpsmd.cmd
|
||||
- -chmod 755 $(sharedir)/tcps.cmd
|
||||
+ -chmod 755 $(sharedir)/tcpsmd.cmd
|
||||
./$(PACKAGE_NAME) $(basedir)/preinst.rexx $(bindir)/$(PACKAGE_NAME) $(demodir)/udpc.cmd $(sharedir)/udpcmd.cmd
|
||||
- -chmod 755 $(sharedir)/udpc.cmd
|
||||
+ -chmod 755 $(sharedir)/udpcmd.cmd
|
||||
./$(PACKAGE_NAME) $(basedir)/preinst.rexx $(bindir)/$(PACKAGE_NAME) $(demodir)/udps.cmd $(sharedir)/udpsmd.cmd
|
||||
- -chmod 755 $(sharedir)/udps.cmd
|
||||
+ -chmod 755 $(sharedir)/udpsmd.cmd
|
||||
./$(PACKAGE_NAME) $(basedir)/preinst.rexx $(bindir)/$(PACKAGE_NAME) $(demodir)/davesim.rex $(sharedir)/udpsmd.cmd
|
||||
-chmod 755 $(sharedir)/davesim.rex
|
||||
$(INSTALL) -c -m 644 $(demodir)/udps.txt $(sharedir)/udps.txt
|
|
@ -1,11 +0,0 @@
|
|||
--- configure.orig Tue Jan 27 11:57:27 2004
|
||||
+++ configure Tue Jan 27 11:57:34 2004
|
||||
@@ -2832,7 +2832,7 @@
|
||||
LD_RXTRANSLIB1="$LD_RXLIB1"
|
||||
;;
|
||||
*freebsd*)
|
||||
- LD_RXLIB1="ld -Bdynamic -Bshareable"
|
||||
+ LD_RXLIB1="${CC} -shared"
|
||||
LD_RXTRANSLIB1="$LD_RXLIB1"
|
||||
;;
|
||||
*pc-sco*)
|
|
@ -1,10 +0,0 @@
|
|||
--- preinst.rexx.orig Tue Jan 27 12:01:19 2004
|
||||
+++ preinst.rexx Tue Jan 27 12:01:27 2004
|
||||
@@ -5,6 +5,6 @@
|
||||
Call Lineout outfile, "#!" || rexx_exe
|
||||
Do While(Lines(infile) > 0)
|
||||
line = Linein(infile)
|
||||
- Call Lineout(outfile, line )
|
||||
+ Call Lineout outfile, line
|
||||
End
|
||||
Return 0
|
|
@ -1,11 +1,12 @@
|
|||
bin/rxsock
|
||||
lib/librxsock.a
|
||||
lib/librxsock.so
|
||||
%%DATADIR%%/davesim.rex
|
||||
%%DATADIR%%/davesim.txt
|
||||
%%DATADIR%%/tcpcmd.cmd
|
||||
%%DATADIR%%/tcpsmd.cmd
|
||||
%%DATADIR%%/tcpc.cmd
|
||||
%%DATADIR%%/tcps.cmd
|
||||
%%DATADIR%%/tcps.txt
|
||||
%%DATADIR%%/udpcmd.cmd
|
||||
%%DATADIR%%/udpsmd.cmd
|
||||
%%DATADIR%%/udpc.cmd
|
||||
%%DATADIR%%/udps.cmd
|
||||
%%DATADIR%%/udps.txt
|
||||
@dirrm %%DATADIR%%
|
||||
|
|
Loading…
Reference in a new issue