Drop FreeBSD < 14.0-BETA5 <sys/timerfd.h> workarounds

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=273373
https://cgit.freebsd.org/src/commit/?h=releng/14.0&id=7454117918cd
https://lists.freebsd.org/archives/freebsd-stable/2023-October/001533.html
Old -CURRENT, -STABLE, -RELENG snapshots were never supported in ports/.

This reverts commit 4458b6d2d9.
This reverts commit f295903414.
This reverts commit d7c830340d.
This reverts commit 572560076d.
This reverts commit f4c28b4891.
This reverts commit 163928669d.
This reverts commit b8948f86c1.
This reverts commit 5e70841f87.
This reverts commit 600ca97fd5.
This commit is contained in:
Jan Beich 2023-10-01 21:23:37 +02:00
parent 6f62438615
commit 19ba14bcd8
8 changed files with 2 additions and 70 deletions

View file

@ -30,12 +30,6 @@ MAKE_JOBS_UNSAFE= yes
INSTALL_TARGET= install-strip
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400097
CFLAGS+= -D__BSD_VISIBLE -D__XSI_VISIBLE
.endif
post-patch:
# libusb can be disabled via src.conf(5), so detect via pkg-config
@${REINPLACE_CMD} -e 's/\(libusb-1\.0\) >= 1\.0\.[0-9]*/\1/' \

View file

@ -1,18 +1,6 @@
--- AIO.xs.orig 2022-09-28 08:22:50 UTC
--- AIO.xs.orig 2022-09-25 16:29:50 UTC
+++ AIO.xs
@@ -169,9 +169,11 @@
# include <sys/eventfd.h>
#endif
+#define cv condvar_cv
#if HAVE_TIMERFD
# include <sys/timerfd.h>
#endif
+#undef cv
#if HAVE_RLIMITS
#include <sys/time.h>
@@ -2926,7 +2928,7 @@ fexecve (SV *fh, SV *args, SV *envs = &PL_sv_undef)
@@ -2924,7 +2924,7 @@ fexecve (SV *fh, SV *args, SV *envs = &PL_sv_undef)
OUTPUT: RETVAL
int

View file

@ -1,20 +0,0 @@
--- tools/libinput-record.c.orig 2023-03-25 17:59:47 UTC
+++ tools/libinput-record.c
@@ -2577,7 +2577,7 @@ enum fposition {
enum fposition {
ERROR,
- NOFILE,
+ NO_FILE,
FIRST,
LAST,
};
@@ -2633,7 +2633,7 @@ find_output_file(int argc, char *argv[], const char **
return ERROR;
}
#undef _m
- return NOFILE;
+ return NO_FILE;
}
enum options {

View file

@ -37,12 +37,6 @@ MANPAGES_PLIST_FILES= man/man1/${PORTNAME}.1.gz \
PIXBUF_USE= GNOME=gdkpixbuf2
PIXBUF_MESON_ENABLED= icons
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400097
CFLAGS+= -D__BSD_VISIBLE -D__XSI_VISIBLE
.endif
post-patch:
# Respect PREFIX for icons
@${REINPLACE_CMD} 's,/usr/share,${DATADIR:H},g' \

View file

@ -78,12 +78,6 @@ WEBP_MESON_ENABLED= webp
ZSH_MESON_ENABLED= zsh
ZSH_PLIST_FILES= share/zsh/site-functions/_${PORTNAME}
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400097
CFLAGS+= -D__BSD_VISIBLE -D__XSI_VISIBLE
.endif
post-patch:
# Respect PREFIX for system-wide config
@${REINPLACE_CMD} 's,/etc,${PREFIX}&,' \

View file

@ -30,12 +30,6 @@ MANPAGES_BUILD_DEPENDS= scdoc:textproc/scdoc
MANPAGES_MESON_ENABLED= man-pages
MANPAGES_PLIST_FILES= man/man1/${PORTNAME}.1.gz
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400097
CFLAGS+= -D__BSD_VISIBLE -D__XSI_VISIBLE
.endif
post-install:
# Rename to avoid conflict with x11/wayout
${MV} ${STAGEDIR}${PREFIX}/bin/${PORTNAME} \

View file

@ -29,10 +29,4 @@ LDFLAGS+= `pkg-config --libs epoll-shim`
PLIST_FILES= bin/wmenu \
man/man1/wmenu.1.gz
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400097
CFLAGS+= -D__BSD_VISIBLE -D__XSI_VISIBLE
.endif
.include <bsd.port.mk>

View file

@ -45,12 +45,6 @@ MANPAGES_BUILD_DEPENDS= scdoc:textproc/scdoc
MANPAGES_MESON_ENABLED= man-pages
MANPAGES_PLIST_FILES= man/man5/${PORTNAME}.5.gz
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400097
CFLAGS+= -D__BSD_VISIBLE -D__XSI_VISIBLE
.endif
post-patch:
@${REINPLACE_CMD} -e 's,/etc,${PREFIX}&,' \
${WRKSRC}/${PORTNAME}.5.scd