- Update to 5.2.2

PR:		ports/146050
Submitted by:	Rob Farmer <rfarmer@predatorlabs.net> (maintainer)
This commit is contained in:
Wen Heping 2010-04-30 08:54:40 +00:00
parent 4641b64d64
commit 19d12f5171
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=253467
4 changed files with 196 additions and 474 deletions

View file

@ -6,8 +6,7 @@
#
PORTNAME= scilab
PORTVERSION= 5.2.1
PORTREVISION= 1
PORTVERSION= 5.2.2
CATEGORIES= math cad parallel java
MASTER_SITES= http://www.scilab.org/download/${PORTVERSION}/
EXTRACT_SUFX= -src.tar.gz
@ -29,8 +28,6 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --without-ocaml
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib ${PTHREAD_LIBS}
OPTIONS= ATLAS "Use Atlas instead of Blas" OFF \
@ -38,8 +35,10 @@ OPTIONS= ATLAS "Use Atlas instead of Blas" OFF \
GUI "Build GUI (requires Java and required for docs)" ON \
NLS "Build localization" OFF \
MATIO "Matlab compatibility" OFF \
OCAML "Build ocaml modelica compiler (requires GUI)" OFF \
PVM "Parallel Virtual Machine support" OFF \
TK "TCL/TK support" OFF
TK "TCL/TK support" OFF \
UMFPACK "Build with umfpack" ON
.include <bsd.port.options.mk>
@ -137,7 +136,8 @@ USE_XORG= x11
CONFIGURE_ARGS+= --with-jdk=${JAVA_HOME} \
--with-docbook=${LOCALBASE}/share/xsl/docbook
DESKTOP_ENTRIES= "SciLab" "A free Matlab clone by INRIA & ENPC" \
DESKTOP_ENTRIES= "SciLab" \
"Scientific software package for numerical computations" \
"${DATADIR}/icons/scilab.xpm" "scilab" \
"Application;Education;Math;" false
@ -187,24 +187,31 @@ LIB_DEPENDS+= matio.1:${PORTSDIR}/math/matio
PLIST_SUB+= MATIO=""
.endif
.if defined(WITHOUT_OCAML)
CONFIGURE_ARGS+= --without-ocaml
PLIST_SUB+= OCAML="@comment "
.else
BUILD_DEPENDS+= ocaml:${PORTSDIR}/lang/ocaml
RUN_DEPENDS+= ocaml:${PORTSDIR}/lang/ocaml
PLIST_SUB+= OCAML=""
.endif
post-patch:
# Configure fixes
${REINPLACE_CMD} -e 's|/usr/share/java|${JAVALIBDIR}|g' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's|/usr/lib/jni|${LOCALBASE}/lib/|g' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's|/usr/lib/java|${JAVALIBDIR}|g' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's|/usr/lib64/jni|${LOCALBASE}/lib/|g' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's|-ldl | |' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's|-lmatio|-lmatio -lgfortran|g' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's|-L$$with_umfpack_library|-L$$with_umfpack_library -lgfortran|' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's|-lumfpack|-lumfpack -lamd -L$$with_umfpack_library -lgfortran|g' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's|TCLTK_LIBS=" -ldl"|TCLTK_LIBS=" "|' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's|batik-all|batik|g' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's|$$jardir/batik.jar|${LOCALBASE}/share/java/batik/batik.jar|g' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's|$$jardir/fop.jar|${LOCALBASE}/share/java/fop/build/fop.jar|' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's|$$jardir/jeuclid-core*.jar|${LOCALBASE}/share/java/jeuclid/repo/jeuclid-core*.jar|' ${WRKSRC}/configure
# Build fixes
${REINPLACE_CMD} -e 's|$$FFLAGS -DNDEBUG|$$FFLAGS -DNDEBUG -fPIC|' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's|$$(CFLAGS:-O%=)|-I${LOCALBASE}/include -L${LOCALBASE}/lib|' ${WRKSRC}/modules/elementary_functions/Makefile.in
${REINPLACE_CMD} -e 's|freebsd|__FreeBSD__|g' ${WRKSRC}/modules/sparse/includes/spConfig.h
${REINPLACE_CMD} -e 1730d ${WRKSRC}/Makefile.in
${REINPLACE_CMD} -e 's|exp10(|pow(10., |g' ${WRKSRC}/modules/graphics/src/c/Format.c \
${WRKSRC}/modules/graphics/src/c/getHandleProperty/set_log_flags_property.c
@# malloc.h -> stdlib.h conversions
@${GREP} -lr "<malloc.h>" ${WRKSRC} \
| ${XARGS} ${REINPLACE_CMD} -e \
@ -213,7 +220,6 @@ post-patch:
${MV} ${WRKSRC}/modules/call_scilab/examples/call_scilab/NET/VB.NET/My\ Project/ \
${WRKSRC}/modules/call_scilab/examples/call_scilab/NET/VB.NET/My_Project/
${REINPLACE_CMD} -e 's|My Project|My_Project|g' ${WRKSRC}/modules/call_scilab/examples/call_scilab/NET/VB.NET/VB.NET.vbproj
${REINPLACE_CMD} -e 319d ${WRKSRC}/contrib/Makefile.in
${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|' ${WRKSRC}/Makefile.in
.if defined(NOPORTDOCS)
@${REINPLACE_CMD} -e '/%%PORTDOCS%%/d' ${WRKSRC}/Makefile.in

View file

@ -1,3 +1,3 @@
MD5 (scilab-5.2.1-src.tar.gz) = 47beab7be09516d89167e9a67a3be856
SHA256 (scilab-5.2.1-src.tar.gz) = f85aa3b7fde0e523f7f0159613da7cca7bd2d125860b50fa2ed00394c97075e0
SIZE (scilab-5.2.1-src.tar.gz) = 54855137
MD5 (scilab-5.2.2-src.tar.gz) = 35e8a22edb348f405360d3a07ed4faab
SHA256 (scilab-5.2.2-src.tar.gz) = 6f8800bc8ac9128187d1f9a98a5e459bbfa2b66967caed8ab659ff2ba51f1cf2
SIZE (scilab-5.2.2-src.tar.gz) = 54088580

View file

@ -0,0 +1,11 @@
--- modules/xcos/src/java/org/scilab/modules/graph/ScilabCanvas.java.orig 2010-04-21 20:20:59.000000000 -0700
+++ modules/xcos/src/java/org/scilab/modules/graph/ScilabCanvas.java 2010-04-21 20:21:25.000000000 -0700
@@ -265,7 +265,7 @@
boolean dashed = mxUtils.isTrue(style,
mxConstants.STYLE_DASHED, false);
drawConnector(pts, penWidth, penColor, startMarker, startSize,
- endMarker, endSize, dashed, rounded);
+ endMarker, endSize, rounded, style);
Object centerMarker = style.get(ScilabConstants.STYLE_CENTERARROW);
if (centerMarker != null) {

File diff suppressed because it is too large Load diff