sysutils/freefilesync: Update to 9.8

Port changes:
* Updated LICENSE_FILE
* Added IGNORE_FreeBSD_10 because of missing _cxa_thread_atexit()
* Added to LIB_DEPENDS
* Added USE_GNOME
* Removed USE_LDCONFIG
* Updated post-patch

PR:		226276
Submitted by:	Olexandr Davydenko <odavydenko@gmail.com>
Approved by:	tcberner (mentor, implicit)
This commit is contained in:
Yuri Victorovich 2018-03-02 08:51:18 +00:00
parent 5c9a928450
commit 19f1bc0500
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=463383
11 changed files with 88 additions and 58 deletions

View file

@ -2,8 +2,7 @@
# $FreeBSD$ # $FreeBSD$
PORTNAME= freefilesync PORTNAME= freefilesync
PORTVERSION= 8.3 DISTVERSION= 9.8
PORTREVISION= 9
CATEGORIES= sysutils CATEGORIES= sysutils
MASTER_SITES= https://www.freefilesync.org/download/ \ MASTER_SITES= https://www.freefilesync.org/download/ \
https://www.freefilesync.org/archive/ https://www.freefilesync.org/archive/
@ -13,23 +12,25 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Backup software to synchronize files and folders COMMENT= Backup software to synchronize files and folders
LICENSE= GPLv3 LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE LICENSE_FILE= ${WRKDIR}/License.txt
BROKEN= fails to build IGNORE_FreeBSD_10= "FreeBSD 10.0 doesn't have _cxa_thread_atexit() implemeneted in libc, it has been implemented since 11
BUILD_DEPENDS= ${LOCALBASE}/include/zenxml/xml.h:textproc/zenxml BUILD_DEPENDS= ${LOCALBASE}/include/zenxml/xml.h:textproc/zenxml
LIB_DEPENDS= libboost_system.so:devel/boost-libs \ LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libnotify.so:devel/libnotify libnotify.so:devel/libnotify
FETCH_ARGS= --user-agent=firefox FETCH_ARGS= --user-agent=firefox
WRKSRC= ${WRKDIR}/FreeFileSync/Source WRKSRC= ${WRKDIR}/FreeFileSync/Source
DOS2UNIX_WRKSRC=${WRKDIR}
DOS2UNIX_GLOB= *.cpp *.h
USES= compiler:c++14-lang dos2unix gmake pkgconfig zip USES= compiler:c++14-lang dos2unix gmake pkgconfig zip
USE_LDCONFIG= yes
USE_WX= 3.0+ USE_WX= 3.0+
USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk20 pango
DOS2UNIX_WRKSRC= ${WRKDIR}
DOS2UNIX_GLOB= *.cpp *.h
post-patch: post-patch:
@${REINPLACE_CMD} -e 's/wx-config/$${WX_CONFIG:T}/' \ @${REINPLACE_CMD} -e 's/wx-config/$${WX_CONFIG:T}/' \
@ -38,7 +39,5 @@ post-patch:
${WRKDIR}/zen/file_access.cpp ${WRKDIR}/zen/file_access.cpp
@${REINPLACE_CMD} -e 's|WEXITSTATUS||' ${WRKDIR}/zen/shell_execute.h @${REINPLACE_CMD} -e 's|WEXITSTATUS||' ${WRKDIR}/zen/shell_execute.h
@${REINPLACE_CMD} -e 's| noexcept;|;|' ${WRKDIR}/zen/scope_guard.h @${REINPLACE_CMD} -e 's| noexcept;|;|' ${WRKDIR}/zen/scope_guard.h
@${REINPLACE_CMD} -e 's|CLOCK_MONOTONIC_RAW|CLOCK_MONOTONIC|' \
${WRKDIR}/zen/tick_count.h
.include <bsd.port.mk> .include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1469892304 TIMESTAMP = 1519893735
SHA256 (FreeFileSync_8.3_Source.zip) = bbde3eaa345d20a088746b14dc6e0721984d316a6f3dbbe54be646b84d60e7a6 SHA256 (FreeFileSync_9.8_Source.zip) = 77a59586284a518d6df6c0cc934c3efa434f247acce70452ab9fe37e7747b96d
SIZE (FreeFileSync_8.3_Source.zip) = 3020292 SIZE (FreeFileSync_9.8_Source.zip) = 2866149

View file

@ -1,6 +1,6 @@
--- Makefile.orig 2016-04-21 22:53:00.000000000 +0800 --- Makefile.orig 2018-02-06 16:36:07 UTC
+++ Makefile 2016-06-30 13:33:16.633078000 +0800 +++ Makefile
@@ -1,14 +1,14 @@ @@ -1,13 +1,13 @@
APPNAME = FreeFileSync APPNAME = FreeFileSync
-prefix = /usr -prefix = /usr
+prefix = $(PREFIX) +prefix = $(PREFIX)
@ -9,16 +9,15 @@
APPSHAREDIR = $(SHAREDIR)/$(APPNAME) APPSHAREDIR = $(SHAREDIR)/$(APPNAME)
DOCSHAREDIR = $(SHAREDIR)/doc/$(APPNAME) DOCSHAREDIR = $(SHAREDIR)/doc/$(APPNAME)
CXXFLAGS = -std=c++14 -pipe -DWXINTL_NO_GETTEXT_MACRO -I../.. -I../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" -Wall \ -CXXFLAGS = -std=c++14 -pipe -DWXINTL_NO_GETTEXT_MACRO -I../.. -I../../zenXml -include "zen/i18n.h" -Wall -O3 -DNDEBUG `wx-config --cxxflags --debug=no` -pthread
--O3 -DNDEBUG `wx-config --cxxflags --debug=no` -DZEN_LINUX -pthread +CXXFLAGS = -std=c++14 -pipe -DWXINTL_NO_GETTEXT_MACRO -I../.. -I../../zenXml -include "zen/i18n.h" -Wall -O3 -DNDEBUG `${WX_CONFIG} --cxxflags --debug=no` -pthread
+-O3 -DNDEBUG `${WX_CONFIG} --cxxflags --debug=no` -DZEN_LINUX -pthread
-LINKFLAGS = -s `wx-config --libs std, aui --debug=no` -lboost_thread -lboost_chrono -lboost_system -lz -pthread -LINKFLAGS = -s `wx-config --libs std, aui --debug=no` -lboost_thread -lboost_chrono -lboost_system -lz -pthread
+LINKFLAGS = -s `${WX_CONFIG} --libs std, aui --debug=no` -lboost_thread -lboost_chrono -lboost_system -lz -pthread +LINKFLAGS = -s `${WX_CONFIG} --libs std, aui --debug=no` -lboost_thread -lboost_chrono -lboost_system -lz -pthread
#Gtk - support recycler/icon loading/no button border/grid scrolling #Gtk - support recycler/icon loading/no button border/grid scrolling
CXXFLAGS += `pkg-config --cflags gtk+-2.0` CXXFLAGS += `pkg-config --cflags gtk+-2.0`
@@ -97,10 +97,10 @@ @@ -99,10 +99,10 @@ launchpad: FreeFileSync
../Obj/FFS_GCC_Make_Release/ffs/src/%.o : %.cpp ../Obj/FFS_GCC_Make_Release/ffs/src/%.o : %.cpp
mkdir -p $(dir $@) mkdir -p $(dir $@)
@ -31,7 +30,7 @@
clean: clean:
rm -rf ../Obj/FFS_GCC_Make_Release rm -rf ../Obj/FFS_GCC_Make_Release
@@ -109,7 +109,7 @@ @@ -111,7 +111,7 @@ clean:
install: install:
mkdir -p $(BINDIR) mkdir -p $(BINDIR)
@ -40,7 +39,7 @@
mkdir -p $(APPSHAREDIR) mkdir -p $(APPSHAREDIR)
cp -R ../Build/Languages/ \ cp -R ../Build/Languages/ \
@@ -120,6 +120,3 @@ @@ -122,6 +122,3 @@ install:
../Build/Resources.zip \ ../Build/Resources.zip \
$(APPSHAREDIR) $(APPSHAREDIR)

View file

@ -1,12 +0,0 @@
--- fs/native.cpp.orig 2016-03-09 02:07:44 UTC
+++ fs/native.cpp
@@ -84,8 +84,7 @@ void preAllocateSpaceBestEffort(FileHand
#elif defined ZEN_LINUX
//don't use potentially inefficient ::posix_fallocate!
- const int rv = ::fallocate(fh, //int fd,
- 0, //int mode,
+ const int rv = ::posix_fallocate(fh, //int fd,
0, //off_t offset
streamSize); //off_t len
if (rv != 0)

View file

@ -0,0 +1,10 @@
--- lib/dir_lock.h.orig 2018-03-02 05:46:44 UTC
+++ lib/dir_lock.h
@@ -11,6 +11,7 @@
#include <chrono>
#include <functional>
#include <zen/file_error.h>
+#include <zen/warn_static.h>
namespace fff

View file

@ -0,0 +1,10 @@
--- ui/main_dlg.cpp.orig 2018-03-02 05:46:44 UTC
+++ ui/main_dlg.cpp
@@ -28,6 +28,7 @@
#include <wx+/image_resources.h>
#include "cfg_grid.h"
#include "version_check.h"
+#include "version_check_impl.h"
#include "gui_status_handler.h"
#include "small_dlgs.h"
#include "progress_indicator.h"

View file

@ -1,22 +1,22 @@
--- ui/version_check.cpp.orig 2016-06-30 13:33:44.614966000 +0800 --- ui/version_check.cpp.orig 2018-03-02 05:46:44 UTC
+++ ui/version_check.cpp 2016-06-30 13:36:17.540454000 +0800 +++ ui/version_check.cpp
@@ -104,16 +104,10 @@ @@ -70,16 +70,10 @@ std::vector<std::pair<std::string, std::
const auto osvMinor = getOsVersion().minor; params.emplace_back("installation_type", isPortableVersion() ? "Portable" : "Local");
#elif defined ZEN_LINUX
- params.emplace_back("os_name", "Linux"); - params.emplace_back("os_name", "Linux");
+ params.emplace_back("os_name", "FreeBSD"); -
- const wxLinuxDistributionInfo distribInfo = wxGetLinuxDistributionInfo(); - const wxLinuxDistributionInfo distribInfo = wxGetLinuxDistributionInfo();
- assert(contains(distribInfo.Release, L'.')); - assert(contains(distribInfo.Release, L'.'));
- std::vector<wxString> digits = split<wxString>(distribInfo.Release, L'.'); //e.g. "15.04" - std::vector<wxString> digits = split<wxString>(distribInfo.Release, L'.', SplitType::ALLOW_EMPTY); //e.g. "15.04"
- digits.resize(2); - digits.resize(2);
- //distribInfo.Id //e.g. "Ubuntu" - //distribInfo.Id //e.g. "Ubuntu"
- + params.emplace_back("os_name", "FreeBSD");
- const int osvMajor = stringTo<int>(digits[0]); - const int osvMajor = stringTo<int>(digits[0]);
- const int osvMinor = stringTo<int>(digits[1]); - const int osvMinor = stringTo<int>(digits[1]);
+ const int osvMajor = 0; + const int osvMajor = 0;
+ const int osvMinor = 0; + const int osvMinor = 0;
#elif defined ZEN_MAC params.emplace_back("os_version", numberTo<std::string>(osvMajor) + "." + numberTo<std::string>(osvMinor));
params.emplace_back("os_name", "Mac");

View file

@ -0,0 +1,12 @@
--- ../../zen/file_io.cpp.orig 2018-03-01 11:10:56.764684000 +0200
+++ ../../zen/file_io.cpp 2018-03-01 11:12:35.599889000 +0200
@@ -305,8 +305,7 @@
{
const FileHandle fh = getHandle();
//don't use potentially inefficient ::posix_fallocate!
- const int rv = ::fallocate(fh, //int fd,
- 0, //int mode,
+ const int rv = ::posix_fallocate(fh, //int fd,
0, //off_t offset
expectedSize); //off_t len
if (rv != 0)

View file

@ -1,11 +0,0 @@
--- ../../zen/scope_guard.h.orig 2016-03-31 20:08:04 UTC
+++ ../../zen/scope_guard.h
@@ -14,7 +14,7 @@
//best of Zen, Loki and C++17
-#ifdef ZEN_WIN
+#if defined(ZEN_WIN) || (defined(_LIBCPP_VERSION) && _LIBCPP_VERSION >= 3700)
inline int getUncaughtExceptionCount() { return std::uncaught_exceptions(); }
#elif defined ZEN_LINUX || defined ZEN_MAC

View file

@ -0,0 +1,21 @@
--- ../../zen/thread.h.orig 2018-03-01 11:48:04.473377000 +0200
+++ ../../zen/thread.h 2018-03-01 11:48:51.214192000 +0200
@@ -12,8 +12,7 @@
#include "scope_guard.h"
#include "type_traits.h"
#include "optional.h"
- #include <sys/prctl.h>
-
+#include <pthread_np.h>
namespace zen
{
@@ -407,7 +406,7 @@
inline
void setCurrentThreadName(const char* threadName)
{
- ::prctl(PR_SET_NAME, threadName, 0, 0, 0);
+ pthread_set_name_np(pthread_self(), threadName);
}

View file

@ -47,6 +47,7 @@ share/FreeFileSync/images/basic-step-start-sync.png
share/FreeFileSync/images/basic-step-sync-config.png share/FreeFileSync/images/basic-step-sync-config.png
share/FreeFileSync/images/calendar-job-added.png share/FreeFileSync/images/calendar-job-added.png
share/FreeFileSync/images/com-settings-context.png share/FreeFileSync/images/com-settings-context.png
share/FreeFileSync/images/command-line-syntax.png
share/FreeFileSync/images/comparison-settings.png share/FreeFileSync/images/comparison-settings.png
share/FreeFileSync/images/comparison-variant-double-click.png share/FreeFileSync/images/comparison-variant-double-click.png
share/FreeFileSync/images/config-double-click.png share/FreeFileSync/images/config-double-click.png
@ -54,9 +55,9 @@ share/FreeFileSync/images/config-multiple-selection.png
share/FreeFileSync/images/copy-alternative-path.png share/FreeFileSync/images/copy-alternative-path.png
share/FreeFileSync/images/dialog-drag-move.png share/FreeFileSync/images/dialog-drag-move.png
share/FreeFileSync/images/direct-synchronize.png share/FreeFileSync/images/direct-synchronize.png
share/FreeFileSync/images/donate.png
share/FreeFileSync/images/explorer-context.png share/FreeFileSync/images/explorer-context.png
share/FreeFileSync/images/filter-context.png share/FreeFileSync/images/filter-context.png
share/FreeFileSync/images/filter-zero-file-size.png
share/FreeFileSync/images/filter.png share/FreeFileSync/images/filter.png
share/FreeFileSync/images/freefilesync-logo.png share/FreeFileSync/images/freefilesync-logo.png
share/FreeFileSync/images/gnome-scheduler.png share/FreeFileSync/images/gnome-scheduler.png
@ -77,7 +78,9 @@ share/FreeFileSync/images/remove-local-settings.png
share/FreeFileSync/images/save-automator.png share/FreeFileSync/images/save-automator.png
share/FreeFileSync/images/select-time-span.png share/FreeFileSync/images/select-time-span.png
share/FreeFileSync/images/setup-batch-job.png share/FreeFileSync/images/setup-batch-job.png
share/FreeFileSync/images/sftp-cloud-picker.png
share/FreeFileSync/images/sftp-login.png share/FreeFileSync/images/sftp-login.png
share/FreeFileSync/images/sftp-performance.png
share/FreeFileSync/images/show-thumbnails.png share/FreeFileSync/images/show-thumbnails.png
share/FreeFileSync/images/sync-settings-context.png share/FreeFileSync/images/sync-settings-context.png
share/FreeFileSync/images/synchronization-settings.png share/FreeFileSync/images/synchronization-settings.png
@ -91,13 +94,12 @@ share/FreeFileSync/italian.lng
share/FreeFileSync/japanese.lng share/FreeFileSync/japanese.lng
share/FreeFileSync/korean.lng share/FreeFileSync/korean.lng
share/FreeFileSync/lithuanian.lng share/FreeFileSync/lithuanian.lng
share/FreeFileSync/outdated/norwegian.lng share/FreeFileSync/norwegian.lng
share/FreeFileSync/polish.lng share/FreeFileSync/polish.lng
share/FreeFileSync/portuguese.lng share/FreeFileSync/portuguese.lng
share/FreeFileSync/portuguese_br.lng share/FreeFileSync/portuguese_br.lng
share/FreeFileSync/romanian.lng share/FreeFileSync/romanian.lng
share/FreeFileSync/russian.lng share/FreeFileSync/russian.lng
share/FreeFileSync/serbian.lng
share/FreeFileSync/slovak.lng share/FreeFileSync/slovak.lng
share/FreeFileSync/slovenian.lng share/FreeFileSync/slovenian.lng
share/FreeFileSync/spanish.lng share/FreeFileSync/spanish.lng