Update to 1.16.35, the newest "super-stable" version
This commit is contained in:
parent
cfcd012da9
commit
19f5611d31
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=276700
5 changed files with 80 additions and 55 deletions
|
@ -7,7 +7,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= xmlrpc-c
|
||||
PORTVERSION= 1.06.42
|
||||
PORTVERSION= 1.16.35
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= SF/${PORTNAME}/Xmlrpc-c%20Super%20Stable/${PORTVERSION}
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
@ -15,11 +15,9 @@ EXTRACT_SUFX= .tgz
|
|||
MAINTAINER= garga@FreeBSD.org
|
||||
COMMENT= XML-RPC library for C and C++
|
||||
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
|
||||
OPTIONS= DEBUG "Compile with debugging information" off \
|
||||
CURL "Compile with curl support" on \
|
||||
LIBWWW "Compile with libwww support" off
|
||||
LIBWWW "Compile with libwww support" on
|
||||
|
||||
CONFLICTS= xmlrpc-epi-0.* xmlrpc-c-devel-[0-9]*
|
||||
|
||||
|
@ -30,8 +28,8 @@ USE_AUTOTOOLS= libtool:env
|
|||
GNU_CONFIGURE= yes
|
||||
MAKEFILE= GNUmakefile
|
||||
MAKE_ARGS= LIBTOOL="${LIBTOOL}" \
|
||||
CFLAGS_COMMON="${CFLAGS}" \
|
||||
CXXFLAGS_COMMON="${CXXFLAGS}"
|
||||
CFLAGS_COMMON="${CFLAGS}"
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
LICENSE= BSD
|
||||
|
@ -56,12 +54,6 @@ CONFIGURE_ARGS+= --enable-libwww-client
|
|||
CONFIGURE_ARGS+= --disable-libwww-client
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_LIBWWW) && defined(WITHOUT_CURL)
|
||||
PLIST_SUB+= CLIENT="@comment "
|
||||
.else
|
||||
PLIST_SUB+= CLIENT=""
|
||||
.endif
|
||||
|
||||
post-extract:
|
||||
@${FIND} ${WRKSRC} -type l -name blddir | ${XARGS} ${RM}
|
||||
@${FIND} ${WRKSRC} -type l -name srcdir | ${XARGS} ${RM}
|
||||
|
@ -69,5 +61,7 @@ post-extract:
|
|||
post-patch:
|
||||
@${GREP} -lR '\-lpthread' ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
|
||||
's|-lpthread|${PTHREAD_LIBS}|g'
|
||||
@${REINPLACE_CMD} -e '/#include.*features.h/d' \
|
||||
${WRKSRC}/tools/xmlrpc_pstream/xmlrpc_pstream.cpp
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (xmlrpc-c-1.06.42.tgz) = c27ecacbcf3dece05e52d130d478936032bf9ac411c01966f992d757efa4d265
|
||||
SIZE (xmlrpc-c-1.06.42.tgz) = 712841
|
||||
SHA256 (xmlrpc-c-1.16.35.tgz) = bb3ae96dd9176e1d548699518af937bbdb920d8322ec59c57dffca6260775b6c
|
||||
SIZE (xmlrpc-c-1.16.35.tgz) = 1876492
|
||||
|
|
11
net/xmlrpc-c/files/patch-src-Makefile
Normal file
11
net/xmlrpc-c/files/patch-src-Makefile
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/Makefile.orig 2011-03-25 13:23:24.000000000 -0300
|
||||
+++ src/Makefile 2011-06-29 15:49:47.000000000 -0300
|
||||
@@ -70,7 +70,7 @@
|
||||
else
|
||||
XMLRPC_XML_PARSER = xmlrpc_expat
|
||||
XML_PARSER_LIBDEP = \
|
||||
- -L$(BLDDIR)/lib/expat/xmlparse -lxmlrpc_xmlparse \
|
||||
+ -L$(BLDDIR)/lib/expat/xmlparse ../lib/expat/xmlparse/libxmlrpc_xmlparse.so \
|
||||
-L$(BLDDIR)/lib/expat/xmltok -lxmlrpc_xmltok
|
||||
XML_PARSER_LIBDEP_DEP = $(LIBXMLRPC_XMLPARSE) $(LIBXMLRPC_XMLTOK)
|
||||
endif
|
|
@ -1,11 +0,0 @@
|
|||
--- src/cpp/Makefile.orig 2008-10-12 21:53:42.000000000 +0400
|
||||
+++ src/cpp/Makefile 2008-10-12 21:53:51.000000000 +0400
|
||||
@@ -139,7 +139,7 @@
|
||||
# RULES TO COMPILE OBJECT MODULES FOR LIBRARIES
|
||||
#-----------------------------------------------------------------------------
|
||||
|
||||
-CXXFLAGS = $(CXXFLAGS_COMMON) $(CFLAGS_PERSONAL) $(CADD)
|
||||
+CXXFLAGS = $(CXXFLAGS_COMMON) $(CFLAGS_PERSONAL) $(CADD) -fPIC
|
||||
|
||||
XmlRpcCpp.o:%.o:%.cpp
|
||||
$(CXX) -c $(BASIC_INCLUDES) $(CXXFLAGS) $<
|
|
@ -1,75 +1,106 @@
|
|||
%%CLIENT%%bin/xmlrpc
|
||||
bin/xmlrpc-c-config
|
||||
%%CLIENT%%bin/xmlrpc_transport
|
||||
include/XmlRpcCpp.h
|
||||
include/xmlrpc-c/abyss.h
|
||||
include/xmlrpc-c/abyss_unixsock.h
|
||||
include/xmlrpc-c/abyss_winsock.h
|
||||
include/xmlrpc-c/base.h
|
||||
include/xmlrpc-c/base.hpp
|
||||
%%CLIENT%%include/xmlrpc-c/client.h
|
||||
%%CLIENT%%include/xmlrpc-c/client.hpp
|
||||
%%CLIENT%%include/xmlrpc-c/client_global.h
|
||||
%%CLIENT%%include/xmlrpc-c/client_simple.hpp
|
||||
%%CLIENT%%include/xmlrpc-c/client_transport.hpp
|
||||
include/xmlrpc-c/c_util.h
|
||||
include/xmlrpc-c/client.h
|
||||
include/xmlrpc-c/client.hpp
|
||||
include/xmlrpc-c/client_global.h
|
||||
include/xmlrpc-c/client_simple.hpp
|
||||
include/xmlrpc-c/client_transport.hpp
|
||||
include/xmlrpc-c/config.h
|
||||
include/xmlrpc-c/girerr.hpp
|
||||
include/xmlrpc-c/girmem.hpp
|
||||
include/xmlrpc-c/inttypes.h
|
||||
include/xmlrpc-c/oldcppwrapper.hpp
|
||||
include/xmlrpc-c/oldxmlrpc.h
|
||||
include/xmlrpc-c/packetsocket.hpp
|
||||
include/xmlrpc-c/registry.hpp
|
||||
include/xmlrpc-c/server.h
|
||||
include/xmlrpc-c/server_abyss.h
|
||||
include/xmlrpc-c/server_abyss.hpp
|
||||
include/xmlrpc-c/server_cgi.h
|
||||
include/xmlrpc-c/server_pstream.hpp
|
||||
include/xmlrpc-c/server_w32httpsys.h
|
||||
include/xmlrpc-c/timeout.hpp
|
||||
%%CLIENT%%include/xmlrpc-c/transport.h
|
||||
include/xmlrpc-c/transport.h
|
||||
include/xmlrpc-c/util.h
|
||||
include/xmlrpc-c/xml.hpp
|
||||
include/xmlrpc.h
|
||||
include/xmlrpc_abyss.h
|
||||
include/xmlrpc_cgi.h
|
||||
include/xmlrpc_client.h
|
||||
include/xmlrpc_server.h
|
||||
include/xmlrpc_abyss.h
|
||||
include/xmlrpc_server_w32httpsys.h
|
||||
lib/libxmlrpc++.a
|
||||
lib/libxmlrpc++.so
|
||||
lib/libxmlrpc++.so.4
|
||||
lib/libxmlrpc++.so.4.16
|
||||
lib/libxmlrpc.a
|
||||
lib/libxmlrpc.la
|
||||
lib/libxmlrpc.so
|
||||
lib/libxmlrpc.so.9
|
||||
lib/libxmlrpc.so.3
|
||||
lib/libxmlrpc.so.3.16
|
||||
lib/libxmlrpc_abyss.a
|
||||
lib/libxmlrpc_abyss.la
|
||||
lib/libxmlrpc_abyss.so
|
||||
lib/libxmlrpc_abyss.so.9
|
||||
%%CLIENT%%lib/libxmlrpc_client++.a
|
||||
%%CLIENT%%lib/libxmlrpc_client.a
|
||||
%%CLIENT%%lib/libxmlrpc_client.la
|
||||
%%CLIENT%%lib/libxmlrpc_client.so
|
||||
%%CLIENT%%lib/libxmlrpc_client.so.9
|
||||
lib/libxmlrpc_abyss.so.3
|
||||
lib/libxmlrpc_abyss.so.3.16
|
||||
lib/libxmlrpc_client++.a
|
||||
lib/libxmlrpc_client++.so
|
||||
lib/libxmlrpc_client++.so.4
|
||||
lib/libxmlrpc_client++.so.4.16
|
||||
lib/libxmlrpc_client.a
|
||||
lib/libxmlrpc_client.so
|
||||
lib/libxmlrpc_client.so.3
|
||||
lib/libxmlrpc_client.so.3.16
|
||||
lib/libxmlrpc_cpp.a
|
||||
lib/libxmlrpc_cpp.so
|
||||
lib/libxmlrpc_cpp.so.4
|
||||
lib/libxmlrpc_cpp.so.4.16
|
||||
lib/libxmlrpc_packetsocket.a
|
||||
lib/libxmlrpc_packetsocket.so
|
||||
lib/libxmlrpc_packetsocket.so.4
|
||||
lib/libxmlrpc_packetsocket.so.4.16
|
||||
lib/libxmlrpc_server++.a
|
||||
lib/libxmlrpc_server++.so
|
||||
lib/libxmlrpc_server++.so.4
|
||||
lib/libxmlrpc_server++.so.4.16
|
||||
lib/libxmlrpc_server.a
|
||||
lib/libxmlrpc_server.la
|
||||
lib/libxmlrpc_server.so
|
||||
lib/libxmlrpc_server.so.9
|
||||
lib/libxmlrpc_server.so.3
|
||||
lib/libxmlrpc_server.so.3.16
|
||||
lib/libxmlrpc_server_abyss++.a
|
||||
lib/libxmlrpc_server_abyss++.so
|
||||
lib/libxmlrpc_server_abyss++.so.4
|
||||
lib/libxmlrpc_server_abyss++.so.4.16
|
||||
lib/libxmlrpc_server_abyss.a
|
||||
lib/libxmlrpc_server_abyss.la
|
||||
lib/libxmlrpc_server_abyss.so
|
||||
lib/libxmlrpc_server_abyss.so.9
|
||||
lib/libxmlrpc_server_abyss.so.3
|
||||
lib/libxmlrpc_server_abyss.so.3.16
|
||||
lib/libxmlrpc_server_cgi++.a
|
||||
lib/libxmlrpc_server_cgi++.so
|
||||
lib/libxmlrpc_server_cgi++.so.4
|
||||
lib/libxmlrpc_server_cgi++.so.4.16
|
||||
lib/libxmlrpc_server_cgi.a
|
||||
lib/libxmlrpc_server_cgi.la
|
||||
lib/libxmlrpc_server_cgi.so
|
||||
lib/libxmlrpc_server_cgi.so.9
|
||||
lib/libxmlrpc_server_cgi.so.3
|
||||
lib/libxmlrpc_server_cgi.so.3.16
|
||||
lib/libxmlrpc_server_pstream++.a
|
||||
lib/libxmlrpc_server_pstream++.so
|
||||
lib/libxmlrpc_server_pstream++.so.4
|
||||
lib/libxmlrpc_server_pstream++.so.4.16
|
||||
lib/libxmlrpc_util.a
|
||||
lib/libxmlrpc_util.la
|
||||
lib/libxmlrpc_util.so
|
||||
lib/libxmlrpc_util.so.9
|
||||
lib/libxmlrpc_util.so.3
|
||||
lib/libxmlrpc_util.so.3.16
|
||||
lib/libxmlrpc_xmlparse.a
|
||||
lib/libxmlrpc_xmlparse.la
|
||||
lib/libxmlrpc_xmlparse.so
|
||||
lib/libxmlrpc_xmlparse.so.9
|
||||
lib/libxmlrpc_xmlparse.so.3
|
||||
lib/libxmlrpc_xmlparse.so.3.16
|
||||
lib/libxmlrpc_xmltok.a
|
||||
lib/libxmlrpc_xmltok.la
|
||||
lib/libxmlrpc_xmltok.so
|
||||
lib/libxmlrpc_xmltok.so.9
|
||||
lib/libxmlrpc_xmltok.so.3
|
||||
lib/libxmlrpc_xmltok.so.3.16
|
||||
@dirrm include/xmlrpc-c
|
||||
|
|
Loading…
Reference in a new issue