Back out to 0.0.11, because the 0.0.16 requires the development version of
py-gtk2 2.3.x (available at MarcusCom CVS). You still can get 0.0.16 at http://people.freebsd.org/~mezz/diff/ if you want to, which I will keep update from there until py-gtk2 2.3.x (will be 2.4) becomes stable. Reported by: Randy Pratt <rpratt1950@earthlink.net>
This commit is contained in:
parent
8a803ed816
commit
1a006ddaae
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=111972
8 changed files with 32 additions and 60 deletions
|
@ -6,7 +6,9 @@
|
|||
#
|
||||
|
||||
PORTNAME= gnome-btdownload
|
||||
PORTVERSION= 0.0.16
|
||||
PORTVERSION= 0.0.11
|
||||
PORTREVISION= 1
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= net gnome
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= gnome-bt
|
||||
|
@ -25,18 +27,9 @@ USE_GNOME= gnomehack gnomeprefix pygnome2
|
|||
GNU_CONFIGURE= yes
|
||||
|
||||
MAN1= gnome-btdownload.1
|
||||
DOCS= AUTHORS COPYING ChangeLog INSTALL README
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|%%X11PREFIX%%|${PREFIX}|g' \
|
||||
${WRKSRC}/src/${PORTNAME}
|
||||
|
||||
.ifndef (NOPORTDOCS)
|
||||
post-install:
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
.for i in ${DOCS}
|
||||
@${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (gnome-btdownload-0.0.16.tar.bz2) = f54826a4b5bc82367cff3f3ca8095f9d
|
||||
SIZE (gnome-btdownload-0.0.16.tar.bz2) = 85870
|
||||
MD5 (gnome-btdownload-0.0.11.tar.bz2) = 023786c0b2d6096f45ab841699658c23
|
||||
SIZE (gnome-btdownload-0.0.11.tar.bz2) = 83482
|
||||
|
|
|
@ -1,17 +1,17 @@
|
|||
--- src/gnome-btdownload.orig Tue Jun 15 00:16:22 2004
|
||||
+++ src/gnome-btdownload Tue Jun 15 00:17:17 2004
|
||||
--- src/gnome-btdownload.orig Thu Jan 8 22:13:40 2004
|
||||
+++ src/gnome-btdownload Thu Jan 8 22:14:05 2004
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/python
|
||||
+#!/usr/bin/env python
|
||||
|
||||
# BitTorrent related modules.
|
||||
import BitTorrent.download, BitTorrent.bencode
|
||||
@@ -72,7 +72,7 @@
|
||||
# Fallback wrapper
|
||||
if not locate_file:
|
||||
def fallback_locate_attempt_prefixes(path):
|
||||
- prefixes = ['', 'usr/', 'usr/local/']
|
||||
+ prefixes = ['', '%%X11PREFIX%%/', 'usr/', 'usr/local/']
|
||||
import os.path, threading, sys, time, re
|
||||
@@ -49,7 +49,7 @@
|
||||
if not locate_file or not get_url:
|
||||
try:
|
||||
def fallback_locate_attempt_prefixes(path):
|
||||
- prefixes = ['', 'usr/', 'usr/local/']
|
||||
+ prefixes = ['', '%%X11PREFIX%%/', 'usr/', 'usr/local/']
|
||||
|
||||
# Try them locally
|
||||
for prefix in prefixes:
|
||||
# Try them locally
|
||||
for prefix in prefixes:
|
||||
|
|
|
@ -1,11 +1,5 @@
|
|||
bin/gnome-btdownload
|
||||
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/COPYING
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
|
||||
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
share/gnome/application-registry/gnome-btdownload.applications
|
||||
share/gnome/gnome-btdownload/glade/contdiag.glade
|
||||
share/gnome/gnome-btdownload/glade/dlsession.glade
|
||||
share/gnome/gnome-btdownload/glade/errdiag.glade
|
||||
share/gnome/gnome-btdownload/pixmaps/download.png
|
||||
|
@ -14,4 +8,3 @@ share/gnome/mime-info/gnome-btdownload.mime
|
|||
@dirrm share/gnome/gnome-btdownload/pixmaps
|
||||
@dirrm share/gnome/gnome-btdownload/glade
|
||||
@dirrm share/gnome/gnome-btdownload
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
|
|
|
@ -6,7 +6,9 @@
|
|||
#
|
||||
|
||||
PORTNAME= gnome-btdownload
|
||||
PORTVERSION= 0.0.16
|
||||
PORTVERSION= 0.0.11
|
||||
PORTREVISION= 1
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= net gnome
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= gnome-bt
|
||||
|
@ -25,18 +27,9 @@ USE_GNOME= gnomehack gnomeprefix pygnome2
|
|||
GNU_CONFIGURE= yes
|
||||
|
||||
MAN1= gnome-btdownload.1
|
||||
DOCS= AUTHORS COPYING ChangeLog INSTALL README
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|%%X11PREFIX%%|${PREFIX}|g' \
|
||||
${WRKSRC}/src/${PORTNAME}
|
||||
|
||||
.ifndef (NOPORTDOCS)
|
||||
post-install:
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
.for i in ${DOCS}
|
||||
@${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (gnome-btdownload-0.0.16.tar.bz2) = f54826a4b5bc82367cff3f3ca8095f9d
|
||||
SIZE (gnome-btdownload-0.0.16.tar.bz2) = 85870
|
||||
MD5 (gnome-btdownload-0.0.11.tar.bz2) = 023786c0b2d6096f45ab841699658c23
|
||||
SIZE (gnome-btdownload-0.0.11.tar.bz2) = 83482
|
||||
|
|
|
@ -1,17 +1,17 @@
|
|||
--- src/gnome-btdownload.orig Tue Jun 15 00:16:22 2004
|
||||
+++ src/gnome-btdownload Tue Jun 15 00:17:17 2004
|
||||
--- src/gnome-btdownload.orig Thu Jan 8 22:13:40 2004
|
||||
+++ src/gnome-btdownload Thu Jan 8 22:14:05 2004
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/python
|
||||
+#!/usr/bin/env python
|
||||
|
||||
# BitTorrent related modules.
|
||||
import BitTorrent.download, BitTorrent.bencode
|
||||
@@ -72,7 +72,7 @@
|
||||
# Fallback wrapper
|
||||
if not locate_file:
|
||||
def fallback_locate_attempt_prefixes(path):
|
||||
- prefixes = ['', 'usr/', 'usr/local/']
|
||||
+ prefixes = ['', '%%X11PREFIX%%/', 'usr/', 'usr/local/']
|
||||
import os.path, threading, sys, time, re
|
||||
@@ -49,7 +49,7 @@
|
||||
if not locate_file or not get_url:
|
||||
try:
|
||||
def fallback_locate_attempt_prefixes(path):
|
||||
- prefixes = ['', 'usr/', 'usr/local/']
|
||||
+ prefixes = ['', '%%X11PREFIX%%/', 'usr/', 'usr/local/']
|
||||
|
||||
# Try them locally
|
||||
for prefix in prefixes:
|
||||
# Try them locally
|
||||
for prefix in prefixes:
|
||||
|
|
|
@ -1,11 +1,5 @@
|
|||
bin/gnome-btdownload
|
||||
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/COPYING
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
|
||||
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
share/gnome/application-registry/gnome-btdownload.applications
|
||||
share/gnome/gnome-btdownload/glade/contdiag.glade
|
||||
share/gnome/gnome-btdownload/glade/dlsession.glade
|
||||
share/gnome/gnome-btdownload/glade/errdiag.glade
|
||||
share/gnome/gnome-btdownload/pixmaps/download.png
|
||||
|
@ -14,4 +8,3 @@ share/gnome/mime-info/gnome-btdownload.mime
|
|||
@dirrm share/gnome/gnome-btdownload/pixmaps
|
||||
@dirrm share/gnome/gnome-btdownload/glade
|
||||
@dirrm share/gnome/gnome-btdownload
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
|
|
Loading…
Reference in a new issue