Update to 2.15.7.
This commit is contained in:
parent
202b5ccddb
commit
1a524f5a1f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=41564
7 changed files with 76 additions and 57 deletions
|
@ -6,9 +6,10 @@
|
|||
#
|
||||
|
||||
PORTNAME= motor
|
||||
PORTVERSION= 2.6.3
|
||||
PORTVERSION= 2.15.7
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://konst.org.ua/download/ \
|
||||
MASTER_SITES= http://download.konst.org.ua/ \
|
||||
http://konst.org.ua/download/ \
|
||||
${MASTER_SITE_LOCAL}
|
||||
MASTER_SITE_SUBDIR= sobomax
|
||||
|
||||
|
@ -18,7 +19,7 @@ LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
|
|||
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="${CFLAGS}" \
|
||||
LOCALBASE="${LOCALBASE}"
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib -lintl"
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (motor-2.6.3.tar.gz) = 4d3ac7566c8d90efc96f0b4a18f152dc
|
||||
MD5 (motor-2.15.7.tar.gz) = f5f39813f996ab51e23db0451fef689a
|
||||
|
|
|
@ -1,16 +0,0 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- configure.orig Tue Feb 20 09:42:20 2001
|
||||
+++ configure Wed Feb 21 00:26:08 2001
|
||||
@@ -563,8 +563,8 @@
|
||||
FreeBSD*)
|
||||
echo "$ac_t""freebsd" 1>&6
|
||||
if test -z "$GCC"; then
|
||||
- LDFLAGS="-L/usr/local/lib -lintl"
|
||||
- CPPFLAGS="-I/usr/local/include"
|
||||
+ LDFLAGS="-L${LOCALBASE}/lib -lintl"
|
||||
+ CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include"
|
||||
fi
|
||||
;;
|
||||
|
14
devel/motor/files/patch-ktools::src::Makefile.in
Normal file
14
devel/motor/files/patch-ktools::src::Makefile.in
Normal file
|
@ -0,0 +1,14 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- ktools/src/Makefile.in 2001/04/17 13:43:29 1.1
|
||||
+++ ktools/src/Makefile.in 2001/04/17 13:43:36
|
||||
@@ -88,7 +88,7 @@
|
||||
noinst_LIBRARIES = libkonst.a
|
||||
libkonst_a_SOURCES = konst.d.cc konst.fs.cc konst.list.cc konst.logic.cc konst.process.cc konst.socket.cc konst.string.cc konst.ui.edit.cc konst.ui.fm.cc konst.ui.func.cc konst.ui.horbar.cc konst.ui.input.cc konst.ui.menu.cc konst.ui.skel.cc konst.ui.text.cc konst.ui.tree.cc konst.ui.window.cc konst.ui.dlg.cc
|
||||
EXTRA_DIST = konst.d.cc konst.fs.cc konst.list.cc konst.logic.cc konst.process.cc konst.socket.cc konst.string.cc konst.ui.edit.cc konst.ui.fm.cc konst.ui.func.cc konst.ui.horbar.cc konst.ui.input.cc konst.ui.menu.cc konst.ui.skel.cc konst.ui.text.cc konst.ui.tree.cc konst.ui.window.cc konst.ui.dlg.cc
|
||||
-CXXFLAGS = -g
|
||||
+#CXXFLAGS = -g
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
||||
CONFIG_HEADER = ../../config.h
|
||||
CONFIG_CLEAN_FILES =
|
|
@ -1,14 +0,0 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- po/Makefile.in 2001/02/20 22:35:16 1.1
|
||||
+++ po/Makefile.in 2001/02/20 22:36:03
|
||||
@@ -23,7 +23,7 @@
|
||||
for i in $(LANGS); do msgfmt -o $$i.mo $$i.po; done
|
||||
|
||||
install:
|
||||
- for i in $(LANGS); do install -D -m 644 $$i.mo ${datadir}/locale/$$i/LC_MESSAGES/motor.mo; done
|
||||
+ for i in $(LANGS); do install -c -D -m 644 $$i.mo ${datadir}/locale/$$i/LC_MESSAGES/motor.mo; done
|
||||
|
||||
uninstall:
|
||||
find ${datadir}/locale/ -name motor.mo -exec rm -f {} \;
|
|
@ -1,14 +1,31 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- src/Makefile.in 2001/02/20 22:38:22 1.1
|
||||
+++ src/Makefile.in 2001/02/20 22:38:53
|
||||
@@ -51,7 +51,7 @@
|
||||
$(CXX) @CPPFLAGS@ $*.cc -c $(INCLUDE) "-DVERSION=\"$(VERSION)\"" "-DSHAREDIR=\"@CONFIG_MOTOR_SHAREDIR@\"" "-DMAKECMD=\"$(MAKE)\"" -o $*.o
|
||||
--- src/Makefile.in.orig Mon Apr 16 23:04:06 2001
|
||||
+++ src/Makefile.in Tue Apr 17 16:50:15 2001
|
||||
@@ -61,6 +61,7 @@
|
||||
CATOBJEXT = @CATOBJEXT@
|
||||
CC = @CC@
|
||||
CXX = @CXX@
|
||||
+CPPFLAGS = @CPPFLAGS@
|
||||
DATADIRNAME = @DATADIRNAME@
|
||||
GENCAT = @GENCAT@
|
||||
GMOFILES = @GMOFILES@
|
||||
@@ -85,7 +86,7 @@
|
||||
l = @l@
|
||||
|
||||
install:
|
||||
- install -Ds motor $(bindir)/$(PROG)
|
||||
+ install -c -Ds motor $(bindir)/$(PROG)
|
||||
mkdir -p $(datadir)/$(PROG)/
|
||||
cp -R ../share/* ../COPYING $(datadir)/$(PROG)
|
||||
INCLUDES = -I../include -I../ktools/include -I../parser/include -I$(top_srcdir)/intl
|
||||
-CPPFLAGS = -DSHARE_DIR=\"$(pkgdatadir)\" -DLOCALE_DIR=\"$(datadir)/locale\"
|
||||
+CPPFLAGS += -DSHARE_DIR=\"$(pkgdatadir)\" -DLOCALE_DIR=\"$(datadir)/locale\"
|
||||
|
||||
bin_PROGRAMS = motor
|
||||
|
||||
@@ -93,7 +94,7 @@
|
||||
|
||||
|
||||
motor_LDADD = -lcurses ../parser/src/libparser.a ../ktools/src/libkonst.a @INTLLIBS@ @LIBS@
|
||||
-CXXFLAGS = -g
|
||||
+#CXXFLAGS = -g
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
||||
CONFIG_HEADER = ../config.h
|
||||
CONFIG_CLEAN_FILES =
|
||||
|
|
|
@ -1,30 +1,47 @@
|
|||
bin/motor
|
||||
share/locale/de/LC_MESSAGES/motor.mo
|
||||
share/locale/pl/LC_MESSAGES/motor.mo
|
||||
share/locale/ru/LC_MESSAGES/motor.mo
|
||||
share/motor/COPYING
|
||||
share/locale/zh_CN/LC_MESSAGES/motor.mo
|
||||
share/motor/external
|
||||
share/motor/syntax
|
||||
share/motor/templates/library/static/Browser
|
||||
share/motor/templates/library/static/Buildrules
|
||||
share/motor/templates/library/static/Debug
|
||||
share/motor/templates/library/static/Dist
|
||||
share/motor/templates/library/static/Folders
|
||||
share/motor/templates/library/static/Makefile
|
||||
share/motor/templates/library/static/rpm.Dist
|
||||
share/motor/templates/library/static/tar.gz.Dist
|
||||
share/motor/templates/library/static/Makefile.func
|
||||
share/motor/templates/library/static/Parserules
|
||||
share/motor/templates/library/static/[value name].spec.tmpl
|
||||
share/motor/templates/library/static/configure.in.tmpl
|
||||
share/motor/templates/terminal program/C++/Browser
|
||||
share/motor/templates/terminal program/C++/Buildrules
|
||||
share/motor/templates/terminal program/C++/Debug
|
||||
share/motor/templates/terminal program/C++/Dist
|
||||
share/motor/templates/terminal program/C++/Folders
|
||||
share/motor/templates/terminal program/C++/Makefile
|
||||
share/motor/templates/terminal program/C++/Makefile.func
|
||||
share/motor/templates/terminal program/C++/Parserules
|
||||
share/motor/templates/terminal program/C++/[value name].cc.tmpl
|
||||
share/motor/templates/terminal program/C++/rpm.Dist
|
||||
share/motor/templates/terminal program/C++/tar.gz.Dist
|
||||
share/motor/templates/terminal program/C++/[value name].spec.tmpl
|
||||
share/motor/templates/terminal program/C++/configure.in.tmpl
|
||||
share/motor/templates/terminal program/C/Browser
|
||||
share/motor/templates/terminal program/C/Buildrules
|
||||
share/motor/templates/terminal program/C/Debug
|
||||
share/motor/templates/terminal program/C/Dist
|
||||
share/motor/templates/terminal program/C/Folders
|
||||
share/motor/templates/terminal program/C/Makefile
|
||||
share/motor/templates/terminal program/C/Makefile.func
|
||||
share/motor/templates/terminal program/C/Parserules
|
||||
share/motor/templates/terminal program/C/[value name].c.tmpl
|
||||
share/motor/templates/terminal program/C/rpm.Dist
|
||||
share/motor/templates/terminal program/C/tar.gz.Dist
|
||||
share/motor/templates/terminal program/C/[value name].spec.tmpl
|
||||
share/motor/templates/terminal program/C/configure.in.tmpl
|
||||
share/motor/templates/terminal program/java/Browser
|
||||
share/motor/templates/terminal program/java/Debug
|
||||
share/motor/templates/terminal program/java/Dist
|
||||
share/motor/templates/terminal program/java/Folders
|
||||
share/motor/templates/terminal program/java/Makefile.func
|
||||
share/motor/templates/terminal program/java/Parserules
|
||||
share/motor/templates/terminal program/java/[value name].java.tmpl
|
||||
share/motor/templates/terminal program/java/[value name].spec.tmpl
|
||||
share/motor/templates/terminal program/java/configure.in.tmpl
|
||||
share/motor/themes
|
||||
@dirrm share/motor/templates/terminal program/java
|
||||
@dirrm share/motor/templates/terminal program/C++
|
||||
@dirrm share/motor/templates/terminal program/C
|
||||
@dirrm share/motor/templates/terminal program
|
||||
|
|
Loading…
Reference in a new issue