Update to 0.9

PR:		46496
Submitted by:	KATO Tsuguru <tkato@prontomail.com>
This commit is contained in:
Tilman Keskinoz 2003-01-03 13:13:33 +00:00
parent d2bc488b75
commit 1a992afbf2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=72399
10 changed files with 112 additions and 74 deletions

View file

@ -7,7 +7,7 @@
#
PORTNAME= tosvcd
PORTVERSION= 0.7
PORTVERSION= 0.9
CATEGORIES= graphics
MASTER_SITES= http://muse.seh.de/tosvcd/
@ -17,18 +17,10 @@ RUN_DEPNDS= mpeg2enc:${PORTSDIR}/multimedia/mjpegtools \
vcdimager:${PORTSDIR}/graphics/vcdimager
USE_BZIP2= yes
USE_REINPLACE= yes
MAKEFILE= makefile
USE_GMAKE= yes
post-patch:
@${REINPLACE_CMD} -e "s|^CFLAGS =|CFLAGS+=|" \
-e "s|^CFLAGS +=|#CFLAGS +=|g" \
-e "s|-lpthread|${PTHREAD_LIBS}|g" \
${WRKSRC}/${MAKEFILE}
@${REINPLACE_CMD} -e "s|malloc.h|stdlib.h|" ${WRKSRC}/decode.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tosvcd ${PREFIX}/bin
MAKEFILE= makefile
MAKE_ENV= CC="${CXX}" CFLAGS="${CXXFLAGS}" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (tosvcd-0.7.tar.bz2) = d821ed70eed67dae5fbbc041217f327f
MD5 (tosvcd-0.9.tar.bz2) = 696c55f668e2019ffa87d9e11902451a

View file

@ -1,6 +1,14 @@
--- decode.c.orig Fri Oct 25 16:01:13 2002
+++ decode.c Fri Oct 25 16:01:31 2002
@@ -21,7 +21,7 @@
--- decode.c.orig Wed Dec 4 22:40:42 2002
+++ decode.c Sat Dec 14 07:25:35 2002
@@ -8,7 +8,6 @@
#include "mm_accel.h"
#include "attributes.h"
#include "mmx.h"
-#include "malloc.h"
extern FILE* log;
@@ -21,7 +20,7 @@
Mpeg2dec::Mpeg2dec(uint32_t mm_accel)
{
config.flags = mm_accel;
@ -9,7 +17,7 @@
memset(picture, 0, sizeof (picture_t));
frames = 0;
frame_ptr[0] = 0;
@@ -66,7 +66,7 @@
@@ -63,7 +62,7 @@
int size = width() * height() / 4;
if (frames)
free(frames);

View file

@ -1,11 +1,39 @@
--- makefile.orig Fri Oct 25 16:04:05 2002
+++ makefile Fri Oct 25 16:04:25 2002
@@ -21,7 +21,7 @@
--- makefile.orig Wed Dec 4 22:40:42 2002
+++ makefile Sat Dec 14 07:27:00 2002
@@ -1,15 +1,15 @@
# use intel compiler 0.6.x
INTEL = no
-CFLAGS = -DVERSION="\"0.9\""
+CFLAGS += -DVERSION="\"0.9\""
ifeq ($(INTEL),yes)
#CC = icc -I/usr/lib/gcc-lib/i686-pc-linux-gnu/2.95.3/include -Kc++ -O -tpp6 -xiMK
CC = icc -Kc++ -O -tpp6 -xiMK
#CC = icc
else
-CC = g++
-CFLAGS += -g -Wall -O3 -fno-exceptions -fno-rtti
+CC ?= g++
+CFLAGS += -fno-exceptions -fno-rtti ${PTHREAD_CFLAGS}
endif
SRC = tosvcd decode header idct idct_mmx motion_comp
@@ -20,15 +20,13 @@
all: tosvcd
tosvcd: $(OBJ)
$(CC) -o tosvcd $(OBJ) -lpthread
- $(CC) -o tosvcd $(OBJ) -lpthread
- su -c "cp tosvcd /usr/bin"
+# su -c "cp tosvcd /usr/bin"
+ $(CC) -o tosvcd $(OBJ) ${PTHREAD_LIBS}
t:
./tosvcd -o reeperbahn /video0/Auf_der_Reeperbahn_nachts_um_halb_eins/2002-03-09.15:21.50.50.rec
./tosvcd -o mafia /home/ws/videos/Mafia/2002-10-21.00:33.50.50.rec
install::
- su -c "mv /usr/bin/tosvcd /usr/bin/tosvcd.old"
- su -c "cp tosvcd /usr/bin"
+ ${BSD_INSTALL_PROGRAM} tosvcd ${PREFIX}/bin
clean:
rm *.o

View file

@ -1,6 +1,6 @@
--- tosvcd.c.orig Fri Sep 13 10:08:52 2002
+++ tosvcd.c Mon Nov 18 16:56:27 2002
@@ -24,14 +24,12 @@
--- tosvcd.c.orig Mon Dec 9 18:24:57 2002
+++ tosvcd.c Sat Dec 14 07:21:57 2002
@@ -20,14 +20,12 @@
#include <fcntl.h>
#include <errno.h>
#include <string.h>
@ -15,13 +15,4 @@
+#include <sys/wait.h>
#include <glob.h>
@@ -1322,7 +1320,7 @@
// catch all signals
//---------------------------------------------------
#if 1
- for (int i = 0; i < _NSIG; ++i) {
+ for (int i = 0; i < NSIG; ++i) {
if (i != SIGABRT)
signal(i, catchSignal);
}
#include "mm_accel.h"

View file

@ -7,7 +7,7 @@
#
PORTNAME= tosvcd
PORTVERSION= 0.7
PORTVERSION= 0.9
CATEGORIES= graphics
MASTER_SITES= http://muse.seh.de/tosvcd/
@ -17,18 +17,10 @@ RUN_DEPNDS= mpeg2enc:${PORTSDIR}/multimedia/mjpegtools \
vcdimager:${PORTSDIR}/graphics/vcdimager
USE_BZIP2= yes
USE_REINPLACE= yes
MAKEFILE= makefile
USE_GMAKE= yes
post-patch:
@${REINPLACE_CMD} -e "s|^CFLAGS =|CFLAGS+=|" \
-e "s|^CFLAGS +=|#CFLAGS +=|g" \
-e "s|-lpthread|${PTHREAD_LIBS}|g" \
${WRKSRC}/${MAKEFILE}
@${REINPLACE_CMD} -e "s|malloc.h|stdlib.h|" ${WRKSRC}/decode.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tosvcd ${PREFIX}/bin
MAKEFILE= makefile
MAKE_ENV= CC="${CXX}" CFLAGS="${CXXFLAGS}" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (tosvcd-0.7.tar.bz2) = d821ed70eed67dae5fbbc041217f327f
MD5 (tosvcd-0.9.tar.bz2) = 696c55f668e2019ffa87d9e11902451a

View file

@ -1,6 +1,14 @@
--- decode.c.orig Fri Oct 25 16:01:13 2002
+++ decode.c Fri Oct 25 16:01:31 2002
@@ -21,7 +21,7 @@
--- decode.c.orig Wed Dec 4 22:40:42 2002
+++ decode.c Sat Dec 14 07:25:35 2002
@@ -8,7 +8,6 @@
#include "mm_accel.h"
#include "attributes.h"
#include "mmx.h"
-#include "malloc.h"
extern FILE* log;
@@ -21,7 +20,7 @@
Mpeg2dec::Mpeg2dec(uint32_t mm_accel)
{
config.flags = mm_accel;
@ -9,7 +17,7 @@
memset(picture, 0, sizeof (picture_t));
frames = 0;
frame_ptr[0] = 0;
@@ -66,7 +66,7 @@
@@ -63,7 +62,7 @@
int size = width() * height() / 4;
if (frames)
free(frames);

View file

@ -1,11 +1,39 @@
--- makefile.orig Fri Oct 25 16:04:05 2002
+++ makefile Fri Oct 25 16:04:25 2002
@@ -21,7 +21,7 @@
--- makefile.orig Wed Dec 4 22:40:42 2002
+++ makefile Sat Dec 14 07:27:00 2002
@@ -1,15 +1,15 @@
# use intel compiler 0.6.x
INTEL = no
-CFLAGS = -DVERSION="\"0.9\""
+CFLAGS += -DVERSION="\"0.9\""
ifeq ($(INTEL),yes)
#CC = icc -I/usr/lib/gcc-lib/i686-pc-linux-gnu/2.95.3/include -Kc++ -O -tpp6 -xiMK
CC = icc -Kc++ -O -tpp6 -xiMK
#CC = icc
else
-CC = g++
-CFLAGS += -g -Wall -O3 -fno-exceptions -fno-rtti
+CC ?= g++
+CFLAGS += -fno-exceptions -fno-rtti ${PTHREAD_CFLAGS}
endif
SRC = tosvcd decode header idct idct_mmx motion_comp
@@ -20,15 +20,13 @@
all: tosvcd
tosvcd: $(OBJ)
$(CC) -o tosvcd $(OBJ) -lpthread
- $(CC) -o tosvcd $(OBJ) -lpthread
- su -c "cp tosvcd /usr/bin"
+# su -c "cp tosvcd /usr/bin"
+ $(CC) -o tosvcd $(OBJ) ${PTHREAD_LIBS}
t:
./tosvcd -o reeperbahn /video0/Auf_der_Reeperbahn_nachts_um_halb_eins/2002-03-09.15:21.50.50.rec
./tosvcd -o mafia /home/ws/videos/Mafia/2002-10-21.00:33.50.50.rec
install::
- su -c "mv /usr/bin/tosvcd /usr/bin/tosvcd.old"
- su -c "cp tosvcd /usr/bin"
+ ${BSD_INSTALL_PROGRAM} tosvcd ${PREFIX}/bin
clean:
rm *.o

View file

@ -1,6 +1,6 @@
--- tosvcd.c.orig Fri Sep 13 10:08:52 2002
+++ tosvcd.c Mon Nov 18 16:56:27 2002
@@ -24,14 +24,12 @@
--- tosvcd.c.orig Mon Dec 9 18:24:57 2002
+++ tosvcd.c Sat Dec 14 07:21:57 2002
@@ -20,14 +20,12 @@
#include <fcntl.h>
#include <errno.h>
#include <string.h>
@ -15,13 +15,4 @@
+#include <sys/wait.h>
#include <glob.h>
@@ -1322,7 +1320,7 @@
// catch all signals
//---------------------------------------------------
#if 1
- for (int i = 0; i < _NSIG; ++i) {
+ for (int i = 0; i < NSIG; ++i) {
if (i != SIGABRT)
signal(i, catchSignal);
}
#include "mm_accel.h"