Update to 4.4.0
This commit is contained in:
parent
dd4d41f7ea
commit
1aa2f1f0d4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=154965
6 changed files with 80 additions and 87 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= BitTorrent
|
||||
PORTVERSION= 4.2.2
|
||||
PORTVERSION= 4.4.0
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES?= net-p2p python
|
||||
MASTER_SITES= http://www.bittorrent.com/dl/ \
|
||||
|
@ -54,26 +54,49 @@ PLIST_FILES+= \
|
|||
bin/bittorrent \
|
||||
bin/maketorrent \
|
||||
share/pixmaps/BitTorrent/bittorrent.ico \
|
||||
share/pixmaps/BitTorrent/broken.png \
|
||||
share/pixmaps/BitTorrent/finished.png \
|
||||
share/pixmaps/BitTorrent/info.png \
|
||||
share/pixmaps/BitTorrent/icons/default/abort.png \
|
||||
share/pixmaps/BitTorrent/icons/default/broken.png \
|
||||
share/pixmaps/BitTorrent/icons/default/finished.png \
|
||||
share/pixmaps/BitTorrent/icons/default/info.png \
|
||||
share/pixmaps/BitTorrent/icons/default/pause.png \
|
||||
share/pixmaps/BitTorrent/icons/default/paused.png \
|
||||
share/pixmaps/BitTorrent/icons/default/play.png \
|
||||
share/pixmaps/BitTorrent/icons/default/queued.png \
|
||||
share/pixmaps/BitTorrent/icons/default/remove.png \
|
||||
share/pixmaps/BitTorrent/icons/default/running.png \
|
||||
share/pixmaps/BitTorrent/icons/default/status-broken.png \
|
||||
share/pixmaps/BitTorrent/icons/default/status-natted.png \
|
||||
share/pixmaps/BitTorrent/icons/default/status-pre-natted.png \
|
||||
share/pixmaps/BitTorrent/icons/default/status-running.png \
|
||||
share/pixmaps/BitTorrent/icons/default/status-starting.png \
|
||||
share/pixmaps/BitTorrent/icons/default/status-stopped.png \
|
||||
share/pixmaps/BitTorrent/icons/default/trashcan.png \
|
||||
share/pixmaps/BitTorrent/icons/old/broken.png \
|
||||
share/pixmaps/BitTorrent/icons/old/finished.png \
|
||||
share/pixmaps/BitTorrent/icons/old/info.png \
|
||||
share/pixmaps/BitTorrent/icons/old/pause.png \
|
||||
share/pixmaps/BitTorrent/icons/old/paused.png \
|
||||
share/pixmaps/BitTorrent/icons/old/play.png \
|
||||
share/pixmaps/BitTorrent/icons/old/queued.png \
|
||||
share/pixmaps/BitTorrent/icons/old/remove.png \
|
||||
share/pixmaps/BitTorrent/icons/old/running.png \
|
||||
share/pixmaps/BitTorrent/icons/old/status-broken.png \
|
||||
share/pixmaps/BitTorrent/icons/old/status-natted.png \
|
||||
share/pixmaps/BitTorrent/icons/old/status-pre-natted.png \
|
||||
share/pixmaps/BitTorrent/icons/old/status-running.png \
|
||||
share/pixmaps/BitTorrent/icons/old/status-starting.png \
|
||||
share/pixmaps/BitTorrent/icons/old/status-stopped.png \
|
||||
share/pixmaps/BitTorrent/logo/bittorrent_32.png \
|
||||
share/pixmaps/BitTorrent/logo/bittorrent_96.png \
|
||||
share/pixmaps/BitTorrent/pause.png \
|
||||
share/pixmaps/BitTorrent/paused.png \
|
||||
share/pixmaps/BitTorrent/play.png \
|
||||
share/pixmaps/BitTorrent/queued.png \
|
||||
share/pixmaps/BitTorrent/remove.png \
|
||||
share/pixmaps/BitTorrent/running.png \
|
||||
share/pixmaps/BitTorrent/status-natted.png \
|
||||
share/pixmaps/BitTorrent/status-running.png \
|
||||
share/pixmaps/BitTorrent/status-stopped.png
|
||||
share/pixmaps/BitTorrent/logo/bittorrent_96.png
|
||||
|
||||
PLIST_SUB+= GUI=""
|
||||
PLIST_DIRS+= \
|
||||
share/pixmaps/BitTorrent/logo \
|
||||
share/pixmaps/BitTorrent/icons/old \
|
||||
share/pixmaps/BitTorrent/icons/default \
|
||||
share/pixmaps/BitTorrent/icons \
|
||||
share/pixmaps/BitTorrent
|
||||
.else
|
||||
EXTRA_PATCHES+= ${FILESDIR}/extra-nogui-patch-setup.py
|
||||
|
||||
PLIST_SUB+= GUI="@comment "
|
||||
.endif
|
||||
# required for PSYCO
|
||||
.ifndef(WITHOUT_PSYCO)
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (BitTorrent-4.2.2.tar.gz) = 2a85715b8ef0335ecc9e8ad91860231b
|
||||
SHA256 (BitTorrent-4.2.2.tar.gz) = cd14416698064015292ad128ddf349747f2cbb6e06d3c0ffa49b7ddfeda254ff
|
||||
SIZE (BitTorrent-4.2.2.tar.gz) = 2238224
|
||||
MD5 (BitTorrent-4.4.0.tar.gz) = 74d4b48202c28f0b27e989b6d5f5b214
|
||||
SHA256 (BitTorrent-4.4.0.tar.gz) = 1c9338ed384240258b5733a814670e2dee8ca2fb65babf3f0ca07978707301e0
|
||||
SIZE (BitTorrent-4.4.0.tar.gz) = 1255281
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- BitTorrent/__init__.py.orig Sun Nov 20 23:18:59 2005
|
||||
+++ BitTorrent/__init__.py Sun Nov 20 23:19:07 2005
|
||||
@@ -64,7 +64,7 @@
|
||||
'te' :u' తెలుగు' ,
|
||||
}
|
||||
|
||||
-#language_names.update(unfinished_language_names)
|
||||
+language_names.update(unfinished_language_names)
|
||||
|
||||
languages = language_names.keys()
|
||||
languages.sort()
|
|
@ -1,11 +1,11 @@
|
|||
--- BitTorrent/defaultargs.py.orig Tue May 24 03:01:06 2005
|
||||
+++ BitTorrent/defaultargs.py Sun May 29 22:48:48 2005
|
||||
@@ -110,7 +110,7 @@
|
||||
_("do not connect to several peers that have the same IP address")),
|
||||
('peer_socket_tos', 8,
|
||||
_("if nonzero, set the TOS option for peer connections to this value")),
|
||||
- ('bad_libc_workaround', MYFALSE,
|
||||
+ ('bad_libc_workaround', MYTRUE,
|
||||
_("enable workaround for a bug in BSD libc that makes file reads very slow.")),
|
||||
('tracker_proxy', '',
|
||||
_("address of HTTP proxy to use for tracker connections")),
|
||||
--- BitTorrent/defaultargs.py.orig Wed Jan 11 19:16:54 2006
|
||||
+++ BitTorrent/defaultargs.py Wed Jan 11 19:17:16 2006
|
||||
@@ -33,6 +33,8 @@
|
||||
if os.name == 'posix':
|
||||
if os.uname()[0] in ['Darwin']:
|
||||
BAD_LIBC_WORKAROUND_DEFAULT = MYTRUE
|
||||
+ if os.uname()[0] in ['FreeBSD']:
|
||||
+ BAD_LIBC_WORKAROUND_DEFAULT = MYTRUE
|
||||
|
||||
MIN_INCOMPLETE = 100
|
||||
if os.name == 'nt':
|
||||
|
|
|
@ -1,9 +0,0 @@
|
|||
--- makei18n.sh.orig Sun Nov 20 23:17:39 2005
|
||||
+++ makei18n.sh Sun Nov 20 23:18:34 2005
|
||||
@@ -1,5 +1,5 @@
|
||||
APP_NAME="bittorrent"
|
||||
-LANGUAGES=`python language_codes.py`
|
||||
+LANGUAGES=`cd po; ls *.po | sed -e 's/\.po//'`
|
||||
MESSAGES_PO="messages.pot"
|
||||
|
||||
rm -f $APP_NAME.lis
|
|
@ -6,6 +6,9 @@ bin/launchmany-console
|
|||
bin/launchmany-curses
|
||||
bin/maketorrent-console
|
||||
bin/torrentinfo-console
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/BeautifulSupe.py
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/BeautifulSupe.pyc
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/BeautifulSupe.pyo
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/Choker.py
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/Choker.pyc
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/Choker.pyo
|
||||
|
@ -42,15 +45,24 @@ bin/torrentinfo-console
|
|||
%%PYTHON_SITELIBDIR%%/BitTorrent/HTTPHandler.py
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/HTTPHandler.pyc
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/HTTPHandler.pyo
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/IPC.py
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/IPC.pyc
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/IPC.pyo
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/LaunchPath.py
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/LaunchPath.pyc
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/LaunchPath.pyo
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/NatCheck.py
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/NatCheck.pyc
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/NatCheck.pyo
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/NatTraversal.py
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/NatTraversal.pyc
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/NatTraversal.pyo
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/NewVersion.py
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/NewVersion.pyc
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/NewVersion.pyo
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/PeerID.py
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/PeerID.pyc
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/PeerID.pyo
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/PiecePicker.py
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/PiecePicker.pyc
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/PiecePicker.pyo
|
||||
|
@ -72,6 +84,9 @@ bin/torrentinfo-console
|
|||
%%PYTHON_SITELIBDIR%%/BitTorrent/Rerequester.py
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/Rerequester.pyc
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/Rerequester.pyo
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/StatusLight.py
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/StatusLight.pyc
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/StatusLight.pyo
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/Storage.py
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/Storage.pyc
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/Storage.pyo
|
||||
|
@ -81,6 +96,9 @@ bin/torrentinfo-console
|
|||
%%PYTHON_SITELIBDIR%%/BitTorrent/TorrentQueue.py
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/TorrentQueue.pyc
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/TorrentQueue.pyo
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/TrayIcon.py
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/TrayIcon.pyc
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/TrayIcon.pyo
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/Uploader.py
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/Uploader.pyc
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/Uploader.pyo
|
||||
|
@ -99,9 +117,6 @@ bin/torrentinfo-console
|
|||
%%PYTHON_SITELIBDIR%%/BitTorrent/configfile.py
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/configfile.pyc
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/configfile.pyo
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/controlsocket.py
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/controlsocket.pyc
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/controlsocket.pyo
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/defaultargs.py
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/defaultargs.pyc
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/defaultargs.pyo
|
||||
|
@ -111,6 +126,9 @@ bin/torrentinfo-console
|
|||
%%PYTHON_SITELIBDIR%%/BitTorrent/download.py
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/download.pyc
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/download.pyo
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/language.py
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/language.pyc
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/language.pyo
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/launchmanycore.py
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/launchmanycore.pyc
|
||||
%%PYTHON_SITELIBDIR%%/BitTorrent/launchmanycore.pyo
|
||||
|
@ -212,32 +230,21 @@ bin/torrentinfo-console
|
|||
%%PYTHON_SITELIBDIR%%/khashmir/utkhashmir.pyo
|
||||
%%DATADIR%%/public.key
|
||||
share/locale/af/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/ar/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/bg/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/ca/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/cs/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/da/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/de/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/eo/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/el/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/es/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/es_MX/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/et/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/eu/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/fi/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/fr/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/ga/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/gr/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/he_IL/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/hr/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/he/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/hu/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/hy/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/is/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/it/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/ja/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/ka/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/ko/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/lt/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/ml/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/ms/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/nb_NO/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/nl/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/pl/LC_MESSAGES/bittorrent.mo
|
||||
|
@ -247,26 +254,15 @@ share/locale/ro/LC_MESSAGES/bittorrent.mo
|
|||
share/locale/ru/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/sk/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/sl/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/sq/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/sv/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/th/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/tlh/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/tr/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/uk/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/vi/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/zh_CN/LC_MESSAGES/bittorrent.mo
|
||||
share/locale/zh_TW/LC_MESSAGES/bittorrent.mo
|
||||
%%GUI%%@dirrm share/pixmaps/BitTorrent/logo
|
||||
%%GUI%%@dirrm share/pixmaps/BitTorrent
|
||||
%%GUI%%@dirrmtry share/pixmaps
|
||||
@dirrmtry share/locale/zh_TW/LC_MESSAGES
|
||||
@dirrmtry share/locale/zh_TW
|
||||
@dirrmtry share/locale/zh_CN/LC_MESSAGES
|
||||
@dirrmtry share/locale/zh_CN
|
||||
@dirrmtry share/locale/uk/LC_MESSAGES
|
||||
@dirrmtry share/locale/uk
|
||||
@dirrmtry share/locale/tlh/LC_MESSAGES
|
||||
@dirrmtry share/locale/tlh
|
||||
@dirrmtry share/locale/sl/LC_MESSAGES
|
||||
@dirrmtry share/locale/sl
|
||||
@dirrmtry share/locale/sk/LC_MESSAGES
|
||||
|
@ -281,14 +277,8 @@ share/locale/zh_TW/LC_MESSAGES/bittorrent.mo
|
|||
@dirrmtry share/locale/nb_NO
|
||||
@dirrmtry share/locale/ko/LC_MESSAGES
|
||||
@dirrmtry share/locale/ko
|
||||
@dirrmtry share/locale/hy/LC_MESSAGES
|
||||
@dirrmtry share/locale/hy
|
||||
@dirrmtry share/locale/he_IL/LC_MESSAGES
|
||||
@dirrmtry share/locale/he_IL
|
||||
@dirrmtry share/locale/gr/LC_MESSAGES
|
||||
@dirrmtry share/locale/gr
|
||||
@dirrmtry share/locale/fi/LC_MESSAGES
|
||||
@dirrmtry share/locale/fi
|
||||
@dirrmtry share/locale/el/LC_MESSAGES
|
||||
@dirrmtry share/locale/el
|
||||
@dirrmtry share/locale/cs/LC_MESSAGES
|
||||
@dirrmtry share/locale/cs
|
||||
@dirrmtry share/locale/ca/LC_MESSAGES
|
||||
|
|
Loading…
Reference in a new issue