Update to 1.92.

Submitted by:	TOGAWA Satoshi <toga@puyo.org>
PR:		31287 (1/2)
This commit is contained in:
Masafumi Max NAKANE 2001-10-28 15:25:08 +00:00
parent 3a50ba81da
commit 1ab1b38327
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=49292
3 changed files with 27 additions and 15 deletions

View file

@ -6,11 +6,9 @@
#
PORTNAME= nkf
PORTVERSION= 1.71
PORTVERSION= 1.92
CATEGORIES= japanese
MASTER_SITES= ftp://ftp.ie.u-ryukyu.ac.jp/pub/software/kono/ \
ftp://ftp.win.ne.jp/pub/misc/ \
ftp://ftp.eos.hokudai.ac.jp/pub/tools/code-conv/nkf/
MASTER_SITES= ftp://ftp.ie.u-ryukyu.ac.jp/pub/software/kono/
EXTRACT_SUFX= .shar
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
@ -24,4 +22,14 @@ NO_WRKSUBDIR= yes
MAN1= nkf.1 ../ja/man1/nkf.1
ALL_TARGET= nkf
do-extract:
@${RM} -rf ${WRKDIR}
@${MKDIR} ${WRKDIR}/NKF
@for file in ${EXTRACT_ONLY}; do \
if ! (cd ${WRKDIR} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/$$file ${EXTRACT_AFTER_ARGS});\
then \
exit 1; \
fi \
done
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (nkf171.shar) = 15c8a80760f5da0416c89cce1690c870
MD5 (nkf192.shar) = 2e560387657d5d7c725875e548394b0f

View file

@ -1,16 +1,19 @@
--- Makefile.orig Mon Nov 16 19:21:45 1998
+++ Makefile Sun Mar 5 05:33:25 2000
@@ -1,14 +1,22 @@
--- Makefile.orig Sun Oct 28 07:30:22 2001
+++ Makefile Sun Oct 28 07:34:31 2001
@@ -1,13 +1,21 @@
-CC = cc
-CFLAGS = -O
+PREFIX?=/usr/local
+PREFIX?= /usr/local
+CC?= cc
+CFLAGS?= -O
SHAR = shar -T
# SHAR = shar
-PERL = perl5
-RM = rm -rf
+PERL?= perl5
+INSTALL?=/usr/bin/install
+RM?= rm -rf
+INSTALL?= /usr/bin/install
VERSION = 19
nkf : nkf.c
$(CC) $(CFLAGS) -o nkf nkf.c
@ -22,8 +25,9 @@
+ ${INSTALL} -c -o root -g wheel -m 444 nkf.1j.euc ${PREFIX}/man/ja/man1/nkf.1
clean:
- rm -fr nkf.o nkf nkf.in nkf.out nkf17 *~
+ rm -fr nkf.o nkf nkf.in nkf.out nkf17 nkf.1j.euc *~
test: nkf
perl nkf_test.pl
-$(RM) nkf.o nkf nkf.in nkf.out nkf$(VERSION) *~ *.bad
@@ -30,3 +38,4 @@
done
( cd nkf$(VERSION) ; $(SHAR) `cat ../MANIFEST` ) > nkf$(VERSION).shar
-$(RM) nkf$(VERSION)
+