update to 1.13

convert to optionsng
add license
fix build with clang

PR:		ports/168614
Submitted by:	Olivier Cochard-Labbé <olivier@cochard.me>
This commit is contained in:
Baptiste Daroussin 2012-06-03 00:17:34 +00:00
parent 36facc3830
commit 1adf67fb61
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=298044
5 changed files with 47 additions and 30 deletions

View file

@ -6,35 +6,49 @@
#
PORTNAME= sslh
PORTVERSION= 1.11
PORTVERSION= 1.13
CATEGORIES= net
MASTER_SITES= http://www.rutschle.net/tech/
MAINTAINER= olivier@cochard.me
COMMENT= A ssl/ssh multiplexer
LICENSE= GPLv2
DISTFILES= ${PORTNAME}-${PORTVERSION}b.tar.gz
LIB_DEPENDS= config:${PORTSDIR}/devel/libconfig
USE_GMAKE= yes
USE_PERL5_BUILD= yes
.if !defined(NO_INSTALL_MANPAGES)
OPTIONS_DEFINE= MANPAGES EXAMPLES
OPTIONS_DEFAULT= MANPAGES EXAMPLES
CFLAGS+= -I${LOCALBASE}/include
MAKE_ENV+= LIBS="-L${LOCALBASE}/lib"
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MMANPAGES}
MAN8= sslh.8
.endif
VARDIR= /var
PLIST_SUB= VARDIR=${VARDIR}
USE_RC_SUBR= sslh
post-patch:
@${REINPLACE_CMD} -e 's|^PREFIX=/usr/local|PREFIX=${PREFIX}|g' ${WRKSRC}/Makefile
PORTEXAMPLES= example.cfg
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/sslh-fork ${PREFIX}/sbin
@${INSTALL_PROGRAM} ${WRKSRC}/sslh-select ${PREFIX}/sbin
@${MKDIR} ${VARDIR}/run/${PORTNAME}
@${CHOWN} -R nobody:nobody ${VARDIR}/run/${PORTNAME}
.if !defined(NO_INSTALL_MANPAGES)
#@${MKDIR} ${VARDIR}/run/${PORTNAME}
#@${CHOWN} -R nobody:nobody ${VARDIR}/run/${PORTNAME}
.if ${PORT_OPTIONS:MMANPAGES}
@${INSTALL_MAN} ${WRKSRC}/sslh.8 ${MANPREFIX}/man/man8
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
@${INSTALL_DATA} ${WRKSRC}/${PORTEXAMPLES} ${EXAMPLESDIR}
.endif
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
SHA256 (sslh-1.11.tar.gz) = e1bf699ac2990954462926c26140b8ae40dabe107bb9aef89967a52c7e141e54
SIZE (sslh-1.11.tar.gz) = 25779
SHA256 (sslh-1.13b.tar.gz) = e6493b53767b542652e99e64a1bceeded1d01a5e7a083fde9d67e7550f9c0eec
SIZE (sslh-1.13b.tar.gz) = 30986

View file

@ -1,20 +1,24 @@
--- Makefile.old 2011-12-02 10:16:46.000000000 +0000
+++ Makefile 2011-12-02 10:18:04.000000000 +0000
@@ -5,7 +5,7 @@
--- ./Makefile.orig 2012-06-03 02:10:16.959537483 +0200
+++ ./Makefile 2012-06-03 02:10:20.312769958 +0200
@@ -4,7 +4,7 @@
USELIBCONFIG=1 # Use libconfig? (necessary to use configuration files)
USELIBWRAP= # Use libwrap?
COV_TEST= # Perform test coverage?
PREFIX=/usr/local
-PREFIX=/usr/local
+PREFIX ?=/usr/local
-MAN=sslh.8.gz # man page name
+MAN=sslh.8 # man page name
MAN=sslh.8.gz # man page name
# End of configuration -- the rest should take care of
# itself
@@ -46,7 +46,7 @@
$(CC) $(CFLAGS) -o echosrv echosrv.o common.o $(LIBS)
@@ -15,10 +15,9 @@
CFLAGS_COV=-fprofile-arcs -ftest-coverage
endif
$(MAN): sslh.pod Makefile
- pod2man --section=8 --release=$(VERSION) --center=" " sslh.pod | gzip -9 - > $(MAN)
+ pod2man --section=8 --release=$(VERSION) --center=" " sslh.pod > $(MAN)
-CC = gcc
-CFLAGS=-Wall -g $(CFLAGS_COV)
+CC ?= gcc
+CFLAGS ?=-Wall -g $(CFLAGS_COV)
# generic install: install binary and man page
install: sslh $(MAN)
-LIBS=
OBJS=common.o sslh-main.o probe.o
ifneq ($(strip $(USELIBWRAP)),)

View file

@ -59,10 +59,10 @@ sslh_openvpntarget=${sslh_openvpntarget:-"localhost:1193"}
sslh_xmpptarget=${sslh_xmpptarget:-"localhost:5222"}
sslh_tinctarget=${sslh_tinctarget:-"localhost:655"}
pidfile=${sslh_pidfile:-"/var/run/sslh/sslh.pid"}
pidfile=${sslh_pidfile:-"/var/run/sslh.pid"}
command="%%PREFIX%%/sbin/${name}-${sslh_mode}"
command_args="-t ${sslh_sshtimeout} -p ${sslh_listening} \
--ssl ${sslh_ssltarget} --ssh ${sslh_sshtarget} -P ${pidfile} \
--ssh ${sslh_sshtarget} --ssl ${sslh_ssltarget} -P ${pidfile} \
--user nobody --openvpn ${sslh_openvpntarget} \
--xmpp ${sslh_xmpptarget} --tinc ${sslh_tinctarget}"

View file

@ -1,3 +1,2 @@
sbin/sslh-fork
sbin/sslh-select
@dirrmtry %%VARDIR%%/run/sslh