Import nbench port. nbench are BYTE magazine's native benchmarks.
Don't ask me how this differs from bytebench, but it seems to be different enough to warrant a seperate port. PR: 5330 Submitted by: Andrey Zakhvatov <andy@icc.surw.chel.su>
This commit is contained in:
parent
9487b7a5a8
commit
1af771fdf0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=10331
7 changed files with 70 additions and 0 deletions
29
benchmarks/nbench/Makefile
Normal file
29
benchmarks/nbench/Makefile
Normal file
|
@ -0,0 +1,29 @@
|
|||
# New ports collection makefile for: nbench
|
||||
# Version required: 2.1
|
||||
# Date created: 17 December 1997
|
||||
# Whom: Andrey Zakhvatov
|
||||
#
|
||||
# $Id$
|
||||
#
|
||||
|
||||
DISTNAME= nbench-byte-2.1
|
||||
PKGNAME= nbench-2.1
|
||||
CATEGORIES= benchmarks
|
||||
MASTER_SITES= ftp://ftp.tux.org/pub/tux/mayer/ \
|
||||
${MASTER_SITE_SUNSITE}
|
||||
MASTER_SITE_SUBDIR= system/benchmark
|
||||
|
||||
MAINTAINER= andy@icc.surw.chel.su
|
||||
|
||||
ALL_TARGET=
|
||||
|
||||
do-install:
|
||||
@ ${INSTALL_PROGRAM} ${WRKSRC}/nbench ${PREFIX}/bin
|
||||
@ ${MKDIR} ${PREFIX}/share/nbench
|
||||
@ ${INSTALL_DATA} ${WRKSRC}/NNET.DAT ${PREFIX}/share/nbench
|
||||
@ ${MKDIR} ${PREFIX}/share/doc/nbench
|
||||
.for file in README README.submit RESULTS bdoc.txt
|
||||
@ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/nbench
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.mk>
|
1
benchmarks/nbench/distinfo
Normal file
1
benchmarks/nbench/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (nbench-byte-2.1.tar.gz) = 18741c3f7d01bf216a57c0132896b196
|
11
benchmarks/nbench/files/patch-aa
Normal file
11
benchmarks/nbench/files/patch-aa
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- nbench1.h Thu Dec 11 20:54:46 1997
|
||||
+++ /home/andy/tmp/wrk/nbench1.h Wed Dec 17 08:28:11 1997
|
||||
@@ -352,7 +352,7 @@
|
||||
** The Neural Net test requires an input data file.
|
||||
** The name is specified here.
|
||||
*/
|
||||
-char *inpath="NNET.DAT";
|
||||
+char *inpath="/usr/local/share/nbench/NNET.DAT";
|
||||
|
||||
/*
|
||||
** PROTOTYPES
|
17
benchmarks/nbench/files/patch-ab
Normal file
17
benchmarks/nbench/files/patch-ab
Normal file
|
@ -0,0 +1,17 @@
|
|||
--- sysinfo.sh Thu Dec 11 20:54:46 1997
|
||||
+++ /home/andy/tmp/wrk/sysinfo.sh Wed Dec 17 08:30:28 1997
|
||||
@@ -50,8 +50,8 @@
|
||||
|
||||
# this bombs out on Ultrix which expect "cut -d"
|
||||
|
||||
-compsystem=`uname -a | cut -b 1-78`
|
||||
-compdate=`date|cut -b1-55`
|
||||
+compsystem=`uname -a | cut -f 1-78`
|
||||
+compdate=`date | cut -f 1-55`
|
||||
|
||||
# let's hope that ctrl-c is not part of any string here
|
||||
# this also will barf later if " is in any of the strings
|
||||
@@ -60,4 +60,4 @@
|
||||
sed -e "s%CCVERSION%$gccversion" -e "s%LIBCVERSION%$libcversion"\
|
||||
-e "s%SYSTEM%$compsystem" -e "s%DATE%$compdate"\
|
||||
${i}.template > $i
|
1
benchmarks/nbench/pkg-comment
Normal file
1
benchmarks/nbench/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
BYTE Magazine's native benchmarks
|
3
benchmarks/nbench/pkg-descr
Normal file
3
benchmarks/nbench/pkg-descr
Normal file
|
@ -0,0 +1,3 @@
|
|||
BYTE Magazine's native benchmarks (also called BYTEmark)
|
||||
designed to expose the capabilities of a system's CPU, FPU,
|
||||
and memory system.
|
8
benchmarks/nbench/pkg-plist
Normal file
8
benchmarks/nbench/pkg-plist
Normal file
|
@ -0,0 +1,8 @@
|
|||
bin/nbench
|
||||
share/nbench/NNET.DAT
|
||||
share/doc/nbench/README
|
||||
share/doc/nbench/README.submit
|
||||
share/doc/nbench/RESULTS
|
||||
share/doc/nbench/bdoc.txt
|
||||
@dirrm share/nbench
|
||||
@dirrm share/doc/nbench
|
Loading…
Reference in a new issue