- Update to 2012.1.15
- Update to working URL - Remove files integrated upstream - Update to new header - Add LICENSE - Remove ABI versions from LIB_DEPENDS - Convert to new options framework - Remove use of bsd.port.pre.mk - See http://lists.freebsd.org/pipermail/freebsd-fs/2012-September/015166.html for more information on the current status of fuse support
This commit is contained in:
parent
5305160a22
commit
1b55c827a9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=304549
10 changed files with 24 additions and 171 deletions
|
@ -1,12 +1,8 @@
|
|||
# New ports collection makefile for: fusefs-ntfs
|
||||
# Date created: 25 July 2006
|
||||
# Whom: Max Khon
|
||||
# Created By: Max Khon
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= ntfs
|
||||
PORTVERSION= 2011.4.12
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 2012.1.15
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= http://tuxera.com/opensource/
|
||||
PKGNAMEPREFIX= fusefs-
|
||||
|
@ -16,8 +12,10 @@ EXTRACT_SUFX= .tgz
|
|||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Mount NTFS partitions (read/write) and disk images
|
||||
|
||||
LICENSE= GPLv2
|
||||
|
||||
BUILD_DEPENDS= fusefs-libs>=2.7.2:${PORTSDIR}/sysutils/fusefs-libs
|
||||
LIB_DEPENDS= fuse.2:${PORTSDIR}/sysutils/fusefs-libs
|
||||
LIB_DEPENDS= fuse:${PORTSDIR}/sysutils/fusefs-libs
|
||||
RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
|
||||
|
||||
CONFLICTS_BUILD= bonobo-1.*
|
||||
|
@ -31,8 +29,10 @@ CONFIGURE_ARGS= --exec-prefix=${PREFIX} --disable-mount-helper \
|
|||
CPPFLAGS+= -I${WRKSRC}/include/ntfs-3g/ -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
|
||||
OPTIONS= LOCK "Lock the device when mounting (avoids access)" on \
|
||||
UBLIO "Enable user space cache for improved speed" on
|
||||
OPTIONS_DEFINE= LOCK UBLIO
|
||||
OPTIONS_DEFAULT=LOCK UBLIO
|
||||
LOCK_DESC= Lock the device when mounting (avoids access)
|
||||
UBLIO_DESC= Enable user space cache for improved speed
|
||||
|
||||
SUB_FILES= pkg-message
|
||||
DOCSDIR= ${PREFIX}/share/doc/ntfs-3g
|
||||
|
@ -42,15 +42,15 @@ MAN8= mkntfs.8 ntfs-3g.8 ntfs-3g.probe.8 \
|
|||
ntfscluster.8 ntfscmp.8 ntfscp.8 ntfsfix.8 ntfsinfo.8 \
|
||||
ntfslabel.8 ntfsls.8 ntfsprogs.8 ntfsresize.8 ntfsundelete.8
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if defined(WITH_LOCK)
|
||||
.if ${PORT_OPTIONS:MLOCK}
|
||||
CFLAGS+= -DUSE_LOCK
|
||||
.endif
|
||||
|
||||
.if defined(WITH_UBLIO)
|
||||
.if ${PORT_OPTIONS:MUBLIO}
|
||||
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-ublio
|
||||
LIB_DEPENDS+= ublio.1:${PORTSDIR}/devel/libublio
|
||||
LIB_DEPENDS+= ublio:${PORTSDIR}/devel/libublio
|
||||
CFLAGS+= -DUSE_UBLIO
|
||||
.endif
|
||||
|
||||
|
@ -72,4 +72,4 @@ post-install:
|
|||
.endif
|
||||
@${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (ntfs-3g_ntfsprogs-2011.4.12.tgz) = aa8c747f0bfe819b2387b05e12db8d35e4ac96dcb2432873a0b939e248b2ee05
|
||||
SIZE (ntfs-3g_ntfsprogs-2011.4.12.tgz) = 1126704
|
||||
SHA256 (ntfs-3g_ntfsprogs-2012.1.15.tgz) = 6f1611c5000de7ca99141a9b853cba2c8dbd86c8e36d5efbe7ba918af773fb25
|
||||
SIZE (ntfs-3g_ntfsprogs-2012.1.15.tgz) = 1149907
|
||||
|
|
|
@ -18,7 +18,7 @@ the FUSE library (a OS independent library to create filesystem drivers), more
|
|||
precisely FUSE's library with fuse4bsd's kernel module (port of the kernel
|
||||
dependent part of FUSE). For more information see:
|
||||
|
||||
NTFS-3G site: http://ntfs-3g.org/
|
||||
NTFS-3G site: http://www.tuxera.com/community/ntfs-3g-download/
|
||||
FUSE site: http://fuse.sourceforge.net/
|
||||
fuse4bsd site: http://fuse4bsd.creo.hu/
|
||||
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
--- libntfs-3g/Makefile.in.orig 2011-04-10 20:04:51.000000000 +0200
|
||||
+++ libntfs-3g/Makefile.in 2011-04-25 18:54:01.000000000 +0200
|
||||
@@ -250,6 +250,7 @@
|
||||
--- ./libntfs-3g/Makefile.in.orig 2012-08-29 19:51:35.000000000 -0500
|
||||
+++ ./libntfs-3g/Makefile.in 2012-08-29 20:00:20.000000000 -0500
|
||||
@@ -251,6 +251,7 @@
|
||||
@INSTALL_LIBRARY_FALSE@noinst_LTLIBRARIES = libntfs-3g.la
|
||||
libntfs_3g_la_CFLAGS = $(AM_CFLAGS) -I$(top_srcdir)/include/ntfs-3g
|
||||
libntfs_3g_la_LDFLAGS = -version-info $(LIBNTFS_3G_VERSION) -no-undefined
|
||||
@FUSE_INTERNAL_TRUE@libntfs_3g_la_LIBADD = $(top_builddir)/libfuse-lite/libfuse-lite.la
|
||||
+libntfs_3g_la_LIBADD = -lublio
|
||||
libntfs_3g_la_SOURCES = acls.c attrib.c attrlist.c bitmap.c bootsect.c \
|
||||
cache.c collate.c compat.c compress.c debug.c device.c dir.c \
|
||||
|
|
|
@ -1,77 +0,0 @@
|
|||
--- ntfsprogs/ntfsclone.3 2011-04-10 20:04:41.000000000 +0200
|
||||
+++ ntfsprogs/ntfsclone.c 2011-04-25 14:06:11.000000000 +0200
|
||||
@@ -89,6 +89,10 @@
|
||||
#define BLKGETSIZE64 _IOR(0x12,114,size_t) /* Get device size in bytes. */
|
||||
#endif
|
||||
|
||||
+#ifdef __sun
|
||||
+#define NO_STATFS 1 /* statfs(2) and f_type are not universal */
|
||||
+#endif
|
||||
+
|
||||
static const char *EXEC_NAME = "ntfsclone";
|
||||
|
||||
static const char *bad_sectors_warning_msg =
|
||||
@@ -119,7 +123,9 @@
|
||||
int restore_image;
|
||||
char *output;
|
||||
char *volume;
|
||||
+#ifndef NO_STATFS
|
||||
struct statfs stfs;
|
||||
+#endif
|
||||
} opt;
|
||||
|
||||
struct bitmap {
|
||||
@@ -629,6 +635,7 @@
|
||||
}
|
||||
|
||||
if (write_all(&fd_out, buff, csize) == -1) {
|
||||
+#ifndef NO_STATFS
|
||||
int err = errno;
|
||||
perr_printf("Write failed");
|
||||
if (err == EIO && opt.stfs.f_type == 0x517b)
|
||||
@@ -637,6 +644,9 @@
|
||||
"efficient sparse file handling by default. "
|
||||
"Please try a different method.\n");
|
||||
exit(1);
|
||||
+#else
|
||||
+ perr_printf("Write failed");
|
||||
+#endif
|
||||
}
|
||||
}
|
||||
|
||||
@@ -1565,6 +1575,7 @@
|
||||
|
||||
static void set_filesize(s64 filesize)
|
||||
{
|
||||
+#ifndef NO_STATFS
|
||||
long fs_type = 0; /* Unknown filesystem type */
|
||||
|
||||
if (fstatfs(fd_out, &opt.stfs) == -1)
|
||||
@@ -1582,22 +1593,27 @@
|
||||
Printf("WARNING: You're using SMBFS and if the remote share "
|
||||
"isn't Samba but a Windows\ncomputer then the clone "
|
||||
"operation will be very inefficient and may fail!\n");
|
||||
+#endif
|
||||
|
||||
if (ftruncate(fd_out, filesize) == -1) {
|
||||
int err = errno;
|
||||
perr_printf("ftruncate failed for file '%s'", opt.output);
|
||||
+#ifndef NO_STATFS
|
||||
if (fs_type)
|
||||
Printf("Destination filesystem type is 0x%lx.\n",
|
||||
(unsigned long)fs_type);
|
||||
+#endif
|
||||
if (err == E2BIG) {
|
||||
Printf("Your system or the destination filesystem "
|
||||
"doesn't support large files.\n");
|
||||
+#ifndef NO_STATFS
|
||||
if (fs_type == 0x517b) {
|
||||
Printf("SMBFS needs minimum Linux kernel "
|
||||
"version 2.4.25 and\n the 'lfs' option"
|
||||
"\nfor smbmount to have large "
|
||||
"file support.\n");
|
||||
}
|
||||
+#endif
|
||||
} else if (err == EPERM) {
|
||||
Printf("Apparently the destination filesystem doesn't "
|
||||
"support sparse files.\nYou can overcome this "
|
|
@ -1,12 +0,0 @@
|
|||
--- ntfsprogs/ntfsresize.2 2011-04-10 20:04:41.000000000 +0200
|
||||
+++ ntfsprogs/ntfsresize.c 2011-04-24 08:34:35.000000000 +0200
|
||||
@@ -48,6 +48,9 @@
|
||||
#ifdef HAVE_ERRNO_H
|
||||
#include <errno.h>
|
||||
#endif
|
||||
+#ifdef HAVE_LIMITS_H
|
||||
+#include <limits.h>
|
||||
+#endif
|
||||
#ifdef HAVE_GETOPT_H
|
||||
#include <getopt.h>
|
||||
#endif
|
|
@ -1,31 +1,5 @@
|
|||
--- src/Makefile.in.orig 2010-03-06 13:12:36.000000000 -0300
|
||||
+++ src/Makefile.in 2010-06-21 21:59:54.000000000 -0300
|
||||
@@ -255,10 +255,10 @@
|
||||
ntfs_3g_LDADD = $(FUSE_LIBS) $(top_builddir)/libntfs-3g/libntfs-3g.la
|
||||
@REALLYSTATIC_TRUE@ntfs_3g_LDFLAGS = $(AM_LDFLAGS) -all-static
|
||||
ntfs_3g_CFLAGS = \
|
||||
+ -I$(top_srcdir)/include/ntfs-3g \
|
||||
$(AM_CFLAGS) \
|
||||
-DFUSE_USE_VERSION=26 \
|
||||
- $(FUSE_CFLAGS) \
|
||||
- -I$(top_srcdir)/include/ntfs-3g
|
||||
+ $(FUSE_CFLAGS)
|
||||
|
||||
ntfs_3g_SOURCES = ntfs-3g.c
|
||||
ntfs_3g_probe_LDADD = $(top_builddir)/libntfs-3g/libntfs-3g.la
|
||||
@@ -267,9 +267,9 @@
|
||||
@REALLYSTATIC_TRUE@ntfs_3g_probe_LDFLAGS = $(AM_LDFLAGS) -all-static
|
||||
@REALLYSTATIC_TRUE@ntfs_3g_usermap_LDFLAGS = $(AM_LDFLAGS) -all-static
|
||||
@REALLYSTATIC_TRUE@ntfs_3g_secaudit_LDFLAGS = $(AM_LDFLAGS) -all-static
|
||||
-ntfs_3g_probe_CFLAGS = $(AM_CFLAGS) -I$(top_srcdir)/include/ntfs-3g
|
||||
-ntfs_3g_usermap_CFLAGS = $(AM_CFLAGS) -I$(top_srcdir)/include/ntfs-3g
|
||||
-ntfs_3g_secaudit_CFLAGS = $(AM_CFLAGS) -I$(top_srcdir)/include/ntfs-3g
|
||||
+ntfs_3g_probe_CFLAGS = -I$(top_srcdir)/include/ntfs-3g $(AM_CFLAGS)
|
||||
+ntfs_3g_usermap_CFLAGS = -I$(top_srcdir)/include/ntfs-3g $(AM_CFLAGS)
|
||||
+ntfs_3g_secaudit_CFLAGS = -I$(top_srcdir)/include/ntfs-3g $(AM_CFLAGS)
|
||||
ntfs_3g_probe_SOURCES = ntfs-3g.probe.c
|
||||
ntfs_3g_usermap_SOURCES = usermap.c
|
||||
ntfs_3g_secaudit_SOURCES = secaudit.c
|
||||
@@ -667,7 +667,7 @@
|
||||
|
||||
info-am:
|
||||
|
|
|
@ -1,33 +0,0 @@
|
|||
--- src/ntfs-3g_common.9 2011-04-23 09:17:21.000000000 +0200
|
||||
+++ src/ntfs-3g_common.c 2011-04-24 08:24:33.000000000 +0200
|
||||
@@ -32,6 +32,10 @@
|
||||
#include <string.h>
|
||||
#endif
|
||||
|
||||
+#ifdef HAVE_LIMITS_H
|
||||
+#include <limits.h>
|
||||
+#endif
|
||||
+
|
||||
#ifdef HAVE_ERRNO_H
|
||||
#include <errno.h>
|
||||
#endif
|
||||
--- src/ntfs-3g_common.c.ref 2011-04-23 08:25:28.000000000 +0200
|
||||
+++ src/ntfs-3g_common.c 2011-04-23 08:32:16.000000000 +0200
|
||||
@@ -58,8 +58,6 @@
|
||||
|
||||
static const char nf_ns_alt_xattr_efsinfo[] = "user.ntfs.efsinfo";
|
||||
|
||||
-#ifdef HAVE_SETXATTR
|
||||
-
|
||||
static const char def_opts[] = "allow_other,nonempty,";
|
||||
|
||||
/*
|
||||
@@ -573,6 +571,8 @@
|
||||
return 0;
|
||||
}
|
||||
|
||||
+#ifdef HAVE_SETXATTR
|
||||
+
|
||||
int ntfs_fuse_listxattr_common(ntfs_inode *ni, ntfs_attr_search_ctx *actx,
|
||||
char *list, size_t size, BOOL prefixing)
|
||||
{
|
|
@ -4,4 +4,4 @@ Server 2003 and Windows 2000 filesystems. Almost the full POSIX filesystem
|
|||
functionality is supported, the major exceptions are changing the file
|
||||
ownerships and the access rights.
|
||||
|
||||
WWW: http://www.tuxera.com/community/
|
||||
WWW: http://www.tuxera.com/community/ntfs-3g-download/
|
||||
|
|
|
@ -36,6 +36,7 @@ include/ntfs-3g/mst.h
|
|||
include/ntfs-3g/ntfstime.h
|
||||
include/ntfs-3g/object_id.h
|
||||
include/ntfs-3g/param.h
|
||||
include/ntfs-3g/realpath.h
|
||||
include/ntfs-3g/reparse.h
|
||||
include/ntfs-3g/runlist.h
|
||||
include/ntfs-3g/security.h
|
||||
|
@ -47,7 +48,7 @@ include/ntfs-3g/xattrs.h
|
|||
lib/libntfs-3g.a
|
||||
lib/libntfs-3g.la
|
||||
lib/libntfs-3g.so
|
||||
lib/libntfs-3g.so.81
|
||||
lib/libntfs-3g.so.83
|
||||
libdata/pkgconfig/libntfs-3g.pc
|
||||
sbin/mkntfs
|
||||
sbin/ntfsclone
|
||||
|
|
Loading…
Reference in a new issue