Update to use: USES+= ada
Additionally: 1) A pre-generated reference manual has been added as a second distfile and is installed 2) License added 3) DESTDIR support added (comes from pkgsrc) (will be useful once staging will hit the tree) 4) gcc 4.7-specific patches 5) PLIST order alphabetically and fix issues with it. PR: ports/178145 Submitted by: John Marino <draco@marino.st>
This commit is contained in:
parent
295c6a5bba
commit
1b7bb411e0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=316919
15 changed files with 2230 additions and 906 deletions
|
@ -1,29 +1,31 @@
|
|||
# New ports collection makefile for: gtkada
|
||||
# Date created: 12 December 2010
|
||||
# Whom: John Marino <draco@marino.st>
|
||||
#
|
||||
# Created by: John Marino <draco@marino.st>
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= gtkada
|
||||
PORTVERSION= 2.22
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= ${GTKADA_VERSION}
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= x11-toolkits
|
||||
MASTER_SITES= http://downloads.dragonlace.net/src/ \
|
||||
http://dragonlace.mirrors.ada.cx/src/
|
||||
MASTER_SITES= http://downloads.dragonlace.net/src/
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
|
||||
gtkada-rm-${GTKADA_VERSION}${EXTRACT_SUFX}
|
||||
|
||||
MAINTAINER= draco@marino.st
|
||||
COMMENT= Ada graphical toolkit based on Gtk2+
|
||||
|
||||
BUILD_DEPENDS= gnat-aux>20101204:${PORTSDIR}/lang/gnat-aux
|
||||
BUILD_DEPENDS+= gtk>=2.22:${PORTSDIR}/x11-toolkits/gtk20
|
||||
RUN_DEPENDS+= gtk>=2.22:${PORTSDIR}/x11-toolkits/gtk20
|
||||
LICENSE= GPLv2
|
||||
|
||||
BUILD_DEPENDS+= makeinfo:${PORTSDIR}/print/texinfo
|
||||
BUILD_DEPENDS+= gtk>=${GTKADA_VERSION}:${PORTSDIR}/x11-toolkits/gtk20
|
||||
RUN_DEPENDS+= gtk>=${GTKADA_VERSION}:${PORTSDIR}/x11-toolkits/gtk20
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
USE_BZIP2= yes
|
||||
USE_LDCONFIG= yes
|
||||
CC= gnatgcc
|
||||
USE_PERL5_BUILD=yes
|
||||
USES+= ada
|
||||
|
||||
GTKADA_VERSION= 2.22
|
||||
PLIST_SUB+= PKGNAME="${PORTNAME}-${GTKADA_VERSION}"
|
||||
|
||||
CONFIGURE_ARGS+= --disable-nls
|
||||
|
||||
|
|
|
@ -1,2 +1,4 @@
|
|||
SHA256 (gtkada-2.22.tar.bz2) = 2512f98925bc6d1e782aade1b4371c0900469d3afa3a79f3c2e9d71f3accffa7
|
||||
SIZE (gtkada-2.22.tar.bz2) = 2775194
|
||||
SHA256 (gtkada-rm-2.22.tar.bz2) = 14e8b69b2b84896b8fdc4ef3a9daf7c0af41b42d004a0d1487881fc3d61fb827
|
||||
SIZE (gtkada-rm-2.22.tar.bz2) = 3263320
|
||||
|
|
12
x11-toolkits/gtkada/files/patch-Makefile.in
Normal file
12
x11-toolkits/gtkada/files/patch-Makefile.in
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-af,v 1.1 2011/10/14 14:02:17 marino Exp $
|
||||
|
||||
--- Makefile.in.orig 2011-10-13 16:16:09.000000000 +0000
|
||||
+++ Makefile.in
|
||||
@@ -16,6 +16,7 @@ all: src tests
|
||||
|
||||
src:
|
||||
$(MAKE) -C $(src_dir)
|
||||
+ $(MAKE) -C $(doc_dir)
|
||||
|
||||
tests: src
|
||||
$(MAKE) -C $(testgtk_dir)
|
22
x11-toolkits/gtkada/files/patch-configure
Normal file
22
x11-toolkits/gtkada/files/patch-configure
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-ah,v 1.1 2011/10/14 14:02:17 marino Exp $
|
||||
|
||||
--- configure.orig 2010-12-01 21:51:08.000000000 +0000
|
||||
+++ configure
|
||||
@@ -3834,7 +3834,7 @@ echo "${ECHO_T}yes" >&6
|
||||
EXEC_PREFIX="$prefix"
|
||||
|
||||
|
||||
- ac_config_files="$ac_config_files Makefile src/Makefile.common src/Makefile src/tools/gtkada-config src/tools/gate src/tools/Makefile testgtk/Makefile src/gtkextra/Makefile src/opengl/Makefile src/glade/Makefile src/gnome/Makefile docs/gtkada_ug/Makefile docs/gtkada_rm/Makefile po/Makefile src/config.h projects/gtkada.pc projects/gtkada_install_dynamic.gpr projects/gtkada_install_dynamic_gl.gpr"
|
||||
+ ac_config_files="$ac_config_files Makefile src/Makefile.common src/Makefile src/tools/gtkada-config src/tools/gate src/tools/Makefile testgtk/Makefile src/gtkextra/Makefile src/opengl/Makefile src/glade/Makefile src/gnome/Makefile docs/gtkada_ug/Makefile docs/gtkada_rm_pregen/Makefile po/Makefile src/config.h projects/gtkada.pc projects/gtkada_install_dynamic.gpr projects/gtkada_install_dynamic_gl.gpr"
|
||||
cat >confcache <<\_ACEOF
|
||||
# This file is a shell script that caches the results of configure
|
||||
# tests run on this system so they can be shared between configure
|
||||
@@ -4397,7 +4397,7 @@ do
|
||||
"src/glade/Makefile" ) CONFIG_FILES="$CONFIG_FILES src/glade/Makefile" ;;
|
||||
"src/gnome/Makefile" ) CONFIG_FILES="$CONFIG_FILES src/gnome/Makefile" ;;
|
||||
"docs/gtkada_ug/Makefile" ) CONFIG_FILES="$CONFIG_FILES docs/gtkada_ug/Makefile" ;;
|
||||
- "docs/gtkada_rm/Makefile" ) CONFIG_FILES="$CONFIG_FILES docs/gtkada_rm/Makefile" ;;
|
||||
+ "docs/gtkada_rm_pregen/Makefile" ) CONFIG_FILES="$CONFIG_FILES docs/gtkada_rmi_pregen/Makefile" ;;
|
||||
"po/Makefile" ) CONFIG_FILES="$CONFIG_FILES po/Makefile" ;;
|
||||
"src/config.h" ) CONFIG_FILES="$CONFIG_FILES src/config.h" ;;
|
||||
"projects/gtkada.pc" ) CONFIG_FILES="$CONFIG_FILES projects/gtkada.pc" ;;
|
22
x11-toolkits/gtkada/files/patch-docs_Makefile
Normal file
22
x11-toolkits/gtkada/files/patch-docs_Makefile
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-ag,v 1.1 2011/10/14 14:02:17 marino Exp $
|
||||
|
||||
--- docs/Makefile.orig 2010-12-01 21:51:08.000000000 +0000
|
||||
+++ docs/Makefile
|
||||
@@ -1,15 +1,13 @@
|
||||
all::
|
||||
- ${MAKE} -C gtkada_rm
|
||||
${MAKE} -C gtkada_ug
|
||||
|
||||
install::
|
||||
- ${MAKE} -C gtkada_rm install
|
||||
${MAKE} -C gtkada_ug install
|
||||
+ ${MAKE} -C gtkada_rm_pregen install
|
||||
|
||||
clean::
|
||||
- ${MAKE} -C gtkada_rm clean
|
||||
${MAKE} -C gtkada_ug clean
|
||||
|
||||
distclean::
|
||||
- ${MAKE} -C gtkada_rm distclean
|
||||
${MAKE} -C gtkada_ug distclean
|
||||
+ ${MAKE} -c gtkada_rm_pregen install
|
28
x11-toolkits/gtkada/files/patch-docs_gtkaga_ug_Makefile.in
Normal file
28
x11-toolkits/gtkada/files/patch-docs_gtkaga_ug_Makefile.in
Normal file
|
@ -0,0 +1,28 @@
|
|||
$NetBSD: patch-bf,v 1.2 2011/10/14 14:02:17 marino Exp $
|
||||
|
||||
--- docs/gtkada_ug/Makefile.in.orig 2010-12-01 21:51:07.000000000 +0000
|
||||
+++ docs/gtkada_ug/Makefile.in
|
||||
@@ -6,21 +6,16 @@ INSTALL = @INSTALL@
|
||||
INSTALL_DATA = @INSTALL_DATA@
|
||||
|
||||
all: gtkada_ug.texi gfdl.texi
|
||||
- echo x | tex gtkada_ug.texi
|
||||
- texindex gtkada_ug.cp
|
||||
- tex gtkada_ug.texi
|
||||
- tex gtkada_ug.texi
|
||||
- dvips gtkada_ug.dvi -o gtkada_ug.ps
|
||||
perl ../texi2html -menu -monolithic gtkada_ug.texi
|
||||
makeinfo --force -o gtkada_ug.info gtkada_ug.texi
|
||||
makeinfo --force --no-headers --no-split -o gtkada_ug.txt gtkada_ug.texi
|
||||
-$(RM) *.aux *.cp *.cps *.dvi *.fn *.ky *.log *.pg *.toc *.tp *.vr
|
||||
|
||||
install:
|
||||
- -$(MKDIR) $(docdir)
|
||||
+ -$(MKDIR) $(DESTDIR)$(docdir)
|
||||
for i in `ls *.html *.info* *.ps *.texi *.txt *.tex *.gif *.jpg`; \
|
||||
do \
|
||||
- $(INSTALL_DATA) $$i $(docdir); \
|
||||
+ $(INSTALL_DATA) $$i $(DESTDIR)$(docdir); \
|
||||
done
|
||||
|
||||
clean:
|
23
x11-toolkits/gtkada/files/patch-examples_Makefile
Normal file
23
x11-toolkits/gtkada/files/patch-examples_Makefile
Normal file
|
@ -0,0 +1,23 @@
|
|||
$NetBSD: patch-bg,v 1.1.1.1 2011/02/03 18:57:15 drochner Exp $
|
||||
|
||||
--- examples/Makefile.orig 2011-02-02 18:48:10.000000000 +0000
|
||||
+++ examples/Makefile
|
||||
@@ -44,13 +44,13 @@ all: ${DIRECTORIES}
|
||||
done
|
||||
|
||||
install:
|
||||
- mkdir -p $(examples)
|
||||
+ mkdir -p $(DESTDIR)$(examples)
|
||||
-for dir in ${DIRECTORIES} ${TUTORIAL_DIRS}; do \
|
||||
- mkdir -p $(examples)/$${dir}; \
|
||||
+ mkdir -p $(DESTDIR)$(examples)/$${dir}; \
|
||||
rm -f $${dir}/b~*; \
|
||||
- cp -p $${dir}/*.ad? $${dir}/*.gpr $(examples)/$${dir} 2>/dev/null; \
|
||||
- cp -p $${dir}/Makefile $(examples)/$${dir} 2>/dev/null; \
|
||||
- cp -p $${dir}/README $(examples)/$${dir} 2>/dev/null; \
|
||||
+ cp -p $${dir}/*.ad? $${dir}/*.gpr $(DESTDIR)$(examples)/$${dir} 2>/dev/null; \
|
||||
+ cp -p $${dir}/Makefile $(DESTDIR)$(examples)/$${dir} 2>/dev/null; \
|
||||
+ cp -p $${dir}/README $(DESTDIR)$(examples)/$${dir} 2>/dev/null; \
|
||||
done
|
||||
|
||||
clean::
|
|
@ -1,13 +0,0 @@
|
|||
--- projects/Makefile.orig 2011-03-01 12:18:08.000000000 +0000
|
||||
+++ projects/Makefile 2011-03-01 12:18:51.000000000 +0000
|
||||
@@ -7,8 +7,8 @@
|
||||
install: force
|
||||
${MKDIR} $(prefix)/lib/gnat/
|
||||
${MKDIR} $(prefix)/lib/gnat/gtkada
|
||||
- $(MKDIR) $(prefix)/lib/pkgconfig/
|
||||
- ${CP} gtkada.pc $(prefix)/lib/pkgconfig/
|
||||
+ $(MKDIR) $(prefix)/libdata/pkgconfig/
|
||||
+ ${CP} gtkada.pc $(prefix)/libdata/pkgconfig/
|
||||
-${RM} ${prefix}/projects/gtkada*
|
||||
./generate_prj.sh GtkAda "${prefix}" ${DEFAULT_LIBRARY_TYPE} ${SOVER} ""
|
||||
${CP} gtkada.gpr ${prefix}/lib/gnat/
|
37
x11-toolkits/gtkada/files/patch-projects_Makefile
Normal file
37
x11-toolkits/gtkada/files/patch-projects_Makefile
Normal file
|
@ -0,0 +1,37 @@
|
|||
$NetBSD: patch-bc,v 1.1.1.1 2011/02/03 18:57:15 drochner Exp $
|
||||
|
||||
--- projects/Makefile.orig 2011-02-02 18:42:10.000000000 +0000
|
||||
+++ projects/Makefile
|
||||
@@ -5,24 +5,23 @@ MKDIR = mkdir -p
|
||||
SOVER=${MAJOR}.${MINOR}
|
||||
|
||||
install: force
|
||||
- ${MKDIR} $(prefix)/lib/gnat/
|
||||
- ${MKDIR} $(prefix)/lib/gnat/gtkada
|
||||
- $(MKDIR) $(prefix)/lib/pkgconfig/
|
||||
- ${CP} gtkada.pc $(prefix)/lib/pkgconfig/
|
||||
- -${RM} ${prefix}/projects/gtkada*
|
||||
+ ${MKDIR} $(DESTDIR)$(prefix)/lib/gnat/
|
||||
+ ${MKDIR} $(DESTDIR)$(prefix)/lib/gnat/gtkada
|
||||
+ $(MKDIR) $(DESTDIR)$(prefix)/libdata/pkgconfig/
|
||||
+ ${CP} gtkada.pc $(DESTDIR)$(prefix)/libdata/pkgconfig/
|
||||
./generate_prj.sh GtkAda "${prefix}" ${DEFAULT_LIBRARY_TYPE} ${SOVER} ""
|
||||
- ${CP} gtkada.gpr ${prefix}/lib/gnat/
|
||||
+ ${CP} gtkada.gpr $(DESTDIR)${prefix}/lib/gnat/
|
||||
ifeq ($(HAVE_LIBGLADE), True)
|
||||
./generate_prj.sh GtkAda_Glade "${prefix}" ${DEFAULT_LIBRARY_TYPE} ${SOVER} ""
|
||||
- ${CP} gtkada_glade.gpr ${prefix}/lib/gnat/
|
||||
+ ${CP} gtkada_glade.gpr $(DESTDIR)${prefix}/lib/gnat/
|
||||
endif
|
||||
ifeq ($(HAVE_OPENGL), True)
|
||||
./generate_prj.sh GtkAda_GL "${prefix}" ${DEFAULT_LIBRARY_TYPE} ${SOVER} opengl
|
||||
- ${CP} gtkada_gl.gpr ${prefix}/lib/gnat/
|
||||
+ ${CP} gtkada_gl.gpr $(DESTDIR)${prefix}/lib/gnat/
|
||||
endif
|
||||
ifeq ($(HAVE_GNOME), True)
|
||||
./generate_prj.sh GtkAda_Gnome "${prefix}" ${DEFAULT_LIBRARY_TYPE} ${SOVER} ""
|
||||
- ${CP} gtkada_gnome.gpr ${prefix}/lib/gnat/
|
||||
+ ${CP} gtkada_gnome.gpr $(DESTDIR)${prefix}/lib/gnat/
|
||||
endif
|
||||
ifeq ($(OS),Windows_NT)
|
||||
${CP} gtkada_install_*.gpr ${prefix}/include/gtkada
|
17
x11-toolkits/gtkada/files/patch-src_Makefile.common.in
Normal file
17
x11-toolkits/gtkada/files/patch-src_Makefile.common.in
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-ad,v 1.1.1.1 2011/02/03 18:57:15 drochner Exp $
|
||||
|
||||
--- src/Makefile.common.in.orig 2011-01-19 22:48:51.000000000 +0100
|
||||
+++ src/Makefile.common.in
|
||||
@@ -12,9 +12,9 @@
|
||||
MINOR = @GTKADA_MINOR_VERSION@
|
||||
MICRO = @GTKADA_MICRO_VERSION@
|
||||
GTK_LIBS = @GTK_LIBS@
|
||||
-HAVE_LIBGLADE = @HAVE_LIBGLADE@
|
||||
-HAVE_OPENGL = @HAVE_OPENGL@
|
||||
-HAVE_GNOME = @HAVE_GNOME@
|
||||
+HAVE_LIBGLADE = False
|
||||
+HAVE_OPENGL = False
|
||||
+HAVE_GNOME = False
|
||||
BUILD_TYPE = @BUILD_TYPE@
|
||||
DEFAULT_LIBRARY_TYPE=@DEFAULT_LIBRARY_TYPE@
|
||||
|
75
x11-toolkits/gtkada/files/patch-src_Makefile.in
Normal file
75
x11-toolkits/gtkada/files/patch-src_Makefile.in
Normal file
|
@ -0,0 +1,75 @@
|
|||
$NetBSD: patch-ba,v 1.2 2011/02/10 10:43:41 drochner Exp $
|
||||
|
||||
--- src/Makefile.in.orig 2010-12-01 21:51:07.000000000 +0000
|
||||
+++ src/Makefile.in
|
||||
@@ -58,46 +58,44 @@ gtkada-intl.adb: gtkada-intl.gpb Makefil
|
||||
install: force
|
||||
@if [ "$(prefix)" != `pwd` ]; then \
|
||||
echo Installing GtkAda in $(prefix); \
|
||||
- $(MKDIR) $(bindir); \
|
||||
- $(MKDIR) $(libdir); \
|
||||
- $(MKDIR) $(incdir); \
|
||||
- $(MKDIR) $(alidir)/static; \
|
||||
- $(INSTALL_DATA) ${OBJ_DIR}/$(ARCHIVENAME) $(alidir)/static; \
|
||||
- $(RM) $(libdir)/$(ARCHIVENAME); \
|
||||
+ $(MKDIR) $(DESTDIR)$(bindir); \
|
||||
+ $(MKDIR) $(DESTDIR)$(libdir); \
|
||||
+ $(MKDIR) $(DESTDIR)$(incdir); \
|
||||
+ $(MKDIR) $(DESTDIR)$(alidir)/static; \
|
||||
+ $(INSTALL_DATA) ${OBJ_DIR}/$(ARCHIVENAME) $(DESTDIR)$(alidir)/static; \
|
||||
if [ -f /usr/bin/$(RANLIB) -o -f /bin/$(RANLIB) ]; then \
|
||||
- $(RANLIB) $(alidir)/static/$(ARCHIVENAME); \
|
||||
+ $(RANLIB) $(DESTDIR)$(alidir)/static/$(ARCHIVENAME); \
|
||||
fi; \
|
||||
if [ $(BUILD_SHARED) = yes ]; then \
|
||||
- $(MKDIR) $(alidir)/relocatable; \
|
||||
+ $(MKDIR) $(DESTDIR)$(alidir)/relocatable; \
|
||||
if [ "$(OS)" = "Windows_NT" ]; then \
|
||||
$(INSTALL_DATA) ${OBJ_DIR}/$(SONAME) $(bindir); \
|
||||
$(CHMOD) +x $(bindir)/$(SONAME); \
|
||||
else \
|
||||
- $(INSTALL_DATA) ${OBJ_DIR}/$(SONAME) $(alidir)/relocatable; \
|
||||
- $(RM) $(libdir)/$(LIBNAME); \
|
||||
- $(LN) $(SONAME) $(alidir)/relocatable/$(LIBNAME); \
|
||||
- $(LN) gtkada/relocatable/$(SONAME) $(libdir)/$(LIBNAME); \
|
||||
- $(LN) gtkada/relocatable/$(SONAME) $(libdir)/$(SONAME); \
|
||||
+ $(INSTALL_DATA) ${OBJ_DIR}/$(SONAME) $(DESTDIR)$(alidir)/relocatable; \
|
||||
+ $(LN) $(SONAME) $(DESTDIR)$(alidir)/relocatable/$(LIBNAME); \
|
||||
+ $(LN) gtkada/relocatable/$(SONAME) $(DESTDIR)$(libdir)/$(LIBNAME); \
|
||||
+ $(LN) gtkada/relocatable/$(SONAME) $(DESTDIR)$(libdir)/$(SONAME); \
|
||||
fi; \
|
||||
- $(CP) $(OBJ_DIR)/glib*.ali $(OBJ_DIR)/gdk*.ali $(alidir)/relocatable; \
|
||||
- $(CP) $(OBJ_DIR)/gtk*.ali $(OBJ_DIR)/pango*.ali $(alidir)/relocatable; \
|
||||
- $(CP) $(OBJ_DIR)/cairo*.ali $(alidir)/relocatable; \
|
||||
+ $(CP) $(OBJ_DIR)/glib*.ali $(OBJ_DIR)/gdk*.ali $(DESTDIR)$(alidir)/relocatable; \
|
||||
+ $(CP) $(OBJ_DIR)/gtk*.ali $(OBJ_DIR)/pango*.ali $(DESTDIR)$(alidir)/relocatable; \
|
||||
+ $(CP) $(OBJ_DIR)/cairo*.ali $(DESTDIR)$(alidir)/relocatable; \
|
||||
fi; \
|
||||
- $(CP) glib*.ads glib*.adb $(MESA_SPECS) $(incdir); \
|
||||
- $(CP) gdk*.ads gdk*.adb $(incdir); \
|
||||
- $(CP) gtk*.ads gtk*.adb $(incdir); \
|
||||
- $(CP) pango*.ads pango*.adb $(incdir); \
|
||||
- $(CP) cairo*.ads cairo*.adb $(incdir); \
|
||||
- $(CP) $(OBJ_DIR)/glib*.ali $(OBJ_DIR)/gdk*.ali $(alidir)/static; \
|
||||
- $(CP) $(OBJ_DIR)/gtk*.ali $(OBJ_DIR)/pango*.ali $(alidir)/static; \
|
||||
- $(CP) $(OBJ_DIR)/cairo*.ali $(alidir)/static; \
|
||||
+ $(CP) glib*.ads glib*.adb $(MESA_SPECS) $(DESTDIR)$(incdir); \
|
||||
+ $(CP) gdk*.ads gdk*.adb $(DESTDIR)$(incdir); \
|
||||
+ $(CP) gtk*.ads gtk*.adb $(DESTDIR)$(incdir); \
|
||||
+ $(CP) pango*.ads pango*.adb $(DESTDIR)$(incdir); \
|
||||
+ $(CP) cairo*.ads cairo*.adb $(DESTDIR)$(incdir); \
|
||||
+ $(CP) $(OBJ_DIR)/glib*.ali $(OBJ_DIR)/gdk*.ali $(DESTDIR)$(alidir)/static; \
|
||||
+ $(CP) $(OBJ_DIR)/gtk*.ali $(OBJ_DIR)/pango*.ali $(DESTDIR)$(alidir)/static; \
|
||||
+ $(CP) $(OBJ_DIR)/cairo*.ali $(DESTDIR)$(alidir)/static; \
|
||||
$(MAKE) -C opengl install; \
|
||||
$(MAKE) -C glade install; \
|
||||
$(MAKE) -C gnome install; \
|
||||
$(MAKE) -C tools install; \
|
||||
- $(CHMOD) ugo-w $(alidir)/static/*.ali; \
|
||||
+ $(CHMOD) ugo-w $(DESTDIR)$(alidir)/static/*.ali; \
|
||||
if [ $(BUILD_SHARED) = yes ]; then \
|
||||
- $(CHMOD) ugo-w $(alidir)/relocatable/*.ali; \
|
||||
+ $(CHMOD) ugo-w $(DESTDIR)$(alidir)/relocatable/*.ali; \
|
||||
fi; \
|
||||
fi
|
||||
|
19
x11-toolkits/gtkada/files/patch-src_tools_Makefile.in
Normal file
19
x11-toolkits/gtkada/files/patch-src_tools_Makefile.in
Normal file
|
@ -0,0 +1,19 @@
|
|||
$NetBSD: patch-bb,v 1.1.1.1 2011/02/03 18:57:15 drochner Exp $
|
||||
|
||||
--- src/tools/Makefile.in.orig 2011-02-02 18:40:39.000000000 +0000
|
||||
+++ src/tools/Makefile.in
|
||||
@@ -27,10 +27,10 @@ all: force
|
||||
|
||||
install: force
|
||||
-${CHMOD} +x ${GATE} ${GTKADA_CONFIG}
|
||||
- ${INSTALL_SCRIPT} ${GATE} ${bindir}
|
||||
- ${INSTALL_SCRIPT} ${GTKADA_CONFIG} ${bindir}
|
||||
- ${INSTALL_PROGRAM} ${OBJ_DIR}/${GATE_EX} ${bindir}
|
||||
- ${INSTALL_PROGRAM} ${OBJ_DIR}/${GDIALOG} ${bindir}
|
||||
+ ${INSTALL_SCRIPT} ${GATE} $(DESTDIR)${bindir}
|
||||
+ ${INSTALL_SCRIPT} ${GTKADA_CONFIG} $(DESTDIR)${bindir}
|
||||
+ ${INSTALL_PROGRAM} ${OBJ_DIR}/${GATE_EX} $(DESTDIR)${bindir}
|
||||
+ ${INSTALL_PROGRAM} ${OBJ_DIR}/${GDIALOG} $(DESTDIR)${bindir}
|
||||
|
||||
clean: module_clean
|
||||
|
34
x11-toolkits/gtkada/files/patch-testgtk_Makefile.in
Normal file
34
x11-toolkits/gtkada/files/patch-testgtk_Makefile.in
Normal file
|
@ -0,0 +1,34 @@
|
|||
$NetBSD: patch-ae,v 1.2 2012/07/08 20:19:00 marino Exp $
|
||||
$NetBSD: patch-bd,v 1.1.1.1 2011/02/03 18:57:15 drochner Exp $
|
||||
|
||||
--- testgtk/Makefile.in.orig 2011-01-19 23:19:14.000000000 +0100
|
||||
+++ testgtk/Makefile.in
|
||||
@@ -29,7 +29,7 @@
|
||||
GTKADA_GL_LIBS=
|
||||
endif
|
||||
|
||||
-GNATMAKELDFLAGS = -largs -L$(src_dir)/lib-obj -L$(opengl_dir) -lgtkada \
|
||||
+GNATMAKELDFLAGS = -shared-libgcc -lgnat -L$(src_dir)/lib-obj -L$(opengl_dir) -lgtkada \
|
||||
$(GTKADA_GL_LIBS) @GTK_LIBS@ $(TARGET_LFLAGS)
|
||||
|
||||
all: opengl/view_gl.adb $(OPENGL_C_OBJECTS) $(target)
|
||||
@@ -45,13 +45,13 @@ lw.o: opengl/lw.c opengl/lw.h
|
||||
$(CC) -c opengl/lw.c -Iopengl @GTK_CFLAGS@
|
||||
|
||||
install: force
|
||||
- $(MKDIR) $(examples)
|
||||
- $(MKDIR) $(examples)/opengl
|
||||
+ $(MKDIR) $(DESTDIR)$(examples)
|
||||
+ $(MKDIR) $(DESTDIR)$(examples)/opengl
|
||||
$(RM) b~*
|
||||
- -$(INSTALL_PROGRAM) testgtk$(EXEEXT) $(examples)
|
||||
- -$(INSTALL_PROGRAM) testcairo$(EXEEXT) $(examples)
|
||||
- $(CP) *.ad? *.xpm *.png *.jpg *.gif *.lwo *.xml $(examples)
|
||||
- $(CP) opengl/*.ad? opengl/*.[ch] $(examples)/opengl
|
||||
+ -$(INSTALL_PROGRAM) testgtk$(EXEEXT) $(DESTDIR)$(examples)
|
||||
+ -$(INSTALL_PROGRAM) testcairo$(EXEEXT) $(DESTDIR)$(examples)
|
||||
+ $(CP) *.ad? *.xpm *.png *.jpg *.gif *.lwo *.xml $(DESTDIR)$(examples)
|
||||
+ $(CP) opengl/*.ad? opengl/*.[ch] $(DESTDIR)$(examples)/opengl
|
||||
|
||||
clean: module_clean
|
||||
|
15
x11-toolkits/gtkada/files/patch-xml_Makefile
Normal file
15
x11-toolkits/gtkada/files/patch-xml_Makefile
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-bh,v 1.1.1.1 2011/02/03 18:57:15 drochner Exp $
|
||||
|
||||
--- xml/Makefile.orig 2011-02-02 18:49:32.000000000 +0000
|
||||
+++ xml/Makefile
|
||||
@@ -3,8 +3,8 @@ include ../src/Makefile.common
|
||||
MKDIR = mkdir -p
|
||||
|
||||
install: force
|
||||
- ${MKDIR} $(prefix)/share/gps/plug-ins
|
||||
- ${CP} gtkada.xml ${prefix}/share/gps/plug-ins/
|
||||
+ ${MKDIR} $(DESTDIR)$(prefix)/share/gps/plug-ins
|
||||
+ ${CP} gtkada.xml $(DESTDIR)${prefix}/share/gps/plug-ins/
|
||||
|
||||
force:
|
||||
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue