Fix build on at least amd64 and maybe others.
Build test by: pav
This commit is contained in:
parent
88413af3b8
commit
1b97dc0155
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=127967
4 changed files with 46 additions and 26 deletions
|
@ -16,10 +16,6 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/0.0.//}
|
|||
MAINTAINER= ahze@FreeBSD.org
|
||||
COMMENT= Multimedia library and tool for encoding H.264/AVC video streams
|
||||
|
||||
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
|
||||
|
||||
ONLY_FOR_ARCHS= i386
|
||||
|
||||
USE_GETOPT_LONG=yes
|
||||
USE_BZIP2= yes
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}
|
||||
|
@ -42,15 +38,16 @@ OPTIONS= DEBUG "Enable Debugging" Off \
|
|||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${ARCH}=="i386"
|
||||
CFLAGS+=-DARCH_X86
|
||||
.endif
|
||||
BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
|
||||
|
||||
CFLAGS+= -DARCH_X86
|
||||
MAKE_ENV+= ARCH_X86="1"
|
||||
.if ${MACHINE_CPU:Mmmx}
|
||||
CFLAGS+=-DHAVE_MMXEXT
|
||||
CFLAGS+= -DHAVE_MMXEXT
|
||||
.endif
|
||||
|
||||
.if ${MACHINE_CPU:Msse}
|
||||
CFLAGS+=-DHAVE_SSE2
|
||||
CFLAGS+= -DHAVE_SSE2
|
||||
.endif
|
||||
.endif
|
||||
|
||||
.if !defined(WITH_DEBUG)
|
||||
|
|
|
@ -1,7 +1,20 @@
|
|||
--- Makefile.orig Tue Jan 25 16:36:54 2005
|
||||
+++ Makefile Tue Jan 25 20:52:45 2005
|
||||
@@ -22,8 +22,11 @@
|
||||
+++ Makefile Mon Jan 31 01:14:20 2005
|
||||
@@ -12,18 +12,19 @@
|
||||
encoder/set.c encoder/macroblock.c encoder/cabac.c \
|
||||
encoder/cavlc.c encoder/encoder.c encoder/eval.c x264.c
|
||||
|
||||
-ifdef SYS_MACOSX
|
||||
-PFLAGS=-DARCH_PPC -DSYS_MACOSX -faltivec
|
||||
-SRCS= $(SRCS_COMMON) common/ppc/mc.c common/ppc/pixel.c
|
||||
-else
|
||||
-PFLAGS=-DARCH_X86 -DHAVE_MMXEXT -DHAVE_SSE2 -DHAVE_MALLOC_H
|
||||
+ifdef ARCH_X86
|
||||
SRCS= $(SRCS_COMMON) common/i386/mc-c.c common/i386/dct-c.c common/i386/predict.c
|
||||
ASMSRC= common/i386/dct-a.asm common/i386/cpu-a.asm common/i386/pixel-a.asm common/i386/mc-a.asm
|
||||
OBJASM= $(ASMSRC:%.asm=%.o)
|
||||
+else
|
||||
+SRCS= $(SRCS_COMMON)
|
||||
endif
|
||||
|
||||
-CC=gcc
|
||||
|
@ -14,7 +27,7 @@
|
|||
ifdef NDEBUG
|
||||
CFLAGS+=-s -DNDEBUG
|
||||
else
|
||||
@@ -39,14 +42,17 @@
|
||||
@@ -39,14 +40,17 @@
|
||||
OBJS = $(SRCS:%.c=%.o)
|
||||
DEP = depend
|
||||
|
||||
|
@ -35,7 +48,7 @@
|
|||
|
||||
checkasm: testing/checkasm.c libx264.a
|
||||
$(CC) $(CFLAGS) -o checkasm $< libx264.a -lm
|
||||
@@ -56,7 +62,7 @@
|
||||
@@ -56,7 +60,7 @@
|
||||
|
||||
.depend: $(SRCS) x264.c
|
||||
rm -f .depend
|
||||
|
|
|
@ -16,10 +16,6 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/0.0.//}
|
|||
MAINTAINER= ahze@FreeBSD.org
|
||||
COMMENT= Multimedia library and tool for encoding H.264/AVC video streams
|
||||
|
||||
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
|
||||
|
||||
ONLY_FOR_ARCHS= i386
|
||||
|
||||
USE_GETOPT_LONG=yes
|
||||
USE_BZIP2= yes
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}
|
||||
|
@ -42,15 +38,16 @@ OPTIONS= DEBUG "Enable Debugging" Off \
|
|||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${ARCH}=="i386"
|
||||
CFLAGS+=-DARCH_X86
|
||||
.endif
|
||||
BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
|
||||
|
||||
CFLAGS+= -DARCH_X86
|
||||
MAKE_ENV+= ARCH_X86="1"
|
||||
.if ${MACHINE_CPU:Mmmx}
|
||||
CFLAGS+=-DHAVE_MMXEXT
|
||||
CFLAGS+= -DHAVE_MMXEXT
|
||||
.endif
|
||||
|
||||
.if ${MACHINE_CPU:Msse}
|
||||
CFLAGS+=-DHAVE_SSE2
|
||||
CFLAGS+= -DHAVE_SSE2
|
||||
.endif
|
||||
.endif
|
||||
|
||||
.if !defined(WITH_DEBUG)
|
||||
|
|
|
@ -1,7 +1,20 @@
|
|||
--- Makefile.orig Tue Jan 25 16:36:54 2005
|
||||
+++ Makefile Tue Jan 25 20:52:45 2005
|
||||
@@ -22,8 +22,11 @@
|
||||
+++ Makefile Mon Jan 31 01:14:20 2005
|
||||
@@ -12,18 +12,19 @@
|
||||
encoder/set.c encoder/macroblock.c encoder/cabac.c \
|
||||
encoder/cavlc.c encoder/encoder.c encoder/eval.c x264.c
|
||||
|
||||
-ifdef SYS_MACOSX
|
||||
-PFLAGS=-DARCH_PPC -DSYS_MACOSX -faltivec
|
||||
-SRCS= $(SRCS_COMMON) common/ppc/mc.c common/ppc/pixel.c
|
||||
-else
|
||||
-PFLAGS=-DARCH_X86 -DHAVE_MMXEXT -DHAVE_SSE2 -DHAVE_MALLOC_H
|
||||
+ifdef ARCH_X86
|
||||
SRCS= $(SRCS_COMMON) common/i386/mc-c.c common/i386/dct-c.c common/i386/predict.c
|
||||
ASMSRC= common/i386/dct-a.asm common/i386/cpu-a.asm common/i386/pixel-a.asm common/i386/mc-a.asm
|
||||
OBJASM= $(ASMSRC:%.asm=%.o)
|
||||
+else
|
||||
+SRCS= $(SRCS_COMMON)
|
||||
endif
|
||||
|
||||
-CC=gcc
|
||||
|
@ -14,7 +27,7 @@
|
|||
ifdef NDEBUG
|
||||
CFLAGS+=-s -DNDEBUG
|
||||
else
|
||||
@@ -39,14 +42,17 @@
|
||||
@@ -39,14 +40,17 @@
|
||||
OBJS = $(SRCS:%.c=%.o)
|
||||
DEP = depend
|
||||
|
||||
|
@ -35,7 +48,7 @@
|
|||
|
||||
checkasm: testing/checkasm.c libx264.a
|
||||
$(CC) $(CFLAGS) -o checkasm $< libx264.a -lm
|
||||
@@ -56,7 +62,7 @@
|
||||
@@ -56,7 +60,7 @@
|
||||
|
||||
.depend: $(SRCS) x264.c
|
||||
rm -f .depend
|
||||
|
|
Loading…
Reference in a new issue