- Update to 4.2.8.
- Add MAKE_JOBS_SAFE. - Trim header. PR: ports/172052 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
This commit is contained in:
parent
0d5f28b877
commit
1b9e13a9ec
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=309283
9 changed files with 86 additions and 137 deletions
|
@ -1,16 +1,12 @@
|
|||
# New ports collection makefile for: HDF_lib
|
||||
# Date created: 17 November 1996
|
||||
# Whom: mi
|
||||
#
|
||||
# Created by: mi
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= hdf
|
||||
DISTVERSION= 4.2.7-patch1
|
||||
DISTVERSION= 4.2.8
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= science archivers graphics
|
||||
MASTER_SITES= ftp://ftp.hdfgroup.org/HDF/HDF_Current/src/ \
|
||||
ftp://ftp.hdfgroup.org/HDF/prev-releases/HDF${PORTVERSION:R}/src/
|
||||
MASTER_SITES= http://www.hdfgroup.org/ftp/HDF/releases/%SUBDIR%/
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME:U}${PORTVERSION}/src/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Hierarchical Data Format library (from NCSA)
|
||||
|
@ -22,31 +18,15 @@ CONFLICTS= netcdf-*
|
|||
|
||||
USE_BZIP2= yes
|
||||
USE_FORTRAN= yes
|
||||
MAKE_JOBS_SAFE= yes
|
||||
# XXX Our libtool breaks, when building this:
|
||||
# XXX can't link libraries with fortran
|
||||
#USE_AUTOTOOLS= libtool
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+=--with-jpeg="${LOCALBASE}" \
|
||||
CONFIGURE_ARGS= --with-jpeg="${LOCALBASE}" \
|
||||
--with-szlib="${LOCALBASE}" \
|
||||
--enable-shared
|
||||
USE_LDCONFIG= yes
|
||||
MAKE_JOBS_SAFE= yes
|
||||
|
||||
MAN1= hdf.1 hdfunpac.1 ncdump.1 ncgen.1
|
||||
MAN3= gr_chunk.3
|
||||
MANCOMPRESSED= no
|
||||
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
check regression-test test: build
|
||||
${MAKE} ${_MAKE_JOBS} -C ${WRKSRC}/hdf/test check
|
||||
|
||||
post-install:
|
||||
# Install man-pages omitted by HDF's own install process
|
||||
${INSTALL_MAN} ${WRKSRC}/man/hdfunpac.1 ${MAN1PREFIX}/man/man1/
|
||||
${INSTALL_MAN} ${WRKSRC}/man/gr_chunk.3 ${MAN1PREFIX}/man/man3/
|
||||
# Removing useless .la files from ${PREFIX}/lib
|
||||
${RM} -f ${PREFIX}/lib/libdf.la ${PREFIX}/lib/libmfhdf.la
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
|
@ -54,4 +34,15 @@ post-install:
|
|||
BROKEN= Does not compile on powerpc
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e \
|
||||
'/PROD_/s|=.*|=""|' ${WRKSRC}/config/freebsd
|
||||
|
||||
post-install:
|
||||
${INSTALL_MAN} ${WRKSRC}/man/hdfunpac.1 ${MAN1PREFIX}/man/man1
|
||||
${INSTALL_MAN} ${WRKSRC}/man/gr_chunk.3 ${MAN3PREFIX}/man/man3
|
||||
|
||||
check regression-test test: build
|
||||
${MAKE} -C ${WRKSRC}/hdf/test check
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (hdf-4.2.7-patch1.tar.bz2) = 3a7b5ba0ac47e5283bee3ec365e8027e88937cd1632d001ceec33af80947d1bd
|
||||
SIZE (hdf-4.2.7-patch1.tar.bz2) = 3027309
|
||||
SHA256 (hdf-4.2.8.tar.bz2) = e8a94ae2c838007ccdd55bb3cd9684adba3ded367c09803ffc84a2704f83c00f
|
||||
SIZE (hdf-4.2.8.tar.bz2) = 3027253
|
||||
|
|
|
@ -1,41 +0,0 @@
|
|||
Don't append optimization flags -- rely on what the building
|
||||
machine has set.
|
||||
--- config/freebsd 2012-03-17 23:44:05.000000000 -0400
|
||||
+++ config/freebsd 2012-04-21 10:30:43.000000000 -0400
|
||||
@@ -102,5 +102,5 @@
|
||||
DEBUG_CFLAGS="-g -ansi -Wall -pedantic "
|
||||
DEBUG_CPPFLAGS=
|
||||
- PROD_CFLAGS="-ansi -Wall -Wpointer-arith -Wcast-qual -Wcast-align -Wwrite-strings -Wconversion -Wmissing-prototypes -Wnested-externs -pedantic -O2"
|
||||
+ PROD_CFLAGS="-ansi -Wall -Wpointer-arith -Wcast-qual -Wcast-align -Wwrite-strings -Wconversion -Wmissing-prototypes -Wnested-externs -pedantic"
|
||||
PROD_CPPFLAGS=
|
||||
PROFILE_CFLAGS="-pg"
|
||||
@@ -112,5 +112,4 @@
|
||||
DEBUG_CFLAGS="-g"
|
||||
DEBUG_CPPFLAGS=
|
||||
- PROD_CFLAGS="-O"
|
||||
PROD_CPPFLAGS=
|
||||
PROFILE_CFLAGS="-pg"
|
||||
@@ -123,5 +122,4 @@
|
||||
FFLAGS="$FFLAGS"
|
||||
DEBUG_FFLAGS="-g"
|
||||
- PROD_FFLAGS="-O"
|
||||
PROFILE_FFLAGS="-pg"
|
||||
;;
|
||||
@@ -130,5 +128,4 @@
|
||||
FFLAGS="$FFLAGS"
|
||||
DEBUG_FFLAGS="-g"
|
||||
- PROD_FFLAGS="-O"
|
||||
PROFILE_FFLAGS="-pg"
|
||||
;;
|
||||
@@ -139,5 +136,4 @@
|
||||
CXXFLAGS="$CXXFLAGS"
|
||||
DEBUG_CXXFLAGS="-g -fverbose-asm"
|
||||
- PROD_CXXFLAGS="-O3 -fomit-frame-pointer"
|
||||
PROFILE_CXXFLAGS="-pg"
|
||||
;;
|
||||
@@ -146,5 +142,4 @@
|
||||
CXXFLAGS="$CXXFLAGS -ansi"
|
||||
DEBUG_CXXFLAGS="-g"
|
||||
- PROD_CXXFLAGS="-O"
|
||||
PROFILE_CXXFLAGS="-pg"
|
||||
;;
|
19
science/hdf/files/patch-configure
Normal file
19
science/hdf/files/patch-configure
Normal file
|
@ -0,0 +1,19 @@
|
|||
--- configure.orig 2012-08-07 13:11:45.000000000 +0900
|
||||
+++ configure 2012-08-14 21:08:48.000000000 +0900
|
||||
@@ -5837,11 +5837,11 @@
|
||||
enable_shared="no"
|
||||
fi
|
||||
|
||||
-if test "X${enable_shared}" = "Xyes"; then
|
||||
- if test "X${BUILD_FORTRAN}" = "Xyes"; then
|
||||
- as_fn_error $? "Cannot build shared fortran libraries. Please configure with --disable-fortran flag." "$LINENO" 5
|
||||
- fi
|
||||
-fi
|
||||
+#if test "X${enable_shared}" = "Xyes"; then
|
||||
+# if test "X${BUILD_FORTRAN}" = "Xyes"; then
|
||||
+# as_fn_error $? "Cannot build shared fortran libraries. Please configure with --disable-fortran flag." "$LINENO" 5
|
||||
+# fi
|
||||
+#fi
|
||||
|
||||
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether ln -s works" >&5
|
20
science/hdf/files/patch-hdf__src__Makefile.in
Normal file
20
science/hdf/files/patch-hdf__src__Makefile.in
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- hdf/src/Makefile.in.orig 2012-08-07 13:11:36.000000000 +0900
|
||||
+++ hdf/src/Makefile.in 2012-08-14 21:08:53.000000000 +0900
|
||||
@@ -187,7 +187,7 @@
|
||||
INSTALL_SCRIPT = @INSTALL_SCRIPT@
|
||||
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
|
||||
LD = @LD@
|
||||
-LDFLAGS = @LDFLAGS@
|
||||
+LDFLAGS = @LDFLAGS@ -version-number 2
|
||||
LEX = @LEX@
|
||||
LIBOBJS = @LIBOBJS@
|
||||
LIBS = @LIBS@
|
||||
@@ -290,8 +290,6 @@
|
||||
CP = cp
|
||||
H4CC = $(bindir)/h4cc
|
||||
H4FC = $(bindir)/h4fc
|
||||
-@HDF_BUILD_XDR_TRUE@XDR_ADD = -R$(abs_top_builddir)/mfhdf/xdr/.libs
|
||||
-@HDF_BUILD_SHARED_TRUE@AM_LDFLAGS = -R$(abs_top_builddir)/mfhdf/libsrc/.libs -R$(abs_top_builddir)/hdf/src/.libs $(XDR_ADD)
|
||||
ACLOCAL_AMFLAGS = "-I m4"
|
||||
lib_LTLIBRARIES = libdf.la
|
||||
FSOURCES = df24ff.f dfanf.c dfanff.f dff.c dfff.f dfpf.c dfpff.f dfr8f.c \
|
|
@ -1,31 +0,0 @@
|
|||
--- hdf/src/Makefile.in 2012-03-17 23:45:49.000000000 -0400
|
||||
+++ hdf/src/Makefile.in 2012-04-21 13:33:36.000000000 -0400
|
||||
@@ -188,5 +188,5 @@
|
||||
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
|
||||
LD = @LD@
|
||||
-LDFLAGS = @LDFLAGS@
|
||||
+LDFLAGS = @LDFLAGS@ -version-number 2
|
||||
LEX = @LEX@
|
||||
LIBOBJS = @LIBOBJS@
|
||||
@@ -291,6 +291,4 @@
|
||||
H4CC = $(bindir)/h4cc
|
||||
H4FC = $(bindir)/h4fc
|
||||
-@HDF_BUILD_XDR_TRUE@XDR_ADD = -R$(abs_top_builddir)/mfhdf/xdr/.libs
|
||||
-@HDF_BUILD_SHARED_TRUE@AM_LDFLAGS = -R$(abs_top_builddir)/mfhdf/libsrc/.libs -R$(abs_top_builddir)/hdf/src/.libs $(XDR_ADD)
|
||||
ACLOCAL_AMFLAGS = "-I m4"
|
||||
lib_LTLIBRARIES = libdf.la
|
||||
+++ mfhdf/libsrc/Makefile.in 2012-04-21 13:33:36.000000000 -0400
|
||||
@@ -188,5 +188,5 @@
|
||||
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
|
||||
LD = @LD@
|
||||
-LDFLAGS = @LDFLAGS@
|
||||
+LDFLAGS = @LDFLAGS@ -version-number 3
|
||||
LEX = @LEX@
|
||||
LIBOBJS = @LIBOBJS@
|
||||
@@ -291,6 +291,4 @@
|
||||
H4CC = $(bindir)/h4cc
|
||||
H4FC = $(bindir)/h4fc
|
||||
-@HDF_BUILD_XDR_TRUE@XDR_ADD = -R$(abs_top_builddir)/mfhdf/xdr/.libs
|
||||
-@HDF_BUILD_SHARED_TRUE@AM_LDFLAGS = -R$(abs_top_builddir)/mfhdf/libsrc/.libs -R$(abs_top_builddir)/hdf/src/.libs $(XDR_ADD)
|
||||
ACLOCAL_AMFLAGS = "-I m4"
|
||||
lib_LTLIBRARIES = libdf.la
|
20
science/hdf/files/patch-mfhdf__libsrc__Makefile.in
Normal file
20
science/hdf/files/patch-mfhdf__libsrc__Makefile.in
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- mfhdf/libsrc/Makefile.in.orig 2012-08-07 13:11:12.000000000 +0900
|
||||
+++ mfhdf/libsrc/Makefile.in 2012-08-14 21:08:58.000000000 +0900
|
||||
@@ -161,7 +161,7 @@
|
||||
INSTALL_SCRIPT = @INSTALL_SCRIPT@
|
||||
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
|
||||
LD = @LD@
|
||||
-LDFLAGS = @LDFLAGS@
|
||||
+LDFLAGS = @LDFLAGS@ -version-number 3
|
||||
LEX = @LEX@
|
||||
LIBOBJS = @LIBOBJS@
|
||||
LIBS = @LIBS@
|
||||
@@ -264,8 +264,6 @@
|
||||
CP = cp
|
||||
H4CC = $(bindir)/h4cc
|
||||
H4FC = $(bindir)/h4fc
|
||||
-@HDF_BUILD_XDR_TRUE@XDR_ADD = -R$(abs_top_builddir)/mfhdf/xdr/.libs
|
||||
-@HDF_BUILD_SHARED_TRUE@AM_LDFLAGS = -R$(abs_top_builddir)/mfhdf/libsrc/.libs -R$(abs_top_builddir)/hdf/src/.libs $(XDR_ADD)
|
||||
ACLOCAL_AMFLAGS = "-I m4"
|
||||
INCLUDES = -I$(top_srcdir)/hdf/src \
|
||||
-I$(top_srcdir)/mfhdf/libsrc
|
|
@ -1,31 +0,0 @@
|
|||
--- configure.ac 2012-03-17 23:45:46.000000000 -0400
|
||||
+++ configure.ac 2012-04-21 10:01:41.000000000 -0400
|
||||
@@ -199,6 +199,5 @@
|
||||
dnl -------------------------------------------------------------------------
|
||||
dnl Build static libraries by default. Furthermore, fortran shared libraries
|
||||
-dnl are unsupported. Disallow a user from enabling both shared libraries and
|
||||
-dnl fortran.
|
||||
+dnl are unsupported.
|
||||
if test "X${enable_shared}" != "Xyes"; then
|
||||
enable_shared="no"
|
||||
@@ -207,5 +206,5 @@
|
||||
if test "X${enable_shared}" = "Xyes"; then
|
||||
if test "X${BUILD_FORTRAN}" = "Xyes"; then
|
||||
- AC_MSG_ERROR([Cannot build shared fortran libraries. Please configure with --disable-fortran flag.])
|
||||
+ AC_MSG_WARN([Fortran shared libraries aren't supported.])
|
||||
fi
|
||||
fi
|
||||
--- configure 2012-03-17 23:45:51.000000000 -0400
|
||||
+++ configure 2012-04-21 09:51:08.000000000 -0400
|
||||
@@ -5838,11 +5838,4 @@
|
||||
fi
|
||||
|
||||
-if test "X${enable_shared}" = "Xyes"; then
|
||||
- if test "X${BUILD_FORTRAN}" = "Xyes"; then
|
||||
- as_fn_error $? "Cannot build shared fortran libraries. Please configure with --disable-fortran flag." "$LINENO" 5
|
||||
- fi
|
||||
-fi
|
||||
-
|
||||
-
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether ln -s works" >&5
|
||||
$as_echo_n "checking whether ln -s works... " >&6; }
|
|
@ -67,13 +67,13 @@ include/hproto_fortran.h
|
|||
include/htags.h
|
||||
include/linklist.h
|
||||
include/local_nc.h
|
||||
include/mfdatainfo.h
|
||||
include/mffunc.inc
|
||||
include/mffunc.f90
|
||||
include/mfhdfi.h
|
||||
include/mfan.h
|
||||
include/mfdatainfo.h
|
||||
include/mffunc.f90
|
||||
include/mffunc.inc
|
||||
include/mfgr.h
|
||||
include/mfhdf.h
|
||||
include/mfhdfi.h
|
||||
include/mstdio.h
|
||||
include/netcdf.f90
|
||||
include/netcdf.h
|
||||
|
@ -82,9 +82,11 @@ include/tbbt.h
|
|||
include/vattr.h
|
||||
include/vg.h
|
||||
lib/libdf.a
|
||||
lib/libdf.la
|
||||
lib/libdf.so
|
||||
lib/libdf.so.2
|
||||
lib/libhdf4.settings
|
||||
lib/libmfhdf.a
|
||||
lib/libmfhdf.la
|
||||
lib/libmfhdf.so
|
||||
lib/libmfhdf.so.3
|
||||
|
|
Loading…
Reference in a new issue