This plugin offers sub-ticket feature for managing tickets.
WWW: http://trac-hacks.org/wiki/SubticketsPlugin PR: ports/177424 Submitted by: Hung-Yi Chen <gaod@hychen.org>
This commit is contained in:
parent
6ce9c856cd
commit
1babe2feae
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=323087
6 changed files with 69 additions and 0 deletions
|
@ -1956,6 +1956,7 @@
|
|||
SUBDIR += trac-scrumburndown
|
||||
SUBDIR += trac-simpleticket
|
||||
SUBDIR += trac-spam-filter
|
||||
SUBDIR += trac-subtickets
|
||||
SUBDIR += trac-tags
|
||||
SUBDIR += trac-themeengine
|
||||
SUBDIR += trac-ticketimport
|
||||
|
|
33
www/trac-subtickets/Makefile
Normal file
33
www/trac-subtickets/Makefile
Normal file
|
@ -0,0 +1,33 @@
|
|||
# Created by: Hung-Yi Chen <gaod@hychen.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= subtickets
|
||||
PORTVERSION= 0.2.0.${GITDATE}
|
||||
CATEGORIES= www devel python
|
||||
MASTER_SITES= http://distfiles.cse.tw/ \
|
||||
https://github.com/itota/trac-subtickets-plugin/tarball/${GITVERSION}/
|
||||
PKGNAMEPREFIX= trac-
|
||||
DISTNAME= itota-trac-subtickets-plugin-a0fc153
|
||||
|
||||
MAINTAINER= gaod@hychen.org
|
||||
COMMENT= Offers sub-ticket feature for managing tickets
|
||||
|
||||
LICENSE= BSD
|
||||
|
||||
RUN_DEPENDS= tracd:${PORTSDIR}/www/trac
|
||||
|
||||
GITVERSION= a0fc153
|
||||
GITDATE= 20130328
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}plugin/0.12
|
||||
WRKSRC= ${WRKDIR}/itota-trac-${PORTNAME}-plugin-${GITVERSION}
|
||||
USE_PYTHON= -2.7
|
||||
USE_PYDISTUTILS= easy_install
|
||||
|
||||
FETCH_ARGS= -Fpr
|
||||
PYDISTUTILS_PKGNAME= TracSubTicketsPlugin
|
||||
PYDISTUTILS_PKGVERSION= ${PORTVERSION:C/${GITDATE}//g}dev
|
||||
PLIST_FILES= bin/check-trac-subtickets \
|
||||
%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
|
||||
|
||||
.include <bsd.port.mk>
|
2
www/trac-subtickets/distinfo
Normal file
2
www/trac-subtickets/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (itota-trac-subtickets-plugin-a0fc153.tar.gz) = 02d41766c2efeb70fabebb269afcbac5af1c1bcbbfc09e1f33f1cc0056c031b2
|
||||
SIZE (itota-trac-subtickets-plugin-a0fc153.tar.gz) = 7444
|
10
www/trac-subtickets/files/patch-setup.cfg
Normal file
10
www/trac-subtickets/files/patch-setup.cfg
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- setup.cfg.orig 2013-03-28 05:06:54.072148000 +0800
|
||||
+++ setup.cfg 2013-03-28 05:06:59.650566000 +0800
|
||||
@@ -1,6 +1,6 @@
|
||||
[egg_info]
|
||||
tag_build = .dev
|
||||
-tag_date = True
|
||||
+tag_date = False
|
||||
|
||||
[extract_messages]
|
||||
add_comments = TRANSLATOR:
|
20
www/trac-subtickets/files/patch-tracsubtickets_api.py
Normal file
20
www/trac-subtickets/files/patch-tracsubtickets_api.py
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- tracsubtickets/api.py.orig 2013-03-28 05:19:20.898573000 +0800
|
||||
+++ tracsubtickets/api.py 2013-03-28 05:19:46.107341000 +0800
|
||||
@@ -153,7 +153,7 @@
|
||||
(parent, ticket.id))
|
||||
# add a comment to old parent
|
||||
xticket = Ticket(self.env, parent)
|
||||
- xticket.save_changes(author, _('Remove a subticket #%s.') % ticket.id)
|
||||
+ xticket.save_changes(author, _('Remove a subticket #%s. (%s)') % (ticket.id, ticket['summary']))
|
||||
tn = TicketNotifyEmail(self.env)
|
||||
tn.notify(xticket, newticket=False, modtime=xticket['changetime'])
|
||||
|
||||
@@ -164,7 +164,7 @@
|
||||
(parent, ticket.id))
|
||||
# add a comment to new parent
|
||||
xticket = Ticket(self.env, parent)
|
||||
- xticket.save_changes(author, _('Add a subticket #%s.') % ticket.id)
|
||||
+ xticket.save_changes(author, _('Add a subticket #%s. (%s)') % (ticket.id, ticket['summary']))
|
||||
tn = TicketNotifyEmail(self.env)
|
||||
tn.notify(xticket, newticket=False, modtime=xticket['changetime'])
|
||||
|
3
www/trac-subtickets/pkg-descr
Normal file
3
www/trac-subtickets/pkg-descr
Normal file
|
@ -0,0 +1,3 @@
|
|||
This plugin offers sub-ticket feature for managing tickets.
|
||||
|
||||
WWW: http://trac-hacks.org/wiki/SubticketsPlugin
|
Loading…
Reference in a new issue