Update to version 2.2.3.
PR: ports/177849 Submitted by: Fernando <fernando.apesteguia@gmail.com> (maintainer) Feature safe: yes
This commit is contained in:
parent
dfc9654278
commit
1bdb2146ca
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=315897
3 changed files with 14 additions and 16 deletions
|
@ -2,15 +2,13 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= openvsp
|
||||
PORTVERSION= 2.2.2
|
||||
PORTVERSION= 2.2.3
|
||||
CATEGORIES= cad
|
||||
MASTER_SITES= https://github.com/OpenVSP/OpenVSP/archive/
|
||||
|
||||
MAINTAINER= fernando.apesteguia@gmail.com
|
||||
COMMENT= Create a 3D model of an aircraft defined by engineering parameters
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/lib/libopenNURBS.a:${PORTSDIR}/graphics/opennurbs
|
||||
|
||||
LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
|
||||
jpeg:${PORTSDIR}/graphics/jpeg \
|
||||
drm:${PORTSDIR}/graphics/libdrm \
|
||||
|
@ -20,9 +18,15 @@ LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
|
|||
fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
|
||||
fltk:${PORTSDIR}/x11-toolkits/fltk \
|
||||
xcb:${PORTSDIR}/x11/libxcb
|
||||
WRKSRC= ${WRKDIR}/OpenVSP-OpenVSP_${PORTVERSION}/src
|
||||
|
||||
USES= cmake
|
||||
USE_GITHUB= yes
|
||||
GH_PROJECT= OpenVSP
|
||||
GH_ACCOUNT= ${GH_PROJECT}
|
||||
GH_TAGNAME= ${GH_PROJECT}_${PORTVERSION}
|
||||
GH_COMMIT= fb52aa2
|
||||
|
||||
CMAKE_SOURCE_PATH= ${WRKSRC}/src
|
||||
USES= cmake:outsource
|
||||
USE_DOS2UNIX= yes
|
||||
USE_ICONV= yes
|
||||
USE_XORG= ice sm x11 xau xdamage xdmcp xext xfixes xft \
|
||||
|
@ -31,7 +35,7 @@ USE_GL= glu
|
|||
USE_GNOME= libxml2
|
||||
|
||||
PORTEXAMPLES= *
|
||||
INSTALL_PORTEXAMPLES= @(cd ${WRKSRC}/../examples/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
|
||||
INSTALL_PORTEXAMPLES= @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
|
||||
|
||||
PLIST_FILES= bin/vsp
|
||||
|
||||
|
@ -39,14 +43,8 @@ CFLAGS+= -I${LOCALBASE}/include/openNURBS
|
|||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
do-fetch:
|
||||
if [ ! -f ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ]; then \
|
||||
${FETCH_BINARY} -o ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} \
|
||||
${MASTER_SITES}OpenVSP_${PORTVERSION}${EXTRACT_SUFX}; \
|
||||
fi
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/vsp/vsp ${PREFIX}/bin
|
||||
@${INSTALL_PROGRAM} ${BUILD_WRKSRC}/vsp/vsp ${PREFIX}/bin
|
||||
.if ${PORT_OPTIONS:MEXAMPLES}
|
||||
@${MKDIR} ${EXAMPLESDIR}
|
||||
@${INSTALL_PORTEXAMPLES}
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (openvsp-2.2.2.tar.gz) = 93dd8978b568eb5726a9392308029b7b9967ae1af8c4033e8e8cba05f5a46e9b
|
||||
SIZE (openvsp-2.2.2.tar.gz) = 2921036
|
||||
SHA256 (openvsp-2.2.3.tar.gz) = 0ae143c31c09cd8bd93ead480c32343d0b360ef132e1ce5d3d2beec3457c7a63
|
||||
SIZE (openvsp-2.2.3.tar.gz) = 2921344
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- /home/fernape/porting/openvsp/original/OpenVSP_2.0_community_src/src/xmlvsp/CMakeLists.txt 2012-04-04 21:03:54.000000000 +0200
|
||||
+++ xmlvsp/CMakeLists.txt 2012-04-04 20:29:08.000000000 +0200
|
||||
+++ src/xmlvsp/CMakeLists.txt 2012-04-04 20:29:08.000000000 +0200
|
||||
@@ -2,7 +2,7 @@
|
||||
|
||||
FIND_PACKAGE(LibXml2 REQUIRED)
|
||||
|
|
Loading…
Reference in a new issue