- update to 1.2.6.1
- make objformat obsolete - configure.ac patch no longer needed as I fixed it upstream Pointy hat to: kris Approved by: ehaupt (mentor)
This commit is contained in:
parent
bc31aba5af
commit
1bef372031
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=185841
6 changed files with 73 additions and 49 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= hamlib
|
||||
PORTVERSION= 1.2.6
|
||||
PORTVERSION= 1.2.6.1
|
||||
CATEGORIES= comms hamradio
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (hamlib-1.2.6.tar.gz) = 4bb058cfb9f13eaa8948b41e47956599
|
||||
SHA256 (hamlib-1.2.6.tar.gz) = 230bc5185521b7b5761677e96b3da29c349e16d074f88b107eb4c9bb717a6ca4
|
||||
SIZE (hamlib-1.2.6.tar.gz) = 1473299
|
||||
MD5 (hamlib-1.2.6.1.tar.gz) = c4aef5fb5060fd3b2d5c18b5fad4506f
|
||||
SHA256 (hamlib-1.2.6.1.tar.gz) = a70d54ee60f26ba8b5c183cf1c140cc1ebbcb10640b04aad03a297830e0c6293
|
||||
SIZE (hamlib-1.2.6.1.tar.gz) = 1474242
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- bindings/Makefile.in.orig Sun Apr 9 16:26:50 2006
|
||||
+++ bindings/Makefile.in Sun Apr 9 20:26:15 2006
|
||||
@@ -270,7 +270,7 @@
|
||||
--- bindings/Makefile.in.orig Thu Feb 22 14:24:58 2007
|
||||
+++ bindings/Makefile.in Thu Feb 22 14:24:59 2007
|
||||
@@ -273,7 +273,7 @@
|
||||
prefix = @prefix@
|
||||
program_transform_name = @program_transform_name@
|
||||
pyexecdir = @pyexecdir@
|
||||
|
@ -9,7 +9,7 @@
|
|||
sbindir = @sbindir@
|
||||
sharedstatedir = @sharedstatedir@
|
||||
subdirs = @subdirs@
|
||||
@@ -283,13 +283,13 @@
|
||||
@@ -286,13 +286,13 @@
|
||||
##########################################
|
||||
# Tcl binding
|
||||
tcl_ltlib = hamlibtcl.la
|
||||
|
@ -25,7 +25,7 @@
|
|||
hamlibtcl_la_DATA = pkgIndex.tcl
|
||||
|
||||
##########################################
|
||||
@@ -302,7 +302,8 @@
|
||||
@@ -305,7 +305,8 @@
|
||||
python_PYTHON = Hamlib.py
|
||||
|
||||
##########################################
|
||||
|
@ -35,7 +35,7 @@
|
|||
EXTRA_DIST = hamlib.swg ignore.swg rig.swg rotator.swg \
|
||||
Makefile.PL perltest.pl tcltest.tcl pytest.py
|
||||
|
||||
@@ -421,6 +422,7 @@
|
||||
@@ -424,6 +425,7 @@
|
||||
-rm -f libtool
|
||||
uninstall-info-am:
|
||||
install-pythonPYTHON: $(python_PYTHON)
|
||||
|
@ -43,7 +43,7 @@
|
|||
@$(NORMAL_INSTALL)
|
||||
test -z "$(pythondir)" || $(mkdir_p) "$(DESTDIR)$(pythondir)"
|
||||
@list='$(python_PYTHON)'; dlist=''; for p in $$list; do\
|
||||
@@ -449,6 +451,7 @@
|
||||
@@ -452,6 +454,7 @@
|
||||
rm -f "$(DESTDIR)$(pythondir)/$${f}o"; \
|
||||
done
|
||||
install-hamlibtcl_laDATA: $(hamlibtcl_la_DATA)
|
||||
|
@ -51,7 +51,7 @@
|
|||
@$(NORMAL_INSTALL)
|
||||
test -z "$(hamlibtcl_ladir)" || $(mkdir_p) "$(DESTDIR)$(hamlibtcl_ladir)"
|
||||
@list='$(hamlibtcl_la_DATA)'; for p in $$list; do \
|
||||
@@ -551,7 +554,8 @@
|
||||
@@ -554,7 +557,8 @@
|
||||
test -z "$$dir" || $(mkdir_p) "$$dir"; \
|
||||
done
|
||||
install: $(BUILT_SOURCES)
|
||||
|
@ -61,7 +61,7 @@
|
|||
install-exec: install-exec-am
|
||||
install-data: install-data-am
|
||||
uninstall: uninstall-am
|
||||
@@ -698,7 +702,6 @@
|
||||
@@ -700,7 +704,6 @@
|
||||
check-tcl: all-tcl
|
||||
TCLLIBPATH=$(builddir)/.libs $(srcdir)/tcltest.tcl || echo "Tcl test failed" 1>&2
|
||||
|
||||
|
@ -69,7 +69,7 @@
|
|||
clean-tcl:
|
||||
distclean-tcl: clean-tcl
|
||||
uninstall-tcl:
|
||||
@@ -713,7 +716,6 @@
|
||||
@@ -715,7 +718,6 @@
|
||||
check-py: all-py
|
||||
$(srcdir)/pytest.py || echo "Python test failed" 1>&2
|
||||
|
||||
|
|
|
@ -1,35 +0,0 @@
|
|||
--- configure.ac.orig Sun Feb 26 14:47:50 2006
|
||||
+++ configure.ac Sun Apr 9 20:10:30 2006
|
||||
@@ -215,6 +215,7 @@
|
||||
BINDING_INSTALL_EXEC=""
|
||||
BINDING_UNINSTALL=""
|
||||
BINDING_LIST=""
|
||||
+BINDING_LIB_TARGETS=""
|
||||
|
||||
dnl Check if cxx-binding not wanted, default is to build it
|
||||
|
||||
@@ -292,6 +293,7 @@
|
||||
BINDING_DISTCLEAN="${BINDING_DISTCLEAN} distclean-tcl"
|
||||
BINDING_INSTALL_EXEC="${BINDING_INSTALL_EXEC} install-tcl"
|
||||
BINDING_UNINSTALL="${BINDING_UNINSTALL} uninstall-tcl"
|
||||
+ BINDING_LIB_TARGETS="${BINDING_LIB_TARGETS} \$(tcl_ltlib)"
|
||||
fi
|
||||
AC_SUBST(TCL_LIB_SPEC)
|
||||
AC_SUBST(TCL_INCLUDE_SPEC)
|
||||
@@ -317,6 +319,7 @@
|
||||
BINDING_DISTCLEAN="${BINDING_DISTCLEAN} distclean-py"
|
||||
BINDING_INSTALL_EXEC="${BINDING_INSTALL_EXEC} install-py"
|
||||
BINDING_UNINSTALL="${BINDING_UNINSTALL} uninstall-py"
|
||||
+ BINDING_LIB_TARGETS="${BINDING_LIB_TARGETS} \$(python_ltlib)"
|
||||
fi
|
||||
|
||||
|
||||
@@ -446,7 +449,7 @@
|
||||
AC_SUBST(BINDING_INSTALL_EXEC)
|
||||
AC_SUBST(BINDING_UNINSTALL)
|
||||
AC_SUBST(BINDING_LIST)
|
||||
-
|
||||
+AC_SUBST(BINDING_LIB_TARGETS)
|
||||
|
||||
AC_SUBST(INCLUDES)
|
||||
|
46
comms/hamlib/files/patch-libltdl_configure
Normal file
46
comms/hamlib/files/patch-libltdl_configure
Normal file
|
@ -0,0 +1,46 @@
|
|||
--- libltdl/configure.orig Thu Feb 22 14:24:59 2007
|
||||
+++ libltdl/configure Thu Feb 22 14:24:59 2007
|
||||
@@ -8189,8 +8189,8 @@
|
||||
;;
|
||||
|
||||
freebsd*)
|
||||
- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
|
||||
- version_type=freebsd-$objformat
|
||||
+# objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
|
||||
+ version_type=freebsd-elf
|
||||
case $version_type in
|
||||
freebsd-elf*)
|
||||
library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext} $libname${shared_ext}'
|
||||
@@ -11897,8 +11897,8 @@
|
||||
;;
|
||||
|
||||
freebsd*)
|
||||
- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
|
||||
- version_type=freebsd-$objformat
|
||||
+# objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
|
||||
+ version_type=freebsd-elf
|
||||
case $version_type in
|
||||
freebsd-elf*)
|
||||
library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext} $libname${shared_ext}'
|
||||
@@ -15050,8 +15050,8 @@
|
||||
;;
|
||||
|
||||
freebsd*)
|
||||
- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
|
||||
- version_type=freebsd-$objformat
|
||||
+# objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
|
||||
+ version_type=freebsd-elf
|
||||
case $version_type in
|
||||
freebsd-elf*)
|
||||
library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext} $libname${shared_ext}'
|
||||
@@ -17412,8 +17412,8 @@
|
||||
;;
|
||||
|
||||
freebsd*)
|
||||
- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
|
||||
- version_type=freebsd-$objformat
|
||||
+# objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
|
||||
+ version_type=freebsd-elf
|
||||
case $version_type in
|
||||
freebsd-elf*)
|
||||
library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext} $libname${shared_ext}'
|
13
comms/hamlib/files/patch-macros_libtools.m4
Normal file
13
comms/hamlib/files/patch-macros_libtools.m4
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- macros/libtool.m4.orig Sun Apr 3 16:25:10 2005
|
||||
+++ macros/libtool.m4 Thu Feb 22 14:24:59 2007
|
||||
@@ -1300,8 +1300,8 @@
|
||||
;;
|
||||
|
||||
freebsd*)
|
||||
- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
|
||||
- version_type=freebsd-$objformat
|
||||
+# objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
|
||||
+ version_type=freebsd-elf
|
||||
case $version_type in
|
||||
freebsd-elf*)
|
||||
library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext} $libname${shared_ext}'
|
Loading…
Reference in a new issue