Integrate a sparc64 patch from base version of binutils
Submitted by: marius
This commit is contained in:
parent
93f2c2133b
commit
1bf999a060
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=370589
2 changed files with 27 additions and 1 deletions
26
devel/binutils/files/patch-bfd_elfxx-sparc.c
Normal file
26
devel/binutils/files/patch-bfd_elfxx-sparc.c
Normal file
|
@ -0,0 +1,26 @@
|
|||
--- bfd/elfxx-sparc.c.orig 2013-11-08 11:13:48.000000000 +0100
|
||||
+++ bfd/elfxx-sparc.c 2014-10-10 16:30:23.316125000 +0200
|
||||
@@ -2942,12 +2942,14 @@
|
||||
Elf_Internal_Rela *relend;
|
||||
int num_relocs;
|
||||
bfd_boolean is_vxworks_tls;
|
||||
+ const struct elf_backend_data *bed;
|
||||
|
||||
htab = _bfd_sparc_elf_hash_table (info);
|
||||
BFD_ASSERT (htab != NULL);
|
||||
symtab_hdr = &elf_symtab_hdr (input_bfd);
|
||||
sym_hashes = elf_sym_hashes (input_bfd);
|
||||
local_got_offsets = elf_local_got_offsets (input_bfd);
|
||||
+ bed = get_elf_backend_data (output_bfd);
|
||||
|
||||
if (elf_hash_table (info)->hgot == NULL)
|
||||
got_base = 0;
|
||||
@@ -3528,6 +3530,8 @@
|
||||
bfd_set_error (bfd_error_bad_value);
|
||||
return FALSE;
|
||||
}
|
||||
+ if (bed->elf_osabi == ELFOSABI_FREEBSD)
|
||||
+ outrel.r_addend -= osec->vma;
|
||||
}
|
||||
|
||||
outrel.r_info = SPARC_ELF_R_INFO (htab, rel, indx,
|
|
@ -1,6 +1,6 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
COMMENT= GNU binutils for sparc64 cross-development
|
||||
PKGNAMEPREFIX= sparc64-
|
||||
PLIST= ${.CURDIR}/pkg-plist
|
||||
|
|
Loading…
Reference in a new issue