- Fix CacheModule http

PR:             ports/121644
Submitted by:   Sergey Samitovsky <svs_at_nktv.mk.ua>
This commit is contained in:
Sergey Matveychuk 2008-12-08 19:33:33 +00:00
parent d291f6256b
commit 1c45538c8f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=224006
2 changed files with 19 additions and 1 deletions

View file

@ -7,7 +7,7 @@
PORTNAME= frox
PORTVERSION= 0.7.18
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= ftp
MASTER_SITES= http://www.hollo.org/frox/download/ \
http://frox.sourceforge.net/download/ \

View file

@ -0,0 +1,18 @@
Apply patch
Patch attached with submission follows:
--- src/cache.c.orig 2008-03-12 16:56:10.000000000 +0200
+++ src/cache.c 2008-03-12 16:56:10.000000000 +0200
@@ -364,7 +364,7 @@
int code;
sstr *msg;
- if(!strcasecmp(config.cachemod, "Local") || !config.forcehttp) {
+ if(!strcasecmp(config.cachemod, "Local") || config.forcehttp) {
send_ccommand("SIZE", sstr_buf(filename));
get_message(&code, &msg);
if(code / 100 != 2) {