New port: www/palemoon
Pale Moon(TM) offers you a browsing experience in a browser completely built from its own, independently developed source that has been forked off from Firefox/Mozilla code a number of years ago, with carefully selected features and optimizations to improve the browser's stability and user experience, while offering full customization and a growing collection of extensions and themes to make the browser truly your own. Some of the main features: - Based on the Unified XUL Platform (UXP) containing our own optimized layout and rendering engine (Goanna). - Safe: Forked from mature Mozilla code and regularly updated with the latest security patches. - Secure: Additional security features and security-aware development - Zero ads; no telemetry, spyware or data gathering - Familiar, efficient, fully customizable interface WWW: https://www.palemoon.org/ PR: 251117 Submitted by: Olivier Certner <olivier.freebsd@free.fr>
This commit is contained in:
parent
9cc1162eb4
commit
1c6c5f24b8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=565330
15 changed files with 451 additions and 1 deletions
1
MOVED
1
MOVED
|
@ -12776,7 +12776,6 @@ devel/rubygem-fastthread||2019-06-30|Has expired: Does not build for all support
|
|||
www/rubygem-responders-rails50|www/rubygem-responders|2019-06-30|Has expired: Use www/rubygem-responders (depends on Rails 5.0) instead
|
||||
emulators/xen-kernel47|emulators/xen-kernel|2019-07-01|Has expired: This port is about to be removed, please update to a newer Xen version
|
||||
sysutils/xen-tools47|sysutils/xen-tools|2019-07-01|Has expired: This port is about to be removed, please update to a newer Xen version
|
||||
www/palemoon||2019-07-03|Not maintained and full of security holes
|
||||
www/seamonkey||2019-07-03|2.49.* is not maintained upstream and full of security holes
|
||||
www/tomcat8||2019-07-06|Has expired: EoL since 2018-06-30
|
||||
devel/libevent-hiphop||2019-07-10|Has expired: Obsoleted with removal of lang/hiphop-php
|
||||
|
|
|
@ -1304,6 +1304,7 @@
|
|||
SUBDIR += p5-pQuery
|
||||
SUBDIR += p5-webservice-validator-css-w3c
|
||||
SUBDIR += p5-webservice-validator-html-w3c
|
||||
SUBDIR += palemoon
|
||||
SUBDIR += paros
|
||||
SUBDIR += payara
|
||||
SUBDIR += pear-HTML_AJAX
|
||||
|
|
196
www/palemoon/Makefile
Normal file
196
www/palemoon/Makefile
Normal file
|
@ -0,0 +1,196 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= palemoon
|
||||
# UXP_VERSION below *MUST BE UPDATED* according to DISTVERSION (see recorded
|
||||
# commit of the 'platform' git sub-module and corresponding release in
|
||||
# UXP/releases; see MASTER_SITES for base URLs).
|
||||
DISTVERSION= 29.0.1
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= https://repo.palemoon.org/MoonchildProductions/Pale-Moon/archive/:palemoon \
|
||||
https://repo.palemoon.org/MoonchildProductions/UXP/archive/:uxp
|
||||
DISTFILES= ${DISTVERSION}_Release.tar.gz:palemoon \
|
||||
RELBASE_${UXP_VERSION}.tar.gz:uxp
|
||||
DIST_SUBDIR= MoonchildProductions
|
||||
|
||||
MAINTAINER= olce.freebsd.ports@certner.fr
|
||||
COMMENT= Open-source web browser
|
||||
|
||||
LICENSE= MPL20 MISC
|
||||
LICENSE_COMB= multi
|
||||
LICENSE_NAME_MISC= Miscellaneous free and open-source licenses
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
LICENSE_FILE_MISC= ${WRKSRC}/platform/toolkit/content/license.html
|
||||
LICENSE_PERMS_MISC= dist-mirror pkg-mirror auto-accept
|
||||
|
||||
# Not sure about the real status of ARM, but only ARM packages of old versions of
|
||||
# PM are available in some Linux distros.
|
||||
ONLY_FOR_ARCHS= amd64 i386
|
||||
ONLY_FOR_ARCHS_REASON=Upstream only cares about i386/amd64
|
||||
|
||||
# Common deps & build options
|
||||
BUILD_DEPENDS= autoconf-2.13:devel/autoconf213 \
|
||||
yasm:devel/yasm \
|
||||
zip:archivers/zip \
|
||||
|
||||
LIB_DEPENDS= libdbus-1.so:devel/dbus \
|
||||
libdbus-glib-1.so:devel/dbus-glib \
|
||||
libfontconfig.so:x11-fonts/fontconfig \
|
||||
libfreetype.so:print/freetype2
|
||||
|
||||
USES= pkgconfig perl5 gmake gnome xorg desktop-file-utils
|
||||
USE_PERL5= build
|
||||
# XXX
|
||||
# GTK3 support currently needs gtk20 and gconf2 to pass old-configure (and
|
||||
# maybe more).
|
||||
# See also: https://repo.palemoon.org/MoonchildProductions/UXP/issues/1638.
|
||||
USE_GNOME= cairo gdkpixbuf2 glib20 pango \
|
||||
gtk30 gtk20:build gconf2:build
|
||||
USE_XORG= xt x11 xcb xext xrender
|
||||
# 9 is the last version endorsed upstream (and was the default in ports when
|
||||
# this was written). Version bumps *MUST* be validated by the maintainer (after
|
||||
# thorough testing, and following upstream's recommendations. Hence
|
||||
# hardcoded. (For the record, building with clang produces malfunctioning
|
||||
# executables.)
|
||||
|
||||
# NOTE: We make sure that there are no runtime dependencies to GCC and
|
||||
# libstdc++. See [GCC-no-rdep-*] tags below. This should rather be solved in
|
||||
# the ports infrastructure proper (see PR 211154, which is a step towards that;
|
||||
# however, it still doesn't remove -rpath and doesn't provide the option to
|
||||
# link C++ code against base's libc++).
|
||||
USE_GCC= 9
|
||||
|
||||
# Put this here pending creation of USES=gtar
|
||||
BUILD_DEPENDS+= gtar:archivers/gtar
|
||||
BINARY_ALIAS+= tar=${LOCALBASE}/bin/gtar
|
||||
|
||||
BUILD_DEPENDS+= tauthon:lang/tauthon
|
||||
BINARY_ALIAS+= python=${LOCALBASE}/bin/tauthon \
|
||||
python2=${LOCALBASE}/bin/tauthon \
|
||||
python2.7=${LOCALBASE}/bin/tauthon
|
||||
|
||||
BUNDLE_LIBS= yes
|
||||
|
||||
## Options
|
||||
|
||||
# Official branding is enabled in compliance with Pale Moon's redistribution
|
||||
# license (see https://www.palemoon.org/redist.shtml), point 8b, as explicitly
|
||||
# confirmed by the owner (Moonchild; see
|
||||
# https://forum.palemoon.org/viewtopic.php?f=5&t=25625), provided options are
|
||||
# not modified beyond what is necessary to get a stable build on FreeBSD. So DO
|
||||
# NOT CHANGE default options without the maintainer's approval.
|
||||
|
||||
OPTIONS_SINGLE+= SOUND
|
||||
OPTIONS_SINGLE_SOUND= ALSA PULSEAUDIO
|
||||
OPTIONS_DEFAULT+= ALSA
|
||||
|
||||
OPTIONS_DEFINE+= SYNC
|
||||
OPTIONS_DEFAULT+= SYNC
|
||||
|
||||
OPTIONS_DEFINE+= SYSTEM_MALLOC
|
||||
|
||||
ALSA_BUILD_DEPENDS= ${PREFIX}/include/alsa/asoundlib.h:audio/alsa-lib
|
||||
ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
|
||||
PULSEAUDIO_BUILD_DEPENDS=${LOCALBASE}/include/pulse/pulseaudio.h:audio/pulseaudio
|
||||
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
|
||||
|
||||
SYNC_DESC= Pale Moon Sync service (see https://www.palemoon.org/sync/)
|
||||
|
||||
SYSTEM_MALLOC_DESC= Use system's jemalloc instead of bundled one
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
## Vars and targets
|
||||
|
||||
UXP_VERSION= 20210205
|
||||
|
||||
WRKSRC= ${WRKDIR}/pale-moon
|
||||
|
||||
# Have GCC link with libc++. Needed because some library dependencies (e.g.,
|
||||
# libgraphite2.so) are linked against libc++ already, and mixing both with this
|
||||
# codebase results in instant executable crash.
|
||||
# As advised here:
|
||||
# https://libcxx.llvm.org/docs/UsingLibcxx.html#using-libc-with-gcc
|
||||
# with the change of linking gcc statically, so that this port doesn't need
|
||||
# to depend on GCC at all at runtime. [GCC-no-rdep-1]
|
||||
# This is similar to what 'compiler.mk' does on using "gcc-c++11-lib".
|
||||
CXXFLAGS+= -nostdinc++ -I/usr/include/c++/v1 -nodefaultlibs \
|
||||
-lc++ -lcxxrt -lm -lc -lgcc \
|
||||
-pthread -lpthread
|
||||
LDFLAGS+= -lgcc
|
||||
|
||||
DOT_MOZCONFIG= ${WRKSRC}/.mozconfig
|
||||
PM_BUILD_DIR= ${WRKSRC}/pmbuild
|
||||
|
||||
PALEMOON_DESKTOP=${WRKSRC}/palemoon/branding/official/palemoon.desktop
|
||||
|
||||
# Extract only -O options
|
||||
PM_OPTIMIZE=${CFLAGS:M-O*}
|
||||
|
||||
.for VAR in PM_BUILD_DIR PM_OPTIMIZE
|
||||
PM_MOZCONFIG_REINPLACE_ARGS+=-e 's!%%${VAR}%%!${${VAR}}!'
|
||||
.endfor
|
||||
|
||||
# Taken from bsd.gecko.mk. See comment there.
|
||||
.if defined(DISABLE_MAKE_JOBS) || defined(MAKE_JOBS_UNSAFE)
|
||||
MAKE_JOBS_NUMBER= 1
|
||||
.endif
|
||||
.if defined(MAKE_JOBS_NUMBER)
|
||||
MOZ_MAKE_FLAGS+= -j${MAKE_JOBS_NUMBER}
|
||||
.endif
|
||||
|
||||
post-extract:
|
||||
${RMDIR} ${WRKSRC}/platform
|
||||
${RLN} ${WRKDIR}/uxp ${WRKSRC}/platform
|
||||
|
||||
# Prepare '.mozconfig' for 'configure'
|
||||
pre-configure:
|
||||
${CP} ${FILESDIR}/dot.mozconfig ${DOT_MOZCONFIG}
|
||||
${REINPLACE_CMD} ${PM_MOZCONFIG_REINPLACE_ARGS} ${DOT_MOZCONFIG}
|
||||
.if ${PORT_OPTIONS:MALSA}
|
||||
${ECHO_CMD} ac_add_options --enable-alsa >> ${DOT_MOZCONFIG}
|
||||
${ECHO_CMD} ac_add_options --disable-pulseaudio >> ${DOT_MOZCONFIG}
|
||||
.endif
|
||||
.if ! ${PORT_OPTIONS:MSYNC}
|
||||
${ECHO_CMD} ac_add_options --disable-sync >> ${DOT_MOZCONFIG}
|
||||
.endif
|
||||
.if ${PORT_OPTIONS:MSYSTEM_MALLOC}
|
||||
${ECHO_CMD} ac_add_options --disable-jemalloc >> ${DOT_MOZCONFIG}
|
||||
.else
|
||||
${ECHO_CMD} ac_add_options --enable-jemalloc >> ${DOT_MOZCONFIG}
|
||||
.endif
|
||||
.if defined(MOZ_MAKE_FLAGS)
|
||||
${ECHO_CMD} mk_add_options MOZ_MAKE_FLAGS=${MOZ_MAKE_FLAGS:Q} \
|
||||
>> ${DOT_MOZCONFIG}
|
||||
.endif
|
||||
# Add build variables
|
||||
.for VAR in CPP CXXCPP CC CXX CPPFLAGS CFLAGS CXXFLAGS LDFLAGS \
|
||||
LD AS AR RANLIB OBJDUMP NM
|
||||
.if defined(${VAR})
|
||||
# Remove -rpath options to GCC's directory [GCC-no-rdep-2]
|
||||
${ECHO_CMD} export ${VAR}=\"${${VAR}:N*-rpath*lib/gcc*}\" >> ${DOT_MOZCONFIG}
|
||||
.endif
|
||||
.endfor
|
||||
|
||||
# Running 'mach configure' separately is "strongly discouraged" (see Mozilla's
|
||||
# doc on build options configuration). Still, things seem to work correctly
|
||||
# here even with this separate step.
|
||||
do-configure:
|
||||
cd ${WRKSRC} && ${SETENV} PATH=${PATH} ./mach configure
|
||||
|
||||
do-build:
|
||||
cd ${WRKSRC} && ${SETENV} PATH=${PATH} ./mach build
|
||||
# Going through the package route (the only one documented upstream)
|
||||
cd ${WRKSRC} && ${SETENV} PATH=${PATH} ./mach package
|
||||
|
||||
do-install:
|
||||
${TAR} -C ${STAGEDIR}${PREFIX}/lib \
|
||||
-xf ${PM_BUILD_DIR:Q}/dist/palemoon*.tar* \
|
||||
palemoon
|
||||
${RLN} ${STAGEDIR}${PREFIX}/lib/palemoon/palemoon \
|
||||
${STAGEDIR}${PREFIX}/bin/palemoon
|
||||
${INSTALL_DATA} ${PALEMOON_DESKTOP} \
|
||||
${STAGEDIR}${PREFIX}/share/applications/palemoon.desktop
|
||||
${RLN} ${STAGEDIR}${PREFIX}/lib/palemoon/browser/icons/mozicon128.png \
|
||||
${STAGEDIR}${PREFIX}/share/pixmaps/palemoon.png
|
||||
|
||||
.include <bsd.port.mk>
|
5
www/palemoon/distinfo
Normal file
5
www/palemoon/distinfo
Normal file
|
@ -0,0 +1,5 @@
|
|||
TIMESTAMP = 1612807197
|
||||
SHA256 (MoonchildProductions/29.0.1_Release.tar.gz) = ea01c74ddf75cc4f8d5aaf5fdf9c145eb8ca0aab16e2969bb109589ec1c20a06
|
||||
SIZE (MoonchildProductions/29.0.1_Release.tar.gz) = 8535288
|
||||
SHA256 (MoonchildProductions/RELBASE_20210205.tar.gz) = 79103c7e01db3290317fa4712700e6f233c9b21f9244414b95811d7008b08c09
|
||||
SIZE (MoonchildProductions/RELBASE_20210205.tar.gz) = 305402568
|
31
www/palemoon/files/dot.mozconfig
Normal file
31
www/palemoon/files/dot.mozconfig
Normal file
|
@ -0,0 +1,31 @@
|
|||
# Standard build options for Pale Moon
|
||||
# See http://developer.palemoon.org/build/linux/
|
||||
|
||||
# The 'configure' ports step replaces %%VAR%% with content of Makefile's VAR
|
||||
# and appends lines to this file.
|
||||
|
||||
mk_add_options MOZ_OBJDIR=%%PM_BUILD_DIR%%
|
||||
|
||||
ac_add_options --enable-application=palemoon
|
||||
ac_add_options --enable-optimize="-w %%PM_OPTIMIZE%%"
|
||||
ac_add_options --enable-default-toolkit=cairo-gtk3
|
||||
ac_add_options --enable-strip
|
||||
ac_add_options --enable-devtools
|
||||
ac_add_options --disable-eme
|
||||
ac_add_options --disable-webrtc
|
||||
ac_add_options --disable-gamepad
|
||||
ac_add_options --disable-tests
|
||||
ac_add_options --disable-debug
|
||||
ac_add_options --disable-necko-wifi
|
||||
ac_add_options --disable-updater
|
||||
ac_add_options --with-pthreads
|
||||
ac_add_options --enable-phoenix-extensions
|
||||
|
||||
ac_add_options --enable-official-branding
|
||||
export MOZILLA_OFFICIAL=1
|
||||
|
||||
# Don't bother compressing, mach's package is just intermediate file
|
||||
export MOZ_PKG_FORMAT=TAR
|
||||
|
||||
# Below this line, build options depending on port options, as well as make and
|
||||
# build flags, will be appended.
|
|
@ -0,0 +1,17 @@
|
|||
--- platform/config/gcc-stl-wrapper.template.h.orig 2021-02-05 18:43:01 UTC
|
||||
+++ platform/config/gcc-stl-wrapper.template.h
|
||||
@@ -32,6 +32,14 @@
|
||||
# define moz_dont_include_mozalloc_for_cstdlib
|
||||
#endif
|
||||
|
||||
+#ifndef moz_dont_include_mozalloc_for_type_traits
|
||||
+# define moz_dont_include_mozalloc_for_type_traits
|
||||
+#endif
|
||||
+
|
||||
+#ifndef moz_dont_include_mozalloc_for_limits
|
||||
+# define moz_dont_include_mozalloc_for_limits
|
||||
+#endif
|
||||
+
|
||||
// Include mozalloc after the STL header and all other headers it includes
|
||||
// have been preprocessed.
|
||||
#if !defined(MOZ_INCLUDE_MOZALLOC_H) && \
|
|
@ -0,0 +1,14 @@
|
|||
--- platform/gfx/harfbuzz/src/hb-blob.cc.orig 2021-02-05 18:43:01 UTC
|
||||
+++ platform/gfx/harfbuzz/src/hb-blob.cc
|
||||
@@ -24,9 +24,11 @@
|
||||
* Red Hat Author(s): Behdad Esfahbod
|
||||
*/
|
||||
|
||||
+#ifndef __FreeBSD__
|
||||
/* http://www.oracle.com/technetwork/articles/servers-storage-dev/standardheaderfiles-453865.html */
|
||||
#ifndef _POSIX_C_SOURCE
|
||||
#define _POSIX_C_SOURCE 199309L
|
||||
+#endif
|
||||
#endif
|
||||
|
||||
#include "hb-private.hh"
|
|
@ -0,0 +1,21 @@
|
|||
--- platform/memory/mozjemalloc/jemalloc.c.orig 2021-02-05 18:43:01 UTC
|
||||
+++ platform/memory/mozjemalloc/jemalloc.c
|
||||
@@ -5251,7 +5251,7 @@ malloc_init_hard(void)
|
||||
* Another thread initialized the allocator before this one
|
||||
* acquired init_lock.
|
||||
*/
|
||||
-#ifndef MOZ_MEMORY_WINDOWS
|
||||
+#if !(defined(MOZ_MEMORY_WINDOWS) || defined(__FreeBSD__))
|
||||
malloc_mutex_unlock(&init_lock);
|
||||
#endif
|
||||
return (false);
|
||||
@@ -6755,7 +6755,8 @@ jemalloc_darwin_init(void)
|
||||
#define is_malloc_(a) malloc_is_ ## a
|
||||
#define is_malloc(a) is_malloc_(a)
|
||||
|
||||
-#if !defined(MOZ_MEMORY_DARWIN) && (is_malloc(malloc_impl) == 1)
|
||||
+#if !(defined(MOZ_MEMORY_DARWIN) || defined(MOZ_MEMORY_BSD)) && \
|
||||
+ (is_malloc(malloc_impl) == 1)
|
||||
# if defined(__GLIBC__) && !defined(__UCLIBC__)
|
||||
/*
|
||||
* glibc provides the RTLD_DEEPBIND flag for dlopen which can make it possible
|
11
www/palemoon/files/patch-platform_old-configure.in
Normal file
11
www/palemoon/files/patch-platform_old-configure.in
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- platform/old-configure.in.orig 2021-02-05 18:43:01 UTC
|
||||
+++ platform/old-configure.in
|
||||
@@ -5554,7 +5554,7 @@ ac_configure_args="$_SUBDIR_CONFIG_ARGS"
|
||||
|
||||
# --with-system-nspr will have been converted into the relevant $NSPR_CFLAGS
|
||||
# and $NSPR_LIBS.
|
||||
-ac_configure_args="`echo $ac_configure_args | sed -e 's/--with-system-nspr\S* *//'`"
|
||||
+ac_configure_args="`echo $ac_configure_args | sed -e 's/--with-system-nspr[^[:space:]]* *//'`"
|
||||
|
||||
if test "$_INTL_API" = no; then
|
||||
ac_configure_args="$ac_configure_args --without-intl-api"
|
|
@ -0,0 +1,14 @@
|
|||
--- platform/python/mozbuild/mozbuild/configure/__init__.py.orig 2021-02-05 18:43:01 UTC
|
||||
+++ platform/python/mozbuild/mozbuild/configure/__init__.py
|
||||
@@ -192,8 +192,9 @@ class ConfigureSandbox(dict):
|
||||
b: __builtins__[b]
|
||||
for b in ('None', 'False', 'True', 'int', 'bool', 'any', 'all', 'len',
|
||||
'list', 'tuple', 'set', 'dict', 'isinstance', 'getattr',
|
||||
- 'hasattr', 'enumerate', 'range', 'zip')
|
||||
- }, __import__=forbidden_import, str=unicode)
|
||||
+ 'hasattr', 'enumerate', 'range', 'zip', '__build_class__')
|
||||
+ if b in __builtins__},
|
||||
+ __import__=forbidden_import, str=unicode)
|
||||
|
||||
# Expose a limited set of functions from os.path
|
||||
OS = ReadOnlyNamespace(path=ReadOnlyNamespace(**{
|
|
@ -0,0 +1,14 @@
|
|||
--- platform/python/mozbuild/mozbuild/frontend/sandbox.py.orig 2021-02-05 18:43:01 UTC
|
||||
+++ platform/python/mozbuild/mozbuild/frontend/sandbox.py
|
||||
@@ -115,7 +115,10 @@ class Sandbox(dict):
|
||||
def __init__(self, context, builtins=None, finder=default_finder):
|
||||
"""Initialize a Sandbox ready for execution.
|
||||
"""
|
||||
- self._builtins = builtins or self.BUILTINS
|
||||
+ self._builtins = ReadOnlyDict(
|
||||
+ (builtins or self.BUILTINS).viewitems() |
|
||||
+ {b: __builtins__[b] for b in ('__build_class__',)
|
||||
+ if b in __builtins__}.viewitems())
|
||||
dict.__setitem__(self, '__builtins__', self._builtins)
|
||||
|
||||
assert isinstance(self._builtins, ReadOnlyDict)
|
33
www/palemoon/files/patch-platform_python_virtualenv_site.py
Normal file
33
www/palemoon/files/patch-platform_python_virtualenv_site.py
Normal file
|
@ -0,0 +1,33 @@
|
|||
--- platform/python/virtualenv/site.py.orig 2021-02-05 18:43:01 UTC
|
||||
+++ platform/python/virtualenv/site.py
|
||||
@@ -233,10 +233,10 @@ def addsitepackages(known_paths, sys_prefix=sys.prefix
|
||||
elif os.sep == '/':
|
||||
sitedirs = [os.path.join(prefix,
|
||||
"lib",
|
||||
- "python" + sys.version[:3],
|
||||
+ "tauthon" + sys.version[:3],
|
||||
"site-packages"),
|
||||
os.path.join(prefix, "lib", "site-python"),
|
||||
- os.path.join(prefix, "python" + sys.version[:3], "lib-dynload")]
|
||||
+ os.path.join(prefix, "tauthon" + sys.version[:3], "lib-dynload")]
|
||||
lib64_dir = os.path.join(prefix, "lib64", "python" + sys.version[:3], "site-packages")
|
||||
if (os.path.exists(lib64_dir) and
|
||||
os.path.realpath(lib64_dir) not in [os.path.realpath(p) for p in sitedirs]):
|
||||
@@ -583,7 +583,7 @@ def virtual_install_main_packages():
|
||||
elif sys.platform == 'win32' and os.sep == '\\':
|
||||
paths = [os.path.join(sys.real_prefix, 'Lib'), os.path.join(sys.real_prefix, 'DLLs')]
|
||||
else:
|
||||
- paths = [os.path.join(sys.real_prefix, 'lib', 'python'+sys.version[:3])]
|
||||
+ paths = [os.path.join(sys.real_prefix, 'lib', 'tauthon'+sys.version[:3])]
|
||||
hardcoded_relative_dirs = paths[:] # for the special 'darwin' case below
|
||||
lib64_path = os.path.join(sys.real_prefix, 'lib64', 'python'+sys.version[:3])
|
||||
if os.path.exists(lib64_path):
|
||||
@@ -602,7 +602,7 @@ def virtual_install_main_packages():
|
||||
# This is a non-multiarch aware Python. Fallback to the old way.
|
||||
arch = sys.platform
|
||||
plat_path = os.path.join(sys.real_prefix, 'lib',
|
||||
- 'python'+sys.version[:3],
|
||||
+ 'tauthon'+sys.version[:3],
|
||||
'plat-%s' % arch)
|
||||
if os.path.exists(plat_path):
|
||||
paths.append(plat_path)
|
|
@ -0,0 +1,20 @@
|
|||
--- platform/python/virtualenv/virtualenv.py.orig 2021-02-05 18:43:01 UTC
|
||||
+++ platform/python/virtualenv/virtualenv.py
|
||||
@@ -49,7 +49,7 @@ try:
|
||||
except NameError:
|
||||
basestring = str
|
||||
|
||||
-py_version = 'python%s.%s' % (sys.version_info[0], sys.version_info[1])
|
||||
+py_version = 'tauthon%s.%s' % (sys.version_info[0], sys.version_info[1])
|
||||
|
||||
is_jython = sys.platform.startswith('java')
|
||||
is_pypy = hasattr(sys, 'pypy_version_info')
|
||||
@@ -131,6 +131,8 @@ if majver == 2:
|
||||
REQUIRED_MODULES.extend(['warnings', 'linecache', '_abcoll', 'abc'])
|
||||
if minver >= 7:
|
||||
REQUIRED_MODULES.extend(['_weakrefset'])
|
||||
+ if minver >= 8:
|
||||
+ REQUIRED_MODULES.extend(['_oserror'])
|
||||
if is_msys2:
|
||||
REQUIRED_MODULES.extend(['functools'])
|
||||
elif majver == 3:
|
17
www/palemoon/pkg-descr
Normal file
17
www/palemoon/pkg-descr
Normal file
|
@ -0,0 +1,17 @@
|
|||
Pale Moon(TM) offers you a browsing experience in a browser completely built
|
||||
from its own, independently developed source that has been forked off from
|
||||
Firefox/Mozilla code a number of years ago, with carefully selected features
|
||||
and optimizations to improve the browser's stability and user experience, while
|
||||
offering full customization and a growing collection of extensions and themes
|
||||
to make the browser truly your own.
|
||||
|
||||
Some of the main features:
|
||||
- Based on the Unified XUL Platform (UXP) containing our own optimized layout
|
||||
and rendering engine (Goanna).
|
||||
- Safe: Forked from mature Mozilla code and regularly updated with the latest
|
||||
security patches.
|
||||
- Secure: Additional security features and security-aware development
|
||||
- Zero ads; no telemetry, spyware or data gathering
|
||||
- Familiar, efficient, fully customizable interface
|
||||
|
||||
WWW: https://www.palemoon.org/
|
57
www/palemoon/pkg-plist
Normal file
57
www/palemoon/pkg-plist
Normal file
|
@ -0,0 +1,57 @@
|
|||
bin/palemoon
|
||||
lib/palemoon/application.ini
|
||||
lib/palemoon/browser/blocklist.xml
|
||||
lib/palemoon/browser/chrome.manifest
|
||||
lib/palemoon/browser/chrome/icons/default/default16.png
|
||||
lib/palemoon/browser/chrome/icons/default/default32.png
|
||||
lib/palemoon/browser/chrome/icons/default/default48.png
|
||||
lib/palemoon/browser/components/components.manifest
|
||||
lib/palemoon/browser/components/libbrowsercomps.so
|
||||
lib/palemoon/browser/defaults/profile/chrome/userChrome-example.css
|
||||
lib/palemoon/browser/defaults/profile/chrome/userContent-example.css
|
||||
lib/palemoon/browser/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}.xpi
|
||||
lib/palemoon/browser/icons/mozicon128.png
|
||||
lib/palemoon/browser/palemoon.res
|
||||
lib/palemoon/browser/searchplugins/bing.xml
|
||||
lib/palemoon/browser/searchplugins/duckduckgo-palemoon.xml
|
||||
lib/palemoon/browser/searchplugins/ecosia.xml
|
||||
lib/palemoon/browser/searchplugins/ekoru.xml
|
||||
lib/palemoon/browser/searchplugins/twitter.xml
|
||||
lib/palemoon/browser/searchplugins/wikipedia.xml
|
||||
lib/palemoon/browser/searchplugins/yahoo.xml
|
||||
lib/palemoon/browser/ua-update.json
|
||||
lib/palemoon/chrome.manifest
|
||||
lib/palemoon/defaults/pref/channel-prefs.js
|
||||
lib/palemoon/dependentlibs.list
|
||||
lib/palemoon/dictionaries/en-US.aff
|
||||
lib/palemoon/dictionaries/en-US.dic
|
||||
lib/palemoon/gtk2/libmozgtk.so
|
||||
lib/palemoon/icudt58l.dat
|
||||
lib/palemoon/libfreebl3.chk
|
||||
lib/palemoon/libfreebl3.so
|
||||
lib/palemoon/liblgpllibs.so
|
||||
lib/palemoon/libmozavcodec.so
|
||||
lib/palemoon/libmozavutil.so
|
||||
lib/palemoon/libmozgtk.so
|
||||
lib/palemoon/libmozsqlite3.so
|
||||
lib/palemoon/libnspr4.so
|
||||
lib/palemoon/libnss3.so
|
||||
lib/palemoon/libnssckbi.so
|
||||
lib/palemoon/libnssutil3.so
|
||||
lib/palemoon/libplc4.so
|
||||
lib/palemoon/libplds4.so
|
||||
lib/palemoon/libsmime3.so
|
||||
lib/palemoon/libsoftokn3.chk
|
||||
lib/palemoon/libsoftokn3.so
|
||||
lib/palemoon/libssl3.so
|
||||
lib/palemoon/libxul.so
|
||||
lib/palemoon/palemoon
|
||||
lib/palemoon/palemoon-bin
|
||||
lib/palemoon/palemoon.res
|
||||
lib/palemoon/platform.ini
|
||||
lib/palemoon/plugin-container
|
||||
lib/palemoon/precomplete
|
||||
lib/palemoon/removed-files
|
||||
lib/palemoon/run-mozilla.sh
|
||||
share/applications/palemoon.desktop
|
||||
share/pixmaps/palemoon.png
|
Loading…
Reference in a new issue