ftp/R-cran-curl: Update to 5.0.0
- Update to 5.0.0 - Drop maintainership
This commit is contained in:
parent
8c199e2063
commit
1cc5fe6101
3 changed files with 14 additions and 20 deletions
|
@ -1,10 +1,9 @@
|
|||
PORTNAME= curl
|
||||
PORTVERSION= 4.3.2
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 5.0.0
|
||||
CATEGORIES= ftp
|
||||
DISTNAME= ${PORTNAME}_${PORTVERSION}
|
||||
|
||||
MAINTAINER= tota@FreeBSD.org
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Modern and Flexible Web Client for R
|
||||
WWW= https://cran.r-project.org/web/packages/curl/
|
||||
|
||||
|
@ -13,6 +12,6 @@ LICENSE= MIT
|
|||
BUILD_DEPENDS= ${LOCALBASE}/include/curl/curl.h:ftp/curl
|
||||
LIB_DEPENDS= libcurl.so:ftp/curl
|
||||
|
||||
USES= cran:auto-plist,compiles
|
||||
USES= cran:auto-plist,compiles
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1624513539
|
||||
SHA256 (curl_4.3.2.tar.gz) = 90b1facb4be8b6315bb3d272ba2dd90b88973f6ea1ab7f439550230f8500a568
|
||||
SIZE (curl_4.3.2.tar.gz) = 793345
|
||||
TIMESTAMP = 1682467525
|
||||
SHA256 (curl_5.0.0.tar.gz) = d7f3cac9b513914ffa8f6f64e6fa5dd96c8273378ace6b0c16b71bc6ba59c9b2
|
||||
SIZE (curl_5.0.0.tar.gz) = 682047
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- src/curl.c.orig 2019-09-11 10:18:36 UTC
|
||||
--- src/curl.c.orig 2022-10-17 18:09:53 UTC
|
||||
+++ src/curl.c
|
||||
@@ -19,11 +19,13 @@
|
||||
@@ -19,7 +19,7 @@
|
||||
#ifdef WORDS_BIGENDIAN
|
||||
#if (defined(__sun) && defined(__SVR4))
|
||||
#include <sys/byteorder.h>
|
||||
|
@ -9,18 +9,13 @@
|
|||
#include <libkern/OSByteOrder.h>
|
||||
#define BSWAP_32 OSSwapInt32
|
||||
#elif (defined(__OpenBSD__))
|
||||
#define BSWAP_32(x) swap32(x)
|
||||
@@ -27,6 +27,9 @@
|
||||
#elif (defined(__NetBSD__))
|
||||
#include <sys/types.h>
|
||||
#include <machine/bswap.h>
|
||||
+#define BSWAP_32(x) bswap32(x)
|
||||
+#elif (defined(__FreeBSD__))
|
||||
+#include <sys/endian.h>
|
||||
#define BSWAP_32(x) bswap32(x)
|
||||
#elif (defined(__GLIBC__))
|
||||
#include <byteswap.h>
|
||||
#define BSWAP_32(x) bswap_32(x)
|
||||
@@ -148,7 +150,7 @@ static size_t rcurl_read(void *target, size_t sz, size
|
||||
static int rcurl_fgetc(Rconnection con) {
|
||||
int x = 0;
|
||||
#ifdef WORDS_BIGENDIAN
|
||||
- return rcurl_read(&x, 1, 1, con) ? BSWAP_32(x) : R_EOF;
|
||||
+ return rcurl_read(&x, 1, 1, con) ? bswap32(x) : R_EOF;
|
||||
#else
|
||||
return rcurl_read(&x, 1, 1, con) ? x : R_EOF;
|
||||
#endif
|
||||
|
|
Loading…
Reference in a new issue