devel/hg-git: allow staging
- Allow staging - Use python auto plist - Patch for dulwich API change PR: ports/182747 Submitted by: Marco Bröder <marco.broeder gmx.eu> (maintainer)
This commit is contained in:
parent
94748d421d
commit
1ce9fcd054
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=330310
4 changed files with 21 additions and 39 deletions
|
@ -12,17 +12,13 @@ COMMENT= Mercurial extension to pull from or push to a Git repository
|
|||
|
||||
LICENSE= GPLv2
|
||||
|
||||
RUN_DEPENDS= ${PKGNAMEPREFIX}dulwich>=0.8.7:${PORTSDIR}/devel/dulwich \
|
||||
mercurial>=2.5.2:${PORTSDIR}/devel/mercurial \
|
||||
RUN_DEPENDS= ${PKGNAMEPREFIX}dulwich>=*:${PORTSDIR}/devel/dulwich \
|
||||
mercurial>=*:${PORTSDIR}/devel/mercurial \
|
||||
${PKGNAMEPREFIX}ordereddict>=1.1:${PORTSDIR}/devel/py-ordereddict
|
||||
|
||||
|
||||
USE_PYTHON= -2.7
|
||||
USE_PYTHON= 2
|
||||
USE_PYDISTUTILS=yes
|
||||
PYDISTUTILS_AUTOPLIST= yes
|
||||
PYDISTUTILS_PKGNAME= ${PORTNAME:S/-/_/}
|
||||
|
||||
NO_STAGE= yes
|
||||
post-install:
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
11
devel/hg-git/files/patch-hggit__git_handler.py
Normal file
11
devel/hg-git/files/patch-hggit__git_handler.py
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- ./hggit/git_handler.py.orig 2013-03-24 22:35:51.000000000 +0100
|
||||
+++ ./hggit/git_handler.py 2013-10-05 10:40:01.222598222 +0200
|
||||
@@ -1034,7 +1034,7 @@
|
||||
and ( ref.startswith('refs/heads/') or ref.startswith('refs/tags/') ) ]
|
||||
want = [x for x in want if x not in self.git]
|
||||
return want
|
||||
- f, commit = self.git.object_store.add_pack()
|
||||
+ f, commit = self.git.object_store.add_pack()[:2]
|
||||
try:
|
||||
try:
|
||||
progress = GitProgress(self.ui)
|
|
@ -1,15 +1,14 @@
|
|||
====
|
||||
|
||||
*** WARNING: Do not use this software in data critical production environments,
|
||||
only in safe test environments! This software is still BETA! ***
|
||||
To enable the Hg-Git extension it has to be added in either
|
||||
|
||||
To enable the Hg-Git extension make sure you have the following lines in your
|
||||
Mercurial global configuration file '~/.hgrc':
|
||||
'$PREFIX/etc/mercurial/hgrc' (per-system),
|
||||
'$HOME/.hgrc' (per-user) or
|
||||
'<repo>/.hg/hgrc' (per-repository)
|
||||
|
||||
Mercurial configuration file:
|
||||
|
||||
[extensions]
|
||||
hggit =
|
||||
|
||||
Note: As of Mercurial 1.8 the required bookmarks extension became a core
|
||||
functionality and can be removed from the extensions list.
|
||||
|
||||
====
|
||||
|
|
|
@ -1,24 +0,0 @@
|
|||
%%PYTHON_SITELIBDIR%%/hggit/__init__.py
|
||||
%%PYTHON_SITELIBDIR%%/hggit/__init__.pyc
|
||||
%%PYTHON_SITELIBDIR%%/hggit/__init__.pyo
|
||||
%%PYTHON_SITELIBDIR%%/hggit/_ssh.py
|
||||
%%PYTHON_SITELIBDIR%%/hggit/_ssh.pyc
|
||||
%%PYTHON_SITELIBDIR%%/hggit/_ssh.pyo
|
||||
%%PYTHON_SITELIBDIR%%/hggit/git_handler.py
|
||||
%%PYTHON_SITELIBDIR%%/hggit/git_handler.pyc
|
||||
%%PYTHON_SITELIBDIR%%/hggit/git_handler.pyo
|
||||
%%PYTHON_SITELIBDIR%%/hggit/gitrepo.py
|
||||
%%PYTHON_SITELIBDIR%%/hggit/gitrepo.pyc
|
||||
%%PYTHON_SITELIBDIR%%/hggit/gitrepo.pyo
|
||||
%%PYTHON_SITELIBDIR%%/hggit/hgrepo.py
|
||||
%%PYTHON_SITELIBDIR%%/hggit/hgrepo.pyc
|
||||
%%PYTHON_SITELIBDIR%%/hggit/hgrepo.pyo
|
||||
%%PYTHON_SITELIBDIR%%/hggit/overlay.py
|
||||
%%PYTHON_SITELIBDIR%%/hggit/overlay.pyc
|
||||
%%PYTHON_SITELIBDIR%%/hggit/overlay.pyo
|
||||
%%PYTHON_SITELIBDIR%%/hggit/util.py
|
||||
%%PYTHON_SITELIBDIR%%/hggit/util.pyc
|
||||
%%PYTHON_SITELIBDIR%%/hggit/util.pyo
|
||||
%%PYTHON_SITELIBDIR%%/hggit/help/git.rst
|
||||
@dirrm %%PYTHON_SITELIBDIR%%/hggit/help
|
||||
@dirrm %%PYTHON_SITELIBDIR%%/hggit
|
Loading…
Reference in a new issue