- Fix pkg-plist
- Remove 4.x cruft - Makefile tweaks PR: ports/113705 Submitted by: Ashish Shukla <wahjava@gmail.com> (maintainer) Approved by: maintainer, sat (mentor)
This commit is contained in:
parent
e33724770e
commit
1d02f6e945
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=194033
5 changed files with 1528 additions and 1483 deletions
|
@ -9,19 +9,25 @@ PORTNAME= libxcb
|
|||
PORTVERSION= 1.0
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= http://xcb.freedesktop.org/dist/
|
||||
MASTER_SITES= XORG/current/src/extras
|
||||
|
||||
MAINTAINER= wahjava@gmail.com
|
||||
COMMENT= The X protocol C-language Binding (XCB) library
|
||||
|
||||
BUILD_DEPENDS= ${LIB_PC_DEPENDS} \
|
||||
${LOCALBASE}/lib/libcheck.a:${PORTSDIR}/devel/libcheck \
|
||||
BUILD_DEPENDS= ${LOCALBASE}/lib/libcheck.a:${PORTSDIR}/devel/libcheck \
|
||||
xsltproc:${PORTSDIR}/textproc/libxslt \
|
||||
doxygen:${PORTSDIR}/devel/doxygen \
|
||||
dot:${PORTSDIR}/graphics/graphviz
|
||||
RUN_DEPENDS= ${LIB_PC_DEPENDS}
|
||||
${LOCALBASE}/libdata/pkgconfig/xcb-proto.pc:${PORTSDIR}/x11/xcb-proto \
|
||||
${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:${PORTSDIR}/devel/libpthread-stubs
|
||||
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/xcb-proto.pc:${PORTSDIR}/x11/xcb-proto \
|
||||
${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:${PORTSDIR}/devel/libpthread-stubs
|
||||
|
||||
.if defined(NOPORTDOCS)
|
||||
CONFIGURE_ARGS+= --disable-build-docs BUILD_DOCS=no
|
||||
.else
|
||||
BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen \
|
||||
dot:${PORTSDIR}/graphics/graphviz
|
||||
.endif
|
||||
|
||||
PREFIX= ${X11BASE}
|
||||
USE_BZIP2= yes
|
||||
USE_GNOME= gnomehack
|
||||
USE_GMAKE= yes
|
||||
|
@ -30,29 +36,19 @@ USE_XORG= xau xdmcp
|
|||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ARGS= --with-check=${LOCALBASE}
|
||||
CONFIGURE_ARGS+= --with-check=${LOCALBASE}
|
||||
.for f in XPROTO_CFLAGS XPROTO_LIBS XDMCP_CFLAGS XDMCP_LIBS NEEDED_CFLAGS NEEDED_LIBS
|
||||
CONFIGURE_ARGS+=${f}="${${f}}"
|
||||
.endfor
|
||||
CONFIGURE_ENV= LIBS="`pkg-config --libs pthread-stubs`"
|
||||
|
||||
LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/xcb-proto.pc:${PORTSDIR}/x11/xcb-proto \
|
||||
${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:${PORTSDIR}/devel/libpthread-stubs
|
||||
NEEDED_CFLAGS= -I${LOCALBASE}/include
|
||||
NEEDED_LIBS= -L${LOCALBASE}/lib -lXau ${PTHREAD_STUBS_LIBS}
|
||||
|
||||
NEEDED_CFLAGS= -I${X11BASE}/include
|
||||
NEEDED_LIBS= -L${X11BASE}/lib -lXau $(PTHREAD_STUBS_LIBS)
|
||||
XDMCP_CFLAGS= -I${LOCALBASE}/include
|
||||
XDMCP_LIBS= -L${LOCALBASE}/lib -lXdmcp
|
||||
|
||||
XDMCP_CFLAGS= -I${X11BASE}/include
|
||||
XDMCP_LIBS= -L${X11BASE}/lib -lXdmcp
|
||||
XPROTO_CFLAGS= -I${LOCALBASE}/include
|
||||
XPROTO_LIBS= -L${LOCALBASE}/lib
|
||||
|
||||
XPROTO_CFLAGS= -I${X11BASE}/include
|
||||
XPROTO_LIBS= -L${X11BASE}/lib
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 500000
|
||||
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src__xcb.h \
|
||||
${FILESDIR}/extra-patch-src__xcb_auth.c
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- ./src/xcb.h.orig Sat Oct 7 22:31:54 2006
|
||||
+++ ./src/xcb.h Sun Nov 5 12:22:13 2006
|
||||
@@ -29,7 +29,7 @@
|
||||
#define __XCB_H__
|
||||
#include <sys/types.h>
|
||||
|
||||
-#if defined(__solaris__)
|
||||
+#if defined(__solaris__) || __FreeBSD__ < 5
|
||||
#include <inttypes.h>
|
||||
#else
|
||||
#include <stdint.h>
|
|
@ -1,10 +0,0 @@
|
|||
--- ./src/xcb_auth.c.orig Sat Oct 7 18:43:12 2006
|
||||
+++ ./src/xcb_auth.c Sun Nov 5 03:44:33 2006
|
||||
@@ -27,6 +27,7 @@
|
||||
|
||||
#include <assert.h>
|
||||
#include <X11/Xauth.h>
|
||||
+#include <sys/types.h>
|
||||
#include <sys/socket.h>
|
||||
#include <netinet/in.h>
|
||||
#include <sys/un.h>
|
21
x11/libxcb/files/patch-Makefile.in
Normal file
21
x11/libxcb/files/patch-Makefile.in
Normal file
|
@ -0,0 +1,21 @@
|
|||
--- Makefile.in.orig Sun Jun 17 17:33:00 2007
|
||||
+++ Makefile.in Sun Jun 17 17:34:18 2007
|
||||
@@ -220,7 +220,7 @@
|
||||
sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
xcbincludedir = @xcbincludedir@
|
||||
-SUBDIRS = src tests doc
|
||||
+SUBDIRS = src tests
|
||||
pkgconfigdir = $(prefix)/libdata/pkgconfig
|
||||
pkgconfig_DATA = \
|
||||
xcb.pc \
|
||||
@@ -269,6 +269,10 @@
|
||||
xcb-xtest.pc.in \
|
||||
xcb-xv.pc.in \
|
||||
xcb-xvmc.pc.in
|
||||
+
|
||||
+ifeq ($(BUILD_DOCS),yes)
|
||||
+SUBDIRS += doc
|
||||
+endif
|
||||
|
||||
all: all-recursive
|
2923
x11/libxcb/pkg-plist
2923
x11/libxcb/pkg-plist
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue