- Update to 0.14.5
PR: 138456 Submitted by: Ports Fury
This commit is contained in:
parent
0ee7add3da
commit
1d2896e2a8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=240724
8 changed files with 78 additions and 24 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= libtorrent
|
||||
PORTVERSION= 0.14.3
|
||||
PORTVERSION= 0.14.5
|
||||
CATEGORIES= net-p2p
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
|
||||
PKGNAMEPREFIX= rb
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (libtorrent-rasterbar-0.14.3.tar.gz) = 6ce3148f8fbddbdfa472ef3c4c4cae61
|
||||
SHA256 (libtorrent-rasterbar-0.14.3.tar.gz) = c769c8b7f0cf87664fb26f9b43ef5d6e485a2c2c70fc75ef8a75c79e1114f4bb
|
||||
SIZE (libtorrent-rasterbar-0.14.3.tar.gz) = 1985127
|
||||
MD5 (libtorrent-rasterbar-0.14.5.tar.gz) = 46734b7c1a7ac81e6a8bc10011c645d1
|
||||
SHA256 (libtorrent-rasterbar-0.14.5.tar.gz) = 4253ad5002e81d95ed8b3ff4116113f1ce7812f6eaf15a1ceef8cad9eecaaad8
|
||||
SIZE (libtorrent-rasterbar-0.14.5.tar.gz) = 1992627
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- configure.in.orig 2009-02-11 15:43:19.000000000 +0900
|
||||
+++ configure.in 2009-04-19 02:16:36.000000000 +0900
|
||||
@@ -67,19 +67,6 @@
|
||||
--- configure.in.orig 2009-08-05 11:29:42.000000000 +0900
|
||||
+++ configure.in 2009-08-29 03:28:28.000000000 +0900
|
||||
@@ -65,19 +65,6 @@
|
||||
AM_CONDITIONAL([ENABLE_SHIPPED_ASIO], false)
|
||||
|
||||
dnl Check for boost libraries.
|
||||
|
@ -20,7 +20,7 @@
|
|||
AX_BOOST_BASE([1.34],[
|
||||
|
||||
dnl the user can choose which Asio library to use
|
||||
@@ -123,7 +110,6 @@
|
||||
@@ -121,7 +108,6 @@
|
||||
esac
|
||||
AM_CONDITIONAL([ENABLE_SHIPPED_ASIO], [test x$enable_shipped_asio = "xyes"])
|
||||
])
|
||||
|
@ -28,7 +28,16 @@
|
|||
|
||||
AC_MSG_NOTICE([BOOST_CPPFLAGS=$BOOST_CPPFLAGS])
|
||||
AC_MSG_NOTICE([BOOST_LDFLAGS=$BOOST_LDFLAGS])
|
||||
@@ -408,7 +394,7 @@
|
||||
@@ -351,7 +337,7 @@
|
||||
esac
|
||||
|
||||
dnl Use possibly specific python install params
|
||||
-if [[ "x$PYTHON_INSTALL_PARAMS" == "x" ]]; then
|
||||
+if [[ "x$PYTHON_INSTALL_PARAMS" = "x" ]]; then
|
||||
PYTHON_INSTALL_PARAMS='--prefix=$(DESTDIR)$(prefix)'
|
||||
fi
|
||||
AC_SUBST(PYTHON_INSTALL_PARAMS)
|
||||
@@ -413,7 +399,7 @@
|
||||
esac
|
||||
|
||||
dnl Set some defines if we are building a shared library
|
||||
|
@ -37,3 +46,21 @@
|
|||
AC_DEFINE(TORRENT_BUILDING_SHARED,,[Make sure the functions and classes are exported.])
|
||||
COMPILETIME_OPTIONS+="-DTORRENT_LINKING_SHARED "
|
||||
fi
|
||||
@@ -425,7 +411,7 @@
|
||||
[case "$enableval" in
|
||||
no)
|
||||
AC_DEFINE(NDEBUG,,[Define to disable debugging])
|
||||
- DEBUGFLAGS="-Os"
|
||||
+ DEBUGFLAGS=""
|
||||
# COMPILETIME_OPTIONS+="-DNDEBUG "
|
||||
;;
|
||||
yes)
|
||||
@@ -438,7 +424,7 @@
|
||||
AC_MSG_ERROR([Unknown --enable-debug option "$enableval". Use either "yes" or "no".])
|
||||
;;
|
||||
esac],
|
||||
- [DEBUGFLAGS="-Os"
|
||||
+ [DEBUGFLAGS=""
|
||||
AC_DEFINE(NDEBUG,,[Define to disable debugging])
|
||||
# COMPILETIME_OPTIONS+="-DNDEBUG "
|
||||
]
|
||||
|
|
|
@ -1,8 +1,6 @@
|
|||
include/libtorrent/GeoIP.h
|
||||
include/libtorrent/alert.hpp
|
||||
include/libtorrent/alert_types.hpp
|
||||
include/libtorrent/assert.hpp
|
||||
include/libtorrent/asio.hpp
|
||||
include/libtorrent/asio/basic_datagram_socket.hpp
|
||||
include/libtorrent/asio/basic_deadline_timer.hpp
|
||||
include/libtorrent/asio/basic_io_object.hpp
|
||||
|
@ -191,6 +189,8 @@ include/libtorrent/asio/windows/stream_handle.hpp
|
|||
include/libtorrent/asio/windows/stream_handle_service.hpp
|
||||
include/libtorrent/asio/write.hpp
|
||||
include/libtorrent/asio/write_at.hpp
|
||||
include/libtorrent/asio.hpp
|
||||
include/libtorrent/assert.hpp
|
||||
include/libtorrent/aux_/session_impl.hpp
|
||||
include/libtorrent/bandwidth_limit.hpp
|
||||
include/libtorrent/bandwidth_manager.hpp
|
||||
|
@ -290,7 +290,7 @@ include/libtorrent/xml_parse.hpp
|
|||
lib/libtorrent-rasterbar.a
|
||||
lib/libtorrent-rasterbar.la
|
||||
lib/libtorrent-rasterbar.so
|
||||
lib/libtorrent-rasterbar.so.3
|
||||
lib/libtorrent-rasterbar.so.5
|
||||
libdata/pkgconfig/libtorrent-rasterbar.pc
|
||||
@dirrm include/libtorrent/kademlia
|
||||
@dirrm include/libtorrent/extensions
|
||||
|
|
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= libtorrent
|
||||
PORTVERSION= 0.14.3
|
||||
PORTVERSION= 0.14.5
|
||||
CATEGORIES= net-p2p
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
|
||||
PKGNAMEPREFIX= rb
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (libtorrent-rasterbar-0.14.3.tar.gz) = 6ce3148f8fbddbdfa472ef3c4c4cae61
|
||||
SHA256 (libtorrent-rasterbar-0.14.3.tar.gz) = c769c8b7f0cf87664fb26f9b43ef5d6e485a2c2c70fc75ef8a75c79e1114f4bb
|
||||
SIZE (libtorrent-rasterbar-0.14.3.tar.gz) = 1985127
|
||||
MD5 (libtorrent-rasterbar-0.14.5.tar.gz) = 46734b7c1a7ac81e6a8bc10011c645d1
|
||||
SHA256 (libtorrent-rasterbar-0.14.5.tar.gz) = 4253ad5002e81d95ed8b3ff4116113f1ce7812f6eaf15a1ceef8cad9eecaaad8
|
||||
SIZE (libtorrent-rasterbar-0.14.5.tar.gz) = 1992627
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- configure.in.orig 2009-02-11 15:43:19.000000000 +0900
|
||||
+++ configure.in 2009-04-19 02:16:36.000000000 +0900
|
||||
@@ -67,19 +67,6 @@
|
||||
--- configure.in.orig 2009-08-05 11:29:42.000000000 +0900
|
||||
+++ configure.in 2009-08-29 03:28:28.000000000 +0900
|
||||
@@ -65,19 +65,6 @@
|
||||
AM_CONDITIONAL([ENABLE_SHIPPED_ASIO], false)
|
||||
|
||||
dnl Check for boost libraries.
|
||||
|
@ -20,7 +20,7 @@
|
|||
AX_BOOST_BASE([1.34],[
|
||||
|
||||
dnl the user can choose which Asio library to use
|
||||
@@ -123,7 +110,6 @@
|
||||
@@ -121,7 +108,6 @@
|
||||
esac
|
||||
AM_CONDITIONAL([ENABLE_SHIPPED_ASIO], [test x$enable_shipped_asio = "xyes"])
|
||||
])
|
||||
|
@ -28,7 +28,16 @@
|
|||
|
||||
AC_MSG_NOTICE([BOOST_CPPFLAGS=$BOOST_CPPFLAGS])
|
||||
AC_MSG_NOTICE([BOOST_LDFLAGS=$BOOST_LDFLAGS])
|
||||
@@ -408,7 +394,7 @@
|
||||
@@ -351,7 +337,7 @@
|
||||
esac
|
||||
|
||||
dnl Use possibly specific python install params
|
||||
-if [[ "x$PYTHON_INSTALL_PARAMS" == "x" ]]; then
|
||||
+if [[ "x$PYTHON_INSTALL_PARAMS" = "x" ]]; then
|
||||
PYTHON_INSTALL_PARAMS='--prefix=$(DESTDIR)$(prefix)'
|
||||
fi
|
||||
AC_SUBST(PYTHON_INSTALL_PARAMS)
|
||||
@@ -413,7 +399,7 @@
|
||||
esac
|
||||
|
||||
dnl Set some defines if we are building a shared library
|
||||
|
@ -37,3 +46,21 @@
|
|||
AC_DEFINE(TORRENT_BUILDING_SHARED,,[Make sure the functions and classes are exported.])
|
||||
COMPILETIME_OPTIONS+="-DTORRENT_LINKING_SHARED "
|
||||
fi
|
||||
@@ -425,7 +411,7 @@
|
||||
[case "$enableval" in
|
||||
no)
|
||||
AC_DEFINE(NDEBUG,,[Define to disable debugging])
|
||||
- DEBUGFLAGS="-Os"
|
||||
+ DEBUGFLAGS=""
|
||||
# COMPILETIME_OPTIONS+="-DNDEBUG "
|
||||
;;
|
||||
yes)
|
||||
@@ -438,7 +424,7 @@
|
||||
AC_MSG_ERROR([Unknown --enable-debug option "$enableval". Use either "yes" or "no".])
|
||||
;;
|
||||
esac],
|
||||
- [DEBUGFLAGS="-Os"
|
||||
+ [DEBUGFLAGS=""
|
||||
AC_DEFINE(NDEBUG,,[Define to disable debugging])
|
||||
# COMPILETIME_OPTIONS+="-DNDEBUG "
|
||||
]
|
||||
|
|
|
@ -1,8 +1,6 @@
|
|||
include/libtorrent/GeoIP.h
|
||||
include/libtorrent/alert.hpp
|
||||
include/libtorrent/alert_types.hpp
|
||||
include/libtorrent/assert.hpp
|
||||
include/libtorrent/asio.hpp
|
||||
include/libtorrent/asio/basic_datagram_socket.hpp
|
||||
include/libtorrent/asio/basic_deadline_timer.hpp
|
||||
include/libtorrent/asio/basic_io_object.hpp
|
||||
|
@ -191,6 +189,8 @@ include/libtorrent/asio/windows/stream_handle.hpp
|
|||
include/libtorrent/asio/windows/stream_handle_service.hpp
|
||||
include/libtorrent/asio/write.hpp
|
||||
include/libtorrent/asio/write_at.hpp
|
||||
include/libtorrent/asio.hpp
|
||||
include/libtorrent/assert.hpp
|
||||
include/libtorrent/aux_/session_impl.hpp
|
||||
include/libtorrent/bandwidth_limit.hpp
|
||||
include/libtorrent/bandwidth_manager.hpp
|
||||
|
@ -290,7 +290,7 @@ include/libtorrent/xml_parse.hpp
|
|||
lib/libtorrent-rasterbar.a
|
||||
lib/libtorrent-rasterbar.la
|
||||
lib/libtorrent-rasterbar.so
|
||||
lib/libtorrent-rasterbar.so.3
|
||||
lib/libtorrent-rasterbar.so.5
|
||||
libdata/pkgconfig/libtorrent-rasterbar.pc
|
||||
@dirrm include/libtorrent/kademlia
|
||||
@dirrm include/libtorrent/extensions
|
||||
|
|
Loading…
Reference in a new issue