Minor cleanups from maintainer.
PR: 11426 Submitted by: maintainer
This commit is contained in:
parent
a90e0c3d8b
commit
1d355b8de1
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=18360
3 changed files with 23 additions and 4 deletions
|
@ -3,7 +3,7 @@
|
|||
# Date created: 21 May 1998
|
||||
# Whom: Andrey Zakhvatov
|
||||
#
|
||||
# $Id: Makefile,v 1.4 1998/08/12 06:29:28 asami Exp $
|
||||
# $Id: Makefile,v 1.5 1998/09/28 02:12:35 steve Exp $
|
||||
#
|
||||
|
||||
DISTNAME= pp-0.01
|
||||
|
@ -31,6 +31,8 @@ do-install:
|
|||
@ ${INSTALL_DATA} ${WRKDIR}/ppinst/*.gif ${PREFIX}/share/pp/pic
|
||||
@ ${MKDIR} ${PREFIX}/share/pp/level
|
||||
@ ${INSTALL_DATA} ${WRKDIR}/ppinst/*.map1 ${PREFIX}/share/pp/level
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
@ ${MKDIR} ${PREFIX}/share/doc/pp
|
||||
.for file in INSTALL LICENSE RULES WARRANTY free-license.html
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- Makefile.orig Sat Apr 5 11:08:26 1997
|
||||
+++ Makefile Sun Sep 27 15:25:36 1998
|
||||
--- Makefile Sat Apr 5 21:08:26 1997
|
||||
+++ /home/andy/tmp/wrk/Makefile Sat May 1 14:30:37 1999
|
||||
@@ -1,10 +1,13 @@
|
||||
####### This section was automatically generated from
|
||||
|
||||
|
@ -16,3 +16,20 @@
|
|||
CC = gcc
|
||||
MOC = moc
|
||||
SHELL = /bin/sh
|
||||
@@ -30,14 +33,14 @@
|
||||
.SUFFIXES: .cpp
|
||||
|
||||
.cpp.o:
|
||||
- $(CC) -c $(CFLAGS) -I$(INCDIR) $<
|
||||
+ $(CXX) -c $(CFLAGS) -I$(INCDIR) $<
|
||||
|
||||
####### Build rules
|
||||
|
||||
all: $(TARGET)
|
||||
|
||||
$(TARGET): $(OBJECTS) $(OBJMETA)
|
||||
- $(CC) $(OBJECTS) $(OBJMETA) -o $(TARGET) $(LFLAGS) -lm
|
||||
+ $(CXX) $(OBJECTS) $(OBJMETA) -o $(TARGET) $(LFLAGS) -lm
|
||||
|
||||
depend:
|
||||
@makedepend -I$(INCDIR) $(SOURCES) 2> /dev/null
|
||||
|
|
|
@ -12,4 +12,4 @@ Cannon 1+2: Attacks vehicles, very strong, large range, but cannot move.
|
|||
Reserch Center: Allows you to build other cars and buildings.
|
||||
Radar: Allows you to see what happens.
|
||||
|
||||
WWW: http://www.mps.de/
|
||||
WWW: http://www.mps.de/pp/home.html
|
||||
|
|
Loading…
Reference in a new issue