- Update to 6.9.0
- Remove CONFLICTS since lang/rakudo was removed - Strip binary executable and shared library - Simplify Makefile: - Remove Makefile.common - Use BROKEN_ia64 - Remove regression-test: - Cosmetic change Changes: https://github.com/parrot/parrot/blob/master/ChangeLog
This commit is contained in:
parent
ef1380dc19
commit
1d7ded6fe9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=376962
5 changed files with 19 additions and 32 deletions
|
@ -2,10 +2,11 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= parrot
|
||||
PORTVERSION= ${PARROT_VERSION}
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 6.9.0
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= ftp://ftp.parrot.org/pub/parrot/releases/stable/${PORTVERSION}/
|
||||
MASTER_SITES= ftp://ftp.parrot.org/pub/parrot/releases/stable/${PORTVERSION}/ \
|
||||
ftp://ftp.parrot.org/pub/parrot/releases/supported/${PORTVERSION}/ \
|
||||
LOCAL/sunpoet
|
||||
|
||||
MAINTAINER= perl@FreeBSD.org
|
||||
COMMENT= Parrot - virtual machine for dynamic languages
|
||||
|
@ -18,8 +19,6 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex \
|
|||
LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp \
|
||||
libicudata.so:${PORTSDIR}/devel/icu
|
||||
|
||||
CONFLICTS= rakudo-[0-9]*
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
ALL_TARGET= installable
|
||||
|
@ -38,15 +37,12 @@ USES= bison gmake perl5 tar:bzip2
|
|||
|
||||
PARROT_SHARE_DIR= share/doc/${PORTNAME}/${PORTVERSION}
|
||||
PARROT_DOCS= ${PARROT_SHARE_DIR}
|
||||
PLIST_SUB+= PARROT_VER="${PORTVERSION}" \
|
||||
PLIST_SUB= PARROT_VER="${PORTVERSION}" \
|
||||
PARROT_DOCS="${PARROT_DOCS}"
|
||||
|
||||
.include "${.CURDIR}/Makefile.common"
|
||||
.include <bsd.port.pre.mk>
|
||||
BROKEN_ia64= Does not compile on ia64
|
||||
|
||||
.if ${ARCH} == ia64
|
||||
BROKEN= Does not compile on ia64
|
||||
.endif
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
post-patch:
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
|
@ -56,7 +52,10 @@ post-patch:
|
|||
do-configure:
|
||||
cd ${WRKSRC} && ${PERL} ${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS}
|
||||
|
||||
post-install:
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/* ${STAGEDIR}${PREFIX}/lib/libparrot.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/parrot/${PORTVERSION}/dynext/*.so
|
||||
|
||||
regression-test test: build
|
||||
cd ${WRKSRC} && ${MAKE} test
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +0,0 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PARROT_VERSION= 5.9.0
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (parrot-5.9.0.tar.bz2) = b4704231d90ddec827f45f945b9ad13dd4f9dc7cc9bc0cfc97ab6e30ec1c38ca
|
||||
SIZE (parrot-5.9.0.tar.bz2) = 4398795
|
||||
SHA256 (parrot-6.9.0.tar.bz2) = ad5f3723c216675b9ebc2e3d3807d24fd13aa55e1eb3e7ffcad4062e0026f482
|
||||
SIZE (parrot-6.9.0.tar.bz2) = 4428559
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- compilers/imcc/imcc.y.orig 2013-01-28 19:57:42 UTC
|
||||
+++ compilers/imcc/imcc.y
|
||||
@@ -45,7 +45,7 @@ This file contains the grammar of the PI
|
||||
|
||||
/* prevent declarations of malloc() and free() in the generated parser. */
|
||||
#define YYMALLOC
|
||||
-#define YYFREE(Ptr) do { /* empty */; } while (YYID (0))
|
||||
+#define YYFREE(Ptr) do { /* empty */; } while (0)
|
||||
|
||||
#ifndef YYENABLE_NLS
|
||||
# define YYENABLE_NLS 0
|
|
@ -1,6 +1,6 @@
|
|||
bin/ops2c
|
||||
bin/parrot
|
||||
bin/parrot-nqp
|
||||
bin/parrot-ops2c
|
||||
bin/parrot-prove
|
||||
bin/parrot_config
|
||||
bin/parrot_nci_thunk_gen
|
||||
|
@ -60,6 +60,7 @@ include/parrot/%%PARROT_VER%%/parrot/longopt.h
|
|||
include/parrot/%%PARROT_VER%%/parrot/memory.h
|
||||
include/parrot/%%PARROT_VER%%/parrot/misc.h
|
||||
include/parrot/%%PARROT_VER%%/parrot/multidispatch.h
|
||||
include/parrot/%%PARROT_VER%%/parrot/namealias.h
|
||||
include/parrot/%%PARROT_VER%%/parrot/namespace.h
|
||||
include/parrot/%%PARROT_VER%%/parrot/nci.h
|
||||
include/parrot/%%PARROT_VER%%/parrot/oo.h
|
||||
|
@ -111,7 +112,6 @@ include/parrot/%%PARROT_VER%%/pmc/pmc_continuation.h
|
|||
include/parrot/%%PARROT_VER%%/pmc/pmc_coroutine.h
|
||||
include/parrot/%%PARROT_VER%%/pmc/pmc_default.h
|
||||
include/parrot/%%PARROT_VER%%/pmc/pmc_env.h
|
||||
include/parrot/%%PARROT_VER%%/pmc/pmc_eval.h
|
||||
include/parrot/%%PARROT_VER%%/pmc/pmc_eventhandler.h
|
||||
include/parrot/%%PARROT_VER%%/pmc/pmc_exception.h
|
||||
include/parrot/%%PARROT_VER%%/pmc/pmc_exceptionhandler.h
|
||||
|
@ -577,13 +577,16 @@ lib/parrot/%%PARROT_VER%%/tools/lib/Parrot/Test/Util.pm
|
|||
lib/parrot/%%PARROT_VER%%/tools/lib/Parrot/Test/Util/Runloop.pm
|
||||
lib/parrot/%%PARROT_VER%%/tools/lib/Parrot/Vtable.pm
|
||||
lib/parrot/%%PARROT_VER%%/tools/myconfig
|
||||
man/man1/ops2c.1.gz
|
||||
man/man1/parrot-nqp.1.gz
|
||||
man/man1/parrot-ops2c.1.gz
|
||||
man/man1/parrot-prove.1.gz
|
||||
man/man1/parrot.1.gz
|
||||
man/man1/parrot_config.1.gz
|
||||
man/man1/parrot_nci_thunk_gen.1.gz
|
||||
man/man1/parrotbug.1.gz
|
||||
man/man1/pbc_disassemble.1.gz
|
||||
man/man1/pbc_dump.1.gz
|
||||
man/man1/pbc_merge.1.gz
|
||||
man/man1/pbc_to_exe.1.gz
|
||||
man/man1/plumage.1.gz
|
||||
man/man1/winxed.1.gz
|
||||
|
@ -616,7 +619,6 @@ src/parrot/%%PARROT_VER%%/pmc/continuation.dump
|
|||
src/parrot/%%PARROT_VER%%/pmc/coroutine.dump
|
||||
src/parrot/%%PARROT_VER%%/pmc/default.dump
|
||||
src/parrot/%%PARROT_VER%%/pmc/env.dump
|
||||
src/parrot/%%PARROT_VER%%/pmc/eval.dump
|
||||
src/parrot/%%PARROT_VER%%/pmc/eventhandler.dump
|
||||
src/parrot/%%PARROT_VER%%/pmc/exception.dump
|
||||
src/parrot/%%PARROT_VER%%/pmc/exceptionhandler.dump
|
||||
|
|
Loading…
Reference in a new issue