Remove expired ports:
2019-07-12 misc/tcb: Abandonware that uses sys/dir.h 2019-07-12 editors/xed: Abandonware using sys/dir.h 2019-07-12 databases/gtksql: Abandonware using sys/dir.h
This commit is contained in:
parent
784fcf303d
commit
1db32cf03f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=506581
22 changed files with 3 additions and 332 deletions
3
MOVED
3
MOVED
|
@ -12846,3 +12846,6 @@ www/seamonkey||2019-07-03|2.49.* is not maintained upstream and full of security
|
|||
www/tomcat8||2019-07-06|Has expired: EoL since 2018-06-30
|
||||
devel/libevent-hiphop||2019-07-10|Has expired: Obsoleted with removal of lang/hiphop-php
|
||||
textproc/apache-solr3|textproc/apache-solr|2019-07-12|Obsolete
|
||||
misc/tcb||2019-07-13|Has expired: Abandonware that uses sys/dir.h
|
||||
editors/xed||2019-07-13|Has expired: Abandonware using sys/dir.h
|
||||
databases/gtksql||2019-07-13|Has expired: Abandonware using sys/dir.h
|
||||
|
|
|
@ -100,7 +100,6 @@
|
|||
SUBDIR += gom
|
||||
SUBDIR += gqlplus
|
||||
SUBDIR += grass7
|
||||
SUBDIR += gtksql
|
||||
SUBDIR += hamsterdb
|
||||
SUBDIR += hashtypes
|
||||
SUBDIR += hbase
|
||||
|
|
|
@ -1,78 +0,0 @@
|
|||
# Created by: Andrey Zakhvatov
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= gtksql
|
||||
PORTVERSION= 0.4.5
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-testing/${PORTNAME}-${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Graphical query tool for PostgreSQL/MySQL/SQLite
|
||||
|
||||
DEPRECATED= Abandonware using sys/dir.h
|
||||
EXPIRATION_DATE= 2019-07-12
|
||||
|
||||
LICENSE= GPLv2+
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
LIB_DEPENDS= libfreetype.so:print/freetype2 \
|
||||
libfontconfig.so:x11-fonts/fontconfig \
|
||||
libscintilla.so:x11-toolkits/scintilla
|
||||
RUN_DEPENDS= xdg-open:devel/xdg-utils
|
||||
|
||||
USES= gettext gmake localbase pkgconfig
|
||||
USE_GNOME= gdkpixbuf2 gtk20 cairo
|
||||
GNU_CONFIGURE= yes
|
||||
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
|
||||
AUTOHEADER="${TRUE}"
|
||||
|
||||
OPTIONS_DEFINE= AVAHI DOCS
|
||||
OPTIONS_MULTI= DB
|
||||
OPTIONS_MULTI_DB= MYSQL PGSQL SQLITE
|
||||
OPTIONS_DEFAULT= SQLITE
|
||||
|
||||
PGSQL_USES= pgsql
|
||||
PGSQL_CONFIGURE_WITH= postgresql
|
||||
|
||||
AVAHI_LIB_DEPENDS= libavahi-common.so:net/avahi-app
|
||||
AVAHI_CONFIGURE_OFF= --without-avahi
|
||||
|
||||
MYSQL_USES= mysql
|
||||
MYSQL_CPPFLAGS= -I${LOCALBASE}/include/mysql
|
||||
MYSQL_LDFLAGS= -L${LOCALBASE}/lib/mysql
|
||||
MYSQL_CONFIGURE_OFF= --without-mysql
|
||||
|
||||
SQLITE_USES= sqlite
|
||||
SQLITE_CONFIGURE_OFF= --without-sqlite
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|-lstdc++|| ; \
|
||||
/^PACKAGE_LIBS=/s|$${packagesrcdir}.*scintilla.a|-lscintilla -lscintilla_lexers| ; \
|
||||
/^CPPFLAGS=/s|../scintilla/include|${LOCALBASE}/include/scintilla| ; \
|
||||
/ac_header/s|postgres.h|libpq-fe.h| ; \
|
||||
s|/usr/local|${PREFIX}| ; \
|
||||
s|-R|-Wl,-rpath=| ; \
|
||||
/^packagedatadir/s|=.*|=share/gtksql|' \
|
||||
${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|-O1|| ; \
|
||||
s|-g$$|-DGTK|' \
|
||||
${WRKSRC}/src/Makefile.in
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|<postgres\.h>|<postgresql/internal/c.h>|' \
|
||||
${WRKSRC}/src/d_postgres_f.c
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|mozilla|xdg-open|' \
|
||||
${WRKSRC}/src/gtkui-object.c
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|/usr/local/gtksql|${PREFIX}/lib/gtksql|' \
|
||||
${WRKSRC}/src/plugins.c
|
||||
# Some structure names were renamed in Scintilla.h (v3.7.1)
|
||||
@${REINPLACE_CMD} -E \
|
||||
's|^#include <string.h>$$|#include <stdlib.h>\${.newline}&| ; \
|
||||
s|(CharacterRange\|TextRange)|Sci_&|' \
|
||||
${WRKSRC}/src/gtksql_query_scintilla.c
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,2 +0,0 @@
|
|||
SHA256 (gtksql-0.4.5.tar.gz) = 114f8a857f5987922c6d571cb498db033cc20dc8efe25201b3eb7297f77dc6e0
|
||||
SIZE (gtksql-0.4.5.tar.gz) = 1393651
|
|
@ -1,19 +0,0 @@
|
|||
--- Makefile.in.orig 2007-11-01 14:05:59 UTC
|
||||
+++ Makefile.in
|
||||
@@ -237,14 +237,12 @@ sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
-SUBDIRS = Pics po scintilla intl src pixmaps man gnome
|
||||
-gtksqldocdir = ${prefix}/doc/gtksql
|
||||
+SUBDIRS = Pics po src pixmaps man gnome
|
||||
+gtksqldocdir = ${docdir}
|
||||
gtksqldoc_DATA = \
|
||||
README\
|
||||
- COPYING\
|
||||
AUTHORS\
|
||||
ChangeLog\
|
||||
- INSTALL\
|
||||
NEWS\
|
||||
TODO
|
||||
|
|
@ -1,10 +0,0 @@
|
|||
--- po/Makefile.in.in.orig 2006-06-13 16:40:55 UTC
|
||||
+++ po/Makefile.in.in
|
||||
@@ -13,6 +13,7 @@
|
||||
PACKAGE = @PACKAGE@
|
||||
VERSION = @VERSION@
|
||||
PACKAGE_BUGREPORT = @PACKAGE_BUGREPORT@
|
||||
+GETTEXT_PACKAGE= @PACKAGE@
|
||||
|
||||
SHELL = /bin/sh
|
||||
@SET_MAKE@
|
|
@ -1,14 +0,0 @@
|
|||
GtkSQL is a graphical query tool for PostgreSQL/MySQL/SQLite. You can
|
||||
work on multiple queries simultaneously:
|
||||
|
||||
* send the current query to the database
|
||||
* add a new query
|
||||
* delete current query
|
||||
* rename current query
|
||||
* export current query
|
||||
* display the table information
|
||||
* move to the next or previous query
|
||||
* SQL keyword, table name and field name autocompletion
|
||||
* rescan the table database.
|
||||
|
||||
WWW: https://sourceforge.net/projects/gtksql/
|
|
@ -1,39 +0,0 @@
|
|||
bin/gtksql
|
||||
man/man1/gtksql.1.gz
|
||||
share/applications/gtksql.desktop
|
||||
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
|
||||
%%PORTDOCS%%%%DOCSDIR%%/NEWS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%%%DOCSDIR%%/TODO
|
||||
%%DATADIR%%/pixmaps/connect-grey.xpm
|
||||
%%DATADIR%%/pixmaps/connect.png
|
||||
%%DATADIR%%/pixmaps/connect.xpm
|
||||
%%DATADIR%%/pixmaps/delete-grey.xpm
|
||||
%%DATADIR%%/pixmaps/delete.xpm
|
||||
%%DATADIR%%/pixmaps/disconnect-grey.xpm
|
||||
%%DATADIR%%/pixmaps/disconnect.png
|
||||
%%DATADIR%%/pixmaps/disconnect.xpm
|
||||
%%DATADIR%%/pixmaps/export-grey.xpm
|
||||
%%DATADIR%%/pixmaps/export.xpm
|
||||
%%DATADIR%%/pixmaps/gtksql.png
|
||||
%%DATADIR%%/pixmaps/gtksql.xpm
|
||||
%%DATADIR%%/pixmaps/gtksql_db.png
|
||||
%%DATADIR%%/pixmaps/gtksql_field.png
|
||||
%%DATADIR%%/pixmaps/gtksql_gnome_icon.png
|
||||
%%DATADIR%%/pixmaps/gtksql_table.png
|
||||
%%DATADIR%%/pixmaps/new-grey.xpm
|
||||
%%DATADIR%%/pixmaps/new.xpm
|
||||
%%DATADIR%%/pixmaps/open-grey.xpm
|
||||
%%DATADIR%%/pixmaps/open.xpm
|
||||
%%DATADIR%%/pixmaps/question.xpm
|
||||
%%DATADIR%%/pixmaps/refresh-grey.xpm
|
||||
%%DATADIR%%/pixmaps/refresh.xpm
|
||||
%%DATADIR%%/pixmaps/rename-grey.xpm
|
||||
%%DATADIR%%/pixmaps/rename.xpm
|
||||
%%DATADIR%%/pixmaps/save-grey.xpm
|
||||
%%DATADIR%%/pixmaps/save.xpm
|
||||
%%DATADIR%%/pixmaps/send-grey.xpm
|
||||
%%DATADIR%%/pixmaps/send.xpm
|
||||
%%DATADIR%%/pixmaps/warning.xpm
|
||||
share/locale/de_DE/LC_MESSAGES/gtksql.mo
|
|
@ -252,7 +252,6 @@
|
|||
SUBDIR += wordgrinder
|
||||
SUBDIR += wxhexeditor
|
||||
SUBDIR += xcoral
|
||||
SUBDIR += xed
|
||||
SUBDIR += xi-core
|
||||
SUBDIR += xi-term
|
||||
SUBDIR += xmlcopyeditor
|
||||
|
|
|
@ -1,29 +0,0 @@
|
|||
# Created by: shanee
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= xed
|
||||
PORTVERSION= 1.3
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= editors
|
||||
MASTER_SITES= XCONTRIB/editors
|
||||
DISTNAME= ${PORTNAME}${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Text editor for X
|
||||
|
||||
DEPRECATED= Abandonware using sys/dir.h
|
||||
EXPIRATION_DATE= 2019-07-12
|
||||
|
||||
LICENSE= MIT
|
||||
|
||||
USES= imake tar:Z
|
||||
USE_XORG= xaw
|
||||
MAKE_ARGS= BINDIR=${PREFIX}/bin \
|
||||
LIBDIR=${PREFIX}/lib/X11 \
|
||||
MANPATH=${PREFIX}/man
|
||||
|
||||
pre-build:
|
||||
@${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -e \
|
||||
's|extern char \*malloc();|/\* extern char \*malloc(); \*/|g'
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,2 +0,0 @@
|
|||
SHA256 (xed1.3.tar.Z) = 9f4d5490bcaac9d4eb171724275db45a68cba65ca2314584baecd5d36a5d979a
|
||||
SIZE (xed1.3.tar.Z) = 89933
|
|
@ -1,19 +0,0 @@
|
|||
--- Imakefile.orig 2015-03-05 04:17:04.000000000 +0300
|
||||
+++ Imakefile 2015-03-05 04:18:12.000000000 +0300
|
||||
@@ -1,4 +1,4 @@
|
||||
- DEFINES = -DHELPFILE=\"$(DESTDIR)${LIBDIR}/xed/xed.help\"
|
||||
+ DEFINES = -DHELPFILE=\"${LIBDIR}/xed/xed.help\"
|
||||
|
||||
XCOMM Please check for some aditional DEFINES
|
||||
XCOMM -DSCROLLBREAK -DUSEGETCWD -DNORENAME -DUSEDIRENT -DUSE_CSH_SYSTEM
|
||||
@@ -30,8 +30,8 @@
|
||||
|
||||
xed.help: helpfile
|
||||
$(RM) $@
|
||||
- cat helpfile | sed "s@<XEDCOMMANDFILE>@$(DESTDIR)$(LIBDIR)/xed/xed.commands@g" | \
|
||||
- sed "s@<XEDRESOURCEFILE>@$(DESTDIR)$(XAPPLOADDIR)/Xed@g" > xed.help
|
||||
+ cat helpfile | sed "s@<XEDCOMMANDFILE>@$(LIBDIR)/xed/xed.commands@g" | \
|
||||
+ sed "s@<XEDRESOURCEFILE>@$(XAPPLOADDIR)/Xed@g" > xed.help
|
||||
|
||||
|
||||
InstallNonExecFile(xed.help,$(LIBDIR)/xed)
|
|
@ -1 +0,0 @@
|
|||
xed - a text editor for X
|
|
@ -1,4 +0,0 @@
|
|||
bin/xed
|
||||
lib/X11/xed/xed.help
|
||||
lib/X11/app-defaults/Xed
|
||||
man/man1/xed.1.gz
|
|
@ -473,7 +473,6 @@
|
|||
SUBDIR += sword
|
||||
SUBDIR += table.el
|
||||
SUBDIR += talkfilters
|
||||
SUBDIR += tcb
|
||||
SUBDIR += tdfiglet
|
||||
SUBDIR += team
|
||||
SUBDIR += telbook
|
||||
|
|
|
@ -1,31 +0,0 @@
|
|||
# Created by: Andrey Zakhvatov
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= tcb
|
||||
PORTVERSION= 1.4a
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= SUNSITE/utils/file
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= File viewer for terminal
|
||||
|
||||
DEPRECATED= Abandonware that uses sys/dir.h
|
||||
EXPIRATION_DATE= 2019-07-12
|
||||
|
||||
USES= gmake
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/tcb ${STAGEDIR}${PREFIX}/bin
|
||||
@${MKDIR} ${STAGEDIR}${PREFIX}/share/tcb
|
||||
${INSTALL_DATA} ${WRKSRC}/tcbrc ${STAGEDIR}${PREFIX}/share/tcb
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/HELP ${STAGEDIR}${PREFIX}/share/tcb
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/tcb.1 ${STAGEDIR}${PREFIX}/man/man1
|
||||
@${MKDIR} ${STAGEDIR}${PREFIX}/share/doc/tcb
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/CHANGES ${STAGEDIR}${PREFIX}/share/doc/tcb
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/COPYING ${STAGEDIR}${PREFIX}/share/doc/tcb
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${PREFIX}/share/doc/tcb
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,2 +0,0 @@
|
|||
SHA256 (tcb-1.4a.tar.gz) = 5a279708c9d89a01a76001d7d6e36d53cdcab510faa64eb8bc2110179a9f1af7
|
||||
SIZE (tcb-1.4a.tar.gz) = 126250
|
|
@ -1,11 +0,0 @@
|
|||
--- Makefile.orig Sun Nov 24 15:48:55 2002
|
||||
+++ Makefile Sun Nov 24 15:49:08 2002
|
||||
@@ -6,7 +6,7 @@
|
||||
|
||||
src/tcb: src/config.h
|
||||
@echo 'Making tcb:'
|
||||
- @cd src; make; cd ..
|
||||
+ @cd src; $(MAKE); cd ..
|
||||
|
||||
src/config.h: config.sh
|
||||
@./config.sh $(USR_DIR) # $(USR_DIR): Debian (Linux)
|
|
@ -1,39 +0,0 @@
|
|||
--- config.sh.orig Mon Nov 23 09:51:15 1998
|
||||
+++ config.sh Thu Dec 24 08:41:14 1998
|
||||
@@ -56,20 +56,24 @@
|
||||
fi
|
||||
fi
|
||||
|
||||
+if [ `uname` = FreeBSD ]; then # FreeBSD
|
||||
+LIB=$USR_DIR/share/$TCB
|
||||
+else
|
||||
LIB=$USR_DIR/lib/$TCB
|
||||
+fi
|
||||
BIN=$USR_DIR/bin
|
||||
MAN=$USR_DIR/man/man1
|
||||
|
||||
cat >> .config <<EOF
|
||||
-CC= gcc
|
||||
+CC?= gcc
|
||||
#CFLAGS= -Wall -O2 -g
|
||||
-CFLAGS= -Wall -O2
|
||||
+CFLAGS?= -Wall -O2
|
||||
#LDFLAGS=
|
||||
LDFLAGS= -s
|
||||
OBJS= alloc.o child.o code.o disp.o fork.o init.o key.o menu.o \\
|
||||
mode.o scroll.o shell.o str.o sub.o tc.o tcb.o vt.o
|
||||
EOF
|
||||
-if which grep >/dev/null && make -v 2>&1|grep 'GNU Make' >/dev/null 2>&1 && which sed >/dev/null; then
|
||||
+if which grep >/dev/null && gmake -v 2>&1|grep 'GNU Make' >/dev/null 2>&1 && which sed >/dev/null; then
|
||||
cat >> .config <<EOF
|
||||
PROT= mode.P tc.P tcb.P
|
||||
|
||||
@@ -113,7 +117,7 @@
|
||||
|
||||
cat > install.sh <<EOF
|
||||
#! /bin/sh
|
||||
-cd src; make; cd ..
|
||||
+cd src; gmake; cd ..
|
||||
echo 'Installing tcb:'
|
||||
mkdir -p \$1$BIN
|
||||
mkdir -p \$1$LIB
|
|
@ -1,20 +0,0 @@
|
|||
--- src/tcb.c.orig Mon Nov 23 15:51:15 1998
|
||||
+++ src/tcb.c Sun Nov 24 15:38:49 2002
|
||||
@@ -12,7 +12,7 @@
|
||||
#include <sys/vt.h>
|
||||
#include <sys/kd.h>
|
||||
#else
|
||||
-#include <machine/console.h>
|
||||
+#include <sys/consio.h>
|
||||
#endif linux
|
||||
|
||||
static struct {
|
||||
@@ -574,7 +574,7 @@
|
||||
void sig_child(int dummy)
|
||||
{
|
||||
int pid;
|
||||
- union wait status;
|
||||
+ int status;
|
||||
|
||||
while ((pid = wait3((int*)&status, WNOHANG, (struct rusage *)0)) > 0) ;
|
||||
}
|
|
@ -1,2 +0,0 @@
|
|||
Tcb is a file viewer that works on a terminal. It allows
|
||||
view file in ASCII or HEX format.
|
|
@ -1,7 +0,0 @@
|
|||
bin/tcb
|
||||
man/man1/tcb.1.gz
|
||||
%%PORTDOCS%%%%DOCSDIR%%/CHANGES
|
||||
%%PORTDOCS%%%%DOCSDIR%%/COPYING
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%DATADIR%%/HELP
|
||||
%%DATADIR%%/tcbrc
|
Loading…
Reference in a new issue