audio/wavbreaker: update to 0.12
- Switch to new home on GitHub - Drop NLS option as gtk30 depends on gettext unconditionally - Update COMMENT and pkg-descr based on upstream strings - Add LICENSE_FILE to avoid "+" using placeholder - Drop "Created by" after refactor Changes: https://github.com/thp/wavbreaker/releases/tag/0.12 Reported by: upstream
This commit is contained in:
parent
07afcea552
commit
1e1ec076f8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=518069
5 changed files with 58 additions and 45 deletions
|
@ -1,29 +1,35 @@
|
|||
# Created by: Kirill Ponomarew <ponomarew@oberon.net>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= wavbreaker
|
||||
PORTVERSION= 0.11
|
||||
PORTREVISION= 3
|
||||
PORTVERSION= 0.12
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= SF
|
||||
|
||||
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
|
||||
PATCHFILES+= 6b73eb4c5d71.patch:-p1
|
||||
PATCHFILES+= c5df6ded1716.patch:-p1
|
||||
|
||||
MAINTAINER= jbeich@FreeBSD.org
|
||||
COMMENT= Tool to split and merge wav files
|
||||
COMMENT= GUI tool to split WAV and MP3 files
|
||||
|
||||
LICENSE= GPLv2+
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
OPTIONS_DEFINE= PULSEAUDIO NLS
|
||||
OPTIONS_SUB= yes
|
||||
LIB_DEPENDS= libao.so:audio/libao
|
||||
|
||||
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
|
||||
PULSEAUDIO_CONFIGURE_ENABLE=pulse
|
||||
NLS_USES= gettext
|
||||
NLS_CONFIGURE_ENABLE= nls
|
||||
|
||||
USE_GNOME= gtk20 libxml2
|
||||
USES= desktop-file-utils gmake gnome localbase pathfix pkgconfig
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --disable-alsa
|
||||
USES= desktop-file-utils gettext-tools gnome meson pkgconfig
|
||||
USE_GITHUB= yes
|
||||
USE_GNOME= cairo gtk30
|
||||
GH_ACCOUNT= thp
|
||||
INSTALLS_ICONS= yes
|
||||
|
||||
OPTIONS_DEFINE= MOODBAR MPG123
|
||||
OPTIONS_DEFAULT=MOODBAR MPG123
|
||||
|
||||
MOODBAR_DESC= Visual representation from .mood files
|
||||
MOODBAR_RUN_DEPENDS= moodbar:audio/moodbar
|
||||
MOODBAR_MESON_TRUE= moodbar
|
||||
|
||||
MPG123_LIB_DEPENDS= libmpg123.so:audio/mpg123
|
||||
MPG123_MESON_TRUE= mp3
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,7 @@
|
|||
SHA256 (wavbreaker-0.11.tar.gz) = a1d70fc54f92f20fb4cc2ef01beb8f60bc5e8d1cedde6b1e5f8f453b14ead2d1
|
||||
SIZE (wavbreaker-0.11.tar.gz) = 496733
|
||||
TIMESTAMP = 1574016889
|
||||
SHA256 (thp-wavbreaker-0.12_GH0.tar.gz) = 6546a80ce77739e3fda9637820a529573a8f9a2b18e5a3349330214fefca0b6b
|
||||
SIZE (thp-wavbreaker-0.12_GH0.tar.gz) = 385108
|
||||
SHA256 (6b73eb4c5d71.patch) = ad209e97ad694ef27a257aaad091b4f776c43004b15c85c12e6d1323ef5a0dcb
|
||||
SIZE (6b73eb4c5d71.patch) = 807
|
||||
SHA256 (c5df6ded1716.patch) = ca5668fbadee525abc35ead39ea9b344d948b097a0355235e1de758fe19bd457
|
||||
SIZE (c5df6ded1716.patch) = 1212
|
||||
|
|
|
@ -1,10 +0,0 @@
|
|||
--- src/toc.c.orig 2012-01-14 00:56:54 UTC
|
||||
+++ src/toc.c
|
||||
@@ -19,6 +19,7 @@
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
+#include <sys/types.h>
|
||||
|
||||
#include "wavbreaker.h"
|
||||
#include "sample.h"
|
|
@ -1,13 +1,25 @@
|
|||
wavbreaker is a tool to take a wave file and break it up into
|
||||
multiple wave files. It makes a clean break at the correct
|
||||
position to burn the files to an audio CD without any dead
|
||||
space between the tracks. It will only read wave files, so use
|
||||
an appropriate tool to convert Ogg, MP3, etc. files and then
|
||||
break them up. The GUI displays a summary of the entire wave
|
||||
file being worked on at the top. There is also a command line
|
||||
tool to merge wave files together (wavmerge). This tool will
|
||||
only work on files that are alike. For example, 44100 khz
|
||||
sample rate, 16-bit sample size, etc. (use sox to convert files
|
||||
first if necessary).
|
||||
This application's purpose in life is to take a WAV file and break it
|
||||
up into multiple WAV files. It makes a clean break at the correct
|
||||
position to burn the files to an Audio CD without any dead air between
|
||||
the tracks.
|
||||
|
||||
WWW: http://wavbreaker.sourceforge.net/
|
||||
wavbreaker now also directly supports breaking up MP3s without
|
||||
re-encoding meaning it's fast and there is no generational
|
||||
loss. Decoding (using mpg123) is only done for playback and waveform
|
||||
display.
|
||||
|
||||
The GUI displays a waveform summary of the entire file at the top. The
|
||||
middle portion displays a zoomed-in view that allows you to select
|
||||
where to start playing and where it will make the break. The bottom
|
||||
portion contains a list of track breaks. You may change file names and
|
||||
uncheck parts that you do not want to have written out to disk when
|
||||
saving.
|
||||
|
||||
There is also a command line tool wavmerge to merge WAV files
|
||||
together. If you download a show and don't like how it was tracked,
|
||||
you can merge them together with wavmerge and then break them back up
|
||||
with wavbreaker. The wavmerge tool will only work on files that have
|
||||
the same format (for example, 44.100 Hz sample rate, 16-bit sample
|
||||
size, etc.).
|
||||
|
||||
WWW: https://github.com/thp/wavbreaker
|
||||
|
|
|
@ -1,4 +1,5 @@
|
|||
bin/wavbreaker
|
||||
bin/wavgen
|
||||
bin/wavinfo
|
||||
bin/wavmerge
|
||||
man/man1/wavbreaker.1.gz
|
||||
|
@ -10,8 +11,7 @@ share/icons/hicolor/22x22/apps/wavbreaker.png
|
|||
share/icons/hicolor/24x24/apps/wavbreaker.png
|
||||
share/icons/hicolor/48x48/apps/wavbreaker.png
|
||||
share/icons/hicolor/scalable/apps/wavbreaker.svg
|
||||
%%NLS%%share/locale/de/LC_MESSAGES/wavbreaker.mo
|
||||
%%NLS%%share/locale/es/LC_MESSAGES/wavbreaker.mo
|
||||
%%NLS%%share/locale/fr/LC_MESSAGES/wavbreaker.mo
|
||||
%%NLS%%share/locale/pt/LC_MESSAGES/wavbreaker.mo
|
||||
share/pixmaps/wavbreaker.png
|
||||
share/locale/de/LC_MESSAGES/wavbreaker.mo
|
||||
share/locale/es/LC_MESSAGES/wavbreaker.mo
|
||||
share/locale/fr/LC_MESSAGES/wavbreaker.mo
|
||||
share/locale/pt/LC_MESSAGES/wavbreaker.mo
|
||||
|
|
Loading…
Reference in a new issue