Upgrade to 1.5.12

Add ipv6 support

Submitted by:	Xander Jansen <Xander.Jansen@surfnet.nl> (ipv6)
This commit is contained in:
Andrey A. Chernov 2002-05-25 14:51:21 +00:00
parent c9d4afc30a
commit 1e2bb9d2d1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=59982
5 changed files with 15 additions and 40 deletions

View file

@ -6,9 +6,8 @@
#
PORTNAME= tin
PORTVERSION= 1.5.11
PORTREVISION= 1
CATEGORIES+= news
PORTVERSION= 1.5.12
CATEGORIES+= news ipv6
MASTER_SITES= ftp://ftp.tin.org/pub/news/clients/tin/v1.5/ \
ftp://nuxi.ucdavis.edu/pub/tin/v1.5/ \
ftp://ftp.nuxi.com/pub/tin/v1.5/
@ -28,6 +27,7 @@ CONFIGURE_ARGS= --with-nntp-default-server=news \
--with-defaults-dir=${PREFIX}/etc \
--with-editor=/usr/bin/ee \
--enable-nls \
--enable-ipv6 \
--enable-curses \
--with-ncurses \
--disable-mime-strict-charset \
@ -58,12 +58,6 @@ post-patch:
pre-configure:
${CP} ${FILESDIR}/pcre.h ${WRKSRC}/pcre
post-configure:
if nm /usr/lib/libc.a | ${GREP} -q strcasestr; then \
${ECHO_CMD} "#define HAVE_STRCASESTR 1" \
>> ${WRKSRC}/include/autoconf.h; \
fi
post-build:
cd ${WRKSRC}/po; ${GMAKE}

View file

@ -1 +1 @@
MD5 (tin-1.5.11.tar.bz2) = 111886abdb0f7b892fc58999d0de89e3
MD5 (tin-1.5.12.tar.bz2) = 8d5e6ee1a2b979cdf457c4d8f1b6799d

View file

@ -1,12 +0,0 @@
--- include/proto.h.orig Tue Jan 29 17:31:11 2002
+++ include/proto.h Tue Mar 19 13:29:43 2002
@@ -628,7 +628,9 @@
extern char *my_strdup (const char *str);
extern char *str_trim (char *string);
extern char *tin_ltoa (long value, int digits);
+#ifndef HAVE_STRCASESTR
extern const char *strcasestr (const char *haystack, const char *needle);
+#endif
extern int sh_format (char *dst, size_t len, const char *fmt, ...);
extern size_t mystrcat (char **t, const char *s);
extern void my_strncpy (char *p, const char *q, size_t n);

View file

@ -1,18 +0,0 @@
--- src/string.c.bak Tue Nov 13 01:45:52 2001
+++ src/string.c Mon Dec 24 23:09:05 2001
@@ -118,6 +118,7 @@
}
+#ifndef HAVE_STRCASESTR
/*
* case-insensitive version of strstr()
*/
@@ -144,6 +145,7 @@
}
return NULL;
}
+#endif
size_t

11
news/tin/files/patch-ad Normal file
View file

@ -0,0 +1,11 @@
--- src/Makefile.in.bak Tue Apr 23 04:23:33 2002
+++ src/Makefile.in Sat May 25 18:30:39 2002
@@ -65,7 +65,7 @@
YACC = @YACC@
CANLIB = # -L../libcanlock -lcanlock
-INTL_LIBS = @INTLDIR_MAKE@ @INTLLIBS@
+INTL_LIBS = @INTLLIBS@
PCRE_LIBS = @PCREDIR_LIBS@ @PCREDIR_MAKE@ -L../pcre -lpcre
LIBS = $(PCRE_LIBS) $(CANLIB) @LIBS@ @INN_NNTPLIB@ $(INTL_LIBS)