- Add suport LDAP

- Add pkg-message
- Bump PORTREVISION

PR: 31351
Submitted by: MAINTAINER
This commit is contained in:
Kevin Lo 2001-10-19 15:52:02 +00:00
parent e9aeb74706
commit 1e2d710bb9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=48950
6 changed files with 49 additions and 23 deletions

View file

@ -7,6 +7,7 @@
PORTNAME= proxy-suite
PORTVERSION= 1.7
PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.suse.com/pub/projects/proxy-suite/src/ \
ftp://ftp.crc.ca/pub/systems/linux/suse/projects/proxy-suite/src/ \
@ -15,11 +16,37 @@ MASTER_SITES= ftp://ftp.suse.com/pub/projects/proxy-suite/src/ \
MAINTAINER= thomas@cuivre.fr.eu.org
CONFIGURE_ARGS= --with-libwrap=/usr/lib/
USE_AUTOCONF= yes
USE_GMAKE= yes
#
# basic configure args
#
CONFIGURE_ARGS= --prefix=${PREFIX} --with-libwrap=/usr/lib --with-regex \
--sysconfdir=${PREFIX}/etc/proxy-suite \
--localstatedir=/var/run \
--enable-warnings --enable-so-linger --enable-rfc1579 \
--disable-proc-mods
#
# OPTIONAL: include ldap-support - currently ldap.2 needs minor fixes...
#
.if defined(WITH_LDAP)
CONFIGURE_ARGS+= --with-libldap
LIB_DEPENDS+= ldap.1:${PORTSDIR}/net/openldap
.else
CONFIGURE_ARGS+= --without-libldap
.endif
#
# OPTIONAL: re-build the sgml documentation (postscript, html)
# unfortunatenly this docu it is not up to date :-((
# reading of the manual pages and HOWTO's makes more sense...
#
.if !defined(WITH_SGMLDOC)
ALL_TARGET= -C ftp-proxy
.endif
MAN8= ftp-proxy.8
MAN5= ftp-proxy.conf.5

View file

@ -0,0 +1,11 @@
--- ftp-proxy/Makefile.in
+++ ftp-proxy/Makefile.in Tue Jun 26 01:12:06 2001
@@ -55,7 +55,7 @@
PROC_FTP= @PROC_FTP@
CONF_SRC= ftp-proxy.conf.sample
-CONF_DST= $(ETC_DIR)/ftp-proxy.conf
+CONF_DST= $(ETC_DIR)/ftp-proxy.conf.sample
FTP_MAN5= ftp-proxy.conf.5
FTP_MAN8= ftp-proxy.8

View file

@ -1,18 +0,0 @@
--- ftp-proxy/ftp-cmds.c.orig Fri Feb 11 15:23:59 2000
+++ ftp-proxy/ftp-cmds.c Fri Feb 11 15:25:33 2000
@@ -371,6 +371,7 @@ static void cmds_user(CONTEXT *ctx, char
for (cmd = cmdlist; cmd->name != NULL; cmd++) {
if (strcasecmp("USER", cmd->name) != 0)
continue;
+#if defined(HAVE_REGEX)
if (cmd->regex == NULL)
break;
if ((p = cmds_reg_exec(cmd->regex, arg)) != NULL) {
@@ -383,6 +384,7 @@ static void cmds_user(CONTEXT *ctx, char
ctx->cli_ctrl->peer, p);
return;
}
+#endif
break;
}

View file

@ -2,7 +2,7 @@ The SuSE Proxy-Suite, a set of programs to enhance firewall security.
The first (and currently only) component being released is the FTP-Proxy.
* Securely relays FTP connections between clients and servers
* Can switch connections from active to passive and vice versa
* Can switch connections from active to passive and vice versa
* Utilizes port ranges for both control and data connections
* Provides extensive auditing (via syslog or rotating log files)
* Can separate user related from system triggered audit events
@ -15,7 +15,8 @@ The first (and currently only) component being released is the FTP-Proxy.
* Planned to support RFC 2428 (IPv6 Extensions for FTP)
* Based on GNU AutoConf, supposed to run on many UNIX systems
Ported to FreeBSD using OpenBSD port by Camiel Dobbelaar <cd@sentia.nl>
Ported to FreeBSD using OpenBSD port by Camiel Dobbelaar <cd@sentia.nl>,
with updates contributed by Marius Tomaschewski <mat@mt-home.net>.
WWW: http://www.suse.de/en/support/proxy_suite/

View file

@ -0,0 +1,4 @@
This port provides a sample configuration file as
PREFIX/etc/proxy-suite/ftp-proxy.conf.sample
Please copy this file to ftp-proxy.conf and edit
to fit your needs. Default PREFIX is /usr/local.

View file

@ -1,2 +1,3 @@
sbin/ftp-proxy
etc/ftp-proxy.conf
etc/proxy-suite/ftp-proxy.conf.sample
@dirrm etc/proxy-suite