Update to 4.0.23a release [1]:

- Use MASTER_SITES_MYSQL
- Add WITHOUT_INNODB knob [2]
- Fix tcp wrappers (hopefully definitely!)

PR:		ports/75598 [1]
Submitted by:	Marcus Grando <marcus@corp.grupos.com.br> [1],
		sobomax [2]
This commit is contained in:
Alex Dupre 2005-01-09 13:20:47 +00:00
parent ab33c8a986
commit 1e5de7912b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=125952
11 changed files with 240 additions and 111 deletions

View file

@ -6,20 +6,11 @@
#
PORTNAME?= mysql
PORTVERSION= 4.0.22
PORTVERSION= 4.0.23a
PORTREVISION?= 0
CATEGORIES= databases
MASTER_SITES= ftp://planetmirror.com/pub/mysql/Downloads/MySQL-4.0/ \
http://www.softagency.co.jp/MySQL/Downloads/MySQL-4.0/ \
ftp://sunsite.dk/mirrors/mysql/Downloads/MySQL-4.0/ \
http://mysql.mediatraffic.fi/Downloads/MySQL-4.0/ \
ftp://filepile.tiscali.de/mirror/mysql/Downloads/MySQL-4.0/ \
http://mirrors.tilian.co.uk/mysql.com/Downloads/MySQL-4.0/ \
ftp://ftp.rtfm.no/pub/mysql/Downloads/MySQL-4.0/ \
http://www.mysql.cz/Downloads/MySQL-4.0/ \
ftp://ftp.u-paris10.fr/mysql.com/Downloads/MySQL-4.0/ \
http://mysql.proserve.nl/Downloads/MySQL-4.0/ \
ftp://ftp.free.fr/pub/MySQL/Downloads/MySQL-4.0/
MASTER_SITES= ${MASTER_SITE_MYSQL}
MASTER_SITE_SUBDIR= MySQL-4.0
PKGNAMESUFFIX?= -server
MAINTAINER= ale@FreeBSD.org
@ -63,6 +54,10 @@ CONFIGURE_ARGS+=--with-openssl=${OPENSSLBASE}
CONFIGURE_ARGS+=--with-mysqld-ldflags=-all-static
.endif
.if defined(WITHOUT_INNODB)
CONFIGURE_ARGS+=--without-innodb
.endif
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"
@ -135,8 +130,12 @@ pre-fetch:
@${ECHO} " (use it if you need speed)."
@${ECHO} " BUILD_STATIC=yes Build a static version of mysqld."
@${ECHO} " (use it if you need even more speed)."
@${ECHO} " WITHOUT_INNODB=yes Disable support for InnoDB table handler."
@${ECHO} ""
post-extract:
@${CP} /usr/include/tcpd.h ${WRKSRC}/sql/mytcpd.h
post-patch:
@${REINPLACE_CMD} -e "s|SUBDIRS =|SUBDIRS = include @docs_dirs@ @sql_server_dirs@ scripts man support-files|g" ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e "s|bin_SCRIPTS =|bin_SCRIPTS = @server_scripts@|g" ${WRKSRC}/scripts/Makefile.in

View file

@ -1,2 +1,2 @@
MD5 (mysql-4.0.22.tar.gz) = fab53259c3ba9f729a319bf271fc8587
SIZE (mysql-4.0.22.tar.gz) = 14395535
MD5 (mysql-4.0.23a.tar.gz) = ea85758104faf3bb2704af08dd6b3b7d
SIZE (mysql-4.0.23a.tar.gz) = 16735725

View file

@ -0,0 +1,29 @@
--- Docs/Makefile.in.orig Sun Jan 9 12:51:43 2005
+++ Docs/Makefile.in Sun Jan 9 12:58:11 2005
@@ -316,7 +316,7 @@
SUBDIRS = Images
GT = $(srcdir)/Support/generate-text-files.pl
-all: $(BUILT_SOURCES)
+all:
$(MAKE) $(AM_MAKEFLAGS) all-recursive
.SUFFIXES:
@@ -626,7 +626,7 @@
for dir in "$(DESTDIR)$(infodir)"; do \
test -z "$$dir" || $(mkdir_p) "$$dir"; \
done
-install: $(BUILT_SOURCES)
+install:
$(MAKE) $(AM_MAKEFLAGS) install-recursive
install-exec: install-exec-recursive
install-data: install-data-recursive
@@ -750,7 +750,7 @@
tags tags-recursive uninstall uninstall-am uninstall-info-am
-all: $(targets) txt_files
+all:
txt_files: ../INSTALL-SOURCE ../COPYING ../EXCEPTIONS-CLIENT \
INSTALL-BINARY ../support-files/MacOSX/ReadMe.txt

View file

@ -1,6 +1,6 @@
--- configure.orig Tue Sep 7 00:30:08 2004
+++ configure Wed Sep 15 15:18:33 2004
@@ -18793,8 +18793,6 @@
--- configure.orig Mon Dec 27 16:30:01 2004
+++ configure Sun Jan 9 10:17:14 2005
@@ -19609,8 +19609,6 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
@ -9,7 +9,7 @@
# Prevent multiple expansion
@@ -19972,43 +19970,8 @@
@@ -20786,43 +20784,7 @@
echo "$as_me:$LINENO: checking \"how to check if pid exists\"" >&5
echo $ECHO_N "checking \"how to check if pid exists\"... $ECHO_C" >&6
PS=$ac_cv_path_PS
@ -18,10 +18,10 @@
-then
- FIND_PROC="$PS p \$\$PID | grep mysqld > /dev/null"
-# Solaris
-elif $PS -p $$ 2> /dev/null | grep $0 > /dev/null
-elif $PS -fp $$ 2> /dev/null | grep $0 > /dev/null
-then
- FIND_PROC="$PS -p \$\$PID | grep mysqld > /dev/null"
# BSD style
-# BSD style
-elif $PS -uaxww 2> /dev/null | grep $0 > /dev/null
-then
FIND_PROC="$PS -uaxww | grep mysqld | grep \" \$\$PID \" > /dev/null"
@ -53,7 +53,7 @@
echo "$as_me:$LINENO: result: \"$FIND_PROC\"" >&5
echo "${ECHO_T}\"$FIND_PROC\"" >&6
@@ -23615,8 +23578,8 @@
@@ -24753,8 +24715,8 @@
# Some system specific hacks
#
@ -64,7 +64,7 @@
# workaround for Sun Forte/x86 see BUG#4681
case $SYSTEM_TYPE-$MACHINE_TYPE-$ac_cv_c_compiler_gnu in
@@ -33651,7 +33614,7 @@
@@ -35738,7 +35700,7 @@
/* ) rel_srcdir="$srcdir" ;;
* ) rel_srcdir="../$srcdir" ;;
esac

View file

@ -1,13 +1,13 @@
--- man/Makefile.in.orig Mon Feb 23 14:54:10 2004
+++ man/Makefile.in Mon Feb 23 14:54:34 2004
@@ -272,9 +272,7 @@
--- man/Makefile.in.orig Mon Dec 27 16:29:53 2004
+++ man/Makefile.in Sun Jan 9 10:26:07 2005
@@ -290,9 +290,7 @@
uname_prog = @uname_prog@
vio_dir = @vio_dir@
vio_libs = @vio_libs@
-man_MANS = mysql.1 isamchk.1 isamlog.1 mysql_zap.1 mysqlaccess.1 \
- mysqladmin.1 mysqld.1 mysqld_multi.1 mysqldump.1 mysqlshow.1 \
- perror.1 replace.1 mysqld_safe.1 mysql_fix_privilege_tables.1
+man_MANS =
EXTRA_DIST = mysql.1.in isamchk.1.in isamlog.1.in mysql_zap.1.in \
mysqlaccess.1.in mysqladmin.1.in mysqld.1.in mysqld_multi.1.in \

View file

@ -1,9 +1,9 @@
--- scripts/Makefile.in.orig Fri May 14 02:54:11 2004
+++ scripts/Makefile.in Tue May 18 10:22:57 2004
@@ -271,25 +271,7 @@
--- scripts/Makefile.in.orig Mon Dec 27 16:29:57 2004
+++ scripts/Makefile.in Sun Jan 9 10:27:55 2005
@@ -292,25 +292,7 @@
uname_prog = @uname_prog@
vio_dir = @vio_dir@
vio_libs = @vio_libs@
-bin_SCRIPTS = @server_scripts@ \
- msql2mysql \
- mysql_config \
@ -25,9 +25,9 @@
- make_win_binary_distribution
+bin_SCRIPTS =
EXTRA_SCRIPTS = make_binary_distribution.sh \
@@ -465,7 +447,7 @@
make_sharedlib_distribution.sh \
@@ -489,7 +471,7 @@
uninstall: uninstall-am
install-am: all-am

View file

@ -1,39 +0,0 @@
--- sql/Makefile.in.orig Tue Sep 7 00:30:06 2004
+++ sql/Makefile.in Mon Sep 20 08:34:53 2004
@@ -348,7 +348,8 @@
sql_udf.cc sql_analyse.cc sql_analyse.h sql_cache.cc \
slave.cc sql_repl.cc sql_union.cc \
mini_client.cc mini_client_errors.c \
- stacktrace.c repl_failsafe.h repl_failsafe.cc
+ stacktrace.c repl_failsafe.h repl_failsafe.cc \
+ mylibwrap.c
gen_lex_hash_SOURCES = gen_lex_hash.cc
gen_lex_hash_LDADD = $(LDADD) $(CXXLDFLAGS)
@@ -399,7 +400,7 @@
sql_analyse.$(OBJEXT) sql_cache.$(OBJEXT) slave.$(OBJEXT) \
sql_repl.$(OBJEXT) sql_union.$(OBJEXT) mini_client.$(OBJEXT) \
mini_client_errors.$(OBJEXT) stacktrace.$(OBJEXT) \
- repl_failsafe.$(OBJEXT)
+ repl_failsafe.$(OBJEXT) mylibwrap.$(OBJEXT)
mysqld_OBJECTS = $(am_mysqld_OBJECTS)
mysqld_DEPENDENCIES = ../myisam/libmyisam.a ../myisammrg/libmyisammrg.a \
../heap/libheap.a ../vio/libvio.a ../mysys/libmysys.a \
@@ -452,7 +453,8 @@
@AMDEP_TRUE@ ./$(DEPDIR)/sql_update.Po ./$(DEPDIR)/sql_yacc.Po \
@AMDEP_TRUE@ ./$(DEPDIR)/stacktrace.Po ./$(DEPDIR)/table.Po \
@AMDEP_TRUE@ ./$(DEPDIR)/thr_malloc.Po ./$(DEPDIR)/time.Po \
-@AMDEP_TRUE@ ./$(DEPDIR)/uniques.Po ./$(DEPDIR)/unireg.Po
+@AMDEP_TRUE@ ./$(DEPDIR)/uniques.Po ./$(DEPDIR)/unireg.Po \
+@AMDEP_TRUE@ ./$(DEPDIR)/mylibwrap.Po
COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
$(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
@@ -629,6 +631,7 @@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/time.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/uniques.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/unireg.Po@am__quote@
+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/mylibwrap.Po@am__quote@
distclean-depend:
-rm -rf ./$(DEPDIR)

View file

@ -1,23 +0,0 @@
--- sql/mylibwrap.c.orig Thu Jan 1 01:00:00 1970
+++ sql/mylibwrap.c Sun Sep 19 15:37:22 2004
@@ -0,0 +1,20 @@
+#include <tcpd.h>
+#include "mylibwrap.h"
+
+void
+my_fromhost(struct request_info *req)
+{
+ fromhost(req);
+}
+
+int
+my_hosts_access(struct request_info *req)
+{
+ return hosts_access(req);
+}
+
+char *
+my_eval_client(struct request_info *req)
+{
+ return eval_client(req);
+}

View file

@ -1,12 +0,0 @@
--- sql/mylibwrap.h.orig Thu Jan 1 01:00:00 1970
+++ sql/mylibwrap.h Sun Sep 19 15:04:21 2004
@@ -0,0 +1,9 @@
+#ifdef __cplusplus
+extern "C" {
+#endif
+extern void my_fromhost(struct request_info *);
+extern int my_hosts_access(struct request_info *);
+extern char *my_eval_client(struct request_info *);
+#ifdef __cplusplus
+}
+#endif

View file

@ -1,6 +1,15 @@
--- sql/mysqld.cc.orig Tue Sep 7 00:29:37 2004
+++ sql/mysqld.cc Mon Sep 20 08:37:21 2004
@@ -107,15 +107,7 @@
--- sql/mysqld.cc.orig Sat Dec 18 18:25:05 2004
+++ sql/mysqld.cc Sun Jan 9 12:43:21 2005
@@ -99,7 +99,7 @@
#endif /* __WIN__ */
#ifdef HAVE_LIBWRAP
-#include <tcpd.h>
+#include "mytcpd.h"
#include <syslog.h>
#ifdef NEED_SYS_SYSLOG_H
#include <sys/syslog.h>
@@ -107,15 +107,6 @@
int allow_severity = LOG_INFO;
int deny_severity = LOG_WARNING;
@ -13,7 +22,26 @@
-#define my_hosts_access(A) hosts_access()
-#define my_eval_client(A) eval_client()
-#endif
+#include "mylibwrap.h"
#endif /* HAVE_LIBWRAP */
#ifdef HAVE_SYS_MMAN_H
@@ -3240,8 +3231,8 @@
struct request_info req;
signal(SIGCHLD, SIG_DFL);
request_init(&req, RQ_DAEMON, libwrapName, RQ_FILE, new_sock, NULL);
- my_fromhost(&req);
- if (!my_hosts_access(&req))
+ fromhost(&req);
+ if (!hosts_access(&req))
{
/*
This may be stupid but refuse() includes an exit(0)
@@ -3249,7 +3240,7 @@
clean_exit() - same stupid thing ...
*/
syslog(deny_severity, "refused connect from %s",
- my_eval_client(&req));
+ eval_client(&req));
/*
C++ sucks (the gibberish in front just translates the supplied

View file

@ -0,0 +1,147 @@
--- sql/mytcpd.h.orig Sun Jan 9 13:33:51 2005
+++ sql/mytcpd.h Sun Jan 9 13:41:42 2005
@@ -6,6 +6,25 @@
* $FreeBSD: /tmp/pcvs/ports/databases/mysql40-server/files/Attic/patch-sql::mytcpd.h,v 1.1 2005-01-09 13:20:47 ale Exp $
*/
+#ifndef _TCPWRAPPERS_TCPD_H
+#define _TCPWRAPPERS_TCPD_H
+
+/* someone else may have defined this */
+#undef __P
+
+/* use prototypes if we have an ANSI C compiler or are using C++ */
+#if defined(__STDC__) || defined(__cplusplus)
+#define __P(args) args
+#else
+#define __P(args) ()
+#endif
+
+/* Need definitions of struct sockaddr_in and FILE. */
+#include <netinet/in.h>
+#include <stdio.h>
+
+__BEGIN_DECLS
+
/* Structure to describe one communications endpoint. */
#define STRING_LENGTH 128 /* hosts, users, processes */
@@ -31,10 +50,10 @@
char pid[10]; /* access via eval_pid(request) */
struct host_info client[1]; /* client endpoint info */
struct host_info server[1]; /* server endpoint info */
- void (*sink) (); /* datagram sink function or 0 */
- void (*hostname) (); /* address to printable hostname */
- void (*hostaddr) (); /* address to printable address */
- void (*cleanup) (); /* cleanup function or 0 */
+ void (*sink) __P((int)); /* datagram sink function or 0 */
+ void (*hostname) __P((struct host_info *)); /* address to printable hostname */
+ void (*hostaddr) __P((struct host_info *)); /* address to printable address */
+ void (*cleanup) __P((struct request_info *)); /* cleanup function or 0 */
struct netconfig *config; /* netdir handle */
};
@@ -67,20 +86,23 @@
/* Global functions. */
#if defined(TLI) || defined(PTX) || defined(TLI_SEQUENT)
-extern void fromhost(); /* get/validate client host info */
+extern void fromhost __P((struct request_info *)); /* get/validate client host info */
#else
#define fromhost sock_host /* no TLI support needed */
#endif
-extern int hosts_access(); /* access control */
-extern void shell_cmd(); /* execute shell command */
-extern char *percent_x(); /* do %<char> expansion */
-extern void rfc931(); /* client name from RFC 931 daemon */
-extern void clean_exit(); /* clean up and exit */
-extern void refuse(); /* clean up and exit */
-extern char *xgets(); /* fgets() on steroids */
-extern char *split_at(); /* strchr() and split */
-extern unsigned long dot_quad_addr(); /* restricted inet_addr() */
+extern void shell_cmd __P((char *)); /* execute shell command */
+extern char *percent_x __P((char *, int, char *, struct request_info *)); /* do %<char> expansion */
+#ifdef INET6
+extern void rfc931 __P((struct sockaddr *, struct sockaddr *, char *)); /* client name from RFC 931 daemon */
+#else
+extern void rfc931 __P((struct sockaddr_in *, struct sockaddr_in *, char *)); /* client name from RFC 931 daemon */
+#endif
+extern void clean_exit __P((struct request_info *)); /* clean up and exit */
+extern void refuse __P((struct request_info *)); /* clean up and exit */
+extern char *xgets __P((char *, int, FILE *)); /* fgets() on steroids */
+extern char *split_at __P((char *, int)); /* strchr() and split */
+extern unsigned long dot_quad_addr __P((char *)); /* restricted inet_addr() */
/* Global variables. */
@@ -98,9 +120,14 @@
*/
#ifdef __STDC__
+extern int hosts_access(struct request_info *request);
+extern int hosts_ctl(char *daemon, char *client_name, char *client_addr,
+ char *client_user);
extern struct request_info *request_init(struct request_info *,...);
extern struct request_info *request_set(struct request_info *,...);
#else
+extern int hosts_access();
+extern int hosts_ctl();
extern struct request_info *request_init(); /* initialize request */
extern struct request_info *request_set(); /* update request structure */
#endif
@@ -123,27 +150,27 @@
* host_info structures serve as caches for the lookup results.
*/
-extern char *eval_user(); /* client user */
-extern char *eval_hostname(); /* printable hostname */
-extern char *eval_hostaddr(); /* printable host address */
-extern char *eval_hostinfo(); /* host name or address */
-extern char *eval_client(); /* whatever is available */
-extern char *eval_server(); /* whatever is available */
+extern char *eval_user __P((struct request_info *)); /* client user */
+extern char *eval_hostname __P((struct host_info *)); /* printable hostname */
+extern char *eval_hostaddr __P((struct host_info *)); /* printable host address */
+extern char *eval_hostinfo __P((struct host_info *)); /* host name or address */
+extern char *eval_client __P((struct request_info *)); /* whatever is available */
+extern char *eval_server __P((struct request_info *)); /* whatever is available */
#define eval_daemon(r) ((r)->daemon) /* daemon process name */
#define eval_pid(r) ((r)->pid) /* process id */
/* Socket-specific methods, including DNS hostname lookups. */
-extern void sock_host(); /* look up endpoint addresses */
-extern void sock_hostname(); /* translate address to hostname */
-extern void sock_hostaddr(); /* address to printable address */
+extern void sock_host __P((struct request_info *));
+extern void sock_hostname __P((struct host_info *));
+extern void sock_hostaddr __P((struct host_info *));
#define sock_methods(r) \
{ (r)->hostname = sock_hostname; (r)->hostaddr = sock_hostaddr; }
/* The System V Transport-Level Interface (TLI) interface. */
#if defined(TLI) || defined(PTX) || defined(TLI_SEQUENT)
-extern void tli_host(); /* look up endpoint addresses etc. */
+extern void tli_host __P((struct request_info *)); /* look up endpoint addresses etc. */
#endif
/*
@@ -184,7 +211,7 @@
* behavior.
*/
-extern void process_options(); /* execute options */
+extern void process_options __P((char *, struct request_info *)); /* execute options */
extern int dry_run; /* verification flag */
/* Bug workarounds. */
@@ -223,3 +250,7 @@
#define strtok my_strtok
extern char *my_strtok();
#endif
+
+__END_DECLS
+
+#endif /* tcpd.h */