graphics/py-pillow-heif: Update to 0.14.0

Changes:	https://github.com/bigcat88/pillow_heif/releases
This commit is contained in:
Po-Chuan Hsieh 2023-12-14 13:36:37 +08:00
parent b79a6f6f69
commit 1e708cf7fb
No known key found for this signature in database
GPG key ID: 9A4BD10F002DD04B
3 changed files with 14 additions and 13 deletions

View file

@ -1,5 +1,5 @@
PORTNAME= pillow-heif
PORTVERSION= 0.13.1
PORTVERSION= 0.14.0
CATEGORIES= graphics python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=61:devel/py-setuptools@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
LIB_DEPENDS= libheif.so:graphics/libheif
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>=9.1.1:graphics/py-pillow@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>=9.2.0:graphics/py-pillow@${PY_FLAVOR}
USES= localbase python
USE_PYTHON= autoplist concurrent pep517

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1697463132
SHA256 (pillow_heif-0.13.1.tar.gz) = 0d46adc8a8afb515297fd47fc0b15657b8927f7ec52ad1fb8d63250413d4c6ba
SIZE (pillow_heif-0.13.1.tar.gz) = 14892936
TIMESTAMP = 1702028132
SHA256 (pillow_heif-0.14.0.tar.gz) = 7abd0279f0ec8b5ba1513dc586e52173666ed9278b38e219bf47da92704262cb
SIZE (pillow_heif-0.14.0.tar.gz) = 14894857

View file

@ -1,9 +1,10 @@
--- setup.py.orig 2023-08-09 12:11:06 UTC
--- setup.py.orig 2023-12-02 13:40:59 UTC
+++ setup.py
@@ -142,6 +142,5 @@ if getenv("READTHEDOCS", "False") == "True":
else:
setup(
version=get_version(),
- cmdclass={"build_ext": PillowHeifBuildExt},
ext_modules=[Extension("_pillow_heif", ["pillow_heif/_pillow_heif.c"])],
)
@@ -269,7 +269,6 @@ try:
else:
setup(
version=get_version(),
- cmdclass={"build_ext": PillowHeifBuildExt},
ext_modules=[Extension("_pillow_heif", ["pillow_heif/_pillow_heif.c"])],
zip_safe=not PLATFORM_MINGW,
)