Add gnome-osd, a project to create an OSD (On-Screen-Display) infrastructure,
similar to XOSD. It includes a command-line client, and sample xchat and rhythmbox plugins. PR: 70778 Submitted by: Jean-Yves Lefort <jylefort@brutele.be>
This commit is contained in:
parent
ad2021a4cc
commit
1e77d6b0a7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=121086
7 changed files with 99 additions and 0 deletions
|
@ -113,6 +113,7 @@
|
|||
SUBDIR += globus2
|
||||
SUBDIR += gman
|
||||
SUBDIR += gnome-icon-theme
|
||||
SUBDIR += gnome-osd
|
||||
SUBDIR += gnomehier
|
||||
SUBDIR += gnomemimedata
|
||||
SUBDIR += gnomesword
|
||||
|
|
46
misc/gnome-osd/Makefile
Normal file
46
misc/gnome-osd/Makefile
Normal file
|
@ -0,0 +1,46 @@
|
|||
# New ports collection makefile for: gnome-osd
|
||||
# Date created: 21 Aug 2004
|
||||
# Whom: Jean-Yves Lefort <jylefort@brutele.be>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= gnome-osd
|
||||
PORTVERSION= 0.4.0
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= http://yang.inescn.pt/~gjc/
|
||||
|
||||
MAINTAINER= jylefort@brutele.be
|
||||
COMMENT= An On-Screen-Display infrastructure using Pango text rendering
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_BZIP2= yes
|
||||
USE_GNOME= gnomehack gnomeprefix intlhack pygnome2
|
||||
USE_PYTHON= yes
|
||||
USE_REINPLACE= yes
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|share/pixmaps|share/gnome/pixmaps|' ${WRKSRC}/gnome-osd-properties
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} \
|
||||
${WRKSRC}/AUTHORS \
|
||||
${WRKSRC}/NEWS \
|
||||
${WRKSRC}/README \
|
||||
${DOCSDIR}
|
||||
${MKDIR} ${EXAMPLESDIR}
|
||||
${INSTALL_DATA} \
|
||||
${WRKSRC}/rbosd.py \
|
||||
${WRKSRC}/xchatosd.py \
|
||||
${EXAMPLESDIR}
|
||||
.endif
|
||||
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.mk>
|
2
misc/gnome-osd/distinfo
Normal file
2
misc/gnome-osd/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
MD5 (gnome-osd-0.4.0.tar.bz2) = 26d4bbaf9c644c6ae722872f63c54f02
|
||||
SIZE (gnome-osd-0.4.0.tar.bz2) = 101249
|
13
misc/gnome-osd/files/patch-README
Normal file
13
misc/gnome-osd/files/patch-README
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- README.orig Sat Aug 21 17:29:37 2004
|
||||
+++ README Sat Aug 21 17:30:03 2004
|
||||
@@ -35,10 +35,3 @@
|
||||
yourself, somewhere. To start, simply run the program with no arguments.
|
||||
From there on, every time rhythmbox changes song, you get an OSD message
|
||||
notifying you of this.
|
||||
-
|
||||
- ** Note **
|
||||
- In order to make rbosd.py work correctly, you need to
|
||||
-apply the patch gnome-python-2.5.90.diff against gnome-python 2.5.90
|
||||
-source and recompile. This is a temporary solution until gnome-python
|
||||
-2.5.91 is released.
|
||||
-
|
8
misc/gnome-osd/pkg-descr
Normal file
8
misc/gnome-osd/pkg-descr
Normal file
|
@ -0,0 +1,8 @@
|
|||
Gnome OSD is a new small project to create an OSD (On-Screen-Display)
|
||||
infrastructure, similar to XOSD. It includes a command-line client,
|
||||
and sample xchat and rhythmbox plugins.
|
||||
|
||||
WWW: http://www.gnomefiles.org/app.php?soft_id=350
|
||||
|
||||
- Jean-Yves Lefort
|
||||
jylefort@brutele.be
|
6
misc/gnome-osd/pkg-message
Normal file
6
misc/gnome-osd/pkg-message
Normal file
|
@ -0,0 +1,6 @@
|
|||
-------------------------------------------------------------------------------
|
||||
IMPORTANT: the GConf daemon must be restarted after installing this
|
||||
port, by typing:
|
||||
|
||||
gconftool-2 --shutdown && gconftool-2 --spawn
|
||||
-------------------------------------------------------------------------------
|
23
misc/gnome-osd/pkg-plist
Normal file
23
misc/gnome-osd/pkg-plist
Normal file
|
@ -0,0 +1,23 @@
|
|||
bin/gnome-osd-client
|
||||
bin/gnome-osd-properties
|
||||
@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/gnome-osd.schemas > /dev/null || /usr/bin/true
|
||||
etc/gconf/schemas/gnome-osd.schemas
|
||||
@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/gnome-osd.schemas > /dev/null || /usr/bin/true
|
||||
libdata/bonobo/servers/GNOME_OSD.server
|
||||
%%PYTHON_SITELIBDIR%%/gconfsync.py
|
||||
%%PYTHON_SITELIBDIR%%/gconfsync.pyc
|
||||
%%PYTHON_SITELIBDIR%%/gconfsync.pyo
|
||||
%%PYTHON_SITELIBDIR%%/gosd.py
|
||||
%%PYTHON_SITELIBDIR%%/gosd.pyc
|
||||
%%PYTHON_SITELIBDIR%%/gosd.pyo
|
||||
libexec/gnome-osd-server
|
||||
share/gnome/control-center-2.0/capplets/gnome-osd-properties.desktop
|
||||
share/gnome/pixmaps/gnome-osd.png
|
||||
share/locale/pt/LC_MESSAGES/gnome-osd.mo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/NEWS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/rbosd.py
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/xchatosd.py
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
|
Loading…
Reference in a new issue