- Update devel/hwloc to 1.6 [1]
- Bump affected net/openmpi PR: ports/174106 [1] Submitted by: Eijiro Shibusawa <phd_kimberlite@yahoo.co.jp>
This commit is contained in:
parent
9232b7b38d
commit
1e8bd2fdd7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=308991
6 changed files with 29 additions and 25 deletions
|
@ -1,10 +1,10 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= hwloc
|
||||
PORTVERSION= 1.5.1
|
||||
PORTVERSION= 1.6
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://www.open-mpi.org/software/hwloc/v1.5/downloads/ \
|
||||
http://icl.cs.utk.edu/open-mpi/software/hwloc/v1.5/downloads/
|
||||
MASTER_SITES= http://www.open-mpi.org/software/hwloc/v1.6/downloads/ \
|
||||
http://icl.cs.utk.edu/open-mpi/software/hwloc/v1.6/downloads/
|
||||
|
||||
MAINTAINER= phd_kimberlite@yahoo.co.jp
|
||||
COMMENT= The Portable Hardware Locality software package
|
||||
|
@ -17,6 +17,7 @@ CONFIGURE_ARGS+= --enable-static \
|
|||
--enable-libxml2
|
||||
USE_BZIP2= yes
|
||||
USE_PKGCONFIG= build
|
||||
USE_ICONV= yes
|
||||
USE_LDCONFIG= yes
|
||||
USE_GNOME= libxml2 gnomehack
|
||||
MAKE_JOBS_SAFE= yes
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
MAN1= hwloc-assembler-remote.1 \
|
||||
MAN1= hwloc-annotate.1 \
|
||||
hwloc-assembler-remote.1 \
|
||||
hwloc-assembler.1 \
|
||||
hwloc-bind.1 \
|
||||
hwloc-calc.1 \
|
||||
|
@ -146,6 +147,8 @@ MAN3= HWLOC_API_VERSION.3 \
|
|||
hwloc_distances_s.3 \
|
||||
hwloc_distribute.3 \
|
||||
hwloc_distributev.3 \
|
||||
hwloc_export_obj_userdata.3 \
|
||||
hwloc_export_obj_userdata_base64.3 \
|
||||
hwloc_free.3 \
|
||||
hwloc_free_xmlbuffer.3 \
|
||||
hwloc_get_ancestor_obj_by_depth.3 \
|
||||
|
@ -290,6 +293,8 @@ MAN3= HWLOC_API_VERSION.3 \
|
|||
hwloc_topology_set_fsroot.3 \
|
||||
hwloc_topology_set_pid.3 \
|
||||
hwloc_topology_set_synthetic.3 \
|
||||
hwloc_topology_set_userdata_export_callback.3 \
|
||||
hwloc_topology_set_userdata_import_callback.3 \
|
||||
hwloc_topology_set_xml.3 \
|
||||
hwloc_topology_set_xmlbuffer.3 \
|
||||
hwloc_topology_support.3 \
|
||||
|
@ -329,7 +334,8 @@ MAN3= HWLOC_API_VERSION.3 \
|
|||
hwlocality_tinker.3 \
|
||||
hwlocality_topology.3 \
|
||||
hwlocality_traversal.3 \
|
||||
hwlocality_types.3
|
||||
hwlocality_types.3 \
|
||||
hwlocality_xmlexport.3
|
||||
|
||||
MAN7= hwloc.7
|
||||
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (hwloc-1.5.1.tar.bz2) = d255bf369d8922bb3e1330b84e3bc5dd9a8ce6cb3c8cbb3af0f4288840087711
|
||||
SIZE (hwloc-1.5.1.tar.bz2) = 2888571
|
||||
SHA256 (hwloc-1.6.tar.bz2) = bc08c84cb37d6aa3f889ba142ec3e57d24ce9a18a4d2e25471e1e2e8f30aa678
|
||||
SIZE (hwloc-1.6.tar.bz2) = 3067679
|
||||
|
|
|
@ -1,12 +1,12 @@
|
|||
--- utils/Makefile.in.orig 2012-07-30 17:36:52.000000000 +0900
|
||||
+++ utils/Makefile.in 2012-08-01 16:17:49.000000000 +0900
|
||||
@@ -1477,9 +1477,7 @@
|
||||
@HWLOC_BUILD_UTILS_TRUE@@HWLOC_HAVE_CAIRO_FALSE@@HWLOC_HAVE_WINDOWS_FALSE@ rm -f $(DESTDIR)$(bindir)/lstopo
|
||||
@HWLOC_BUILD_UTILS_TRUE@@HWLOC_HAVE_CAIRO_FALSE@@HWLOC_HAVE_WINDOWS_FALSE@ cd $(DESTDIR)$(bindir) && $(LN_S) lstopo-no-graphics$(EXEEXT) lstopo$(EXEEXT) || true
|
||||
@HWLOC_BUILD_UTILS_TRUE@ rm -f $(DESTDIR)$(man1dir)/hwloc-ls.1 $(DESTDIR)$(man1dir)/hwloc-info.1
|
||||
-@HWLOC_BUILD_UTILS_TRUE@ cd $(DESTDIR)$(man1dir) && $(LN_S) lstopo.1 hwloc-ls.1 && $(LN_S) lstopo.1 hwloc-info.1
|
||||
@HWLOC_BUILD_UTILS_TRUE@ rm -f $(DESTDIR)$(man1dir)/lstopo-no-graphics.1
|
||||
-@HWLOC_BUILD_UTILS_TRUE@ cd $(DESTDIR)$(man1dir) && $(LN_S) lstopo.1 lstopo-no-graphics.1
|
||||
@HWLOC_BUILD_UTILS_TRUE@ $(SED) -e 's/abs_top_builddir\/utils/bindir/' -e '/abs_top_builddir/d' $(DESTDIR)$(bindir)/hwloc-assembler-remote > $(DESTDIR)$(bindir)/hwloc-assembler-remote.tmp && mv -f $(DESTDIR)$(bindir)/hwloc-assembler-remote.tmp $(DESTDIR)$(bindir)/hwloc-assembler-remote
|
||||
@HWLOC_BUILD_UTILS_TRUE@ chmod +x $(DESTDIR)$(bindir)/hwloc-assembler-remote
|
||||
--- utils/Makefile.in.orig 2012-12-04 00:27:15.000000000 +0900
|
||||
+++ utils/Makefile.in 2012-12-04 00:27:30.000000000 +0900
|
||||
@@ -1505,9 +1505,7 @@
|
||||
@HWLOC_HAVE_CAIRO_FALSE@@HWLOC_HAVE_WINDOWS_FALSE@ rm -f $(DESTDIR)$(bindir)/lstopo
|
||||
@HWLOC_HAVE_CAIRO_FALSE@@HWLOC_HAVE_WINDOWS_FALSE@ cd $(DESTDIR)$(bindir) && $(LN_S) lstopo-no-graphics$(EXEEXT) lstopo$(EXEEXT) || true
|
||||
rm -f $(DESTDIR)$(man1dir)/hwloc-ls.1 $(DESTDIR)$(man1dir)/hwloc-info.1
|
||||
- cd $(DESTDIR)$(man1dir) && $(LN_S) lstopo.1 hwloc-ls.1 && $(LN_S) lstopo.1 hwloc-info.1
|
||||
rm -f $(DESTDIR)$(man1dir)/lstopo-no-graphics.1
|
||||
- cd $(DESTDIR)$(man1dir) && $(LN_S) lstopo.1 lstopo-no-graphics.1
|
||||
$(SED) -e 's/abs_top_builddir\/utils/bindir/' -e '/abs_top_builddir/d' $(DESTDIR)$(bindir)/hwloc-assembler-remote > $(DESTDIR)$(bindir)/hwloc-assembler-remote.tmp && mv -f $(DESTDIR)$(bindir)/hwloc-assembler-remote.tmp $(DESTDIR)$(bindir)/hwloc-assembler-remote
|
||||
chmod +x $(DESTDIR)$(bindir)/hwloc-assembler-remote
|
||||
|
||||
|
|
|
@ -1,3 +1,4 @@
|
|||
bin/hwloc-annotate
|
||||
bin/hwloc-assembler
|
||||
bin/hwloc-assembler-remote
|
||||
bin/hwloc-bind
|
||||
|
@ -21,7 +22,7 @@ include/hwloc/rename.h
|
|||
lib/libhwloc.a
|
||||
lib/libhwloc.la
|
||||
lib/libhwloc.so
|
||||
lib/libhwloc.so.6
|
||||
lib/libhwloc.so.7
|
||||
libdata/pkgconfig/hwloc.pc
|
||||
share/hwloc/hwloc-valgrind.supp
|
||||
share/hwloc/hwloc.dtd
|
||||
|
|
|
@ -1,16 +1,12 @@
|
|||
# Ports collection makefile for: openmpi
|
||||
# Date created: August 22, 2005
|
||||
# Whom: Brooks Davis <brooks@freebsd.org>
|
||||
#
|
||||
# Created by: Brooks Davis <brooks@freebsd.org>
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
# TODO:
|
||||
# - etc/*.sample support
|
||||
|
||||
PORTNAME= openmpi
|
||||
DISTVERSION= 1.6.1
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= net parallel
|
||||
MASTER_SITES= http://www.open-mpi.org/software/ompi/v1.6/downloads/
|
||||
|
||||
|
|
Loading…
Reference in a new issue