WebInject is a free tool for automated testing of web applications and web

services. It can be used to test individual system components that have HTTP
interfaces (JSP, ASP, CGI, PHP, Servlets, HTML Forms, XML/SOAP Web Services,
etc), and can be used as a test harness to create a suite of [HTTP level]
automated functional, acceptance, and regression tests. A test harness, also
referred to as a test driver or a test framework, allows you to run many
test cases and collect/report your results. WebInject offers real-time
results display and may also be used for monitoring system response times.

WebInject can be used as a complete test framework that is controlled by the
WebInject User Interface (GUI). Optionally, it can be used as a standalone
test runner (text/console application) which can be integrated and called
from other test frameworks or applications.

WWW: http://www.webinject.org/

PR:		ports/102402
Submitted by:	Gerrit Beine <gerrit.beine(at)gmx.de>
This commit is contained in:
Martin Wilke 2006-09-12 08:28:30 +00:00
parent fec0752630
commit 1eb6a3c54d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=172831
5 changed files with 97 additions and 0 deletions

View file

@ -1046,6 +1046,7 @@
SUBDIR += webcrawl
SUBDIR += webfs
SUBDIR += webglimpse
SUBDIR += webinject
SUBDIR += weblint
SUBDIR += weblint++
SUBDIR += webredirect

58
www/webinject/Makefile Normal file
View file

@ -0,0 +1,58 @@
# New ports collection makefile for: webinject
# Date created: August 22nd 2006
# Whom: Gerrit Beine <gerrit.beine@gmx.de>
#
# $FreeBSD$
#
PORTNAME= webinject
PORTVERSION= 1.41
CATEGORIES= www perl5 devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= webinject
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
MAINTAINER= gerrit.beine@gmx.de
COMMENT= A tool for automated testing of web applications
RUN_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/mach/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
${SITE_PERL}/Getopt/Long.pm:${PORTSDIR}/devel/p5-Getopt-Long \
${SITE_PERL}/Error.pm:${PORTSDIR}/lang/p5-Error \
${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple \
${SITE_PERL}/${PERL_ARCH}/Crypt/SSLeay.pm:${PORTSDIR}/security/p5-Crypt-SSLeay
.if !defined(WITHOUT_X11)
# some work to do here
#RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Tk.pm:${PORTSDIR}/x11-toolkits/p5-Tk
.endif
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
PLIST_FILES= bin/webinject.pl \
${DATADIR:S,^${PREFIX}/,,}/config.xml \
${DATADIR:S,^${PREFIX}/,,}/testcases.xml
PLIST_DIRS= ${DATADIR:S,^${PREFIX}/,,}
do-install:
@${MKDIR} ${DATADIR}
@cd ${WRKSRC} && ${INSTALL_DATA} *.xml ${DATADIR}
@cd ${WRKSRC} && ${INSTALL_SCRIPT} webinject.pl ${PREFIX}/bin
.if !defined(NOPORTDOCS)
PORTDOCS= LICENSE README
post-install:
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500800
IGNORE= requires at least Perl 5.8 due to dependencies. Please install lang/perl5.8 and try again
.endif
.include <bsd.port.post.mk>

3
www/webinject/distinfo Normal file
View file

@ -0,0 +1,3 @@
MD5 (webinject-1.41.src.tar.gz) = 5c90ddd69719d897afd8ccb2f8528163
SHA256 (webinject-1.41.src.tar.gz) = e1bfc77d9673c15a06bc385992df9e28eb40101a8a9cd5ba18fdaa51aa43036b
SIZE (webinject-1.41.src.tar.gz) = 29024

View file

@ -0,0 +1,20 @@
--- webinject.pl.orig Wed Jan 4 19:10:30 2006
+++ webinject.pl Mon Sep 4 16:19:08 2006
@@ -1362,12 +1362,12 @@
#------------------------------------------------------------------
sub getdirname { #get the directory webinject engine is running from
- $dirname = $0;
- $dirname =~ s~(.*/).*~$1~; #for nix systems
- $dirname =~ s~(.*\\).*~$1~; #for windoz systems
- if ($dirname eq $0) {
+# $dirname = $0;
+# $dirname =~ s~(.*/).*~$1~; #for nix systems
+# $dirname =~ s~(.*\\).*~$1~; #for windoz systems
+# if ($dirname eq $0) {
$dirname = './';
- }
+# }
}
#------------------------------------------------------------------
sub getoptions { #command line options

15
www/webinject/pkg-descr Normal file
View file

@ -0,0 +1,15 @@
WebInject is a free tool for automated testing of web applications and web
services. It can be used to test individual system components that have HTTP
interfaces (JSP, ASP, CGI, PHP, Servlets, HTML Forms, XML/SOAP Web Services,
etc), and can be used as a test harness to create a suite of [HTTP level]
automated functional, acceptance, and regression tests. A test harness, also
referred to as a test driver or a test framework, allows you to run many
test cases and collect/report your results. WebInject offers real-time
results display and may also be used for monitoring system response times.
WebInject can be used as a complete test framework that is controlled by the
WebInject User Interface (GUI). Optionally, it can be used as a standalone
test runner (text/console application) which can be integrated and called
from other test frameworks or applications.
WWW: http://www.webinject.org/