Update to curlpp-0.7.0.

In addition to the patch from Vasil, also finally remove the warning
about the incompatibility with ancient curlpp versions.

PR:		108295
Submitted by:	vd
This commit is contained in:
Peter Pentchev 2007-01-26 13:23:12 +00:00
parent f1533ea412
commit 1eb866ba37
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=183337
4 changed files with 11 additions and 41 deletions

View file

@ -7,17 +7,16 @@
#
PORTNAME= curlpp
PORTVERSION= 0.6.1
PORTREVISION= 1
PORTVERSION= 0.7.0
CATEGORIES= ftp
MASTER_SITES= http://rrette.com/downloads/sources/
MASTER_SITES= http://rrette.com/files/curlpp/curlpp-${PORTVERSION:R}/
MAINTAINER= roam@FreeBSD.org
COMMENT= A C++ wrapper for libcurl
LIB_DEPENDS= curl.4:${PORTSDIR}/ftp/curl
USE_GCC= 3.4
USE_GCC= 3.4+
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@ -31,12 +30,6 @@ USE_LDCONFIG= yes
BROKEN= Does not compile on alpha 4.x
.endif
pre-everything::
@${ECHO} ""
@${ECHO} "NOTE to people using 0.3.x: cURLpp 0.3.x is dead!"
@${ECHO} "The current version ${PORTVERSION} is incompatible with the old 0.3.x versions"
@${ECHO} ""
post-patch:
@${REINPLACE_CMD} -e 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' ${WRKSRC}/Makefile.in

View file

@ -1,3 +1,3 @@
MD5 (curlpp-0.6.1.tar.gz) = 9f843154cc3d23fd547cc6cbfdb99e90
SHA256 (curlpp-0.6.1.tar.gz) = 7812059a562dbd4b26b69e4c32d9a4149b4957e4a0428efed7b712fc8f704afe
SIZE (curlpp-0.6.1.tar.gz) = 433513
MD5 (curlpp-0.7.0.tar.gz) = 34cd0c82795b9f245930335bb5e2e764
SHA256 (curlpp-0.7.0.tar.gz) = c211937ff8c92ab371cf08cc256340bb62bb85167443730c27fac061fcb79bbe
SIZE (curlpp-0.7.0.tar.gz) = 457303

View file

@ -1,28 +0,0 @@
--- curlpp/Info.cpp.orig Sun Jan 14 19:53:08 2007
+++ curlpp/Info.cpp Sun Jan 14 19:53:13 2007
@@ -5,9 +5,11 @@
#include "Info.hpp"
+namespace cURLpp {
+
template< >
void
-cURLpp::InfoTypeConverter< std::string >::get(cURLpp::Easy &handle,
+InfoTypeConverter< std::string >::get(cURLpp::Easy &handle,
CURLINFO info,
std::string &value)
{
@@ -18,9 +20,11 @@
template< >
void
-cURLpp::InfoTypeConverter< std::list< std::string > >::get(cURLpp::Easy &,
+InfoTypeConverter< std::list< std::string > >::get(cURLpp::Easy &,
CURLINFO ,
std::list< std::string > &)
{
+}
+
}

View file

@ -8,6 +8,7 @@ include/curlpp/Form.hpp
include/curlpp/Info.hpp
include/curlpp/Info.inl
include/curlpp/Infos.hpp
include/curlpp/Multi.hpp
include/curlpp/NonCopyable.hpp
include/curlpp/Option.hpp
include/curlpp/Option.inl
@ -82,5 +83,9 @@ libdata/pkgconfig/curlpp.pc
%%PORTDOCS%%%%EXAMPLESDIR%%/example10.cpp
%%PORTDOCS%%%%EXAMPLESDIR%%/example11.cpp
%%PORTDOCS%%%%EXAMPLESDIR%%/example12.cpp
%%PORTDOCS%%%%EXAMPLESDIR%%/example13.cpp
%%PORTDOCS%%%%EXAMPLESDIR%%/example14.cpp
%%PORTDOCS%%%%EXAMPLESDIR%%/example15.cpp
%%PORTDOCS%%%%EXAMPLESDIR%%/example16.cpp
%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%